Overclock.net › Forums › Graphics Cards › AMD/ATI › What is my problem with my 5970
New Posts  All Forums:Forum Nav:

What is my problem with my 5970

post #1 of 5
Thread Starter 
Well after having problems for the past few months with my 5970 card,I pulled it out and placed my old GTX275 back and now my system is running really good... So I have came to these three items that could be the problem.

1-Drivers for the 5970
2-The Card itself-- During the summer time we had a bad storm blow through and knocked off the power, when the power came back on line, my card was making a really bad noise(fan) and the red light was on...Also my ram was damaged during this time ..
3 my system is Bottleneck to the 5970 card?

I'm not sure but i really think its number 2,or number 1 it seemed to start acting up since then but have become worse the past few months.....
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 -920 Evga X58 X3SLI Le GTX275 temp for now 6GB Muskin 2000Mhz 
Hard DriveOptical DriveOSMonitor
640 WD black Off brand dvd drive win 7 64bit Benq24 inch 
KeyboardPowerCaseMouse
arcotsa ENERMAX REVOLUTION85+ HAF932 Lachesis 
Mouse Pad
razer pad 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 -920 Evga X58 X3SLI Le GTX275 temp for now 6GB Muskin 2000Mhz 
Hard DriveOptical DriveOSMonitor
640 WD black Off brand dvd drive win 7 64bit Benq24 inch 
KeyboardPowerCaseMouse
arcotsa ENERMAX REVOLUTION85+ HAF932 Lachesis 
Mouse Pad
razer pad 
  hide details  
Reply
post #2 of 5
do you have your rigg plugged into a surge protector device? confused.gif and can you be more specific with what problems you are having with the 5970?
Voodoo Omen x79
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel I7 4930k  Asus Rampage IV Black Edition  EVGA GTX Titan 16gb Corsair Dominator Platinum ddr3 2400mhz 
Hard DriveHard DriveOptical DriveCooling
WD RE3 1TB 7200rpm  Samsung 840 Pro SSD 256gb Boot OS LG BluRay Player All disc reader/burner Corsair H80i 
OSMonitorKeyboardPower
Windows 7 Home Premium 64bit Samsung Syncmaster 26'' LCD 5ms 1920x1200 Razer Lycossa Thermaltake Toughpower 1200watt 
CaseMouse
Voodoo Omen Razer Mamba Wireless 
  hide details  
Reply
Voodoo Omen x79
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel I7 4930k  Asus Rampage IV Black Edition  EVGA GTX Titan 16gb Corsair Dominator Platinum ddr3 2400mhz 
Hard DriveHard DriveOptical DriveCooling
WD RE3 1TB 7200rpm  Samsung 840 Pro SSD 256gb Boot OS LG BluRay Player All disc reader/burner Corsair H80i 
OSMonitorKeyboardPower
Windows 7 Home Premium 64bit Samsung Syncmaster 26'' LCD 5ms 1920x1200 Razer Lycossa Thermaltake Toughpower 1200watt 
CaseMouse
Voodoo Omen Razer Mamba Wireless 
  hide details  
Reply
post #3 of 5
If you think its the driver, do a clean uninstall with driver sweeper. And if it still doesnt help, then I hope that your 5970 is still under warranty. It should be hardware damaged since you that there was a storm.
Did you PSU get damaged? Because most PSUs have over current protection and your Enermax PSU should have that to shut down your com, or is this a new PSU?
mamma mia
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k Asus Sabertooth P67 Sapphire 6850 Toxic kingston value RAM 
Hard DriveOSMonitorPower
Samsung 1Tb Win 7 64bit 1280x1024 (17'') Seasonic M12II 
CaseMouse Pad
CoolerMaster elite 370 Razor Goliathus 
  hide details  
Reply
mamma mia
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k Asus Sabertooth P67 Sapphire 6850 Toxic kingston value RAM 
Hard DriveOSMonitorPower
Samsung 1Tb Win 7 64bit 1280x1024 (17'') Seasonic M12II 
CaseMouse Pad
CoolerMaster elite 370 Razor Goliathus 
  hide details  
Reply
post #4 of 5
Thread Starter 
ya i have tried cleaning out drivers..... its a gigabyte card.. This is the PSU http://www.newegg.com/Product/Product.aspx?Item=N82E16817194081 well its the same but my is 1050Watts

I think my PSU is fine, it seems to be working fine, i just have a gut feeling it is the card,

Here are a few problems i have with the 5970

When i load up a game, ex:TF2 i would see the menu screen and also a menu screen going up and down with two lines., random lock ups,some stutter out of no where in games, some games would have missing textures or flashing textures,then they go away and come back to flashing, and overall sluggish performance for what that card should be running at

I planning on trying again and just going to install the 10.5A and try it again, if it stable with them and all seems good, Then they are going to stay installed until i have to install new drivers, If i install the 10.5a and have the same trouble, then im going to say for sure that the card is damaged
Edited by BigB76toold - 12/23/10 at 9:21pm
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 -920 Evga X58 X3SLI Le GTX275 temp for now 6GB Muskin 2000Mhz 
Hard DriveOptical DriveOSMonitor
640 WD black Off brand dvd drive win 7 64bit Benq24 inch 
KeyboardPowerCaseMouse
arcotsa ENERMAX REVOLUTION85+ HAF932 Lachesis 
Mouse Pad
razer pad 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 -920 Evga X58 X3SLI Le GTX275 temp for now 6GB Muskin 2000Mhz 
Hard DriveOptical DriveOSMonitor
640 WD black Off brand dvd drive win 7 64bit Benq24 inch 
KeyboardPowerCaseMouse
arcotsa ENERMAX REVOLUTION85+ HAF932 Lachesis 
Mouse Pad
razer pad 
  hide details  
Reply
post #5 of 5
Thread Starter 
Well i put the big card back in my box today and installed the 10.5 drivers and when i was done with the install... it said warnings was found or something along that line.... I see how my games play...........
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 -920 Evga X58 X3SLI Le GTX275 temp for now 6GB Muskin 2000Mhz 
Hard DriveOptical DriveOSMonitor
640 WD black Off brand dvd drive win 7 64bit Benq24 inch 
KeyboardPowerCaseMouse
arcotsa ENERMAX REVOLUTION85+ HAF932 Lachesis 
Mouse Pad
razer pad 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 -920 Evga X58 X3SLI Le GTX275 temp for now 6GB Muskin 2000Mhz 
Hard DriveOptical DriveOSMonitor
640 WD black Off brand dvd drive win 7 64bit Benq24 inch 
KeyboardPowerCaseMouse
arcotsa ENERMAX REVOLUTION85+ HAF932 Lachesis 
Mouse Pad
razer pad 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › What is my problem with my 5970