Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Strange Internet Connectivity Problem with Windows
New Posts  All Forums:Forum Nav:

Strange Internet Connectivity Problem with Windows

post #1 of 7
Thread Starter 
Here's the deal. I live in a residential hotel with shared WiFi internet access throughout the entire building. From what I can tell it's ComCast Business with the modem wired to one WiFi router that is then wired to five other WiFi routers in different parts of the building to provide full coverage. From what I can tell all of the routers are D-Link DI-524, but I've only seen one of them physically and I don't have access to them until the manager get's back. I have no idea what revision they are or what firmware is installed. Over the past couple of years the connection has been fairly consistent and stable with the occasional outage that lasts for a couple of minutes and restores itself automatically. About once a month or so they have to reset/cycle the modem but nothing out of the ordinary for the most part. A couple of months ago we started having a lot of problems with the WiFi network working but no internet access. Reseting/cycling didn't always restore the connection the first time. It would often times take several times to finally restore the internet connection (and yes, they were waiting an appropriate amount of time when cycling the routers and/or modem).

In trying to help the manager get things straightened out I was able to determine that when the internet went out in my area of the building 2 of the routers would still have access to the internet, but the router by me and 3 of the others did not. I explained the problem to one of the workers who passed the info on to the manager and he performed a more thorough reset/cycle of the routers. I don't know exactly what he did, but from what I was able to glean from one of the other workers here he unplugged all of the routers, cycled the modem, plugged in the first router, then plugged each of the routers in one at a time waiting a couple of minutes between them. After he did this he left on an extended vacation, but all seemed well for the first couple of days. All of the routers now had full internet access.

Now comes the goofy part. After a couple of days everyone in the building started having severe internet connection problems. Cycling the routers and modem would only restore things for a short time. People with Windows XP had less of a problem than people with Vista or Win 7. XP works about 60% of the time while Vista/7 works maybe 15% of the time. I've tried clean installs of XP, Vista, and 7 without updating them trying to see if one of the Windows updates was causing the problem, but that doesn't appear to have any effect. There is a wide variety of hardware among the many people having the problems so I don't see it as a hardware or driver issue at the computer level. We can connect to the routers fine, but no internet. We don't get the limited or no connectivity warning, just no internet.

But wait. It get's even stranger. I can get online with Linux with >99% uptime even when the Windows systems won't (basically a momentary dropout that comes back after a minute or two are my only downtime). Fedora, Mint, PCLinuxOS, Mandriva, the 'Buntu's, 32bit, 64bit, it doesn't matter. Linux gets on the internet when Windows won't using the exact same hardware, even from a Live CD. The building manager should be back the first of next week and I'm trying to gather some ideas of what he (or possibly we) need to be looking at to fix this. I'm not a Networking expert, but I'm fairly computer literate overall. If anyone has heard of anything like this and has any ideas of where we should be concentrating our efforts I would be greatly appreciative as having to run Linux this much is really a pain since so much of the software I need to use will not run in Linux and there aren't any Linux alternatives. It's driving everyone here up a wall.
Edited by PapaSmurf - 12/24/10 at 3:55pm
442
(15 items)
 
Q6600
(14 items)
 
Piece O' Crappola
(13 items)
 
CPUMotherboardGraphicsRAM
Q9550 E0 DFI LanParty LT P35-T2R 2 x HD4670QT512P CF Patriot PVS24G8500ELKN 
CoolingOSMonitorPower
Stock pfsense Acer H233H Antec EarthWatts 430 
CaseAudio
custom onboard 
CPUMotherboardGraphicsRAM
Q6600 B3 Lapped @ 3.4 GA-EP45-UD3R EVGA 9600GSO 384m 96SP 4G (2x2) Patriot Viper PC2-8500 
Hard DriveOptical DriveCoolingOS
80g Maxtor, 320WDC. 320Seagate NEC ND-3550 & LiteOn CM Hyper 212+ w/PP Blademasters XP Pro SP3 
MonitorPowerCase
Acer H233H Rosewill RG630-S12 NZXT BetaEVO 
CPUMotherboardGraphicsRAM
E6420 GA-P35-DS3L GeForce 7300LE 2G PNY PC2-6400 
Hard DriveOptical DriveOSMonitor
80Gig WDC SATA NEC ND3540A Win 7 Ultimate 64bit/XP Pro Acer H233H 
PowerCase
Antec Earthwatts 430 none 
  hide details  
Reply
442
(15 items)
 
Q6600
(14 items)
 
Piece O' Crappola
(13 items)
 
CPUMotherboardGraphicsRAM
Q9550 E0 DFI LanParty LT P35-T2R 2 x HD4670QT512P CF Patriot PVS24G8500ELKN 
CoolingOSMonitorPower
Stock pfsense Acer H233H Antec EarthWatts 430 
CaseAudio
custom onboard 
CPUMotherboardGraphicsRAM
Q6600 B3 Lapped @ 3.4 GA-EP45-UD3R EVGA 9600GSO 384m 96SP 4G (2x2) Patriot Viper PC2-8500 
Hard DriveOptical DriveCoolingOS
80g Maxtor, 320WDC. 320Seagate NEC ND-3550 & LiteOn CM Hyper 212+ w/PP Blademasters XP Pro SP3 
MonitorPowerCase
Acer H233H Rosewill RG630-S12 NZXT BetaEVO 
CPUMotherboardGraphicsRAM
E6420 GA-P35-DS3L GeForce 7300LE 2G PNY PC2-6400 
Hard DriveOptical DriveOSMonitor
80Gig WDC SATA NEC ND3540A Win 7 Ultimate 64bit/XP Pro Acer H233H 
PowerCase
Antec Earthwatts 430 none 
  hide details  
Reply
post #2 of 7
Thread Starter 
2 days and over 100 views and not a single response. Doesn't anyone have some idea of something to try?
442
(15 items)
 
Q6600
(14 items)
 
Piece O' Crappola
(13 items)
 
CPUMotherboardGraphicsRAM
Q9550 E0 DFI LanParty LT P35-T2R 2 x HD4670QT512P CF Patriot PVS24G8500ELKN 
CoolingOSMonitorPower
Stock pfsense Acer H233H Antec EarthWatts 430 
CaseAudio
custom onboard 
CPUMotherboardGraphicsRAM
Q6600 B3 Lapped @ 3.4 GA-EP45-UD3R EVGA 9600GSO 384m 96SP 4G (2x2) Patriot Viper PC2-8500 
Hard DriveOptical DriveCoolingOS
80g Maxtor, 320WDC. 320Seagate NEC ND-3550 & LiteOn CM Hyper 212+ w/PP Blademasters XP Pro SP3 
MonitorPowerCase
Acer H233H Rosewill RG630-S12 NZXT BetaEVO 
CPUMotherboardGraphicsRAM
E6420 GA-P35-DS3L GeForce 7300LE 2G PNY PC2-6400 
Hard DriveOptical DriveOSMonitor
80Gig WDC SATA NEC ND3540A Win 7 Ultimate 64bit/XP Pro Acer H233H 
PowerCase
Antec Earthwatts 430 none 
  hide details  
Reply
442
(15 items)
 
Q6600
(14 items)
 
Piece O' Crappola
(13 items)
 
CPUMotherboardGraphicsRAM
Q9550 E0 DFI LanParty LT P35-T2R 2 x HD4670QT512P CF Patriot PVS24G8500ELKN 
CoolingOSMonitorPower
Stock pfsense Acer H233H Antec EarthWatts 430 
CaseAudio
custom onboard 
CPUMotherboardGraphicsRAM
Q6600 B3 Lapped @ 3.4 GA-EP45-UD3R EVGA 9600GSO 384m 96SP 4G (2x2) Patriot Viper PC2-8500 
Hard DriveOptical DriveCoolingOS
80g Maxtor, 320WDC. 320Seagate NEC ND-3550 & LiteOn CM Hyper 212+ w/PP Blademasters XP Pro SP3 
MonitorPowerCase
Acer H233H Rosewill RG630-S12 NZXT BetaEVO 
CPUMotherboardGraphicsRAM
E6420 GA-P35-DS3L GeForce 7300LE 2G PNY PC2-6400 
Hard DriveOptical DriveOSMonitor
80Gig WDC SATA NEC ND3540A Win 7 Ultimate 64bit/XP Pro Acer H233H 
PowerCase
Antec Earthwatts 430 none 
  hide details  
Reply
post #3 of 7
i would investigate some sort of dns problem maybe? i know you say you cant connect but based on what? browser says can't find server? can you ping out? can you ping the routers ip e.g. 192.168.x.x. can you ping your own PUBLIC ip or your gateway on the internet? this is definitely a weird problem because if linux works 99% of the time then to me that means the routers and modem are working 99% of the time too.
ambalamps
(16 items)
 
  
CPUMotherboardGraphicsRAM
980X X58A-UD3R 2x 7970 12 GB Corsair Dominator 
Hard DriveHard DriveOptical DriveCooling
2x Crucial M4 raid0 2x 2TB HD's samsung x22 dvd h70, lots of megaflows 
OSMonitorKeyboardPower
windows 7 x64 Samsung S27A750D Razer Black Widow Ultimate coolermaster 1KW 
CaseMouseMouse PadAudio
HAF-X Logitech g9x 9hd x-fi titanium hd 
  hide details  
Reply
ambalamps
(16 items)
 
  
CPUMotherboardGraphicsRAM
980X X58A-UD3R 2x 7970 12 GB Corsair Dominator 
Hard DriveHard DriveOptical DriveCooling
2x Crucial M4 raid0 2x 2TB HD's samsung x22 dvd h70, lots of megaflows 
OSMonitorKeyboardPower
windows 7 x64 Samsung S27A750D Razer Black Widow Ultimate coolermaster 1KW 
CaseMouseMouse PadAudio
HAF-X Logitech g9x 9hd x-fi titanium hd 
  hide details  
Reply
post #4 of 7
Thread Starter 
I can ping the routers, the default gateway, and the local computers just fine, but I can't ping anything on the internet from the Windows systems when the problem is happening. I can ping any one of the Windows systems that won't connect to the internet from any of the other Windows systems that won't connect. When I ping a URL like www.google.com or it's IP address of 74.125.95.103 from any of the Windows systems it times out. I can successfully ping either the URL or the IP address from the Linux system with no problem.

This isn't just my systems, it's every system in the building that is having the problem. Many were systems that were working just fine one day then after the manager did the last big reset everyone started having problems so the chances of the problem being all of our computers is remote. I just can't figure out why Linux isn't having a problem as I'm positive that would lead us to the problem with the network.

A couple of the people took their laptops to the local library and connected to their WiFi with absolutely NO problems which also supports the theory that it is the network in this building, not the individual computers. I know for a fact that the only changes made on my laptop (XP Pro SP3 and 32bit Win 7 Ultimate) and my desktop with XP Pro SP3 have been AV updates. I haven't done any Windows updates since the problem started on either of the them. My other desktop has been changed though as I tried to figure out what the problem is. I have access to the copy of 64bit Win 7 Ultimate that has been there all along as well as a clean install of 64bit Win 7 Ultimate with no updates at all.
442
(15 items)
 
Q6600
(14 items)
 
Piece O' Crappola
(13 items)
 
CPUMotherboardGraphicsRAM
Q9550 E0 DFI LanParty LT P35-T2R 2 x HD4670QT512P CF Patriot PVS24G8500ELKN 
CoolingOSMonitorPower
Stock pfsense Acer H233H Antec EarthWatts 430 
CaseAudio
custom onboard 
CPUMotherboardGraphicsRAM
Q6600 B3 Lapped @ 3.4 GA-EP45-UD3R EVGA 9600GSO 384m 96SP 4G (2x2) Patriot Viper PC2-8500 
Hard DriveOptical DriveCoolingOS
80g Maxtor, 320WDC. 320Seagate NEC ND-3550 & LiteOn CM Hyper 212+ w/PP Blademasters XP Pro SP3 
MonitorPowerCase
Acer H233H Rosewill RG630-S12 NZXT BetaEVO 
CPUMotherboardGraphicsRAM
E6420 GA-P35-DS3L GeForce 7300LE 2G PNY PC2-6400 
Hard DriveOptical DriveOSMonitor
80Gig WDC SATA NEC ND3540A Win 7 Ultimate 64bit/XP Pro Acer H233H 
PowerCase
Antec Earthwatts 430 none 
  hide details  
Reply
442
(15 items)
 
Q6600
(14 items)
 
Piece O' Crappola
(13 items)
 
CPUMotherboardGraphicsRAM
Q9550 E0 DFI LanParty LT P35-T2R 2 x HD4670QT512P CF Patriot PVS24G8500ELKN 
CoolingOSMonitorPower
Stock pfsense Acer H233H Antec EarthWatts 430 
CaseAudio
custom onboard 
CPUMotherboardGraphicsRAM
Q6600 B3 Lapped @ 3.4 GA-EP45-UD3R EVGA 9600GSO 384m 96SP 4G (2x2) Patriot Viper PC2-8500 
Hard DriveOptical DriveCoolingOS
80g Maxtor, 320WDC. 320Seagate NEC ND-3550 & LiteOn CM Hyper 212+ w/PP Blademasters XP Pro SP3 
MonitorPowerCase
Acer H233H Rosewill RG630-S12 NZXT BetaEVO 
CPUMotherboardGraphicsRAM
E6420 GA-P35-DS3L GeForce 7300LE 2G PNY PC2-6400 
Hard DriveOptical DriveOSMonitor
80Gig WDC SATA NEC ND3540A Win 7 Ultimate 64bit/XP Pro Acer H233H 
PowerCase
Antec Earthwatts 430 none 
  hide details  
Reply
post #5 of 7
From the sound of it, the routers themselves are probably starting to act up and probably need replacing; for routers/modems, the typical life is generally ~3-5 years.
RAD GT
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K MSI P67A-GD65 eVga GeForce GTX 480 Hydro Copper G.Skill Ripjaws X DDR3-1066 4x4Gb 
Hard DriveOptical DriveCoolingOS
2x 500Gb SATA | 750Gb SATA | 1Tb SATA LG SATA DVD-RW DangerDen Water Windows 7 Ultimate X64 
MonitorMonitorPower
AOC 2236VW 1920x1080 22" WS AOC 2236VW 1920x1080 22" WS SilverStone Strider ST850 
  hide details  
Reply
RAD GT
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K MSI P67A-GD65 eVga GeForce GTX 480 Hydro Copper G.Skill Ripjaws X DDR3-1066 4x4Gb 
Hard DriveOptical DriveCoolingOS
2x 500Gb SATA | 750Gb SATA | 1Tb SATA LG SATA DVD-RW DangerDen Water Windows 7 Ultimate X64 
MonitorMonitorPower
AOC 2236VW 1920x1080 22" WS AOC 2236VW 1920x1080 22" WS SilverStone Strider ST850 
  hide details  
Reply
post #6 of 7
Thread Starter 
Thanks. That's what I was thinking, especially due to when they discontinued the ones they are using. Add in that the two areas of the building that have been having the most problems are the two areas that would have the most use that would make sense.
442
(15 items)
 
Q6600
(14 items)
 
Piece O' Crappola
(13 items)
 
CPUMotherboardGraphicsRAM
Q9550 E0 DFI LanParty LT P35-T2R 2 x HD4670QT512P CF Patriot PVS24G8500ELKN 
CoolingOSMonitorPower
Stock pfsense Acer H233H Antec EarthWatts 430 
CaseAudio
custom onboard 
CPUMotherboardGraphicsRAM
Q6600 B3 Lapped @ 3.4 GA-EP45-UD3R EVGA 9600GSO 384m 96SP 4G (2x2) Patriot Viper PC2-8500 
Hard DriveOptical DriveCoolingOS
80g Maxtor, 320WDC. 320Seagate NEC ND-3550 & LiteOn CM Hyper 212+ w/PP Blademasters XP Pro SP3 
MonitorPowerCase
Acer H233H Rosewill RG630-S12 NZXT BetaEVO 
CPUMotherboardGraphicsRAM
E6420 GA-P35-DS3L GeForce 7300LE 2G PNY PC2-6400 
Hard DriveOptical DriveOSMonitor
80Gig WDC SATA NEC ND3540A Win 7 Ultimate 64bit/XP Pro Acer H233H 
PowerCase
Antec Earthwatts 430 none 
  hide details  
Reply
442
(15 items)
 
Q6600
(14 items)
 
Piece O' Crappola
(13 items)
 
CPUMotherboardGraphicsRAM
Q9550 E0 DFI LanParty LT P35-T2R 2 x HD4670QT512P CF Patriot PVS24G8500ELKN 
CoolingOSMonitorPower
Stock pfsense Acer H233H Antec EarthWatts 430 
CaseAudio
custom onboard 
CPUMotherboardGraphicsRAM
Q6600 B3 Lapped @ 3.4 GA-EP45-UD3R EVGA 9600GSO 384m 96SP 4G (2x2) Patriot Viper PC2-8500 
Hard DriveOptical DriveCoolingOS
80g Maxtor, 320WDC. 320Seagate NEC ND-3550 & LiteOn CM Hyper 212+ w/PP Blademasters XP Pro SP3 
MonitorPowerCase
Acer H233H Rosewill RG630-S12 NZXT BetaEVO 
CPUMotherboardGraphicsRAM
E6420 GA-P35-DS3L GeForce 7300LE 2G PNY PC2-6400 
Hard DriveOptical DriveOSMonitor
80Gig WDC SATA NEC ND3540A Win 7 Ultimate 64bit/XP Pro Acer H233H 
PowerCase
Antec Earthwatts 430 none 
  hide details  
Reply
post #7 of 7
Thread Starter 
Well we have an update. Still not sure exactly what the building manager has done so far, but we are back to the way it was before he left. 2 of the routers are working with WIndows just fine and the other 4 (including the one for my area) are cutting out quite often for the Windows users. I can still get online from Linux no matter what, although it is a bit glitchy at times. I'm leaning towards either some of the routers are failing or the cat 5 going to then has a problem of some sort. I'm going to try some sort of home made cantenna tomorrow after I go to the store to get some supplies to see if I can start connecting to one of the other routers in the other wing of the building.

I just wish I could figure out why Linux is working while Windows won't. If I walk about 50 feet down the hall I connect to a different router in Windows without any configuration changes at all, but I don't feel like sitting out in the hall any longer than necessary for some testing.
442
(15 items)
 
Q6600
(14 items)
 
Piece O' Crappola
(13 items)
 
CPUMotherboardGraphicsRAM
Q9550 E0 DFI LanParty LT P35-T2R 2 x HD4670QT512P CF Patriot PVS24G8500ELKN 
CoolingOSMonitorPower
Stock pfsense Acer H233H Antec EarthWatts 430 
CaseAudio
custom onboard 
CPUMotherboardGraphicsRAM
Q6600 B3 Lapped @ 3.4 GA-EP45-UD3R EVGA 9600GSO 384m 96SP 4G (2x2) Patriot Viper PC2-8500 
Hard DriveOptical DriveCoolingOS
80g Maxtor, 320WDC. 320Seagate NEC ND-3550 & LiteOn CM Hyper 212+ w/PP Blademasters XP Pro SP3 
MonitorPowerCase
Acer H233H Rosewill RG630-S12 NZXT BetaEVO 
CPUMotherboardGraphicsRAM
E6420 GA-P35-DS3L GeForce 7300LE 2G PNY PC2-6400 
Hard DriveOptical DriveOSMonitor
80Gig WDC SATA NEC ND3540A Win 7 Ultimate 64bit/XP Pro Acer H233H 
PowerCase
Antec Earthwatts 430 none 
  hide details  
Reply
442
(15 items)
 
Q6600
(14 items)
 
Piece O' Crappola
(13 items)
 
CPUMotherboardGraphicsRAM
Q9550 E0 DFI LanParty LT P35-T2R 2 x HD4670QT512P CF Patriot PVS24G8500ELKN 
CoolingOSMonitorPower
Stock pfsense Acer H233H Antec EarthWatts 430 
CaseAudio
custom onboard 
CPUMotherboardGraphicsRAM
Q6600 B3 Lapped @ 3.4 GA-EP45-UD3R EVGA 9600GSO 384m 96SP 4G (2x2) Patriot Viper PC2-8500 
Hard DriveOptical DriveCoolingOS
80g Maxtor, 320WDC. 320Seagate NEC ND-3550 & LiteOn CM Hyper 212+ w/PP Blademasters XP Pro SP3 
MonitorPowerCase
Acer H233H Rosewill RG630-S12 NZXT BetaEVO 
CPUMotherboardGraphicsRAM
E6420 GA-P35-DS3L GeForce 7300LE 2G PNY PC2-6400 
Hard DriveOptical DriveOSMonitor
80Gig WDC SATA NEC ND3540A Win 7 Ultimate 64bit/XP Pro Acer H233H 
PowerCase
Antec Earthwatts 430 none 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security
Overclock.net › Forums › Software, Programming and Coding › Networking & Security › Strange Internet Connectivity Problem with Windows