Overclock.net › Forums › Cooling › Water Cooling › H50 pump not working
New Posts  All Forums:Forum Nav:

H50 pump not working

post #1 of 6
Thread Starter 
The pump in my H50 is making a sound. However, the water is not flowing through the tube. What can be the problem?
My system
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom ii x6 1090t ASUS Crosshair IV 890FX EVGA GeForce GTX 580 Corsair XMS3 12GB DDR3 1600 
Hard DriveOSMonitorPower
Intel X25M 120 GB & WD 1TB Caviar Green Windows 7 64-bit 32" LG 1080p LED TV Corsair 850-Watt TX 
Case
CM HAF-X 
  hide details  
Reply
My system
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom ii x6 1090t ASUS Crosshair IV 890FX EVGA GeForce GTX 580 Corsair XMS3 12GB DDR3 1600 
Hard DriveOSMonitorPower
Intel X25M 120 GB & WD 1TB Caviar Green Windows 7 64-bit 32" LG 1080p LED TV Corsair 850-Watt TX 
Case
CM HAF-X 
  hide details  
Reply
post #2 of 6
How do you know the water is not following through the tube without physically opening the tube and checking yourself?
post #3 of 6
i would disassemble that pump and see what the deal is. should be pretty easy
Current Rig
(15 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k ASRock Extreme3 Gen3 xfx 290x Cryovenom Corsair Vengeance 
Hard DriveCoolingOSMonitor
Intel SSD CPU and GPU in common loop Windows 7 x64 Dell Ultrasharp 24" 
PowerCaseMouseMouse Pad
PC Power and Cooling 610W Coolermaster 690 II Advanced DeathAdder Old Class Notebook 
Audio
X-Fi Titanium 
  hide details  
Reply
Current Rig
(15 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k ASRock Extreme3 Gen3 xfx 290x Cryovenom Corsair Vengeance 
Hard DriveCoolingOSMonitor
Intel SSD CPU and GPU in common loop Windows 7 x64 Dell Ultrasharp 24" 
PowerCaseMouseMouse Pad
PC Power and Cooling 610W Coolermaster 690 II Advanced DeathAdder Old Class Notebook 
Audio
X-Fi Titanium 
  hide details  
Reply
post #4 of 6
Thread Starter 
Quote:
Originally Posted by mbudden View Post
How do you know the water is not following through the tube without physically opening the tube and checking yourself?
I'm trying to add an swiftech reservoir and clear tubing to my H50.

Quote:
Originally Posted by qbical View Post
i would disassemble that pump and see what the deal is. should be pretty easy
there's air blowing inside the pump when disassembled. Is that what suppose to happen?
My system
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom ii x6 1090t ASUS Crosshair IV 890FX EVGA GeForce GTX 580 Corsair XMS3 12GB DDR3 1600 
Hard DriveOSMonitorPower
Intel X25M 120 GB & WD 1TB Caviar Green Windows 7 64-bit 32" LG 1080p LED TV Corsair 850-Watt TX 
Case
CM HAF-X 
  hide details  
Reply
My system
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom ii x6 1090t ASUS Crosshair IV 890FX EVGA GeForce GTX 580 Corsair XMS3 12GB DDR3 1600 
Hard DriveOSMonitorPower
Intel X25M 120 GB & WD 1TB Caviar Green Windows 7 64-bit 32" LG 1080p LED TV Corsair 850-Watt TX 
Case
CM HAF-X 
  hide details  
Reply
post #5 of 6
There should be no air inside your pump. That's why it could seem like it's not working.
post #6 of 6
Quote:
Originally Posted by SillyCang View Post
The pump in my H50 is making a sound. However, the water is not flowing through the tube. What can be the problem?
I would start a thread over in Corsair's official support forum so at least they can acknowledge the problem and help you in case you need to RMA the cooler. Here's the link.
reaper's Scythe
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 3770k Intel DZ77GA-70K 2 x EVGA GTX 570 SLI Corsair Vengeance 16GB DDR3 
Hard DriveOptical DriveOSMonitor
Intel X25-M G2 160GB, WD 3TB Samsung SH-S223Q Windows 8 Professional Asus VH236HL-P 23" 
KeyboardPowerCaseMouse
KMAC 2 Corsair HX1000W Corsair Obsidian 800D CM Spawn 
Mouse Pad
XTRAC Pads Logic 
  hide details  
Reply
reaper's Scythe
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 3770k Intel DZ77GA-70K 2 x EVGA GTX 570 SLI Corsair Vengeance 16GB DDR3 
Hard DriveOptical DriveOSMonitor
Intel X25-M G2 160GB, WD 3TB Samsung SH-S223Q Windows 8 Professional Asus VH236HL-P 23" 
KeyboardPowerCaseMouse
KMAC 2 Corsair HX1000W Corsair Obsidian 800D CM Spawn 
Mouse Pad
XTRAC Pads Logic 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › H50 pump not working