Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Help with very slow OCZ Agility 2 brand new drive
New Posts  All Forums:Forum Nav:

Help with very slow OCZ Agility 2 brand new drive

post #1 of 8
Thread Starter 
Got a 90gb OCZ Agility 2 for xmas. I also have a 64gb super talent ssd. Both are running incredibly slow. This is on a fresh install of win 7.

I upgraded to an i7-950, and I'm using a MSI big bang Xpower motherboard.
I ran AS SSD benchmark and I'm getting 114mb/s read, and 124mb/s write, absolutely horrible.

I've tried turning on everything that says ACHI in the bios but nothing works.

Any help would be greatly appreciated.
New i7 950 build
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-950 @ 4.2ghz MSI Big Bang x58  Crossfire Sapphire 7970 OC  6gb HyperX 1600 
Hard DriveHard DriveCoolingOS
C300 64gb , Agility2 90gb, 2x WD greens Raid 0 Samsung 830 series 64gb H100 Windows 7 64bit 
MonitorPowerCase
Crossover 1440p OCZ ZX850W Lian li Pc-x2000f 
  hide details  
Reply
New i7 950 build
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-950 @ 4.2ghz MSI Big Bang x58  Crossfire Sapphire 7970 OC  6gb HyperX 1600 
Hard DriveHard DriveCoolingOS
C300 64gb , Agility2 90gb, 2x WD greens Raid 0 Samsung 830 series 64gb H100 Windows 7 64bit 
MonitorPowerCase
Crossover 1440p OCZ ZX850W Lian li Pc-x2000f 
  hide details  
Reply
post #2 of 8
Thread Starter 
Ok so I plugged my SSD into the SATA 6gb/s ports on my board to see what happened and I got better results. On AS SSD benchmark it shows m91xx instead of pciide. I'm getting 202mb/s reads on my super salent drive with samsung controller, and I'm only getting 142mb/s reads on my Agility 2.


I'm about to tell my dad to return this one and pick up the c300 like i wanted.
New i7 950 build
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-950 @ 4.2ghz MSI Big Bang x58  Crossfire Sapphire 7970 OC  6gb HyperX 1600 
Hard DriveHard DriveCoolingOS
C300 64gb , Agility2 90gb, 2x WD greens Raid 0 Samsung 830 series 64gb H100 Windows 7 64bit 
MonitorPowerCase
Crossover 1440p OCZ ZX850W Lian li Pc-x2000f 
  hide details  
Reply
New i7 950 build
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-950 @ 4.2ghz MSI Big Bang x58  Crossfire Sapphire 7970 OC  6gb HyperX 1600 
Hard DriveHard DriveCoolingOS
C300 64gb , Agility2 90gb, 2x WD greens Raid 0 Samsung 830 series 64gb H100 Windows 7 64bit 
MonitorPowerCase
Crossover 1440p OCZ ZX850W Lian li Pc-x2000f 
  hide details  
Reply
post #3 of 8
Thread Starter 
Ok, I have installed the intel drivers, now in AS SSD it shows IASTOR, which is correct right?

I have the Drive plugged into the SATA 3gb/s plug on my board. I have enabled ACHI mode in windows by doing the registry fix.

I have enabled ACHI mode in the bios (I believe it is enabled i'm not sure how to find out in windows if it actually is).

Everything seems to be configured correctly but i'm still not getting the correct read speeds from the drive.

My crappy samsung controller drive is blowing my new sandforce drive out of the water by over 60mb/s.

What else do I need to look at here?
New i7 950 build
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-950 @ 4.2ghz MSI Big Bang x58  Crossfire Sapphire 7970 OC  6gb HyperX 1600 
Hard DriveHard DriveCoolingOS
C300 64gb , Agility2 90gb, 2x WD greens Raid 0 Samsung 830 series 64gb H100 Windows 7 64bit 
MonitorPowerCase
Crossover 1440p OCZ ZX850W Lian li Pc-x2000f 
  hide details  
Reply
New i7 950 build
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-950 @ 4.2ghz MSI Big Bang x58  Crossfire Sapphire 7970 OC  6gb HyperX 1600 
Hard DriveHard DriveCoolingOS
C300 64gb , Agility2 90gb, 2x WD greens Raid 0 Samsung 830 series 64gb H100 Windows 7 64bit 
MonitorPowerCase
Crossover 1440p OCZ ZX850W Lian li Pc-x2000f 
  hide details  
Reply
post #4 of 8
not sure if it's the fault of the intel ahci driver, but i noticed better performance with the default msahci driver (Microsoft AHCI), as in, you don't need to install any drivers in Win7 unless you're running RAID.

other things to look at are your cluster size (but win7 install to SSD should set that up automatically), and make sure you're running the latest firmware.
    
CPUMotherboardGraphicsGraphics
Core i7-920 C0 4.00GHz HT Asus P6T Deluxe V2 Radeon HD5970 Radeon HD5870 
RAMHard DriveHard DriveHard Drive
12GB Mushkin DDR3-1600 Samsung Spinpoint F4 HD204UI Samsung Spinpoint F2 HD154UI Samsung Spinpoint F1 HD103UJ 
Hard DriveHard DriveOptical DriveCooling
Samsung Spinpoint F3 HD103SJ Samsung 840 Pro SSD Samsung 22X DVDRW ThermalRight Venomous-X 
OSMonitorKeyboardPower
Win7Ultimate x64 Asus VH222H Micro Innovations Antec TruePowerQuattro 850W 
CaseMouseOther
Silverstoned FT01 BW Logitech M100 Logitech G25 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
Core i7-920 C0 4.00GHz HT Asus P6T Deluxe V2 Radeon HD5970 Radeon HD5870 
RAMHard DriveHard DriveHard Drive
12GB Mushkin DDR3-1600 Samsung Spinpoint F4 HD204UI Samsung Spinpoint F2 HD154UI Samsung Spinpoint F1 HD103UJ 
Hard DriveHard DriveOptical DriveCooling
Samsung Spinpoint F3 HD103SJ Samsung 840 Pro SSD Samsung 22X DVDRW ThermalRight Venomous-X 
OSMonitorKeyboardPower
Win7Ultimate x64 Asus VH222H Micro Innovations Antec TruePowerQuattro 850W 
CaseMouseOther
Silverstoned FT01 BW Logitech M100 Logitech G25 
  hide details  
Reply
post #5 of 8
Thread Starter 
Nothing is working! I've done everything, I just got done updating the firmware and my motherboard bios. mad.gif
Still slow as hell!
ssd.jpg
New i7 950 build
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-950 @ 4.2ghz MSI Big Bang x58  Crossfire Sapphire 7970 OC  6gb HyperX 1600 
Hard DriveHard DriveCoolingOS
C300 64gb , Agility2 90gb, 2x WD greens Raid 0 Samsung 830 series 64gb H100 Windows 7 64bit 
MonitorPowerCase
Crossover 1440p OCZ ZX850W Lian li Pc-x2000f 
  hide details  
Reply
New i7 950 build
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-950 @ 4.2ghz MSI Big Bang x58  Crossfire Sapphire 7970 OC  6gb HyperX 1600 
Hard DriveHard DriveCoolingOS
C300 64gb , Agility2 90gb, 2x WD greens Raid 0 Samsung 830 series 64gb H100 Windows 7 64bit 
MonitorPowerCase
Crossover 1440p OCZ ZX850W Lian li Pc-x2000f 
  hide details  
Reply
post #6 of 8
What bios version are you running?

I'm using the intel ports, RAID 0 on my vertex 2 w/o any problems at all. Speed is superb. I'm also on the latest Xpower beta bios well as of 3 weeks ago, 1.48.

183604d1291666510-crystaldiskmark-ssd-bench-thread-crystal.png
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
post #7 of 8
Quote:
Originally Posted by strap624;11783874 
Nothing is working! I've done everything, I just got done updating the firmware and my motherboard bios. mad.gif
Still slow as hell!
ssd.jpg

The Sandforce drives don't get advertised speeds with random incompressable data like with AS SSD benchmark and CDM3 default. Try CDM3 and select all 0 or all 1's. Sandforce drives only get advertised speeds with compressable data.
    
CPUMotherboardGraphicsRAM
i7-930 Asus P6x-58D Premium HD5970+5870 950/1200 12gb Kingston HyperX 
Hard DriveOptical DriveOSMonitor
3x100GbOCZ VertexLE+2x120Gb Vertex2 RAID0 LG Win7 Professional Asus M276HE 
KeyboardPowerCaseMouse
Razer Lycosa ABS 1100watt Thermaltake SwordM Razer DeathAdder 
Mouse Pad
wowpad 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7-930 Asus P6x-58D Premium HD5970+5870 950/1200 12gb Kingston HyperX 
Hard DriveOptical DriveOSMonitor
3x100GbOCZ VertexLE+2x120Gb Vertex2 RAID0 LG Win7 Professional Asus M276HE 
KeyboardPowerCaseMouse
Razer Lycosa ABS 1100watt Thermaltake SwordM Razer DeathAdder 
Mouse Pad
wowpad 
  hide details  
Reply
post #8 of 8
Thread Starter 
hmmphh C300 is on the way!! i'm returning this agility 2
New i7 950 build
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-950 @ 4.2ghz MSI Big Bang x58  Crossfire Sapphire 7970 OC  6gb HyperX 1600 
Hard DriveHard DriveCoolingOS
C300 64gb , Agility2 90gb, 2x WD greens Raid 0 Samsung 830 series 64gb H100 Windows 7 64bit 
MonitorPowerCase
Crossover 1440p OCZ ZX850W Lian li Pc-x2000f 
  hide details  
Reply
New i7 950 build
(15 items)
 
  
CPUMotherboardGraphicsRAM
i7-950 @ 4.2ghz MSI Big Bang x58  Crossfire Sapphire 7970 OC  6gb HyperX 1600 
Hard DriveHard DriveCoolingOS
C300 64gb , Agility2 90gb, 2x WD greens Raid 0 Samsung 830 series 64gb H100 Windows 7 64bit 
MonitorPowerCase
Crossover 1440p OCZ ZX850W Lian li Pc-x2000f 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: SSD
Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Help with very slow OCZ Agility 2 brand new drive