Overclock.net › Forums › Graphics Cards › NVIDIA › Low FPS on 570 gtx
New Posts  All Forums:Forum Nav:

Low FPS on 570 gtx - Page 4

post #31 of 74
I'm tella ya ... if old games are doing funky stuff and new games are okay, with a fresh install of Win7, you should go to MS site and grab the DirectX redistrutable (don't do the automatic web download), and run/install it.

It may not fix this problem, but I've had that situation come up before where DX9 games didn't work right on a fresh install, and that fixed it. It's worth doing in any case IMHO.
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
post #32 of 74
log your clock speeds, and run games and check the ACTUAL clock speeds your gpu is running at,

league of legends is more processor based btw i had gtx 275 sli with a q6600 and then jumped over to i7 with the same clocks and same sli setup , Processor makes the difference in that game, not gpu
white phantom
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 GA X58 UD3R rev 2.0 zotac GTX 580 sli 6GB Corsair xms cl9 1600hz 
Hard DriveOptical DriveMonitorPower
Corsair ssd 32GB none asus 1080p 120hz, acer 1080p 120hz Thermaltake TR2 RX 850w 
Case
nzxt phantom 
  hide details  
Reply
white phantom
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 GA X58 UD3R rev 2.0 zotac GTX 580 sli 6GB Corsair xms cl9 1600hz 
Hard DriveOptical DriveMonitorPower
Corsair ssd 32GB none asus 1080p 120hz, acer 1080p 120hz Thermaltake TR2 RX 850w 
Case
nzxt phantom 
  hide details  
Reply
post #33 of 74
Guys ... NOTHING related to the processor (bottlenecks, cpu-dependency of a game, etc) makes sense as an answer here. His 5850 was working fine, and all he did hardware-wise is switched the GPU, and now he's getting a fraction of the his old framerate. It should be much higher (or at worst equal) no matter what is going on with the processor.

It's also very unlikely to be a PSU problem. Inadequate power can cause other problems like crashing/freezing/restarts, but it shouldn't cause uber-low FPS on random games.

Although ... since we're so low on 'options' here what PSU do you have exactly, and do have the card hooked up via 2 PCI-Ex connectors, one 8-pin and one 6-pin, coming directly from the PSU? If not, how exactly is it hooked up?
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
post #34 of 74
Thread Starter 
Quote:
Originally Posted by brettjv View Post
Guys ... NOTHING related to the processor (bottlenecks, cpu-dependency of a game, etc) makes sense as an answer here. His 5850 was working fine, and all he did hardware-wise is switched the GPU, and now he's getting a fraction of the his old framerate. It should be much higher (or at worst equal) no matter what is going on with the processor.

It's also very unlikely to be a PSU problem. Inadequate power can cause other problems like crashing/freezing/restarts, but it shouldn't cause uber-low FPS on random games.

Although ... since we're so low on 'options' here what PSU do you have exactly, and do have the card hooked up via 2 PCI-Ex connectors, one 8-pin and one 6-pin, coming directly from the PSU? If not, how exactly is it hooked up?
Yeah you get my point, I should get at worst the fps I had on that game with my old gpu.

I just went to a pc store and they borrowed me a 1000 watts cooler master silent pro gold and when I started the game league of legends was running at 218 fps and on intense fights around 100. Right now as I type im trying league of legends with my PSU which is a ocz stealth x stream 700 watts. The 570 gtx has x2 6 pin connectors...and im using 3 +12v rails(supposed to be each one at 18 amps).

Well it just loaded and it gave me 15 fps...maybe the psu has something to do also?

By the way when I was trying it with the 1000 watts psu everything was fine, i tried like 5 games but then i tried spiderman shattered dimensions and it lagged so bad,...after that all my games lagged.

This is awful....I minimized the game to write this then after i open the game again it was giving me 1 fps... 1 fps that's just incredible I had to shut down the game.

And yes inadequate PSU should give crashes or pc shutdowns(my brother had a 18 amp psu on a videocard that asked 22 amps and when the temps went to 80 the PC shut down).

Im gonna try the directx redistributable thing from microsoft.

edit. im downloading directx_aug2009_redist.exe

edit2: After directx redistributable it's still giving me low fps(15 fps).
Edited by tosen - 12/29/10 at 12:33pm
post #35 of 74
Quote:
Originally Posted by brettjv View Post
I'm tella ya ... if old games are doing funky stuff and new games are okay, with a fresh install of Win7, you should go to MS site and grab the DirectX redistrutable (don't do the automatic web download), and run/install it.

It may not fix this problem, but I've had that situation come up before where DX9 games didn't work right on a fresh install, and that fixed it. It's worth doing in any case IMHO.
Do you have a link for the directx? I was also looking for it but microsoft's download site is... fail
P.S is it this one? June 2010: http://www.microsoft.com/downloads/e...1-50ceb6d8fa8d
Edited by zefs - 12/29/10 at 12:49pm
    
CPUMotherboardGraphicsRAM
[intel] i5 2500K @ 4.5 GHz [Asus] P8Z68-V [GB] GTX 970 G1 [Kingston] HyperX Fury 1600MHz - 16GB 
Hard DriveOSMonitorPower
[Crucial] MX 100 Windows 10 64 bit [BenQ] XL2411Z [EVGA] SuperNOVA 750W G2 
Case
[Corsair] 330R 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
[intel] i5 2500K @ 4.5 GHz [Asus] P8Z68-V [GB] GTX 970 G1 [Kingston] HyperX Fury 1600MHz - 16GB 
Hard DriveOSMonitorPower
[Crucial] MX 100 Windows 10 64 bit [BenQ] XL2411Z [EVGA] SuperNOVA 750W G2 
Case
[Corsair] 330R 
  hide details  
Reply
post #36 of 74
Thread Starter 
I believe he meant that one:

http://www.microsoft.com/downloads/e...1-442d8712d553

It worked for him, not for me...maybe it works for you!
post #37 of 74
Quote:
Originally Posted by tosen View Post
I believe he meant that one:

http://www.microsoft.com/downloads/e...1-442d8712d553

It worked for him, not for me...maybe it works for you!
That's... last year's
Try the one that I linked.
    
CPUMotherboardGraphicsRAM
[intel] i5 2500K @ 4.5 GHz [Asus] P8Z68-V [GB] GTX 970 G1 [Kingston] HyperX Fury 1600MHz - 16GB 
Hard DriveOSMonitorPower
[Crucial] MX 100 Windows 10 64 bit [BenQ] XL2411Z [EVGA] SuperNOVA 750W G2 
Case
[Corsair] 330R 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
[intel] i5 2500K @ 4.5 GHz [Asus] P8Z68-V [GB] GTX 970 G1 [Kingston] HyperX Fury 1600MHz - 16GB 
Hard DriveOSMonitorPower
[Crucial] MX 100 Windows 10 64 bit [BenQ] XL2411Z [EVGA] SuperNOVA 750W G2 
Case
[Corsair] 330R 
  hide details  
Reply
post #38 of 74
Thread Starter 
Quote:
Originally Posted by zefs View Post
That's... last year's
Try the one that I linked.
Thanks, now I see again a little light of hope. Downloading atm.

Edit: Well I downloaded it and extracted the files on a folder on desktop, then proceed to run the dxsetup, installed and told me it has been installed....where do I place the folder on desktop now?

Trying a game meanwhile...
Edited by tosen - 12/29/10 at 1:21pm
post #39 of 74
What do you mean you're using 3 12V+ rails to run your card? You should be using the two PCI-Ex 6-pin cables coming out of your PSU, is that what you're doing, or not? How is the card physically hooked up?

Not that it matters with regards to this problem since it sounds like what you're saying is that you still have problems even with the 1000W unit, right?

So ... does everything work okay until you first alt-tab out of some game? And are you running games in full-screen mode?
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
post #40 of 74
Thread Starter 
Quote:
Originally Posted by brettjv View Post
What do you mean you're using 3 12V+ rails to run your card? You should be using the two PCI-Ex 6-pin cables coming out of your PSU, is that what you're doing, or not? How is the card physically hooked up?

Not that it matters with regards to this problem since it sounds like what you're saying is that you still have problems even with the 1000W unit, right?

So ... does everything work okay until you first alt-tab out of some game? And are you running games in full-screen mode?
Yes, my PSU has x2 PCI Express cables, im using those.

The card is hooked up to a PCI Express, the same way the 5850 was hooked up.

Yes, still problems with the 1000 watts PSU but I was able to get for a game 200 fps something right now Im not even able to get past 20 fps.

The game was working for 20 fps, then I alt tab to type here, came back to the game and it was at 1-3 fps, so I quit the game.

Yes, full screen mode, but full screen mode has never been a problem for me in any game except for Call of Duty black ops that is a big CPU demandant game, unlike Metro 2033 that is GPU hungry.

The game called Amnesia the dark descent is about to finish downloading, then I install and then i reboot pc...since I just installed Directx redist june 2010.

Oh also EVGA support told me something about memory timings if they were manually set...this is the info my BIOS is giving me:

Regarding the manual memory it was automatic, on manual it appears this:

Cannot be changed:

Current memory speed 800 mhz
Current memory setting 5-5-5-18

Can be changed:

Memory frequency: 667MHz( with the options of 667,800,1066,1333,1600) However the memory is 800 MHz.
tCL: 4 (can be changed from 3 to 10)
tRCD: 5 ( can be changed from 3 to 11)
tRP: 5 (can be changed from 3 to 11)
tRASmin: 13 (can be changed from 9 to 28)

-----------------------------------------------------------------------------------------------------------------------------

PCI Express Configuration
PEG Negotiated Width 16(Cannot be changed)

Compliance Test pattern Disable ( Can be changed to Enable)

-----------------------------------------------------------------------------------------------------------------------------

PCI Latency Timer 32( Can be chaged to 64,96,128,160,192,224,248)
HPET Disable )Can be changed to Enable)
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › Low FPS on 570 gtx