Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Dual boot Windows 7 & Vista on SSD and 2x HDD's in RAID0
New Posts  All Forums:Forum Nav:

Dual boot Windows 7 & Vista on SSD and 2x HDD's in RAID0

post #1 of 4
Thread Starter 
What I wanted

Right here is my situation. I have been running Windows Vista 64 for about 3 years off of 2 HDD's in RAID0 and I just got a 60GB SSD which I wanted to install Windows 7 on it and still be able to dual boot my Vista 64 from my RAIDED drives. And then shrink the partition on my RAIDED drives to roughly 50% and create a new partition on them for my Windows 7 install to also be able to use to install programs and files. Which I was told elsewhere is totally possible.

Windows 7 Install

When installing Windows 7 on my SSD I couldn't get it to install with the SATA MODE in the BIOS set to RAID, it would say "cannot install to this disc, check if its enabled in BIOS". So I had to set it to AHCI MODE, which worked, so I unplugged every drive in my system and installed Windows 7 on the SSD like this. Maybe I should have installed it with my RAID drives plugged in, but they would be in JBOD arrangement then as I could only install in AHCI MODE.

Problem

So the problem is when I plug my RAIDED drives back in they will only boot when the MODE in the BIOS is set to RAID but then the Windows 7 on the SSD doesn't boot as that only boots when the MODE is set to AHCI. In my BIOS the SSD is only visible in AHCI MODE, my RAID drives are visible in both MODES but as Intel_Array in RAID MODE and as 2 seperate drives in AHCI mode.

So I am in a bit of a pickle and not sure what to do... I don't mind have to change the SATA MODE settings in the BIOS to dual boot back and forth, but will I be able to shrink and re-partition the RAID drive so Windows 7 can use them? With the MODE set to AHCI I can boot to Windows 7 from the SSD, and after installing the Intel Rapid Maxtrix Storage Controller I can access most files on the RAID array so it does detect the RAID array even when its set to AHCI but will not boot the RAID array in this MODE.

I fear the problem may be with my BIOS, Motherboard or the Storage Drivers as the RAID mode should be able to support a RAID array aswell as a stand alone drives using AHCI. But for me it seems when I enable RAID MODE, AHCI fails to work on the SSD. This could be because I installed it on the AHCI MODE but thats all I could do.

Solutions?

There is 3 ways I think it could be solved:

1) Make the SSD able to boot in RAID Mode
2) Use Acronis to make an image of my Vista install and put it on my single 640GB Western Digital drive and boot Vista from that. Then reformat my RAID clean and let Windows 7 use it all as an extra drive (which works in AHCI from what I can tell).
3) Re-install Windows 7 with the RAID drives plugged in, but this would still be in AHCI mode, not sure if it will make a difference because I cannot boot the RAID in AHCI mode after installing anyway.


My drives:

2x 250GB Western Digital in RAID0 booting with VISTA 64 (for about 3 years).
1x 60GB NEW Corsair SSD with Windows 7 (64) on it.
1x 640GB Western Digital Storage drive (currently unplugged).
Turismo
(13 items)
 
  
CPUMotherboardGraphicsRAM
E2160 @ 3.0GHz (BIOS 1.315v) (CPU-Z 1.272v) Abit IP35 "Dark Raider" ATI 512MB HD3850 (720/1800) 4GB Crucial Ballistix PC2-6400 
Hard DriveOptical DriveOSMonitor
Corsair Force F60 + 640GB WD 2x250GB WD RAID0 Sony NEC 20x Dual Layer DVD±RW Windows 7 Ultimate 64 20.1' Belinea @ 1680x1050 
KeyboardPowerCaseMouse
Logitech Corsair 450W VX 12V@33A CM690 + Zalman MFC1 Wolf King Trooper 
  hide details  
Reply
Turismo
(13 items)
 
  
CPUMotherboardGraphicsRAM
E2160 @ 3.0GHz (BIOS 1.315v) (CPU-Z 1.272v) Abit IP35 "Dark Raider" ATI 512MB HD3850 (720/1800) 4GB Crucial Ballistix PC2-6400 
Hard DriveOptical DriveOSMonitor
Corsair Force F60 + 640GB WD 2x250GB WD RAID0 Sony NEC 20x Dual Layer DVD±RW Windows 7 Ultimate 64 20.1' Belinea @ 1680x1050 
KeyboardPowerCaseMouse
Logitech Corsair 450W VX 12V@33A CM690 + Zalman MFC1 Wolf King Trooper 
  hide details  
Reply
post #2 of 4
Does your motherboard have more than one SATA controller? Mine has 3...

You'd need to have the RAID on one controller and the SSD on the other.
 
Gateway LT2207h
(13 items)
 
 
CPUMotherboardGraphicsRAM
AMD Phenom II X4 955 BE @ 3.9GHz Gigabyte GA-870A-UD3 MSI GTX 460 1GB @ 850/1700/2112 12GB DDR3 1600 8-8-8-21 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 64GB Samsung Spinpoint F3 1TB Asus 24x DVD burner Corsair H70 
OSMonitorKeyboardPower
Windows 7 64-bit Samsung P2370HD Logitech G15 Corsair TX750W 
CaseMouseAudioAudio
Antec 300 Illusion Logitech G500 ASUS Xonar DG Sony MDR-V6 
Audio
Altec Lansing VS4621 
CPUMotherboardGraphicsRAM
AMD Athlon II Neo K125 @ 1.7GHz Gateway JV01-NL Radeon HD 4225 2GB DDR3 800 6-6-6-15 
Hard DriveOSMonitorPower
Seagate Momentus XT 500GB Windows 7 HP 32-bit 10.1" LCD 6-cell Lithium Ion battery 
  hide details  
Reply
 
Gateway LT2207h
(13 items)
 
 
CPUMotherboardGraphicsRAM
AMD Phenom II X4 955 BE @ 3.9GHz Gigabyte GA-870A-UD3 MSI GTX 460 1GB @ 850/1700/2112 12GB DDR3 1600 8-8-8-21 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 64GB Samsung Spinpoint F3 1TB Asus 24x DVD burner Corsair H70 
OSMonitorKeyboardPower
Windows 7 64-bit Samsung P2370HD Logitech G15 Corsair TX750W 
CaseMouseAudioAudio
Antec 300 Illusion Logitech G500 ASUS Xonar DG Sony MDR-V6 
Audio
Altec Lansing VS4621 
CPUMotherboardGraphicsRAM
AMD Athlon II Neo K125 @ 1.7GHz Gateway JV01-NL Radeon HD 4225 2GB DDR3 800 6-6-6-15 
Hard DriveOSMonitorPower
Seagate Momentus XT 500GB Windows 7 HP 32-bit 10.1" LCD 6-cell Lithium Ion battery 
  hide details  
Reply
post #3 of 4
Well looking at your motherboard, it just has the 6 sata ports right? You might have to buy an add-on card.
 
Gateway LT2207h
(13 items)
 
 
CPUMotherboardGraphicsRAM
AMD Phenom II X4 955 BE @ 3.9GHz Gigabyte GA-870A-UD3 MSI GTX 460 1GB @ 850/1700/2112 12GB DDR3 1600 8-8-8-21 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 64GB Samsung Spinpoint F3 1TB Asus 24x DVD burner Corsair H70 
OSMonitorKeyboardPower
Windows 7 64-bit Samsung P2370HD Logitech G15 Corsair TX750W 
CaseMouseAudioAudio
Antec 300 Illusion Logitech G500 ASUS Xonar DG Sony MDR-V6 
Audio
Altec Lansing VS4621 
CPUMotherboardGraphicsRAM
AMD Athlon II Neo K125 @ 1.7GHz Gateway JV01-NL Radeon HD 4225 2GB DDR3 800 6-6-6-15 
Hard DriveOSMonitorPower
Seagate Momentus XT 500GB Windows 7 HP 32-bit 10.1" LCD 6-cell Lithium Ion battery 
  hide details  
Reply
 
Gateway LT2207h
(13 items)
 
 
CPUMotherboardGraphicsRAM
AMD Phenom II X4 955 BE @ 3.9GHz Gigabyte GA-870A-UD3 MSI GTX 460 1GB @ 850/1700/2112 12GB DDR3 1600 8-8-8-21 
Hard DriveHard DriveOptical DriveCooling
Crucial M4 64GB Samsung Spinpoint F3 1TB Asus 24x DVD burner Corsair H70 
OSMonitorKeyboardPower
Windows 7 64-bit Samsung P2370HD Logitech G15 Corsair TX750W 
CaseMouseAudioAudio
Antec 300 Illusion Logitech G500 ASUS Xonar DG Sony MDR-V6 
Audio
Altec Lansing VS4621 
CPUMotherboardGraphicsRAM
AMD Athlon II Neo K125 @ 1.7GHz Gateway JV01-NL Radeon HD 4225 2GB DDR3 800 6-6-6-15 
Hard DriveOSMonitorPower
Seagate Momentus XT 500GB Windows 7 HP 32-bit 10.1" LCD 6-cell Lithium Ion battery 
  hide details  
Reply
post #4 of 4
Thread Starter 
Yeah all 6 are on the Intel cntrl. After digging it looks like I has a too old version (v7.0) of the intel rom ahci controller needs to be v8 or higher and I have no bios updates from abit as it's bust.

So yeah raid card is the only way but they aren't cheap so not worth it IMO.
Edited by OCZedd - 12/31/10 at 2:45am
Turismo
(13 items)
 
  
CPUMotherboardGraphicsRAM
E2160 @ 3.0GHz (BIOS 1.315v) (CPU-Z 1.272v) Abit IP35 "Dark Raider" ATI 512MB HD3850 (720/1800) 4GB Crucial Ballistix PC2-6400 
Hard DriveOptical DriveOSMonitor
Corsair Force F60 + 640GB WD 2x250GB WD RAID0 Sony NEC 20x Dual Layer DVD±RW Windows 7 Ultimate 64 20.1' Belinea @ 1680x1050 
KeyboardPowerCaseMouse
Logitech Corsair 450W VX 12V@33A CM690 + Zalman MFC1 Wolf King Trooper 
  hide details  
Reply
Turismo
(13 items)
 
  
CPUMotherboardGraphicsRAM
E2160 @ 3.0GHz (BIOS 1.315v) (CPU-Z 1.272v) Abit IP35 "Dark Raider" ATI 512MB HD3850 (720/1800) 4GB Crucial Ballistix PC2-6400 
Hard DriveOptical DriveOSMonitor
Corsair Force F60 + 640GB WD 2x250GB WD RAID0 Sony NEC 20x Dual Layer DVD±RW Windows 7 Ultimate 64 20.1' Belinea @ 1680x1050 
KeyboardPowerCaseMouse
Logitech Corsair 450W VX 12V@33A CM690 + Zalman MFC1 Wolf King Trooper 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Operating Systems
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Dual boot Windows 7 & Vista on SSD and 2x HDD's in RAID0