Overclock.net › Forums › Components › Sound Cards and Computer Audio › Troubles playing 5.1 through my 5850 via HDMI directly to the receiver
New Posts  All Forums:Forum Nav:

Troubles playing 5.1 through my 5850 via HDMI directly to the receiver - Page 2

post #11 of 19
Thread Starter 
Quote:
Originally Posted by astrallite View Post
You need bluray software like arcsoft total threater to either bitstream or decode HD codes.
So DTS and all the other encoders are limited to only if the output is in that format? Is there a way to have the video card output DTS similar to what my sound card was doing?
Edited by Domino - 12/31/10 at 7:58pm
post #12 of 19
Thread Starter 
Sorry for all the newbie questions.

Is there a way to shy away from PCM mode on hdmi? I would like to be able to have all 5.1 channels (or even use a encoder) while gaming. Windows has the settings to be played back at 5.1, along with the 5.1 tests working fine. However if played in games such as COHO it does not play back 5.1 and furthermore my receiver only shows PCM. Any ideas on how to fix?
Edited by Domino - 12/31/10 at 8:13pm
post #13 of 19
Ok...Let's get the info on how you are running your system.
The HDMI cable is coming out of your vid card into what?
I'm going to assume it's going into a receiver? As I don't know of any PC speaker systems that use HDMI.
If for some reason you are running the HDMI into your monitor and then somehow running speakers from the monitor, the HDMI DTS signal will NOT pass through to the 3.5 jack that's running your speakers.
If you ARE running through a receiver that handles 5.1, the only thing I can think is that the HDMI connection is somehow limiting itself to 2.0 for some reason, being as I assume COHO doesn't put out a recognized 5.1 or higher digitally signed signal for the HDMI to use.
I'm just guessing here.
Edit: There is no way to force your card to output DTS if the source doesn't have it. It's like trying to make a CD player use a vinyl LP, it's just not how it works.
Blue Fury
(19 items)
 
  
CPUMotherboardGraphicsRAM
AMD A8 6600k asus Sapphire 290X Tri-OCX 4GB 2x4 (8)GB G-Skill Ripjaws 1600 
Hard DriveHard DriveHard DriveHard Drive
OCZVertex3 60GB Seagate 1TB WD 500GB Samsung 
Hard DriveOptical DriveCoolingOS
Samsung Evo 850 ASUS DVDRW24x Corsair H100 W10 
MonitorKeyboardPowerCase
55" 4k Hisense Razer Blackwidow Ultimate 2013 Corsair CX750 AzzA Hurrican 
MouseMouse PadAudio
Razer Deathadder 3500 Diablo3 RoS LE onboard 
  hide details  
Reply
Blue Fury
(19 items)
 
  
CPUMotherboardGraphicsRAM
AMD A8 6600k asus Sapphire 290X Tri-OCX 4GB 2x4 (8)GB G-Skill Ripjaws 1600 
Hard DriveHard DriveHard DriveHard Drive
OCZVertex3 60GB Seagate 1TB WD 500GB Samsung 
Hard DriveOptical DriveCoolingOS
Samsung Evo 850 ASUS DVDRW24x Corsair H100 W10 
MonitorKeyboardPowerCase
55" 4k Hisense Razer Blackwidow Ultimate 2013 Corsair CX750 AzzA Hurrican 
MouseMouse PadAudio
Razer Deathadder 3500 Diablo3 RoS LE onboard 
  hide details  
Reply
post #14 of 19
Thread Starter 
Quote:
Originally Posted by Nixuz View Post
Ok...Let's get the info on how you are running your system.
The HDMI cable is coming out of your vid card into what?
I'm going to assume it's going into a receiver? As I don't know of any PC speaker systems that use HDMI.
If for some reason you are running the HDMI into your monitor and then somehow running speakers from the monitor, the HDMI DTS signal will NOT pass through to the 3.5 jack that's running your speakers.
If you ARE running through a receiver that handles 5.1, the only thing I can think is that the HDMI connection is somehow limiting itself to 2.0 for some reason, being as I assume COHO doesn't put out a recognized 5.1 or higher digitally signed signal for the HDMI to use.
I'm just guessing here.
Edit: There is no way to force your card to output DTS if the source doesn't have it. It's like trying to make a CD player use a vinyl LP, it's just not how it works.
I have it set up as following:

The 5850 has a DVI-D heading to my monitor. The HDMI output is heading directly to the Pioneer 520 Receiver. There is sound playback, but is only in PCM mode. I've just recently found out that is a 2.0 channel mode.

Under "sound" I have it selected as my default audio device. The output is in 24-bit 192'000. It states that it has support for 8 channels, HDCP, and bit depths of 16, 20, and 24-bit. Sample rates go from 32.0 kHz to 192.0 kHz. The encoded formats are DTS Audio/DD Plus, DTS-HD, Dolby TrueHD, and Dolby Digital. Both "allow applications to take exclusive control of this device" and "Give exclusive mode applications priory" is checked. Furthermore, the speaker configuration in windows is set to 5.1. Using the test also confirms that (might be good to say that there is a sort of delay between channel playback).

The 5850 also recognizes the receiver as a monitor as well. Under the display settings I must have "duplicate these displays" in order for the HDMI "playback" option to be available. If I force the display settings to only use my normal monitor it disables the HDMI playback option.

On my sound card I was able to force DTS on the coaxial cable. DTS would also show up on my receiver. From there it would generate the surround sound from the source for all my gaming uses. Even in company of heroes online (COHO).


Cheers for the help so far guys.

Edit: Just an update, I think the problem could arise from my monitors internal speakers? Could it be possible that since my monitor has built in speakers that it is coming into conflict with the amp? I know my soundcard did not have any issues, but by default the main display is the ASUS monitor. Would the 5850 detect the speakers from the monitor as well (there is no HDMI connection, only a single 3.5 mm plug that you can connect directly from the computer to the screen itself. I'm not using those speakers, but just throwing this out there. Is there a way to bypass the audio directly to the amp and have the amp do the encoding?
Edited by Domino - 1/1/11 at 12:20am
post #15 of 19
The first thing you should do is to make sure you are not setting your HDMI output to 192KHz. This can result in some quirkiness with Windows 7 HDMI audio.

The second thing to do is to make sure to disable your monitor's sound if it is showing up in the Hardware and Sound control panel.

Third is to make sure that your HDMI output device in the Hardware and Sound are configured to 5.1. Sometimes this can reset if you are turning the receiver and monitor in different order.

Fourth, try this below:
----------------------------------------------------------------------


http://www.lindberg.no/hires/test/2L...4_mch_96k.flac

To download audio, provide the username HD and the password 2L
--------------------------------------------------------------------------

Play this and see if you get sound from all channels. This is a 5.1 channel FLAC file.

If the above file works, and your HDMI 5.1/7.1 speaker test is working properly, then your game should work properly.

If 5.1 gaming sound still doesn't work, go back into the Hardware and Sound control panel, and select 7.1 mode, and for ambient speakers, enable only the surrounds or only the surround backs, and test it again in the game.
DOS Gaming Beast
(13 items)
 
  
CPUGraphicsRAMHard Drive
Intel 3770k @ 4.3GHz GTX Titan @ 1136MHz 16GB DDR3 1600 CAS 8 OCZ Vertex EX 
OSMonitorPowerCase
Windows 7 Ultimate 32" 32LG70 IPS 120Hz LCD TV Corsair 1000W Coolermaster Cosmos 1000S 
  hide details  
Reply
DOS Gaming Beast
(13 items)
 
  
CPUGraphicsRAMHard Drive
Intel 3770k @ 4.3GHz GTX Titan @ 1136MHz 16GB DDR3 1600 CAS 8 OCZ Vertex EX 
OSMonitorPowerCase
Windows 7 Ultimate 32" 32LG70 IPS 120Hz LCD TV Corsair 1000W Coolermaster Cosmos 1000S 
  hide details  
Reply
post #16 of 19
Thread Starter 
Quote:
Originally Posted by astrallite View Post
The first thing you should do is to make sure you are not setting your HDMI output to 192KHz. This can result in some quirkiness with Windows 7 HDMI audio.

The second thing to do is to make sure to disable your monitor's sound if it is showing up in the Hardware and Sound control panel.

Third is to make sure that your HDMI output device in the Hardware and Sound are configured to 5.1. Sometimes this can reset if you are turning the receiver and monitor in different order.

Fourth, try this below:
----------------------------------------------------------------------


http://www.lindberg.no/hires/test/2L...4_mch_96k.flac

To download audio, provide the username HD and the password 2L
--------------------------------------------------------------------------

Play this and see if you get sound from all channels. This is a 5.1 channel FLAC file.

If the above file works, and your HDMI 5.1/7.1 speaker test is working properly, then your game should work properly.

If 5.1 gaming sound still doesn't work, go back into the Hardware and Sound control panel, and select 7.1 mode, and for ambient speakers, enable only the surrounds or only the surround backs, and test it again in the game.
I'll give it a shot the next time I'm in the other house. Right now I'm just up North going to school and now and then, once every couple weeks, I get to head down. I've tried different kHz outputs and it didn't change anything. Surprisingly when I do the windows 5.1 speaker test, it is able to distinguish between each individual speaker.

Just another question. Would I need different drivers other than the ATI audio drivers? I've heard people had more success if they also had realtek drivers installed as well. I tend to not install them as it comes into conflict with the auzentech card, let alone enable the audio processing in bios for the intergraded HD4250 and the integraded audio card.
post #17 of 19
If you install Realtek's HDMI driver off of their website all it does is control motherboard HDMI output. I tried it and it doesn't do anything for the ATI GPUs.
DOS Gaming Beast
(13 items)
 
  
CPUGraphicsRAMHard Drive
Intel 3770k @ 4.3GHz GTX Titan @ 1136MHz 16GB DDR3 1600 CAS 8 OCZ Vertex EX 
OSMonitorPowerCase
Windows 7 Ultimate 32" 32LG70 IPS 120Hz LCD TV Corsair 1000W Coolermaster Cosmos 1000S 
  hide details  
Reply
DOS Gaming Beast
(13 items)
 
  
CPUGraphicsRAMHard Drive
Intel 3770k @ 4.3GHz GTX Titan @ 1136MHz 16GB DDR3 1600 CAS 8 OCZ Vertex EX 
OSMonitorPowerCase
Windows 7 Ultimate 32" 32LG70 IPS 120Hz LCD TV Corsair 1000W Coolermaster Cosmos 1000S 
  hide details  
Reply
post #18 of 19
Quote:
Originally Posted by Domino View Post
Not yet, I don't have a bluray player on the PC. Which setting is best? I only could select PCM right now, but the moment it uses a better encoder it would auto switch to that format correct?
I had the 520-K.

When it's connected via HDMI through your graphics card (the best way to set it up), if your card ends up sending out a display setting, just select "duplicate display" with one of your actual screens (unless if you use the HDMI passthrough for video on a television).

Anyways, PCM is a proper signal. However, the unfortunate part about the 520-K (and other Pioneer receivers) is that when you are sending a lossless HDMI signal, you can't use the receiver to upmix the signal to surround (if you're playing 2-channel music). You can select "extended stereo", which uses all the speakers, but that's just extended stereo (still nice though). It will switch from PCM to Dolby whatever when you are using a surround signal (it will stay PCM in games which support surround and it will be proper surround, so you know).
    
CPUMotherboardGraphicsRAM
Intel i7 2600k Asus P8P67 Pro Sapphire 5770 1GB 8GB 1600MHz G.Skill 
Hard DriveOptical DriveOSMonitor
1TB WD Blue SATA3 CD/DVD & Bluray Windows 7 27" BenQ 
KeyboardPowerCaseMouse
Das Professional 850W Silverstone Strider NZXT Phantom (Black) Rat 7 
Mouse Pad
Steelseries SX 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel i7 2600k Asus P8P67 Pro Sapphire 5770 1GB 8GB 1600MHz G.Skill 
Hard DriveOptical DriveOSMonitor
1TB WD Blue SATA3 CD/DVD & Bluray Windows 7 27" BenQ 
KeyboardPowerCaseMouse
Das Professional 850W Silverstone Strider NZXT Phantom (Black) Rat 7 
Mouse Pad
Steelseries SX 
  hide details  
Reply
post #19 of 19
Thread Starter 
Quote:
Originally Posted by PaulWog View Post
I had the 520-K.

When it's connected via HDMI through your graphics card (the best way to set it up), if your card ends up sending out a display setting, just select "duplicate display" with one of your actual screens (unless if you use the HDMI passthrough for video on a television).

Anyways, PCM is a proper signal. However, the unfortunate part about the 520-K (and other Pioneer receivers) is that when you are sending a lossless HDMI signal, you can't use the receiver to upmix the signal to surround (if you're playing 2-channel music). You can select "extended stereo", which uses all the speakers, but that's just extended stereo (still nice though). It will switch from PCM to Dolby whatever when you are using a surround signal (it will stay PCM in games which support surround and it will be proper surround, so you know).
Alright. That is what I ended up doing too, telling it to duplicate displays.

However I do have it set to 5.1 on games/windows/etc. but still only gives the PCM and stereo sound (no sound coming from the center and rears). Even on games it does not switch to Dolby/DTS and give the rear speakers any sound. When I get back I'm going to try all the things suggested but can't right now.

I was also wondering if maybe I should try using the HD4290 to do the audio out? As it is not the main display, would I get better luck with 5.1?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Troubles playing 5.1 through my 5850 via HDMI directly to the receiver