Overclock.net › Forums › Components › Hard Drives & Storage › Little problem with Scorpio Blue WD5000BEVT
New Posts  All Forums:Forum Nav:

Little problem with Scorpio Blue WD5000BEVT

post #1 of 6
Thread Starter 
Yesterday I installed two Scorpio Blue WD5000BEVT in RAID 0 as storage.

It seems that they sleep after sometime without being used, and that annoys me, because when trying to access then you have to wait 1 to 3 seconds until they are ready, and when listening to music, the music starts (RAID is geting information from one HHD) and then freezes (RAID is trying to get information from the other HHD) for about the same time.

Is there a way to fiz that? Can I disable these feature?

Thanks!!!
post #2 of 6
Quote:
Originally Posted by Rafael Vale;11842554 
Yesterday I installed two Scorpio Blue WD5000BEVT in RAID 0 as storage.

It seems that they sleep after sometime without being used, and that annoys me, because when trying to access then you have to wait 1 to 3 seconds until they are ready, and when listening to music, the music starts (RAID is geting information from one HHD) and then freezes (RAID is trying to get information from the other HHD) for about the same time.

Is there a way to fiz that? Can I disable these feature?

Thanks!!!

Q: Have you checked Western Digital's website for info on this? Seems to me they should have a utility to adjust sleep time.
(BTW: If you find ANY info- be sure to POST BACK your findings, links to files etc.)

Q: I think I read something on Newegg about Raid problems- you might want to check the feedback section for drive.
(Via Firefox you can easily search for words on a page- don't know about IE.)


PS: Bad idea to use the RAID 0 for storage.... That's a good way to lose allot of data.

When a drive fails the file system cannot cope with such a large loss of data and coherency since the data is "striped" across all drives (the data cannot be recovered without the missing disk). Data can be recovered using special tools, however, this data will be incomplete and most likely corrupt, and data recovery is typically very costly and not guaranteed.


http://en.wikipedia.org/wiki/Standard_RAID_levels#RAID_0_failure_rate

.
post #3 of 6
Found some info...

By Yitsel.
So after one of my WD20EADS 2tb Green drives failed I came across some research on other forums that pointed out that one of the features of the Western Digital green drives is "Intellipark".

What is Intellipark you ask? Well its a "feature" on these green drives that parks the head every x seconds of inactivity, the default being 8 seconds for both read & write. This feature is fine for Windows, but as I am running my disks in RAID 1 on a Linux machine with many reads & not many writes, I encountered some problems.

Because these disks are being used in Linux, it basically causes unending park/unparks of the head, due to the way Linux's I/O works. It is my understanding that Linux reads data into a buffer every 20 seconds, so therefore the data was being read, then 8 seconds later the head was being parked, then another 12 seconds later more data was read.

Can you see the problem?

Another issue consumers are experiencing is the disk being kicked out of a RAID array due to Time Limited Error Recovery being disabled. TLER is a feature available on Western Digital's premium, higher-priced range of RAID enabled drives, and luckily, we can enable it on our green drives smile.gif

Fortunately there are ways around these issues.

DISCLAIMER: Perform these tweaks at your own peril! I've heard reports that this may void your warranty. Hell you will probably lose data too so don't forget to back up!

To enable these fixes, you will need to unplug any drives you do not wish to apply these fixes to, and then you will need to boot into DOS using your favourite boot disk.

To fix the head parking issue:
A utility once released by Western Digital called WDIDLE3.EXE
is available from http://www.synology.com/support/faq_show.php?lang=enu&q_id=407

What this utility does is allows you to change the time until the head is parked on your drive(s), or disable it completely.

USAGE:
WDIDLE3 [/S[]] [/D] [/R] [/?]
where:
/S[] Set timer, units in seconds. Default=8.0 (8.0 seconds).
Resolution is 0.1 seconds from 0.1 to 12.7 seconds.
Resolution is 30 seconds from 30 seconds to 300000 seconds.
Note, times between 12.8 and 30 seconds will be set to 30 seconds.
/D Disable timer.
/R Report current timer.
/? This help info.

Simply running "wdidle3 /D" should be enough to disable Intellipark, but if you run into issues, I've read that "wdidle3 /S0" works instead. Either that or you can set it to some ridiculously huge amount.

To enable TLER:
You will need the WDTLER utility available here: http://shifteightgeneration.com/content/wdtler-fix-tler-setting-wd-desktop-hard-drives

First of all, make sure your drives are in "IDE Mode" in your BIOS settings.

You can simply run "TLER-ON" to enable TLER with a default of 7 seconds, and "TLER-OFF" to turn it off. Both of these are batch files included with the utility. If you are running off a hardware RAID card, I recommend you check with your manufacturer as to what to set your TLER setting to.

I can confirm that both of these utilities work on my replacement WD20EADS-00R6B0 which I received today & was eager to apply these fixes to. I'm awaiting my other drive to fail so that it can be replaced under warranty before I bother with it, the head has probably been parked more than I want to think about!

I really hope this helps someone as I had to search about 20 different threads on Google to get the info I was looking for.
Edited by WeAreNotAlone - 12/31/10 at 11:40pm
post #4 of 6
Another useful tip regarding WD's wdidle3 utility:

You need to have 2GB of ram or less and boot into DOS and use WD's wdidle3 utility. Also if using Intel sata ports make sure you update the driver to the latest from 12-15-2010. I also had to update my BIOS as well. Make sure you format the drives using Windows 7 or know what you're doing otherwise.
post #5 of 6
http://www.storagereview.com/how_stop_excessive_load_cycles_western_digital_2tb_caviar_green_wd20ears_wdidle3

Changing Idle3 Timer on Western Digital drives
http://www.youtube.com/v/gqY5zlCXQmU



Search for "use WDIDLE3 to increase the idle time before parking" .
http://forums.audioholics.com/forums/archive/index.php/t-69637.html


http://forums.whirlpool.net.au/archive/1367904

http://www.geekstogo.com/forum/topic/285453-whats-the-optimal-time-in-seconds-for-hard-drives-to-park-heads/page__p__1896472#entry1896472


http://community.wdc.com/t5/Desktop/APM-and-Head-parking-on-a-Scorpio-Blue-drive/td-p/48155

http://www.google.com/search?q=wd+drive+park+heads+delay&ie=utf-8&oe=utf-8&aq=t&rls=org.mozilla:en-US:official&client=firefox-a

http://hardforum.com/forumdisplay.php?f=29


http://www.sagaforce.com/~sound/wdantiparkd/
Quote:
I recently bought a Western Digital Green drive (WD10EADS-00M2B0) for my Kurobox Pro and discovered that it made a constant clicking sound every x seconds. After doing some internet research, the clicking comes from the head parking feature of the WD Green drives. In order to conserve power, WD Green hard drives have a feature called "Intellipark" which unintelligently parks the drive's head after 8 seconds of inactivity. While this feature works great in USB enclosures, when used as the main drive on any operating system, the drive's head is frequently unparked due to filesystem synchronization mechanisms. This results in LLC (Load/Unload Cycles) counts of as high as 100 per hour. As WD Green hard drives are rated for 300000 cycles, the limit can be reached within months.

My KuroBox Pro idles most of the time, but over a period of 80 hours, the harddrive has racked up over 5000 LLC! This is unacceptable! Therefore I have come up with a simple solution which reduces the LLC count and at the same time makes use of Intellipark to save power when the disk is idle!

More information:
http://www.silentpcreview.com/forums/viewtopic.php?t=51401
http://forum.synology.com/enu/viewforum.php?f=124
Hard drives affected

Most (well, all of the) Western Digital Green drives. To see if your drive is affected, use smartctl.

smartctl -a /dev/sda

Take Load_Cycle_Count and divide it by Power_On_Hours and if the value is > 50, your drive is affected.

Edited by WeAreNotAlone - 1/1/11 at 12:35am
post #6 of 6
Thread Starter 
Thank You Very Much WeAreNotAlone!!!

Ill try to fix the problem with those tips you gave and then post the results.

You definitely deserves a REP+

Thanks again!!!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Hard Drives & Storage
Overclock.net › Forums › Components › Hard Drives & Storage › Little problem with Scorpio Blue WD5000BEVT