Overclock.net › Forums › Video Games › PC Gaming › problem with GTA4
New Posts  All Forums:Forum Nav:

problem with GTA4

post #1 of 18
Thread Starter 
Hi!

I am having problems with my setup and playing GTA 4. I have a i7 920 @ 4.2ghz and a 6970 graphics card, and when I run the benchmark on maximum settings I get about 45 FPS. I installed the latest patch for it. I think the problem might be related to the CPU, as it says CPU Usage: 17%. A friend of mine with i7 920 @ 3.5ghz and a 5870 get's 63 FPS on the same settings.

I also tried the 2 GTA 4 episodes, and my CPU usage there too is about 17%, while the FPS is down in the 20's. I was really looking forward to gaming my favourite game on my new setup, but so far I am very dissapointed :/

So I have compared my score with other peoples scores on youtube etc, and I am beaten by much worse systems.

So I was wondering if you guys know how to make my CPU work harder in GTA. I have tried other games like Black Ops, and that works fine, but again that game isn't really that CPU hungry. I also tested my CPU score in 3dmark, and I got very high scores there. Thanks
Cake?
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 D0 @ 4.4 Ghz Asus P6T Asus 6970 + 6950 Crossfire Corsair 6gb 1600Mhz 
Hard DriveCoolingOSMonitor
Intel X-25 80GB SSD EK-Supreme HF, Bitspower D5 Mod Pump Top V2, RX... WIndows 7 64-bit Dell U2410 + HP W2408H 
KeyboardPowerCaseMouse
Logitech G11 Corsair TX750W Antec 1200 Razer Deathadder 
  hide details  
Reply
Cake?
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 D0 @ 4.4 Ghz Asus P6T Asus 6970 + 6950 Crossfire Corsair 6gb 1600Mhz 
Hard DriveCoolingOSMonitor
Intel X-25 80GB SSD EK-Supreme HF, Bitspower D5 Mod Pump Top V2, RX... WIndows 7 64-bit Dell U2410 + HP W2408H 
KeyboardPowerCaseMouse
Logitech G11 Corsair TX750W Antec 1200 Razer Deathadder 
  hide details  
Reply
post #2 of 18
Thats how it is with GTA IV. Just gotta accept it. Kinda like rape...after it happens.

Try maybe Reinstalling the game or installing new drivers? Seems odd that the CPU usage is at 17%. Make sure you patch the game too.

GTA IV had problems with multi-core support, so if its not patched that MIGHT be the reason. I do not guarantee anything.
Edited by KrisBKreeme - 1/4/11 at 1:55pm
My One and Only
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 760 @ 4.1GHz MSI P55-CD53 EVGA GTX 570 SC 8 GB Mushkin Blackline DDR3 PC1333 
Hard DriveOptical DriveOSMonitor
500GB WD Blue Lite-On DVD Burner Windows 7 Ultimate 64bit AOC 23" LED LCD 1920 x 1080 
PowerCaseMouse
Silverstone 1000W Modular CM HAF 922 Razer Deathadder 
  hide details  
Reply
My One and Only
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 760 @ 4.1GHz MSI P55-CD53 EVGA GTX 570 SC 8 GB Mushkin Blackline DDR3 PC1333 
Hard DriveOptical DriveOSMonitor
500GB WD Blue Lite-On DVD Burner Windows 7 Ultimate 64bit AOC 23" LED LCD 1920 x 1080 
PowerCaseMouse
Silverstone 1000W Modular CM HAF 922 Razer Deathadder 
  hide details  
Reply
post #3 of 18
Thread Starter 
Quote:
Originally Posted by KrisBKreeme View Post
Thats how it is with GTA IV. Just gotta accept it. Kinda like rape...after it happens.

Try maybe Reinstalling the game or installing new drivers? Seems odd that the CPU usage is at 17%. Make sure you patch the game too.

GTA IV had problems with multi-core support, so if its not patched that MIGHT be the reason. I do not guarantee anything.
I will try re'installing it and patching it again. But I did install the latest patch for GTA 4. Think it was 1.7 or something. I also installed the lastest GPU drivers. The problem is really that the CPU is only working 17%, and other i7 920 I have seen uses about 40-50% Usage.
Cake?
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 D0 @ 4.4 Ghz Asus P6T Asus 6970 + 6950 Crossfire Corsair 6gb 1600Mhz 
Hard DriveCoolingOSMonitor
Intel X-25 80GB SSD EK-Supreme HF, Bitspower D5 Mod Pump Top V2, RX... WIndows 7 64-bit Dell U2410 + HP W2408H 
KeyboardPowerCaseMouse
Logitech G11 Corsair TX750W Antec 1200 Razer Deathadder 
  hide details  
Reply
Cake?
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 D0 @ 4.4 Ghz Asus P6T Asus 6970 + 6950 Crossfire Corsair 6gb 1600Mhz 
Hard DriveCoolingOSMonitor
Intel X-25 80GB SSD EK-Supreme HF, Bitspower D5 Mod Pump Top V2, RX... WIndows 7 64-bit Dell U2410 + HP W2408H 
KeyboardPowerCaseMouse
Logitech G11 Corsair TX750W Antec 1200 Razer Deathadder 
  hide details  
Reply
post #4 of 18
But you are running eyefinity correct?
post #5 of 18
Thread Starter 
Quote:
Originally Posted by The Master Chief View Post
But you are running eyefinity correct?
I haven't tried that on GTA 4. Running on a 24" 1080p monitor atm.
Cake?
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 D0 @ 4.4 Ghz Asus P6T Asus 6970 + 6950 Crossfire Corsair 6gb 1600Mhz 
Hard DriveCoolingOSMonitor
Intel X-25 80GB SSD EK-Supreme HF, Bitspower D5 Mod Pump Top V2, RX... WIndows 7 64-bit Dell U2410 + HP W2408H 
KeyboardPowerCaseMouse
Logitech G11 Corsair TX750W Antec 1200 Razer Deathadder 
  hide details  
Reply
Cake?
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 D0 @ 4.4 Ghz Asus P6T Asus 6970 + 6950 Crossfire Corsair 6gb 1600Mhz 
Hard DriveCoolingOSMonitor
Intel X-25 80GB SSD EK-Supreme HF, Bitspower D5 Mod Pump Top V2, RX... WIndows 7 64-bit Dell U2410 + HP W2408H 
KeyboardPowerCaseMouse
Logitech G11 Corsair TX750W Antec 1200 Razer Deathadder 
  hide details  
Reply
post #6 of 18
Quote:
Originally Posted by The Master Chief View Post
But you are running eyefinity correct?
Didnt even see that lol. If he is running it across 3 monitors, i can see why it would be having issues.

EDIT: Whoop nvm... got ninjad
My One and Only
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 760 @ 4.1GHz MSI P55-CD53 EVGA GTX 570 SC 8 GB Mushkin Blackline DDR3 PC1333 
Hard DriveOptical DriveOSMonitor
500GB WD Blue Lite-On DVD Burner Windows 7 Ultimate 64bit AOC 23" LED LCD 1920 x 1080 
PowerCaseMouse
Silverstone 1000W Modular CM HAF 922 Razer Deathadder 
  hide details  
Reply
My One and Only
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 760 @ 4.1GHz MSI P55-CD53 EVGA GTX 570 SC 8 GB Mushkin Blackline DDR3 PC1333 
Hard DriveOptical DriveOSMonitor
500GB WD Blue Lite-On DVD Burner Windows 7 Ultimate 64bit AOC 23" LED LCD 1920 x 1080 
PowerCaseMouse
Silverstone 1000W Modular CM HAF 922 Razer Deathadder 
  hide details  
Reply
post #7 of 18
I got 60+ fps in bench, something is wrong.
R2
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570K @ 4.2 GHz Asus Rampage Gene IV XFX DD HD7950 Kingston 8gb 
Hard DriveOptical DriveOSMonitor
Samsung 830 Series Optiarc Windows 7 Ultimate x64 Dell UltraSharp U2212HM 
MonitorKeyboardPowerCase
U2713HM Blackwidow Corsair GS600 Fractal Design Define R2 
MouseMouse PadAudioAudio
Deathadder 3.5G Razer Goliathus Control Asus Xonar Essence STX Senn HD595 
Audio
M-Audio AV40 
  hide details  
Reply
R2
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570K @ 4.2 GHz Asus Rampage Gene IV XFX DD HD7950 Kingston 8gb 
Hard DriveOptical DriveOSMonitor
Samsung 830 Series Optiarc Windows 7 Ultimate x64 Dell UltraSharp U2212HM 
MonitorKeyboardPowerCase
U2713HM Blackwidow Corsair GS600 Fractal Design Define R2 
MouseMouse PadAudioAudio
Deathadder 3.5G Razer Goliathus Control Asus Xonar Essence STX Senn HD595 
Audio
M-Audio AV40 
  hide details  
Reply
post #8 of 18
How far are the draw views? The sliders?

do they have that in the benchmark? I've never tried it so I dont know, just going from the game settings.
post #9 of 18
Thread Starter 

I put everything to max, sliders to 100.

I did the same as this guy did:


And here I get about 40 FPS, while he get's 63. I could try running my CPU with stock settings and see what I get maybe?
Cake?
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 D0 @ 4.4 Ghz Asus P6T Asus 6970 + 6950 Crossfire Corsair 6gb 1600Mhz 
Hard DriveCoolingOSMonitor
Intel X-25 80GB SSD EK-Supreme HF, Bitspower D5 Mod Pump Top V2, RX... WIndows 7 64-bit Dell U2410 + HP W2408H 
KeyboardPowerCaseMouse
Logitech G11 Corsair TX750W Antec 1200 Razer Deathadder 
  hide details  
Reply
Cake?
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 D0 @ 4.4 Ghz Asus P6T Asus 6970 + 6950 Crossfire Corsair 6gb 1600Mhz 
Hard DriveCoolingOSMonitor
Intel X-25 80GB SSD EK-Supreme HF, Bitspower D5 Mod Pump Top V2, RX... WIndows 7 64-bit Dell U2410 + HP W2408H 
KeyboardPowerCaseMouse
Logitech G11 Corsair TX750W Antec 1200 Razer Deathadder 
  hide details  
Reply
post #10 of 18
I got 38.59 fps on my sig rig.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › problem with GTA4