Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Corsair Nova 64 not booting?
New Posts  All Forums:Forum Nav:

Corsair Nova 64 not booting?

post #1 of 7
Thread Starter 
I have had my nova ssd running great for several months, but today I went to turn on the computer and it sticks on achi devices. So I disconnected the HDD's and the SSD. Then I reconected each on till I got stuck again. Which happened when I plugged the SSD back in. I swaped cables and such with no luck.

Anyone have any ideas on what is going on?
Maxi
(11 items)
 
  
Reply
Maxi
(11 items)
 
  
Reply
post #2 of 7
So your not getting past your posting screen? Have you tried a different Sata port on your motherboard?
post #3 of 7
Thread Starter 
Quote:
Originally Posted by Mattb2e View Post
So your not getting past your posting screen? Have you tried a different Sata port on your motherboard?
yeah even tried the drive in my laptop and the same thing, the laptop wouldn't go past post. I am baffled by this because it worked fine yesterday, then when I go to turn on the computer today I have this issue.
Maxi
(11 items)
 
  
Reply
Maxi
(11 items)
 
  
Reply
post #4 of 7
The only thing I can suggest is booting with a different drive and try to access the Nova as a data drive. If you can do that, a reformat may fix the problem. If it doesnt, you may need to RMA it.
post #5 of 7
Thread Starter 
Quote:
Originally Posted by Mattb2e View Post
The only thing I can suggest is booting with a different drive and try to access the Nova as a data drive. If you can do that, a reformat may fix the problem. If it doesnt, you may need to RMA it.
Yeah that was my train of thought with putting it in the laptop. However any computer it is connected to won't post.

Anyone know how good or bad corsairs rma process is?
Maxi
(11 items)
 
  
Reply
Maxi
(11 items)
 
  
Reply
post #6 of 7
Quote:
Originally Posted by wheth4400 View Post
Yeah that was my train of thought with putting it in the laptop. However any computer it is connected to won't post.

Anyone know how good or bad corsairs rma process is?
Although I havent dealt with them personally, ive heard great things about their customer support and RMA process. I suggest you go that route.
post #7 of 7
Thread Starter 
Quote:
Originally Posted by Mattb2e View Post
Although I havent dealt with them personally, ive heard great things about their customer support and RMA process. I suggest you go that route.
I filled out a RMA request with them on Saturday, their form says you will recieve a RMA number within one business day. Here we are rolling into Wensday and I still haven't recieved one. I am going to go ahead and fill out another RMA request form and hope for the best.
Maxi
(11 items)
 
  
Reply
Maxi
(11 items)
 
  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: SSD
Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Corsair Nova 64 not booting?