post #1 of 1
Thread Starter 
So I've been using a Xai for several months, love it, but I've noticed something funky the last few days. I accidentally gave it a static shock the other day and while nothing about the performance of the mouse was noticeably changed, the mouse itself is heating up on the bottom around where the sensor is. I never noticed this happening until after the shock, and it doesn't seem to be affecting the mouse's performance, but it worries me that if I leave it in place for a few hours that my mousepad is very warm to the touch under where I left it sitting.

What I'm really asking is, has anybody else ever had this issue? Even though it's still performing fine I am still quite concerned and since Bestbuy seems to be clearing out their stock of Xais I could easily pick another one up for $45 right now.
System 1
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 4.0GHz 1.25V EVGA x58 SLI LE EVGA GTX 560 Ti (950/1125) 6GB GSkill Ripjaws 
Hard DriveOSMonitorKeyboard
1TB Spinpoint F3 + 128GB Crucial C300 Windows 7 Pro x64 Viewsonic VX2265wm 22" 120Hz ABS M1 
PowerCaseMouseMouse Pad
XFX Black 850W Antec 1200 Steelseries Xai Steelseries 4HD 
  hide details  
Reply
System 1
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 4.0GHz 1.25V EVGA x58 SLI LE EVGA GTX 560 Ti (950/1125) 6GB GSkill Ripjaws 
Hard DriveOSMonitorKeyboard
1TB Spinpoint F3 + 128GB Crucial C300 Windows 7 Pro x64 Viewsonic VX2265wm 22" 120Hz ABS M1 
PowerCaseMouseMouse Pad
XFX Black 850W Antec 1200 Steelseries Xai Steelseries 4HD 
  hide details  
Reply