Overclock.net › Forums › Graphics Cards › NVIDIA › gtx580 - lag in just cause 2?
New Posts  All Forums:Forum Nav:

gtx580 - lag in just cause 2? - Page 2

post #11 of 18
Quote:
Originally Posted by TheChris2233;11947080 
Hmm I noticed I had old version of driver sweeper. Newest version found some ati leftovers. After removing those + reboot, I seem to be getting 35-40ish. Not great, but then I think the town I'm testing in is probably incredibly gpu intensive...foiilage and shadows everywhere.

I'll give gamebooster a try to. Any other suggestions?

You do know Just Cause 2 enables Bokeh filter and water simulation if it detects an nVidia card right? Those utilise CUDA and put more strain/workload on the GPU.

Also, I've noticed that disabling Vsync gave me much better performance. For some reason the game caps at 30 FPS in some parts of the game while in others it caps at 60. Vsync solves this but especially with a GTX 580 you might get over 70FPS and at that rate screen tearing occurs. Hope this helped wink.gif
Pernod
(28 items)
 
Oleo
(14 items)
 
The Sidewinder
(18 items)
 
CPUCPUMotherboardGraphics
Intel Xeon E5-4650 Intel Xeon E5-4650 Asus Z9PE-D8 WS GeForce GTX 780 Ti 
RAMRAMHard DriveHard Drive
4 x 4GB Corsair Dominator Platinum 4 x 4GB Corsair Dominator Platinum Samsung Spinpoint F3 2TB Sandisk Ultra 64GB 
Hard DriveCoolingCoolingCooling
mushkin Triactor 240GB EK Supremacy Nickel/Plexi EK Supremacy Nickel/Plexi TFC XChanger 360 
CoolingCoolingCoolingOS
Koolance RP452X2 Swiftech MCP-655 Corsair SP120 "QE" Windows 10 Enterprise x64 
OSMonitorMonitorMonitor
openSUSE Leap 42.1 x64 Dell U2412M Dell U2412M Acer P241W-d 
KeyboardPowerCaseMouse
Ducky 1008 w/ Cherry MX Blue Coolermaster Silent Pro M2 1.5kW Silverstone Raven RV01B-W Microsoft Sidewinder X5 
AudioAudioAudioOther
Asus Xonar DX Beyerdynamic DT 880 Premium AudioEngine A2 (2.0) Wacom Intuos Pen & Touch 
CPUMotherboardGraphicsRAM
Core i7 2600K @5.2  MSI MPower Z77 GeForce GTX 470 Corsair Vengeance 2000MHz C10 
Hard DriveCoolingCoolingCooling
Samsung Spinpoint F1 XSPC Raystorm EK Spin Bay Res Clear mcp-350 (ddc1) 
CoolingCoolingOSOS
XSPC EX120 XSPC EX240 openSUSE 12.3 x64 elementaryOS 0.3 (Freya) x64 
PowerCase
Corsair TX750 750W Lian Li A05NB 
CPUMotherboardGraphicsRAM
Intel C2Q Q9550 Asus P5G41C-M LX GeForce GTX 470 Corsair XMS2 DDR2 800 
Hard DriveHard DriveHard DriveHard Drive
Seagate LP 500GB Crucial M4 128GB WD Red 2TB WD Red 4TB 
CoolingOSMonitorPower
Scythe Big Shuriken w/ Silverstone Suscool 121 Windows 10 Home x64 Sony Bravia KDL-37EX500 Antec TP650 New 
CaseOther
Lian Li V351B Silverstone Suscool 121 120mm case fans 
  hide details  
Reply
Pernod
(28 items)
 
Oleo
(14 items)
 
The Sidewinder
(18 items)
 
CPUCPUMotherboardGraphics
Intel Xeon E5-4650 Intel Xeon E5-4650 Asus Z9PE-D8 WS GeForce GTX 780 Ti 
RAMRAMHard DriveHard Drive
4 x 4GB Corsair Dominator Platinum 4 x 4GB Corsair Dominator Platinum Samsung Spinpoint F3 2TB Sandisk Ultra 64GB 
Hard DriveCoolingCoolingCooling
mushkin Triactor 240GB EK Supremacy Nickel/Plexi EK Supremacy Nickel/Plexi TFC XChanger 360 
CoolingCoolingCoolingOS
Koolance RP452X2 Swiftech MCP-655 Corsair SP120 "QE" Windows 10 Enterprise x64 
OSMonitorMonitorMonitor
openSUSE Leap 42.1 x64 Dell U2412M Dell U2412M Acer P241W-d 
KeyboardPowerCaseMouse
Ducky 1008 w/ Cherry MX Blue Coolermaster Silent Pro M2 1.5kW Silverstone Raven RV01B-W Microsoft Sidewinder X5 
AudioAudioAudioOther
Asus Xonar DX Beyerdynamic DT 880 Premium AudioEngine A2 (2.0) Wacom Intuos Pen & Touch 
CPUMotherboardGraphicsRAM
Core i7 2600K @5.2  MSI MPower Z77 GeForce GTX 470 Corsair Vengeance 2000MHz C10 
Hard DriveCoolingCoolingCooling
Samsung Spinpoint F1 XSPC Raystorm EK Spin Bay Res Clear mcp-350 (ddc1) 
CoolingCoolingOSOS
XSPC EX120 XSPC EX240 openSUSE 12.3 x64 elementaryOS 0.3 (Freya) x64 
PowerCase
Corsair TX750 750W Lian Li A05NB 
CPUMotherboardGraphicsRAM
Intel C2Q Q9550 Asus P5G41C-M LX GeForce GTX 470 Corsair XMS2 DDR2 800 
Hard DriveHard DriveHard DriveHard Drive
Seagate LP 500GB Crucial M4 128GB WD Red 2TB WD Red 4TB 
CoolingOSMonitorPower
Scythe Big Shuriken w/ Silverstone Suscool 121 Windows 10 Home x64 Sony Bravia KDL-37EX500 Antec TP650 New 
CaseOther
Lian Li V351B Silverstone Suscool 121 120mm case fans 
  hide details  
Reply
post #12 of 18
Besides the bokeh/h2o simulation that's only on nV cards, I believe that the foliage animations are more elaborate on nV cards ... I don't have solid proof of this, but I finished the game on my 5850's in xfire, then when I switched to my current setup I played it some more, and could swear I was seeing the plants 'doing stuff', dancing around in ways that I never saw before w/my ATI cards. JC2 just looks noticeably better all around on Fermi, IMHO, so I think that's why it runs a little slower than on ATI.

I just restarted the game (again) and have been noticing some fairly severe FPS dips (into the 30's) in the Casino assault (training) level even w/my OC'd 470's in SLI (playing totally maxed at 1920x1200 w/8xCSAA) so what you're getting doesn't sound too abnormal. Once you really get into the regular game I bet you'll rarely drop below 45fps or so.
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
post #13 of 18
Quote:
Originally Posted by kora04;11946332 
No need to format.

ATI drivers are not the problem.

Try this OP.




No idea what the story behind that is, but worth a shot.


Is that serious?

He didn't know that he was running F@H?
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
post #14 of 18
Thread Starter 
Short fix:
  • Disable vsync in game AND in control panel
  • Force vsync and triple buffer on with D3DOverrider (google it) or deal with tearing
  • Framelock your FPS to acceptable level

    Or

  • use ATI cards
  • Turn off GPU water simulation
  • Beast it with SLI

Explanation:

A bit of a late reply but hopefully this will help if anyone else has same issue. Fixed it with forcing off vsync in game and in nvidia control panel and then forcing it on w/ triple buffering with 3D3override. Apparently this game's implementation of vsync is retarded.

It seems to have hard caps set for 30 and 60fps. So if you drop below 60fps, it caps the game to 30. So what happens is when you are driving somewhere and dips to 55 fps, the game drops it another 25fps to 30. Then it immediately starts going back to 60 where it will drop it again. Whether this issue is present on ATI cards or whether it just never occured from performance difference mentioned below, I don't know.

Also, I understand that 5850 CF is a little more powerful than gtx580, but the majority of benchies I've found puts them within 5-10%, which would not explain the huge drops in fps.

After reviewing several websites, it does look like JC2 heavily favors ATI cards. I even saw one site showing 5850 neck and neck with a 480gtx. (with CUDA extras turned off). I also agree that the game looks prettier on gtx580 (not just talking about extra options either). Makes me think there is some extra processing going on that just isn't available to ATI.

For what its worth I also turned off motion blur and brokeh filter. I absolutely hate "film grain" effect. I can't understand why people want to spend mucho $$$ to make stuff look blurry.

The gpu water was still making me occasionally dip from costant 60 to 45-55ish, so I just hardcapped the FPS at 40. Smooth as butter now. When I disabled the GPU water simulation, FPS stayed at constant 60

Appreciate all the help
Raven 2012
(16 items)
 
BigHeavy 2009
(10 items)
 
 
CPUMotherboardGraphicsRAM
Intel 3770k (4.6ghz) Asus Sabertooth z77 Galaxy GTX680 4GB SLI 16GB Corsair Vengeance LP 
Hard DriveHard DriveOptical DriveCooling
Samsung 840 PRO 256GB Western Digital Black 1TB ASUS DVD-RW Tuniq Extreme 120 with Gelid blue fan 
OSMonitorKeyboardPower
Windows 7 Overlord x270oc Logitech G510 Seasonic Platinum 1000w 
CaseMouseMouse PadAudio
Silverstone Raven RV03 Logitech G600 Logitech g440 Sound Blaster ZXR 
CPUMotherboardGraphicsRAM
I7-920 (oc 3.5ghz) Asus P6T V2 EVGA GTX580 SC (SLI) 12GB Corsair Dominator (2Gb x 6) 
Hard DriveOptical DriveOSMonitor
Crucial M4 256GB + Western Digital Black 750GB DVD-RW x2 Windows 7 pro Samsung SyncMaster XL 2370 
PowerCase
Silverstone Strider 850watt CM HAF 932 
  hide details  
Reply
Raven 2012
(16 items)
 
BigHeavy 2009
(10 items)
 
 
CPUMotherboardGraphicsRAM
Intel 3770k (4.6ghz) Asus Sabertooth z77 Galaxy GTX680 4GB SLI 16GB Corsair Vengeance LP 
Hard DriveHard DriveOptical DriveCooling
Samsung 840 PRO 256GB Western Digital Black 1TB ASUS DVD-RW Tuniq Extreme 120 with Gelid blue fan 
OSMonitorKeyboardPower
Windows 7 Overlord x270oc Logitech G510 Seasonic Platinum 1000w 
CaseMouseMouse PadAudio
Silverstone Raven RV03 Logitech G600 Logitech g440 Sound Blaster ZXR 
CPUMotherboardGraphicsRAM
I7-920 (oc 3.5ghz) Asus P6T V2 EVGA GTX580 SC (SLI) 12GB Corsair Dominator (2Gb x 6) 
Hard DriveOptical DriveOSMonitor
Crucial M4 256GB + Western Digital Black 750GB DVD-RW x2 Windows 7 pro Samsung SyncMaster XL 2370 
PowerCase
Silverstone Strider 850watt CM HAF 932 
  hide details  
Reply
post #15 of 18
Quote:
Originally Posted by kora04;11946332 
No need to format.

ATI drivers are not the problem.

Try this OP.

No idea what the story behind that is, but worth a shot.

I really doubt that is the issue, how did they not know they were running Folding@Home? wth.gif
>.<
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 4.0ghz 1.27v EVGA E758 3-Way (black/gray) Evga GTX 480 / Evga 9800gtx+ (physx&folding) Corsair Dominator 6gb 1600 8-8-8-24 
Hard DriveOSMonitorPower
x25-M SSD 80gb + 1TB F3 + 2x2TB WD Green Win 7 64bit Viewsonic 20" + Samsung 40" Corsair 1000w 
Case
Haf 932 (modded) - Now caseless 
  hide details  
Reply
>.<
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 4.0ghz 1.27v EVGA E758 3-Way (black/gray) Evga GTX 480 / Evga 9800gtx+ (physx&folding) Corsair Dominator 6gb 1600 8-8-8-24 
Hard DriveOSMonitorPower
x25-M SSD 80gb + 1TB F3 + 2x2TB WD Green Win 7 64bit Viewsonic 20" + Samsung 40" Corsair 1000w 
Case
Haf 932 (modded) - Now caseless 
  hide details  
Reply
post #16 of 18
Quote:
Originally Posted by TheChris2233;12050763 
Short fix:
  • Disable vsync in game AND in control panel
  • Force vsync and triple buffer on with D3DOverrider (google it) or deal with tearing
  • Framelock your FPS to acceptable level

    Or

  • use ATI cards
  • Turn off GPU water simulation
  • Beast it with SLI

Explanation:

A bit of a late reply but hopefully this will help if anyone else has same issue. Fixed it with forcing off vsync in game and in nvidia control panel and then forcing it on w/ triple buffering with 3D3override. Apparently this game's implementation of vsync is retarded.

It seems to have hard caps set for 30 and 60fps. So if you drop below 60fps, it caps the game to 30. So what happens is when you are driving somewhere and dips to 55 fps, the game drops it another 25fps to 30. Then it immediately starts going back to 60 where it will drop it again. Whether this issue is present on ATI cards or whether it just never occured from performance difference mentioned below, I don't know.

That is how vsync (without triple buffering) works. On a typical 60Hz system your framerate can only be 60 or its dividers (meaning 30, 20, 15...). This has nothing to do with the game's implementation, nvidia/ati or any other unrelated factor.

Some games do implicit triple buffering when their vsync option is turned on.
post #17 of 18
Quote:
Originally Posted by TheChris2233;12050763 
Short fix:
  • Disable vsync in game AND in control panel
  • Force vsync and triple buffer on with D3DOverrider (google it) or deal with tearing

Interesting. I actually played the whole game the first time through w/my 2x5850's using d3doverrider cause v-sync straight up didn't work on those cards (in most games actually).

I'm going to try this solution of going back to d3dOR and v-sync off, see if my FPS comes back up to where it was before w/the ATI cards.
Quote:
Originally Posted by TFL Replica;12050830 
That is how vsync (without triple buffering) works. On a typical 60Hz system your framerate can only be 60 or any of its dividers (meaning 30, 20, 15, 10, 5). This has nothing to do with the game's implementation, nvidia/ati or any other unrelated factor.

There are definitely some 'unrelated' factors involved, because I play games w/V-sync on, but without triple-buffering, and I get FPS between 30 and 60 ... like ... all the time.

Somehow or another, the whole phenomenon of "dropping to 30fps as soon as you drop below 60fps w/v-sync on" is most certainly situation-specific. Not saying I know what the deciding factor IS, but ... there is one or more of them.

I will say though that anytime I have had that v-sync/30fps problem, using D3DOverrider to force v-sync + triple buffering has fixed it thumb.gif
Edited by brettjv - 1/17/11 at 10:41pm
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
post #18 of 18
Okay, so I just tested it with JC2 ... in-game v-sync seems to work just fine. I'm not getting dips to 30fps whenever frames drop below 60fps. I'm not using d3doverrider, and I don't have triple buffering enabled in NVCP (which only works in OpenGL anyways ... plus triple buffering is not even possible with SLI ... from all I've read anyways).

I think there's just some parts in the early tutorial parts of the game (like Casino Bust or whatever) that are particularly tough to run, so I'm seeing some very occasional dips into the 30's (but it's never as low as 30fps).
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › gtx580 - lag in just cause 2?