Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › can't restore default panels
New Posts  All Forums:Forum Nav:

can't restore default panels

post #1 of 6
Thread Starter 
ok so i was trying to customize my gnome with different themes and such last night, and finally found something i liked. however, after my meds kick in i have absolutely no memory of anything the next morning.

so i boot up my laptop and see no panels. after browsing the ubuntu forums i figured out how to add the panel back (although, it is not my default panel) and doesn't include the wifi signal applet.

i have tried killall gnome-panel and all that stuff that would normally restore the panel, but it just flashes, and i get this little blank space between the panel i added and every window i open.

question is, how do i successfully delete all the panels and start over, but not delete my themes? and what could i have possibly done (since i don't remember anything) that would cause this? using Ubuntu 10.10 x86.

Gamer
(10 items)
 
Home Server
(13 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 2500k ASUS P8Z68-V LX Galaxy 780 HOF Hyper-X@1600 
Hard DriveHard DriveCoolingOS
Crucial MX300 Crucial M4 Thermaltake Frio Windows 10 Pro 
PowerCase
EVGA SuperNova GQ 650W Haf 922 
CPUMotherboardRAMHard Drive
AMD A4-5300 FM2-A75MA-E35 2 x 2 gb HyperX WD Velociraptor 
Hard DriveCoolingOSMonitor
WD Red Stock Windows Server 2012 R2 none 
KeyboardPowerCaseMouse
none 650 w Rosewill 4U none 
Mouse Pad
none 
  hide details  
Reply
Gamer
(10 items)
 
Home Server
(13 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 2500k ASUS P8Z68-V LX Galaxy 780 HOF Hyper-X@1600 
Hard DriveHard DriveCoolingOS
Crucial MX300 Crucial M4 Thermaltake Frio Windows 10 Pro 
PowerCase
EVGA SuperNova GQ 650W Haf 922 
CPUMotherboardRAMHard Drive
AMD A4-5300 FM2-A75MA-E35 2 x 2 gb HyperX WD Velociraptor 
Hard DriveCoolingOSMonitor
WD Red Stock Windows Server 2012 R2 none 
KeyboardPowerCaseMouse
none 650 w Rosewill 4U none 
Mouse Pad
none 
  hide details  
Reply
post #2 of 6
It's a hidden home file, the ones with a . in front.... I don't remember if it's in ~/.config or ~/.gnome2? I think it's the panel folder in .gnome2 but I'm not going to test it. If all else fails you can delete the .gnome2 folder and just log out/back in and all your desktop defaults will be reset. The folder might be .gnome, if that is the case the panel folder might be under .gnome/apps
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #3 of 6
http://www.watchingthenet.com/restor...-settings.html

http://www.starryhope.com/linux/ubun...els-in-ubuntu/

give either of those a shot if the above suggestion doesn't work out.

~Devoid~

Edit: Also, its easy to get your wifi applet back. Right click on the panel and choose "add to panel". Then add the "notification area" applet.
Edited by Devoid - 1/11/11 at 10:48am
The Shield
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 Quad Q9450 @ 2.66GHz Gigabyte GA-EP45-DS3R HIS Radeon 4870 G.SKILL 2x2GB DDR2 800 
Hard DriveOSMonitorKeyboard
Hitachi 500GB Windows 7 64-bit / Ubuntu 10.10 64-bit Samsung 21.6" LCD Logitech K200 
PowerCaseMouse
Cooler Master 650w Raidmax Sagitta Logitech M500 
  hide details  
Reply
The Shield
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core 2 Quad Q9450 @ 2.66GHz Gigabyte GA-EP45-DS3R HIS Radeon 4870 G.SKILL 2x2GB DDR2 800 
Hard DriveOSMonitorKeyboard
Hitachi 500GB Windows 7 64-bit / Ubuntu 10.10 64-bit Samsung 21.6" LCD Logitech K200 
PowerCaseMouse
Cooler Master 650w Raidmax Sagitta Logitech M500 
  hide details  
Reply
post #4 of 6
Thread Starter 
neither worked from the links, nor did deleting the .config and the .gnome2 folders completely. if i manually add a new panel, it puts it below the blank space instead of above it now. so there's a gap, then the new panel, then my windows.
Gamer
(10 items)
 
Home Server
(13 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 2500k ASUS P8Z68-V LX Galaxy 780 HOF Hyper-X@1600 
Hard DriveHard DriveCoolingOS
Crucial MX300 Crucial M4 Thermaltake Frio Windows 10 Pro 
PowerCase
EVGA SuperNova GQ 650W Haf 922 
CPUMotherboardRAMHard Drive
AMD A4-5300 FM2-A75MA-E35 2 x 2 gb HyperX WD Velociraptor 
Hard DriveCoolingOSMonitor
WD Red Stock Windows Server 2012 R2 none 
KeyboardPowerCaseMouse
none 650 w Rosewill 4U none 
Mouse Pad
none 
  hide details  
Reply
Gamer
(10 items)
 
Home Server
(13 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 2500k ASUS P8Z68-V LX Galaxy 780 HOF Hyper-X@1600 
Hard DriveHard DriveCoolingOS
Crucial MX300 Crucial M4 Thermaltake Frio Windows 10 Pro 
PowerCase
EVGA SuperNova GQ 650W Haf 922 
CPUMotherboardRAMHard Drive
AMD A4-5300 FM2-A75MA-E35 2 x 2 gb HyperX WD Velociraptor 
Hard DriveCoolingOSMonitor
WD Red Stock Windows Server 2012 R2 none 
KeyboardPowerCaseMouse
none 650 w Rosewill 4U none 
Mouse Pad
none 
  hide details  
Reply
post #5 of 6
If you want to make sure all the configs are set, Warning: this will re-set the entire desktop to defaults...

sudo rm .* -r

If you have a .wine folder, I'd recomend renaming it, same goes with .mozilla/.q3a or any other application name that you recognize. You can view them by "view hidden files" under the view menu. Just remove the . and then run the command, this will reset EVERYTHING and leave it just like it was when you first logged in.

[edit] Of course you have to log out and back in for any changes to take effect, same with the deletions you did previously. If you haven't logged out and back in since you deleted the .gnome and .config folders then you won't see any changes until you do.
Edited by mushroomboy - 1/11/11 at 9:36pm
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #6 of 6
Thread Starter 
wouldn't it be easier to just create a new user profile? it sounds like that's what i'm essentially about to do with that command.
Gamer
(10 items)
 
Home Server
(13 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 2500k ASUS P8Z68-V LX Galaxy 780 HOF Hyper-X@1600 
Hard DriveHard DriveCoolingOS
Crucial MX300 Crucial M4 Thermaltake Frio Windows 10 Pro 
PowerCase
EVGA SuperNova GQ 650W Haf 922 
CPUMotherboardRAMHard Drive
AMD A4-5300 FM2-A75MA-E35 2 x 2 gb HyperX WD Velociraptor 
Hard DriveCoolingOSMonitor
WD Red Stock Windows Server 2012 R2 none 
KeyboardPowerCaseMouse
none 650 w Rosewill 4U none 
Mouse Pad
none 
  hide details  
Reply
Gamer
(10 items)
 
Home Server
(13 items)
 
 
CPUMotherboardGraphicsRAM
Core i5 2500k ASUS P8Z68-V LX Galaxy 780 HOF Hyper-X@1600 
Hard DriveHard DriveCoolingOS
Crucial MX300 Crucial M4 Thermaltake Frio Windows 10 Pro 
PowerCase
EVGA SuperNova GQ 650W Haf 922 
CPUMotherboardRAMHard Drive
AMD A4-5300 FM2-A75MA-E35 2 x 2 gb HyperX WD Velociraptor 
Hard DriveCoolingOSMonitor
WD Red Stock Windows Server 2012 R2 none 
KeyboardPowerCaseMouse
none 650 w Rosewill 4U none 
Mouse Pad
none 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › can't restore default panels