Overclock.net › Forums › Overclockers Care › Overclock.net Folding@Home Team › any Ubuntu experts? i cant get HFM to work..
New Posts  All Forums:Forum Nav:

any Ubuntu experts? i cant get HFM to work..

post #1 of 7
Thread Starter 
ubuntu 10.4, followed zodac's guide

so here's the weird part, at step 2 where it says "HFM will open. For now, close it. We'll now make a launcher for it."

it opened fine, then i followed the steps for creating the launcher and it hasnt worked since..

here's what happens when i do mono HFM.exe in terminal.. any ideas?


Code:
koven@ubuntu:~/Desktop/HFM$ mono HFM.exe

** (HFM.exe:11003): WARNING **: The following assembly referenced from /home/koven/Desktop/HFM/protobuf-net.dll could not be loaded:
     Assembly:   System.Runtime.Serialization    (assemblyref_index=2)
     Version:    3.0.0.0
     Public Key: b77a5c561934e089
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/home/koven/Desktop/HFM/).


** (HFM.exe:11003): WARNING **: Could not load file or assembly 'System.Runtime.Serialization, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies.

** (HFM.exe:11003): WARNING **: Could not load file or assembly 'System.Runtime.Serialization, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' or one of its dependencies.
Stacktrace:

  at ProtoBuf.Serializer.TryGetTag (System.Reflection.MemberInfo,int&,string&,ProtoBuf.DataFormat&,ProtoBuf.MemberSerializationOptions&) <0xffffffff>
  at ProtoBuf.Serializer.TryGetTag (System.Reflection.MemberInfo,int&,string&,ProtoBuf.DataFormat&,ProtoBuf.MemberSerializationOptions&) <0x00030>
  at ProtoBuf.Serializer`1<object>.Build () <0x00373>
  at ProtoBuf.Serializer`1<object>.SerializeChecked (object,ProtoBuf.SerializationContext) <0x0004f>
  at ProtoBuf.SerializerItemProxy`2<HFM.Framework.XmlStatsData, HFM.Framework.XmlStatsData>.Serialize (HFM.Framework.XmlStatsData,ProtoBuf.SerializationContext) <0x0004b>
  at ProtoBuf.SerializerProxy`1<object>.Serialize (object,System.IO.Stream) <0x00057>
  at ProtoBuf.Serializer.Serialize<object> (System.IO.Stream,object) <0x0006b>
  at HFM.Framework.XmlStatsDataContainer.Serialize (HFM.Framework.XmlStatsData,string) <0x000b3>
  at HFM.Framework.XmlStatsDataContainer.Write () <0x00057>
  at HFM.Framework.XmlStatsDataContainer.GetEocXmlData (bool) <0x001b7>
  at HFM.Forms.frmMain.RefreshUserStatsData (bool) <0x0002a>
  at HFM.Forms.frmMain.UserStatsEnabledChanged () <0x00053>
  at HFM.Forms.frmMain.Initialize () <0x00037>
  at (wrapper remoting-invoke-with-check) HFM.Forms.frmMain.Initialize () <0xffffffff>
  at HFM.Program.Main (string[]) <0x00527>
  at (wrapper runtime-invoke) HFM.Program.runtime_invoke_void_object (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:

    mono() [0x47b77f]
    mono() [0x4aef3f]
    /lib/libpthread.so.0(+0xf8f0) [0x7f488a3258f0]
    mono(mono_object_new_specific+0x16) [0x4caa86]
    mono(mono_exception_from_name_domain+0x1d) [0x50e1ed]
    mono(mono_exception_from_name_msg+0xe) [0x50e4de]
    mono() [0x41eb36]
    mono() [0x483521]
    [0x41fc4168]

Debug info from gdb:

[Thread debugging using libthread_db enabled]
[New Thread 0x7f487853a700 (LWP 11014)]
[New Thread 0x7f4878d96700 (LWP 11011)]
[New Thread 0x7f4878f97700 (LWP 11010)]
[New Thread 0x7f48795a1700 (LWP 11009)]
[New Thread 0x7f48797a2700 (LWP 11008)]
[New Thread 0x7f4888b76700 (LWP 11005)]
[New Thread 0x7f488b02d700 (LWP 11004)]
0x00007f488a32493d in read () from /lib/libpthread.so.0
  8 Thread 0x7f488b02d700 (LWP 11004)  0x00007f488a32511d in nanosleep ()
   from /lib/libpthread.so.0
  7 Thread 0x7f4888b76700 (LWP 11005)  0x00007f488a323b50 in sem_wait ()
   from /lib/libpthread.so.0
  6 Thread 0x7f48797a2700 (LWP 11008)  0x00007f488a32511d in nanosleep ()
   from /lib/libpthread.so.0
  5 Thread 0x7f48795a1700 (LWP 11009)  0x00007f488a321bc9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
  4 Thread 0x7f4878f97700 (LWP 11010)  0x00007f4889df6d03 in epoll_wait ()
   from /lib/libc.so.6
  3 Thread 0x7f4878d96700 (LWP 11011)  0x00007f488a321bc9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
  2 Thread 0x7f487853a700 (LWP 11014)  0x00007f488a321bc9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
* 1 Thread 0x7f488b022740 (LWP 11003)  0x00007f488a32493d in read ()
   from /lib/libpthread.so.0

Thread 8 (Thread 0x7f488b02d700 (LWP 11004)):
#0  0x00007f488a32511d in nanosleep () from /lib/libpthread.so.0
#1  0x0000000000556342 in ?? ()
#2  0x00007f488a31c9ca in start_thread () from /lib/libpthread.so.0
#3  0x00007f4889df670d in clone () from /lib/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7f4888b76700 (LWP 11005)):
#0  0x00007f488a323b50 in sem_wait () from /lib/libpthread.so.0
#1  0x00000000004e4aaa in ?? ()
#2  0x0000000000505035 in ?? ()
#3  0x0000000000570073 in ?? ()
#4  0x000000000058de21 in ?? ()
#5  0x00007f488a31c9ca in start_thread () from /lib/libpthread.so.0
#6  0x00007f4889df670d in clone () from /lib/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f48797a2700 (LWP 11008)):
#0  0x00007f488a32511d in nanosleep () from /lib/libpthread.so.0
#1  0x000000000056f134 in ?? ()
#2  0x0000000000507d21 in ?? ()
#3  0x0000000000505035 in ?? ()
#4  0x0000000000570073 in ?? ()
#5  0x000000000058de21 in ?? ()
#6  0x00007f488a31c9ca in start_thread () from /lib/libpthread.so.0
#7  0x00007f4889df670d in clone () from /lib/libc.so.6
#8  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f48795a1700 (LWP 11009)):
#0  0x00007f488a321bc9 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#1  0x000000000055b45d in ?? ()
#2  0x00000000005736d6 in ?? ()
#3  0x00000000005078b4 in ?? ()
#4  0x0000000000505035 in ?? ()
#5  0x0000000000570073 in ?? ()
#6  0x000000000058de21 in ?? ()
#7  0x00007f488a31c9ca in start_thread () from /lib/libpthread.so.0
#8  0x00007f4889df670d in clone () from /lib/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f4878f97700 (LWP 11010)):
#0  0x00007f4889df6d03 in epoll_wait () from /lib/libc.so.6
#1  0x00000000005084f7 in ?? ()
#2  0x0000000000505035 in ?? ()
#3  0x0000000000570073 in ?? ()
#4  0x000000000058de21 in ?? ()
#5  0x00007f488a31c9ca in start_thread () from /lib/libpthread.so.0
#6  0x00007f4889df670d in clone () from /lib/libc.so.6
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f4878d96700 (LWP 11011)):
#0  0x00007f488a321bc9 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#1  0x000000000055b45d in ?? ()
#2  0x00000000005736d6 in ?? ()
#3  0x0000000000508903 in ?? ()
#4  0x0000000000505035 in ?? ()
#5  0x0000000000570073 in ?? ()
#6  0x000000000058de21 in ?? ()
#7  0x00007f488a31c9ca in start_thread () from /lib/libpthread.so.0
#8  0x00007f4889df670d in clone () from /lib/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f487853a700 (LWP 11014)):
#0  0x00007f488a321bc9 in pthread_cond_timedwait@@GLIBC_2.3.2 ()
   from /lib/libpthread.so.0
#1  0x000000000055b45d in ?? ()
#2  0x00000000005736d6 in ?? ()
#3  0x00000000005078b4 in ?? ()
#4  0x0000000000505035 in ?? ()
#5  0x0000000000570073 in ?? ()
#6  0x000000000058de21 in ?? ()
#7  0x00007f488a31c9ca in start_thread () from /lib/libpthread.so.0
#8  0x00007f4889df670d in clone () from /lib/libc.so.6
#9  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f488b022740 (LWP 11003)):
#0  0x00007f488a32493d in read () from /lib/libpthread.so.0
#1  0x000000000047b8f4 in ?? ()
#2  0x00000000004aef3f in ?? ()
#3  <signal handler called>
#4  0x00000000004caa86 in mono_object_new_specific ()
#5  0x000000000050e1ed in mono_exception_from_name_domain ()
#6  0x000000000050e4de in mono_exception_from_name_msg ()
#7  0x000000000041eb36 in ?? ()
#8  0x0000000000483521 in ?? ()
#9  0x0000000041fc4168 in ?? ()
#10 0x0000000000000000 in ?? ()

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.
=================================================================

Aborted
post #2 of 7
Thread Starter 
or anyone know a good ubuntu forum where they can help diagnose errors like this?

should i just wipe everything and try again but with 10.10?


smp client is acting weird too...

Code:
[05:48:35] Completed 70000 out of 250000 steps  (28%)
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented

NOTE: Turning on dynamic load balancing


fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
fixme:file:MoveFileWithProgressW MOVEFILE_WRITE_THROUGH unimplemented
although it's still folding despite these msgs
Edited by koven - 1/11/11 at 10:26pm
post #3 of 7
PM Z, it loves fixing Ubuntu errors.
Honestly I have no clue, I haven't tried folding on there since bigadv went windows.

Was going to suggest trying in the AMD bigadv thread but you already did...
Edited by LiLChris - 1/11/11 at 10:52pm
>.<
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 4.0ghz 1.27v EVGA E758 3-Way (black/gray) Evga GTX 480 / Evga 9800gtx+ (physx&folding) Corsair Dominator 6gb 1600 8-8-8-24 
Hard DriveOSMonitorPower
x25-M SSD 80gb + 1TB F3 + 2x2TB WD Green Win 7 64bit Viewsonic 20" + Samsung 40" Corsair 1000w 
Case
Haf 932 (modded) - Now caseless 
  hide details  
Reply
>.<
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 4.0ghz 1.27v EVGA E758 3-Way (black/gray) Evga GTX 480 / Evga 9800gtx+ (physx&folding) Corsair Dominator 6gb 1600 8-8-8-24 
Hard DriveOSMonitorPower
x25-M SSD 80gb + 1TB F3 + 2x2TB WD Green Win 7 64bit Viewsonic 20" + Samsung 40" Corsair 1000w 
Case
Haf 932 (modded) - Now caseless 
  hide details  
Reply
post #4 of 7
I'd try just deleting HFM, and starting again. If you said it opened fine before the launcher, then it's not a major issue... just a little thing causing loads of problems.
Megadoomer
(14 items)
 
Family Computer
(13 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X6 1090T @ 4.0Ghz ASUS M4A89GTD PRO Sparkle GTS 450 2x4GB G-Skill Sniper 
Hard DriveCoolingOSMonitor
Samsung F1 1TB CM Hyper 212+ Windows 7 Professional x64 Samsung T220 
KeyboardPowerCaseMouse
Logitech MX3000 Laser CM 1000M HAF 922 Logitech VX Revolution 
CPUMotherboardGraphicsRAM
Q6600 Asus PN5-D 750i Evga GTS 250 2x2GB Crucial Ballistix 
Hard DriveOptical DriveOSMonitor
750GB Hitachi Samsung Super Writemaster Windows 7 Professional x64 19" Dell 
PowerCase
Corsair 450VX Antec 900 
  hide details  
Reply
Megadoomer
(14 items)
 
Family Computer
(13 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X6 1090T @ 4.0Ghz ASUS M4A89GTD PRO Sparkle GTS 450 2x4GB G-Skill Sniper 
Hard DriveCoolingOSMonitor
Samsung F1 1TB CM Hyper 212+ Windows 7 Professional x64 Samsung T220 
KeyboardPowerCaseMouse
Logitech MX3000 Laser CM 1000M HAF 922 Logitech VX Revolution 
CPUMotherboardGraphicsRAM
Q6600 Asus PN5-D 750i Evga GTS 250 2x2GB Crucial Ballistix 
Hard DriveOptical DriveOSMonitor
750GB Hitachi Samsung Super Writemaster Windows 7 Professional x64 19" Dell 
PowerCase
Corsair 450VX Antec 900 
  hide details  
Reply
post #5 of 7
Thread Starter 
tried deleting and unzip it again but same error..

cant find any info on google seems like a specific problem
post #6 of 7
Give v10.10 a go then; can't be any worse.
Megadoomer
(14 items)
 
Family Computer
(13 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X6 1090T @ 4.0Ghz ASUS M4A89GTD PRO Sparkle GTS 450 2x4GB G-Skill Sniper 
Hard DriveCoolingOSMonitor
Samsung F1 1TB CM Hyper 212+ Windows 7 Professional x64 Samsung T220 
KeyboardPowerCaseMouse
Logitech MX3000 Laser CM 1000M HAF 922 Logitech VX Revolution 
CPUMotherboardGraphicsRAM
Q6600 Asus PN5-D 750i Evga GTS 250 2x2GB Crucial Ballistix 
Hard DriveOptical DriveOSMonitor
750GB Hitachi Samsung Super Writemaster Windows 7 Professional x64 19" Dell 
PowerCase
Corsair 450VX Antec 900 
  hide details  
Reply
Megadoomer
(14 items)
 
Family Computer
(13 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X6 1090T @ 4.0Ghz ASUS M4A89GTD PRO Sparkle GTS 450 2x4GB G-Skill Sniper 
Hard DriveCoolingOSMonitor
Samsung F1 1TB CM Hyper 212+ Windows 7 Professional x64 Samsung T220 
KeyboardPowerCaseMouse
Logitech MX3000 Laser CM 1000M HAF 922 Logitech VX Revolution 
CPUMotherboardGraphicsRAM
Q6600 Asus PN5-D 750i Evga GTS 250 2x2GB Crucial Ballistix 
Hard DriveOptical DriveOSMonitor
750GB Hitachi Samsung Super Writemaster Windows 7 Professional x64 19" Dell 
PowerCase
Corsair 450VX Antec 900 
  hide details  
Reply
post #7 of 7
Thread Starter 
ugh.. ok, think i'll wait 2 days for this bigadv to finish first

according to http://www.linuxforge.net/bonuscalc2.php im getting ~27k PPD.. so i guess don't need hfm but it'd be nice
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Overclock.net Folding@Home Team
Overclock.net › Forums › Overclockers Care › Overclock.net Folding@Home Team › any Ubuntu experts? i cant get HFM to work..