Overclock.net › Forums › Components › Sound Cards and Computer Audio › Xonar D2 Echo in Games
New Posts  All Forums:Forum Nav:

Xonar D2 Echo in Games

post #1 of 5
Thread Starter 
Hi, just got this card.

Music sounds incredible, but the games not so good. Everything in-game sounds like it's echoing, but very quickly. Like it's being repeated twice very quickly. It does not happen to the menu sounds or in-game music and voice though. It's insanely annoying.

I have tried both BC2 and Crysis and it does it in both, so I assume it will do it in all my games.

All I changed in the control panel was set it up to 5.1 surround and change it to 8 channels like the instructions suggest for games. I have tried 6 channels and 2 channels but it did not fix the issue.

Any ideas?
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
post #2 of 5
BC2 has its own audio engine which normally could create effects like this. But from playing the game I haven't noticed this. Try disabling those surround effects and see what happens. Also, enable a higher speaker count in Windows' sound settings and open the settings.ini file for BC2. Change the speaker count to the number of channels windows is outputting (5.1 = 6 channels).

It may not be an .ini file. I haven't played BC2 for awhile. Plus I haven't used an asus sound card yet.
post #3 of 5
Thread Starter 
I read somewhere else that the card has a problem with 5.1 and headphones. I set the options to 7.1 and the sound is perfect again. It's a shame really, but it still sounds great with 7.1. I'm not sure if I could be missing out on any rear sounds though?
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
post #4 of 5
Quote:
Originally Posted by Domino View Post
BC2 has its own audio engine which normally could create effects like this. But from playing the game I haven't noticed this. Try disabling those surround effects and see what happens. Also, enable a higher speaker count in Windows' sound settings and open the settings.ini file for BC2. Change the speaker count to the number of channels windows is outputting (5.1 = 6 channels).

It may not be an .ini file. I haven't played BC2 for awhile. Plus I haven't used an asus sound card yet.
^^ This, turn GX (DS3D) off. I set mine to Soft Rock on the equalizer and leave it at that.
post #5 of 5
Do you have the game sound set to Wartapes by chance?
Malignance
(24 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K Asus P8Z68-V eVGA GTX670 FTW 16GB Mushkin DDR3-2100 1.5V 
Hard DriveHard DriveHard DriveOptical Drive
2 x 128GB Crucial M4 2 x 1TB Samsung F3 RAID0 1.5TB Seagate Asus 22X DVDRW 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate 64-bit Dell Ultrasharp U2410 Asus ProArt PA248Q 
KeyboardPowerCaseMouse
Rosewill RK-9000BR PCP&P Silencer MKIII 600W Lian Li PC-A05NB Logitech G500 
Mouse PadAudioAudioAudio
Rocketfish Dual Sided Asus Xonar Essence STX Infinity Primus P153 | Dayton DTA-120 Amplifier... Shure SRH840 
AudioAudioAudio
Audio Technica ATH-AD700X Objective DAC Audio-Technica ATR2500-USB 
  hide details  
Reply
Malignance
(24 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K Asus P8Z68-V eVGA GTX670 FTW 16GB Mushkin DDR3-2100 1.5V 
Hard DriveHard DriveHard DriveOptical Drive
2 x 128GB Crucial M4 2 x 1TB Samsung F3 RAID0 1.5TB Seagate Asus 22X DVDRW 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate 64-bit Dell Ultrasharp U2410 Asus ProArt PA248Q 
KeyboardPowerCaseMouse
Rosewill RK-9000BR PCP&P Silencer MKIII 600W Lian Li PC-A05NB Logitech G500 
Mouse PadAudioAudioAudio
Rocketfish Dual Sided Asus Xonar Essence STX Infinity Primus P153 | Dayton DTA-120 Amplifier... Shure SRH840 
AudioAudioAudio
Audio Technica ATH-AD700X Objective DAC Audio-Technica ATR2500-USB 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Xonar D2 Echo in Games