Overclock.net › Forums › Components › Sound Cards and Computer Audio › Logitech X-540 5.1 Surround Sound not working!
New Posts  All Forums:Forum Nav:

Logitech X-540 5.1 Surround Sound not working!

post #1 of 18
Thread Starter 
Hi
I've got an odd issue
I've got some new x540 speakers and they are not working properly. They are all plugged in as they should be to my 5.1 sound card but sound is wrong. For example
Left Front Speaker= Working correct
Right Front= Working Correct
Centre= Working Correct
Back Left= working Correct
Subwoofer= Sound coming from centre speaker???
Back Right= Sound coming from subwoofer?
Any ideas
Cheers
My soundcard is onboard 5.1 VIA HD Audio
Edited by mark.fuller - 1/15/11 at 8:46am
post #2 of 18
Do you have the Matrix(thing) button on or off(near the volume)
Main
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K Rampage Gene-Z EVGA GTX570 DS G-Skill sniper 8GB 1600Mhz 
Hard DriveCoolingOSMonitor
120Gb SSD + 1tbf3 H70 + typhoon Windows 7 24" Samsung P2450 
PowerCase
600w Modxstream Silverstone Ps07 
  hide details  
Reply
Main
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K Rampage Gene-Z EVGA GTX570 DS G-Skill sniper 8GB 1600Mhz 
Hard DriveCoolingOSMonitor
120Gb SSD + 1tbf3 H70 + typhoon Windows 7 24" Samsung P2450 
PowerCase
600w Modxstream Silverstone Ps07 
  hide details  
Reply
post #3 of 18
I had to put the, in 7.1 channel mode for them to work and disable which ever ones did not work so i had to disable 2 since this is 5.1 channel. Basically when i had them configured for 5.1 channel i had same problem as you.
Ishimura
(21 items)
 
Silent Knight
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 3770K @ 4.6GHz ASRock Z77E-ITX eVGA GTX 1080 Ti Hybrid AMD Radeon R9 16GB DDR3-2400MHz  
Hard DriveHard DriveCoolingCooling
SanDisk Ultra II 960GB Toshiba X300 5TB Corsair H100i GTX eVGA Hybrid Water Cooler  
CoolingOSMonitorKeyboard
4x GentleTyphoon AP-15 Windows 10 Pro 64-Bit Philips Brilliance BDM4065UC 4K Razer BlackWidow Chroma  
PowerCaseMouseMouse Pad
eVGA SuperNOVA 750 G3 Define Nano S Logitech G502 Proteus Core PECHAM Gaming Mouse Pad XX-Large 
AudioAudioAudioAudio
Audioengine D1 DAC Mackie CR Series CR3 Audio-Technica ATH-M50 Sennheiser HD 598 
Audio
Sony XB950BT 
CPUMotherboardGraphicsRAM
AMD Phenom II X4 955 @ 4.2GHz ASUS M4A79XTD EVO AMD Radeon HD 7970 3GB @ 1200/1500 2x 4GB G.SKILL Ripjaws X DDR3-1600 
Hard DriveHard DriveHard DriveCooling
OCZ Agility 3 60GB WD Caviar Green 1.5TB 2 x Seagate Barracuda 2TB XSPC Raystorm 
CoolingCoolingOSPower
EK-FC7970 XSPC RS360 Windows 10 Pro 64-Bit Corsair TX750 
Case
NZXT Switch 810  
  hide details  
Reply
Ishimura
(21 items)
 
Silent Knight
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 3770K @ 4.6GHz ASRock Z77E-ITX eVGA GTX 1080 Ti Hybrid AMD Radeon R9 16GB DDR3-2400MHz  
Hard DriveHard DriveCoolingCooling
SanDisk Ultra II 960GB Toshiba X300 5TB Corsair H100i GTX eVGA Hybrid Water Cooler  
CoolingOSMonitorKeyboard
4x GentleTyphoon AP-15 Windows 10 Pro 64-Bit Philips Brilliance BDM4065UC 4K Razer BlackWidow Chroma  
PowerCaseMouseMouse Pad
eVGA SuperNOVA 750 G3 Define Nano S Logitech G502 Proteus Core PECHAM Gaming Mouse Pad XX-Large 
AudioAudioAudioAudio
Audioengine D1 DAC Mackie CR Series CR3 Audio-Technica ATH-M50 Sennheiser HD 598 
Audio
Sony XB950BT 
CPUMotherboardGraphicsRAM
AMD Phenom II X4 955 @ 4.2GHz ASUS M4A79XTD EVO AMD Radeon HD 7970 3GB @ 1200/1500 2x 4GB G.SKILL Ripjaws X DDR3-1600 
Hard DriveHard DriveHard DriveCooling
OCZ Agility 3 60GB WD Caviar Green 1.5TB 2 x Seagate Barracuda 2TB XSPC Raystorm 
CoolingCoolingOSPower
EK-FC7970 XSPC RS360 Windows 10 Pro 64-Bit Corsair TX750 
Case
NZXT Switch 810  
  hide details  
Reply
post #4 of 18
Thread Starter 
Thanks for your replies
No that button is off as my sound card is 5.1
How do i disable speakers in 7.1 mode in VIA HD audio deck?
Thanks
post #5 of 18
Thread Starter 
It is now randomly playing left and right front out of centre now. Surely this should be an easy job??????!
post #6 of 18
Not sure as i use about yours but look at mine. If i put 5.1 i get no middle speaker but i get side ones.
Ishimura
(21 items)
 
Silent Knight
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 3770K @ 4.6GHz ASRock Z77E-ITX eVGA GTX 1080 Ti Hybrid AMD Radeon R9 16GB DDR3-2400MHz  
Hard DriveHard DriveCoolingCooling
SanDisk Ultra II 960GB Toshiba X300 5TB Corsair H100i GTX eVGA Hybrid Water Cooler  
CoolingOSMonitorKeyboard
4x GentleTyphoon AP-15 Windows 10 Pro 64-Bit Philips Brilliance BDM4065UC 4K Razer BlackWidow Chroma  
PowerCaseMouseMouse Pad
eVGA SuperNOVA 750 G3 Define Nano S Logitech G502 Proteus Core PECHAM Gaming Mouse Pad XX-Large 
AudioAudioAudioAudio
Audioengine D1 DAC Mackie CR Series CR3 Audio-Technica ATH-M50 Sennheiser HD 598 
Audio
Sony XB950BT 
CPUMotherboardGraphicsRAM
AMD Phenom II X4 955 @ 4.2GHz ASUS M4A79XTD EVO AMD Radeon HD 7970 3GB @ 1200/1500 2x 4GB G.SKILL Ripjaws X DDR3-1600 
Hard DriveHard DriveHard DriveCooling
OCZ Agility 3 60GB WD Caviar Green 1.5TB 2 x Seagate Barracuda 2TB XSPC Raystorm 
CoolingCoolingOSPower
EK-FC7970 XSPC RS360 Windows 10 Pro 64-Bit Corsair TX750 
Case
NZXT Switch 810  
  hide details  
Reply
Ishimura
(21 items)
 
Silent Knight
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 3770K @ 4.6GHz ASRock Z77E-ITX eVGA GTX 1080 Ti Hybrid AMD Radeon R9 16GB DDR3-2400MHz  
Hard DriveHard DriveCoolingCooling
SanDisk Ultra II 960GB Toshiba X300 5TB Corsair H100i GTX eVGA Hybrid Water Cooler  
CoolingOSMonitorKeyboard
4x GentleTyphoon AP-15 Windows 10 Pro 64-Bit Philips Brilliance BDM4065UC 4K Razer BlackWidow Chroma  
PowerCaseMouseMouse Pad
eVGA SuperNOVA 750 G3 Define Nano S Logitech G502 Proteus Core PECHAM Gaming Mouse Pad XX-Large 
AudioAudioAudioAudio
Audioengine D1 DAC Mackie CR Series CR3 Audio-Technica ATH-M50 Sennheiser HD 598 
Audio
Sony XB950BT 
CPUMotherboardGraphicsRAM
AMD Phenom II X4 955 @ 4.2GHz ASUS M4A79XTD EVO AMD Radeon HD 7970 3GB @ 1200/1500 2x 4GB G.SKILL Ripjaws X DDR3-1600 
Hard DriveHard DriveHard DriveCooling
OCZ Agility 3 60GB WD Caviar Green 1.5TB 2 x Seagate Barracuda 2TB XSPC Raystorm 
CoolingCoolingOSPower
EK-FC7970 XSPC RS360 Windows 10 Pro 64-Bit Corsair TX750 
Case
NZXT Switch 810  
  hide details  
Reply
post #7 of 18
Thread Starter 
Cheers for that
I put mine in 7.1 mode but it just gives me two side speakers that make no sound and same issue is there with centre speaker playing sound that is meant to come from subwoofer and back right sound being played from subwoofer and not back right
Very odd
post #8 of 18
D:

I know what your problem is i think

on 5.1 mode
Play the sound test and click the speaker fill and bass management while its playing
and make sure swap sub/center is off

Thats what i done anyway

But testing after that you cant edit the settings otherwise it will reset
Splash of blue
(13 items)
 
  
CPUMotherboardGraphicsRAM
I5 4690k Asus Maximus VII Hero Titan X 16GB Kingston HyperX Blue 
Hard DriveCoolingOSMonitor
Crucial BX100 1TB Prolimatech Megahalems Blue Windows 8.1 FTW Edition Asus PG348Q 
PowerCaseMouseMouse Pad
Seasonic X Series 650w Silverstone FT05 Roccat Kone Pure Steelseries S&S 
Audio
Microlab Solo 9C 
  hide details  
Reply
Splash of blue
(13 items)
 
  
CPUMotherboardGraphicsRAM
I5 4690k Asus Maximus VII Hero Titan X 16GB Kingston HyperX Blue 
Hard DriveCoolingOSMonitor
Crucial BX100 1TB Prolimatech Megahalems Blue Windows 8.1 FTW Edition Asus PG348Q 
PowerCaseMouseMouse Pad
Seasonic X Series 650w Silverstone FT05 Roccat Kone Pure Steelseries S&S 
Audio
Microlab Solo 9C 
  hide details  
Reply
post #9 of 18
you sure they are plugged in correctly at the back of the sub?
    
CPUMotherboardGraphicsRAM
i5 2500k ASUS P8Z68-V LX Intel 3000 G-Skill Sniper 
Hard DriveCoolingOSMonitor
Intel 320 Series SSD Stock Intel HSF , 2 Antec 100 stock fans, 2 ult... Windows 7 64 Bit Professional Samsung Syncmaster B2430 
KeyboardPowerCaseMouse
Logitech Illuminated Corsair CX430 V2 Antec 100 Logitech Dinovo 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5 2500k ASUS P8Z68-V LX Intel 3000 G-Skill Sniper 
Hard DriveCoolingOSMonitor
Intel 320 Series SSD Stock Intel HSF , 2 Antec 100 stock fans, 2 ult... Windows 7 64 Bit Professional Samsung Syncmaster B2430 
KeyboardPowerCaseMouse
Logitech Illuminated Corsair CX430 V2 Antec 100 Logitech Dinovo 
  hide details  
Reply
post #10 of 18
Thread Starter 
Thanks but unfortunately when i click it it stops playing and I start it again but it didn't work. Bass management and speaker fill are on anyway. It's very annoying! Yes I am certain they are plugged in correctly
Edited by mark.fuller - 1/15/11 at 9:06am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Logitech X-540 5.1 Surround Sound not working!