Overclock.net › Forums › Cooling › Water Cooling › bit of black plastic stuck to impeller
New Posts  All Forums:Forum Nav:

bit of black plastic stuck to impeller

post #1 of 3
Thread Starter 
I have an xspc ddc bay res and a swiftech 355.

While I was turning the pump on/off repeatedly to get rid of air bubbles, I spotted a bit of black plastic between the impeller and the o ring. Sometimes when i stopped the pump it would appear and other times it wasn't visible from my point of view, so I'm pretty sure it's rotating with the pump impeller and grinding along the pump top. ATM the loop is filled and the bubbles have been bled out so I'd like to just remove the pump and get the plastic out of there. Should I just unscrew the pump from the bay res with a bucket underneath and get the plastic out?

Davs Jr.
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K Gigabyte GA-Z68X-UD4-B3 MSI GeForce GTX 570 1280 MB G.SKILL Ripjaws X 2x4GB DDR3-1600 CL9-9-9-24 
Hard DriveOSMonitorKeyboard
OCZ Vertex 2 60 GB Win 7 32-bit BenQ 24" VA LED Logitech Illuminated Keyboard 
PowerCase
Corsair Professional Series Gold CMPSU-1200AX Coolermaster HAF-X 
  hide details  
Reply
Davs Jr.
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K Gigabyte GA-Z68X-UD4-B3 MSI GeForce GTX 570 1280 MB G.SKILL Ripjaws X 2x4GB DDR3-1600 CL9-9-9-24 
Hard DriveOSMonitorKeyboard
OCZ Vertex 2 60 GB Win 7 32-bit BenQ 24" VA LED Logitech Illuminated Keyboard 
PowerCase
Corsair Professional Series Gold CMPSU-1200AX Coolermaster HAF-X 
  hide details  
Reply
post #2 of 3
Thread Starter 
Well, I removed the pump and I think it was just a black strip of coating on the metal part of the rotor. Refraction has foiled me again!
Davs Jr.
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K Gigabyte GA-Z68X-UD4-B3 MSI GeForce GTX 570 1280 MB G.SKILL Ripjaws X 2x4GB DDR3-1600 CL9-9-9-24 
Hard DriveOSMonitorKeyboard
OCZ Vertex 2 60 GB Win 7 32-bit BenQ 24" VA LED Logitech Illuminated Keyboard 
PowerCase
Corsair Professional Series Gold CMPSU-1200AX Coolermaster HAF-X 
  hide details  
Reply
Davs Jr.
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K Gigabyte GA-Z68X-UD4-B3 MSI GeForce GTX 570 1280 MB G.SKILL Ripjaws X 2x4GB DDR3-1600 CL9-9-9-24 
Hard DriveOSMonitorKeyboard
OCZ Vertex 2 60 GB Win 7 32-bit BenQ 24" VA LED Logitech Illuminated Keyboard 
PowerCase
Corsair Professional Series Gold CMPSU-1200AX Coolermaster HAF-X 
  hide details  
Reply
post #3 of 3
Quote:
Originally Posted by Davs View Post
Well, I removed the pump and I think it was just a black strip of coating on the metal part of the rotor. Refraction has foiled me again!
better safe than sorry ;-)
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › bit of black plastic stuck to impeller