Overclock.net › Forums › Cooling › Water Cooling › Another spill
New Posts  All Forums:Forum Nav:

Another spill

post #1 of 44
Thread Starter 
So it seems that once again I have failed to learn from my mistakes. Yesterday I moved my loop from an older case in to a Obsidian 800D case and connected everything up. I ran the loop for 24 hours without any leaks and so started to connect up all of the power to the board and cards. Whilst it was powered down a clamp came lose on my radiator and spilled a bunch of coolant on my board and graphics cards. I cleaned it up as best I could and waited 4 hours and then tried to power it on. Nada, zip. I know that the power supply is fine because when I short it I can get the pump and fans working, it just won't power on the PC.

Any suggestions?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 Gigabyte X58A-UD3R GTX 470 WC AquaGraFX block Corsair Dominator GT 1866 
Hard DriveOptical DriveOSMonitor
SSD 32GB Blu Ray writer Win 7 x64 Ultimate Sharp Aquos 46" 
PowerCase
1000W Thermaltake A90 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 Gigabyte X58A-UD3R GTX 470 WC AquaGraFX block Corsair Dominator GT 1866 
Hard DriveOptical DriveOSMonitor
SSD 32GB Blu Ray writer Win 7 x64 Ultimate Sharp Aquos 46" 
PowerCase
1000W Thermaltake A90 
  hide details  
Reply
post #2 of 44
Ouch i must be one of the luckyest sob or my asus likes water i leaked on my board 4 times doing dumb stuff lol and every time worked perfect.
SABERWOLF
(18 items)
 
XEON-WOLF
(18 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-6800K MSI X99A GAMING PRO CARBON EVGA GTX 1080 FTW Hydro Copper G.SKILL TridentZ Series 
Hard DriveCoolingCoolingCooling
Samsung EVO 850 500 EK-SBAY Dual DDC 3.2 PWM Serial Alphacool NexXxoS ST30 Full Copper Radiator 360 Hardware Labs Black Ice SR2 Multiport Black Car... 
CoolingCoolingOSMonitor
EK-CoolStream RAD XTC 420 koolance 380i Windows 10 Pro ASUS VW246H Black 24" 2ms 
PowerCaseMouseAudio
SeaSonic M12D SS-850 850W  Thermaltake core x71 CM Storm Sentinel Advance II Corsair Void 
CPUMotherboardGraphicsRAM
X5675@4400 1.344 ASUS P6X58D-E XfX RX480 RS F3-12800CL7T-6GBPI 6-7-6-21 1T 
RAMHard DriveHard DriveHard Drive
F3-12800CL9S-4GBRL WDC WD1001FALS-00J7B1 ST31000340AS WDC WD7500AAKS-00RBA0 
Hard DriveOptical DriveCoolingOS
Hitachi HDS723020BLA642 ihas 624-A SilverStone Heligon HE01 windows 10 64 Pro 
MonitorPowerCase
Vizio 42inch lcd tv CORSAIR CMPSU-950TX Modded Rocketfish 
  hide details  
Reply
SABERWOLF
(18 items)
 
XEON-WOLF
(18 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7-6800K MSI X99A GAMING PRO CARBON EVGA GTX 1080 FTW Hydro Copper G.SKILL TridentZ Series 
Hard DriveCoolingCoolingCooling
Samsung EVO 850 500 EK-SBAY Dual DDC 3.2 PWM Serial Alphacool NexXxoS ST30 Full Copper Radiator 360 Hardware Labs Black Ice SR2 Multiport Black Car... 
CoolingCoolingOSMonitor
EK-CoolStream RAD XTC 420 koolance 380i Windows 10 Pro ASUS VW246H Black 24" 2ms 
PowerCaseMouseAudio
SeaSonic M12D SS-850 850W  Thermaltake core x71 CM Storm Sentinel Advance II Corsair Void 
CPUMotherboardGraphicsRAM
X5675@4400 1.344 ASUS P6X58D-E XfX RX480 RS F3-12800CL7T-6GBPI 6-7-6-21 1T 
RAMHard DriveHard DriveHard Drive
F3-12800CL9S-4GBRL WDC WD1001FALS-00J7B1 ST31000340AS WDC WD7500AAKS-00RBA0 
Hard DriveOptical DriveCoolingOS
Hitachi HDS723020BLA642 ihas 624-A SilverStone Heligon HE01 windows 10 64 Pro 
MonitorPowerCase
Vizio 42inch lcd tv CORSAIR CMPSU-950TX Modded Rocketfish 
  hide details  
Reply
post #3 of 44
Four hours is probably not enough, did you take the GPU's out of the slots and check the slots? Dang, hate it when that happens, hope it turns out to be something simple to fix like you forgot to plug/seat something correctly.

Does anything smell shorted? It's usually a good sign if there is no burnt smell and always bad if there is. I fried a $200 SSD and my DVD drive a couple weeks ago when a 4 pin molex to 2 SATA power cable's pins came out of the molex I must have put them back in crossed.
Edited by sgilmore62 - 1/18/11 at 4:51pm
    
CPUMotherboardGraphicsRAM
i7-930 Asus P6x-58D Premium HD5970+5870 950/1200 12gb Kingston HyperX 
Hard DriveOptical DriveOSMonitor
3x100GbOCZ VertexLE+2x120Gb Vertex2 RAID0 LG Win7 Professional Asus M276HE 
KeyboardPowerCaseMouse
Razer Lycosa ABS 1100watt Thermaltake SwordM Razer DeathAdder 
Mouse Pad
wowpad 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7-930 Asus P6x-58D Premium HD5970+5870 950/1200 12gb Kingston HyperX 
Hard DriveOptical DriveOSMonitor
3x100GbOCZ VertexLE+2x120Gb Vertex2 RAID0 LG Win7 Professional Asus M276HE 
KeyboardPowerCaseMouse
Razer Lycosa ABS 1100watt Thermaltake SwordM Razer DeathAdder 
Mouse Pad
wowpad 
  hide details  
Reply
post #4 of 44
Might be water in the socket. I'd suggest removing the block and double checking.

And then, let it dry for 24 hours before powering up.
post #5 of 44
Quote:
Originally Posted by sgilmore62 View Post
Four hours is probably not enough, did you take the GPU's out of the slots and check the slots? Dang, hate it when that happens, hope it turns out to be something simple to fix like you forgot to plug/seat something correctly.
This.

Sidenote-only reason I like my Raven...small leaks off my block will only drip onto the solid metal RAM heatspreaders away from exposed PCBs.
DD Boxen
(23 items)
 
   
CPUMotherboardGraphicsRAM
Intel Xeon E3-1230 Asus Maximus IV Gene-Z/Gen3 Powercolor 6970 2GB G. Skill 1600mHz Ripjaws 
Hard DriveOptical DriveCoolingCooling
SpinpontF3 1TB, WD 250, and WD320 Lite-On DT Waterblocks DT5Noz Waterblock Swiftech Komodo 6900-1 Waterblock 
CoolingCoolingCoolingOS
Swiftech MCR-220 Drive radiator Swiftech MCR-220 QP radiator 6xGentle Typhoon AP-15s Archx64 KDE4.5, Windows 7 x64 
MonitorKeyboardPowerCase
Eyefinity 3-head 5265x1050 OCN Ducky!! MX Blue Switches XFX 750W Black Edition Mountain Mods H2gO 
MouseAudioAudioAudio
Razer Naga Asus Xonar Essence STX Sennheiser 595 Sony STR-DE995 A/V receiver 
OtherOther
Lian Li Card flash memory reader Asus PCE-N15 Wifi-N card 
CPUMotherboardGraphicsRAM
AMD 1055T Gigabyte 790 Sapphire 4850x2 2x2GB 1600mHz 
Hard DriveOptical DriveOSKeyboard
A few Yes Vista/7 Das Keyboard 
Power
Ugly 
CPUMotherboardGraphicsRAM
Qualcomm Snapdragon APQ8060 1.2 GHz Something kinda small Qualcomm Adreno core 16GB 
Hard DriveOptical DriveOSMonitor
None N/A WebOS 3.0.2 9.7" XGA, multitouch 
PowerCase
6300mAh Piano Black 
  hide details  
Reply
DD Boxen
(23 items)
 
   
CPUMotherboardGraphicsRAM
Intel Xeon E3-1230 Asus Maximus IV Gene-Z/Gen3 Powercolor 6970 2GB G. Skill 1600mHz Ripjaws 
Hard DriveOptical DriveCoolingCooling
SpinpontF3 1TB, WD 250, and WD320 Lite-On DT Waterblocks DT5Noz Waterblock Swiftech Komodo 6900-1 Waterblock 
CoolingCoolingCoolingOS
Swiftech MCR-220 Drive radiator Swiftech MCR-220 QP radiator 6xGentle Typhoon AP-15s Archx64 KDE4.5, Windows 7 x64 
MonitorKeyboardPowerCase
Eyefinity 3-head 5265x1050 OCN Ducky!! MX Blue Switches XFX 750W Black Edition Mountain Mods H2gO 
MouseAudioAudioAudio
Razer Naga Asus Xonar Essence STX Sennheiser 595 Sony STR-DE995 A/V receiver 
OtherOther
Lian Li Card flash memory reader Asus PCE-N15 Wifi-N card 
CPUMotherboardGraphicsRAM
AMD 1055T Gigabyte 790 Sapphire 4850x2 2x2GB 1600mHz 
Hard DriveOptical DriveOSKeyboard
A few Yes Vista/7 Das Keyboard 
Power
Ugly 
CPUMotherboardGraphicsRAM
Qualcomm Snapdragon APQ8060 1.2 GHz Something kinda small Qualcomm Adreno core 16GB 
Hard DriveOptical DriveOSMonitor
None N/A WebOS 3.0.2 9.7" XGA, multitouch 
PowerCase
6300mAh Piano Black 
  hide details  
Reply
post #6 of 44
Thread Starter 
No burnt smell. Think i will pull everything out of the mobo and get busy with some ear buds.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 Gigabyte X58A-UD3R GTX 470 WC AquaGraFX block Corsair Dominator GT 1866 
Hard DriveOptical DriveOSMonitor
SSD 32GB Blu Ray writer Win 7 x64 Ultimate Sharp Aquos 46" 
PowerCase
1000W Thermaltake A90 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 Gigabyte X58A-UD3R GTX 470 WC AquaGraFX block Corsair Dominator GT 1866 
Hard DriveOptical DriveOSMonitor
SSD 32GB Blu Ray writer Win 7 x64 Ultimate Sharp Aquos 46" 
PowerCase
1000W Thermaltake A90 
  hide details  
Reply
post #7 of 44
Whenever you have a leak you should wait more than 4 hours before turning the equipment back on. Better to be safe than sorry.
Labor of Love
(14 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 5.0 GHz/1.42v ASUS P8P67 Pro MSI GTX 670 OC 20 GB/1600/7-7-7-24 
Hard DriveHard DriveOptical DriveOS
120GB Vertex SSD Western Digital 1TB None! Ubuntu 12.04/Win8/OSX 10.8.2 
MonitorKeyboardPowerCase
27" 1440p X-Star OCN Mechanical - MX Browns Seasonic X-560 800D w/RX480 top mounted 
Mouse
Logitech USB Generic 
  hide details  
Reply
Labor of Love
(14 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 5.0 GHz/1.42v ASUS P8P67 Pro MSI GTX 670 OC 20 GB/1600/7-7-7-24 
Hard DriveHard DriveOptical DriveOS
120GB Vertex SSD Western Digital 1TB None! Ubuntu 12.04/Win8/OSX 10.8.2 
MonitorKeyboardPowerCase
27" 1440p X-Star OCN Mechanical - MX Browns Seasonic X-560 800D w/RX480 top mounted 
Mouse
Logitech USB Generic 
  hide details  
Reply
post #8 of 44
Use a hair dryer and completely bone-dry every component before you attempt to power it on. If you don't smell anything burnt, that's a good sign. Chances are, nothing is damaged, you just need to get the moisture out.


After you dry everything out, if it still doesn't turn on, try removing components (video card, ram, etc) and start checking beep codes (or check your LED POST if you have one)
beast
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 4Ghz Gigabyte X58A-UD7 rev 1 GTX 580 EK Nickel+Acetal 6GB Corsair Dominator @ 2000 
Hard DriveOSMonitorKeyboard
WD 1TB Windows 7 64 Ultimate 2x Viewsonic 24" Razer Reclusa 
PowerCaseMouse
Corsair HX1000 Corsair Obsidian 800D Razer Death Adder 
  hide details  
Reply
beast
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 @ 4Ghz Gigabyte X58A-UD7 rev 1 GTX 580 EK Nickel+Acetal 6GB Corsair Dominator @ 2000 
Hard DriveOSMonitorKeyboard
WD 1TB Windows 7 64 Ultimate 2x Viewsonic 24" Razer Reclusa 
PowerCaseMouse
Corsair HX1000 Corsair Obsidian 800D Razer Death Adder 
  hide details  
Reply
post #9 of 44
Thread Starter 
Quote:
Originally Posted by mhaneline View Post
Use a hair dryer and completely bone-dry every component before you attempt to power it on. If you don't smell anything burnt, that's a good sign. Chances are, nothing is damaged, you just need to get the moisture out.


After you dry everything out, if it still doesn't turn on, try removing components (video card, ram, etc) and start checking beep codes (or check your LED POST if you have one)
No beep codes as there is no power going to the board. There is a light on the front of my box on the power switch but when I press it, it does nothing. It was done last night and I wont get the chance to try again till tomorrow so it will have been 48 hours since the spill when I next try. Fingers crossed.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 Gigabyte X58A-UD3R GTX 470 WC AquaGraFX block Corsair Dominator GT 1866 
Hard DriveOptical DriveOSMonitor
SSD 32GB Blu Ray writer Win 7 x64 Ultimate Sharp Aquos 46" 
PowerCase
1000W Thermaltake A90 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 Gigabyte X58A-UD3R GTX 470 WC AquaGraFX block Corsair Dominator GT 1866 
Hard DriveOptical DriveOSMonitor
SSD 32GB Blu Ray writer Win 7 x64 Ultimate Sharp Aquos 46" 
PowerCase
1000W Thermaltake A90 
  hide details  
Reply
post #10 of 44
yeah, use a hair dryer, then you wont have to wait 24 hours, it'll dry it quick
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › Another spill