Overclock.net › Forums › Intel › Intel CPUs › P8P67 EVO + 2600k = Why isn't Turbo working and why is my BCLK @ 103 mhz?
New Posts  All Forums:Forum Nav:

P8P67 EVO + 2600k = Why isn't Turbo working and why is my BCLK @ 103 mhz?

post #1 of 5
Thread Starter 
I don't understand.

I left everything at stock settings, except the BLCK which, I set at exactly 100 mhz. Why is it going up to 103? It seems BIOS isn't even saving my settings.

Isn't Turbo supposed to go up to 3.8ghz (multi @ 38x)?

And isn't it dangerous for the BLCK to go up to 103 mhz? I heard increasing it can screw up lots of things. But I set it @ 100 mhz in the BIOS.

What's happening? I'm running the stock BIOS, BTW. Version 0604.

Son of a Bridge
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.2ghz | 1.24v Asus P8P67 EVO [B3 Revision] Sapphire HD6870 1GB GDDR5 @ 1ghz Core 4GB Kingston HyperX DDR3 1600mhz 
Hard DriveOptical DriveOSMonitor
Hitachi Deskstar P7K500 500gb 16MB Cache SATA II SATA LG DVD burner Windows 7 Ultimate x64 Acer LCD 17" 1280x1024 
PowerCaseMouseMouse Pad
Corsair TX650 Modded regular case X7 X-760H 2000 DPI N@NO 
  hide details  
Reply
Son of a Bridge
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.2ghz | 1.24v Asus P8P67 EVO [B3 Revision] Sapphire HD6870 1GB GDDR5 @ 1ghz Core 4GB Kingston HyperX DDR3 1600mhz 
Hard DriveOptical DriveOSMonitor
Hitachi Deskstar P7K500 500gb 16MB Cache SATA II SATA LG DVD burner Windows 7 Ultimate x64 Acer LCD 17" 1280x1024 
PowerCaseMouseMouse Pad
Corsair TX650 Modded regular case X7 X-760H 2000 DPI N@NO 
  hide details  
Reply
post #2 of 5
Is the TPU enabled on the board..? Also, you need to have Enhanced Intel Speedstep, Intel Turbo and C3/C6 States enabled to overclock on Asus boards. Turbo doesn't engage when all 4 cores are on full load I believe.

Also, quick correction... Increasing the BCLK TOO HIGH can screw up things, just like on any other Core i7 or i5 processor.
The Wtfer
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600K ASUS P8Z68-V PRO EVGA GTX 465 w/ 470 Shaders/Memory/Clocks 8GB G.Skill DDR3 1866 
Hard DriveOptical DriveOSMonitor
Samsung F3 1TB LG 22X DVD±R DVD Burner Windows 7 Professional 64-Bit Dell U2311H + LG W2242S 
PowerCase
Corsair 750TX Coolermaster RC-692 Advanced 
  hide details  
Reply
The Wtfer
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600K ASUS P8Z68-V PRO EVGA GTX 465 w/ 470 Shaders/Memory/Clocks 8GB G.Skill DDR3 1866 
Hard DriveOptical DriveOSMonitor
Samsung F3 1TB LG 22X DVD±R DVD Burner Windows 7 Professional 64-Bit Dell U2311H + LG W2242S 
PowerCase
Corsair 750TX Coolermaster RC-692 Advanced 
  hide details  
Reply
post #3 of 5
Either you enabled TPU or on the Easy UEFI Screen, you chose Performance which overrides all manual input in the Advanced Screen. When you do that, the system does a basic overclock somehow and it seems 103 is the number it chooses. You're supposed to keep it at normal. I had this issue where I thought choosing Performance gave me optimal choices.
 
Uni. PC
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 3820 @ 4.5GHz Gigabyte X79-UD5 Gigabyte Windforce GTX670 4 x 4GB G.Skill Ripjaws X 
Hard DriveOptical DriveCoolingOS
120GB Pyro SE+2x2TB Caviar Black+2x2TB Caviar G... Pioneer DVR-217 Corsair H80 Windows 7 x64 
MonitorKeyboardPowerCase
Dell u2711 Das Ultimate S-S/Noppoo Choc Mini/Razer Black W... Seasonic x-760 Corsair 600T SE White 
MouseMouse PadAudio
Logitech G502/Logitech G700/Logitech MX1100 Steelseries I-2 White Glass Creative Titanium HD 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K @ 4.6GHz (~1.3v) Asus P8P67 Pro eVGA GTX470 16GB RipJaws X 
Hard DriveOptical DriveOSMonitor
Corsair F60 SSD+2x1TB Cav. Black+2x2TB Cav. Green Pioneer DVR-217 Windows 7 x64 Dell u2311h 
KeyboardPowerCaseMouse
Razer BWU/Noppoo Choc Mini XFX 750w Black Edition NZXT Phantom White Logitech G5/Razer Imperator 4G 
Mouse Pad
Steelseries Experience I-2 
  hide details  
Reply
 
Uni. PC
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 3820 @ 4.5GHz Gigabyte X79-UD5 Gigabyte Windforce GTX670 4 x 4GB G.Skill Ripjaws X 
Hard DriveOptical DriveCoolingOS
120GB Pyro SE+2x2TB Caviar Black+2x2TB Caviar G... Pioneer DVR-217 Corsair H80 Windows 7 x64 
MonitorKeyboardPowerCase
Dell u2711 Das Ultimate S-S/Noppoo Choc Mini/Razer Black W... Seasonic x-760 Corsair 600T SE White 
MouseMouse PadAudio
Logitech G502/Logitech G700/Logitech MX1100 Steelseries I-2 White Glass Creative Titanium HD 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K @ 4.6GHz (~1.3v) Asus P8P67 Pro eVGA GTX470 16GB RipJaws X 
Hard DriveOptical DriveOSMonitor
Corsair F60 SSD+2x1TB Cav. Black+2x2TB Cav. Green Pioneer DVR-217 Windows 7 x64 Dell u2311h 
KeyboardPowerCaseMouse
Razer BWU/Noppoo Choc Mini XFX 750w Black Edition NZXT Phantom White Logitech G5/Razer Imperator 4G 
Mouse Pad
Steelseries Experience I-2 
  hide details  
Reply
post #4 of 5
Thread Starter 
Quote:
Originally Posted by dev1ance View Post
Either you enabled TPU or on the Easy UEFI Screen, you chose Performance which overrides all manual input in the Advanced Screen. When you do that, the system does a basic overclock somehow and it seems 103 is the number it chooses. You're supposed to keep it at normal. I had this issue where I thought choosing Performance gave me optimal choices.
It seems I have to do a bit of reading

I have a TPU switch on my mobo, but I don't know what it does yet. What is it for?

What should I set it to, on the Easy UEFI screen?
Son of a Bridge
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.2ghz | 1.24v Asus P8P67 EVO [B3 Revision] Sapphire HD6870 1GB GDDR5 @ 1ghz Core 4GB Kingston HyperX DDR3 1600mhz 
Hard DriveOptical DriveOSMonitor
Hitachi Deskstar P7K500 500gb 16MB Cache SATA II SATA LG DVD burner Windows 7 Ultimate x64 Acer LCD 17" 1280x1024 
PowerCaseMouseMouse Pad
Corsair TX650 Modded regular case X7 X-760H 2000 DPI N@NO 
  hide details  
Reply
Son of a Bridge
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.2ghz | 1.24v Asus P8P67 EVO [B3 Revision] Sapphire HD6870 1GB GDDR5 @ 1ghz Core 4GB Kingston HyperX DDR3 1600mhz 
Hard DriveOptical DriveOSMonitor
Hitachi Deskstar P7K500 500gb 16MB Cache SATA II SATA LG DVD burner Windows 7 Ultimate x64 Acer LCD 17" 1280x1024 
PowerCaseMouseMouse Pad
Corsair TX650 Modded regular case X7 X-760H 2000 DPI N@NO 
  hide details  
Reply
post #5 of 5
Quote:
Originally Posted by PanicProne View Post
It seems I have to do a bit of reading

I have a TPU switch on my mobo, but I don't know what it does yet. What is it for?

What should I set it to, on the Easy UEFI screen?
Set it to NORMAL, The TPU is an automatic overclocking processor. If it's enabled, it overclocks your processor typically with the BCLK. So if its enabled, disable it.
The Wtfer
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600K ASUS P8Z68-V PRO EVGA GTX 465 w/ 470 Shaders/Memory/Clocks 8GB G.Skill DDR3 1866 
Hard DriveOptical DriveOSMonitor
Samsung F3 1TB LG 22X DVD±R DVD Burner Windows 7 Professional 64-Bit Dell U2311H + LG W2242S 
PowerCase
Corsair 750TX Coolermaster RC-692 Advanced 
  hide details  
Reply
The Wtfer
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600K ASUS P8Z68-V PRO EVGA GTX 465 w/ 470 Shaders/Memory/Clocks 8GB G.Skill DDR3 1866 
Hard DriveOptical DriveOSMonitor
Samsung F3 1TB LG 22X DVD±R DVD Burner Windows 7 Professional 64-Bit Dell U2311H + LG W2242S 
PowerCase
Corsair 750TX Coolermaster RC-692 Advanced 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel CPUs
Overclock.net › Forums › Intel › Intel CPUs › P8P67 EVO + 2600k = Why isn't Turbo working and why is my BCLK @ 103 mhz?