Overclock.net › Forums › Intel › Intel CPUs › New i5 2500K Speeds Not Correct?
New Posts  All Forums:Forum Nav:

New i5 2500K Speeds Not Correct?

post #1 of 17
Thread Starter 
Just got my new i5 installed and what I thought was good to go. I have the multi set to 38, so it should be running at 3.8ghz. When I run CPU-Z, it shows me at 1.5ghz. I went in and turned off Speedstep, yet it still shows as that. CPU-Z will randomly jump and show the correct multi and core speed (38 and 3.8ghz respectively), but then it will immediately go back down.



I'm lost as to what I'm doing wrong. This is my sig rig BTW.

Oh, I've also got the most up-to-date BIOs (they were just released yesterday)
Edited by waylo88 - 1/21/11 at 6:54pm
KOKAYNE DAWKiNS
(16 items)
 
  
Reply
KOKAYNE DAWKiNS
(16 items)
 
  
Reply
post #2 of 17
Thread Starter 
So, I just started up Black Ops and got into a server to see if the speeds would jump up since I'm running a 3D application. The processor would randomly jump to 3.3ghz, but then it'd go down to 2.6ghz, then back down to 1.5ghz. It'd randomly cycle the entire time.
KOKAYNE DAWKiNS
(16 items)
 
  
Reply
KOKAYNE DAWKiNS
(16 items)
 
  
Reply
post #3 of 17
Isn't Intel speedstep suppose to remain on? Turn it back on and while in game shooting guns check ur clocks. If you alt tabbing to check clocks they might be dropping down, as the load is now gone.
My System(s)
(15 items)
 
  
CPUMotherboardGraphicsRAM
5820k MSI X99S PLUS MSI Lightning GTX 780 3GB Team Group 2x4GB 2400MHz Ordering new ram soon. 
Hard DriveOptical DriveCoolingOS
Mushkin Enhanced Chronos Deluxe LG 22X DVDRW XSPC 240mm kit Windows 8.1 
MonitorKeyboardPowerCase
Qnix QX2710 (96Hz) Logitech G15 Corsair HX850 Azza Hurrican (R) 
Audio
Creative Labs Titanium X-FI 
  hide details  
Reply
My System(s)
(15 items)
 
  
CPUMotherboardGraphicsRAM
5820k MSI X99S PLUS MSI Lightning GTX 780 3GB Team Group 2x4GB 2400MHz Ordering new ram soon. 
Hard DriveOptical DriveCoolingOS
Mushkin Enhanced Chronos Deluxe LG 22X DVDRW XSPC 240mm kit Windows 8.1 
MonitorKeyboardPowerCase
Qnix QX2710 (96Hz) Logitech G15 Corsair HX850 Azza Hurrican (R) 
Audio
Creative Labs Titanium X-FI 
  hide details  
Reply
post #4 of 17
do you have the most up to date version of cpu-z? if not i recommend you get it, sandy bridge is very new and there is bound to be some software compatibility issues.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k p8p67 deluxe reference gtx 680 Ripjaws(blue)1866, 8-9-8-24-2t 
Hard DriveOptical DriveOSMonitor
c300, 2X WD CAVAIAR BLACK 640GB RAID 0 LG Bluray/Dvd Rewriter 7 Ult Gateway 24" lcd 1920x1200 
KeyboardPowerCaseMouse
Lycosa Corsair 750w tx Cooler Master HAF 932 black g9 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k p8p67 deluxe reference gtx 680 Ripjaws(blue)1866, 8-9-8-24-2t 
Hard DriveOptical DriveOSMonitor
c300, 2X WD CAVAIAR BLACK 640GB RAID 0 LG Bluray/Dvd Rewriter 7 Ult Gateway 24" lcd 1920x1200 
KeyboardPowerCaseMouse
Lycosa Corsair 750w tx Cooler Master HAF 932 black g9 
  hide details  
Reply
post #5 of 17
Thread Starter 
I just reformatted, so it's whatever version they've got up on the site, which I'm assuming is the newest one.
KOKAYNE DAWKiNS
(16 items)
 
  
Reply
KOKAYNE DAWKiNS
(16 items)
 
  
Reply
post #6 of 17
Thread Starter 
Have Speedstep back on and it still does the same thing. I hate the it downclocks while it's idle, but I could deal with it if it'd just run at it's stock clocks when in games rather than jumping all over the place and eventually settling at 1.5ghz.
KOKAYNE DAWKiNS
(16 items)
 
  
Reply
KOKAYNE DAWKiNS
(16 items)
 
  
Reply
post #7 of 17
Turn off C-State (C1E) & Speedstep.

Any other energy options aswell.
post #8 of 17
Thread Starter 
Speedstep and C1E are disabled yet it still shows 1.5ghz.
KOKAYNE DAWKiNS
(16 items)
 
  
Reply
KOKAYNE DAWKiNS
(16 items)
 
  
Reply
post #9 of 17
Clear your CMOS, my good sir.
Marshmallow
(14 items)
 
Corsair H100 - Excellent Compact Cooler
Corsair Hydro Series H100 Extreme Performance Liquid CPU Cooler (CWCH100)
 
CPUMotherboardGraphicsRAM
Core i7 920 @ 4.0GHz - 1.21v EVGA Classified X58 Asus GTX 580 DirectCU II 6GB Mushkin Blackline 
Hard DriveCoolingOSMonitor
Corsair F60 + 1TB Spinpoint F3 Corsair H100 Windows 7 Ultimate x64 Asus MK241H 24" 1920x1200 
KeyboardPowerCaseMouse
Das Model S Professional Silent Antec BP550 Plus NZXT Phantom Razer DeathAdder 
  hide details  
Reply
Marshmallow
(14 items)
 
Corsair H100 - Excellent Compact Cooler
Corsair Hydro Series H100 Extreme Performance Liquid CPU Cooler (CWCH100)
 
CPUMotherboardGraphicsRAM
Core i7 920 @ 4.0GHz - 1.21v EVGA Classified X58 Asus GTX 580 DirectCU II 6GB Mushkin Blackline 
Hard DriveCoolingOSMonitor
Corsair F60 + 1TB Spinpoint F3 Corsair H100 Windows 7 Ultimate x64 Asus MK241H 24" 1920x1200 
KeyboardPowerCaseMouse
Das Model S Professional Silent Antec BP550 Plus NZXT Phantom Razer DeathAdder 
  hide details  
Reply
post #10 of 17
Thread Starter 
Did that too.

I just went ahead and reverted my BIOs back to default and set the turbo to 4ghz. Runs at 1.5ghz idle and then goes up to 4ghz correctly when in-game. Guess I'll just leave it. Thanks for trying to help me out guys.
KOKAYNE DAWKiNS
(16 items)
 
  
Reply
KOKAYNE DAWKiNS
(16 items)
 
  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel CPUs
Overclock.net › Forums › Intel › Intel CPUs › New i5 2500K Speeds Not Correct?