Overclock.net › Forums › Intel › Intel Motherboards › i5 2500k turbo mode not working?
New Posts  All Forums:Forum Nav:

i5 2500k turbo mode not working?

post #1 of 3
Thread Starter 
Isn't i5 2500k supposed to hit 3.7ghz if you stress your cpu with prime 95? When i stress my cpu Ghz doesn't go up more then 3.4ghz .
how do you enable turbo mode?
post #2 of 3
Enable Intel Speed Step; set the long/short power limit to 200 each and then the duration as high as you can go. Watch temps though.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2500k @ 5GHz ASRock P67 Extreme4 GTX 580 8GB G.Skill Ripjaws X @ 1600 8-8-8-24 
Hard DriveMonitorPowerCase
64GB Crucial SSD/1 TB WD Caviar Black Asus VG236H 23" 3D Corsair 850 TX 800D 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2500k @ 5GHz ASRock P67 Extreme4 GTX 580 8GB G.Skill Ripjaws X @ 1600 8-8-8-24 
Hard DriveMonitorPowerCase
64GB Crucial SSD/1 TB WD Caviar Black Asus VG236H 23" 3D Corsair 850 TX 800D 
  hide details  
Reply
post #3 of 3
Thread Starter 
Quote:
Originally Posted by bl1nk View Post
Enable Intel Speed Step; set the long/short power limit to 200 each and then the duration as high as you can go. Watch temps though.
do you know what is the default setting for Intel Speed Step ?
because I remember something when I first installed my asus board it came with old asus bios 0703 in my board, Ghz used to go up from 3.4ghz to 3.7ghz automatic when running prime 95 but after updating asus latest bios 1053 the old setting for Intel Speed Step settings is gone...
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › i5 2500k turbo mode not working?