Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI, your drivers are evidently still crap
New Posts  All Forums:Forum Nav:

ATI, your drivers are evidently still crap - Page 5  

post #41 of 159
Quote:
Originally Posted by GsxR1000Ryda View Post
Must be user error. I've used 10.12 on both my AMD and Intel machine with the card clocked at 1000/1250 and have yet to run into any issues.
impossible not that many users can fail at installing a driver
post #42 of 159
Quote:
Originally Posted by pioneerisloud View Post
You know what's really funny here, I just got done using a 4890. I actually REGRET getting rid of it now for this 470 due to Nvidia driver issues. And yes, I've formatted even since then. Everytime I install the Nvidia drivers, if I forget about it, they completely wipe out my sound if I let them. Plus my cards NEVER downclock and undervolt like they're supposed to.

I honestly have never ONCE had an issue with ATI / AMD drivers. Never. I have had a few issues with Nvidia drivers, but nothing bad enough to keep me from buying their cards again.

Both brands have LEGITIMATE driver problems occasionally. The other 99.9% of the time (made up figure here), its user error that causes these so called driver problems.

What issues do you have with your Nvidia Drivers?
    
CPUMotherboardGraphicsRAM
|i7 2600K| |EVGA P67 SLI| |N560GTX-Ti Hawk| Waiting on Sandy Bridge :) 
Hard DriveOSMonitorPower
Waiting on Sandy Bridge :) |Windows 7 Ulitmate 64-Bit| |Hanns-G HZ281HPB 1920x1200| |Silverstone Strider Plus 850W| 
Case
|SilverStone RV03| ETA: 04/05/11 
  hide details  
    
CPUMotherboardGraphicsRAM
|i7 2600K| |EVGA P67 SLI| |N560GTX-Ti Hawk| Waiting on Sandy Bridge :) 
Hard DriveOSMonitorPower
Waiting on Sandy Bridge :) |Windows 7 Ulitmate 64-Bit| |Hanns-G HZ281HPB 1920x1200| |Silverstone Strider Plus 850W| 
Case
|SilverStone RV03| ETA: 04/05/11 
  hide details  
post #43 of 159
Quote:
Originally Posted by ShortySmalls View Post
ive never owned a ati desktop card (several freinds have them and they have had several problems due to drivers) but on my laptop (ati 4650 1gb) i can't update my drivers at all as they say my card is not detected.. yet i see it just fine in device manager and games n such
That's because you're using a laptop and most of the time, the manufacture of that laptop has some 3rd party **** installed giving you issues.

Like when Microsoft wants me to download drivers for my ATI card after a clean reformat....

I am NOT going to let Micro$oft install drivers for me... no thank you.
     
CPUMotherboardGraphicsGraphics
Core i7 2600K Asus Maximus IV Extreme AMD Radeon 7970 AMD Radeon 7970 
RAMHard DriveOptical DriveCooling
16gb Gskill 1866mhz Vertex 3 240gb. 1TB Seagate 7200. 160gb WD 7200. LG 24x DVD XSPC Raystorm, MCP655, Frozen-Q Tvirus, RS360mm... 
OSMonitorKeyboardPower
Windows 7 24'' 1080p by Asus Razer Blackwidow Ultimate Corsair 1000watt HX Modular 
CaseMouseMouse PadAudio
Corsair 800D Razer Mamba Razer Ironclad Razer Megalodon's  
  hide details  
     
CPUMotherboardGraphicsGraphics
Core i7 2600K Asus Maximus IV Extreme AMD Radeon 7970 AMD Radeon 7970 
RAMHard DriveOptical DriveCooling
16gb Gskill 1866mhz Vertex 3 240gb. 1TB Seagate 7200. 160gb WD 7200. LG 24x DVD XSPC Raystorm, MCP655, Frozen-Q Tvirus, RS360mm... 
OSMonitorKeyboardPower
Windows 7 24'' 1080p by Asus Razer Blackwidow Ultimate Corsair 1000watt HX Modular 
CaseMouseMouse PadAudio
Corsair 800D Razer Mamba Razer Ironclad Razer Megalodon's  
  hide details  
post #44 of 159
Quote:
Originally Posted by AK-47 View Post
impossible not that many users can fail at installing a driver
You would be surprised
     
CPUMotherboardGraphicsGraphics
Core i7 2600K Asus Maximus IV Extreme AMD Radeon 7970 AMD Radeon 7970 
RAMHard DriveOptical DriveCooling
16gb Gskill 1866mhz Vertex 3 240gb. 1TB Seagate 7200. 160gb WD 7200. LG 24x DVD XSPC Raystorm, MCP655, Frozen-Q Tvirus, RS360mm... 
OSMonitorKeyboardPower
Windows 7 24'' 1080p by Asus Razer Blackwidow Ultimate Corsair 1000watt HX Modular 
CaseMouseMouse PadAudio
Corsair 800D Razer Mamba Razer Ironclad Razer Megalodon's  
  hide details  
     
CPUMotherboardGraphicsGraphics
Core i7 2600K Asus Maximus IV Extreme AMD Radeon 7970 AMD Radeon 7970 
RAMHard DriveOptical DriveCooling
16gb Gskill 1866mhz Vertex 3 240gb. 1TB Seagate 7200. 160gb WD 7200. LG 24x DVD XSPC Raystorm, MCP655, Frozen-Q Tvirus, RS360mm... 
OSMonitorKeyboardPower
Windows 7 24'' 1080p by Asus Razer Blackwidow Ultimate Corsair 1000watt HX Modular 
CaseMouseMouse PadAudio
Corsair 800D Razer Mamba Razer Ironclad Razer Megalodon's  
  hide details  
post #45 of 159
Quote:
Originally Posted by pioneerisloud View Post
You know what's really funny here, I just got done using a 4890. I actually REGRET getting rid of it now for this 470 due to Nvidia driver issues. And yes, I've formatted even since then. Everytime I install the Nvidia drivers, if I forget about it, they completely wipe out my sound if I let them. Plus my cards NEVER downclock and undervolt like they're supposed to.

I honestly have never ONCE had an issue with ATI / AMD drivers. Never. I have had a few issues with Nvidia drivers, but nothing bad enough to keep me from buying their cards again.

Both brands have LEGITIMATE driver problems occasionally. The other 99.9% of the time (made up figure here), its user error that causes these so called driver problems.
This, i have owned a Rage3D, 9600, 2200XT, 3850, 4870, 5970 ( 2 of them), and a 6870. the only issues i had was the Rage3D, and the 5970 quadfire scaling.
post #46 of 159
Quote:
Originally Posted by AK-47 View Post
impossible not that many users can fail at installing a driver
You hold the user up too high.
post #47 of 159
Quote:
Originally Posted by Poisoner View Post
Quit using a poll to justify your trolling
Opinion Doesn't Equal Trollin'.
why does everyone on OCN think this...

He has a point. the Poll clearly shows he has a point.

i had a HD5850 and the drivers for it where so bad. I'm never buying ATI again.
you don't understand how annoying it is when your playing a game and all of a sudden it closes and you see some error message about Drivers crashing
    
CPUMotherboardGraphicsRAM
|i7 2600K| |EVGA P67 SLI| |N560GTX-Ti Hawk| Waiting on Sandy Bridge :) 
Hard DriveOSMonitorPower
Waiting on Sandy Bridge :) |Windows 7 Ulitmate 64-Bit| |Hanns-G HZ281HPB 1920x1200| |Silverstone Strider Plus 850W| 
Case
|SilverStone RV03| ETA: 04/05/11 
  hide details  
    
CPUMotherboardGraphicsRAM
|i7 2600K| |EVGA P67 SLI| |N560GTX-Ti Hawk| Waiting on Sandy Bridge :) 
Hard DriveOSMonitorPower
Waiting on Sandy Bridge :) |Windows 7 Ulitmate 64-Bit| |Hanns-G HZ281HPB 1920x1200| |Silverstone Strider Plus 850W| 
Case
|SilverStone RV03| ETA: 04/05/11 
  hide details  
post #48 of 159
Quote:
Originally Posted by AK-47 View Post
impossible not that many users can fail at installing a driver
Installing the latest beta 11.1a I messed up and blamed it on the driver, tried to reinstall the old drivers and buggered that up too, it took me around 7-8 attempts to get one of them installed stable... still not sure what I did wrong but the 10.12 had installed flawlessly the first time around.
Grendel
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel 4790K Asus Maximus VII Gene GTX970  32gb DDR3 2133Mhz 
Hard DriveHard DriveHard DriveHard Drive
120gb Kingston SSD 120gb Kingston SSD 2tb WD caviar green 3tb WD caviar green 
CoolingOSMonitorKeyboard
NH-D15 Windows 10 Samsung S24D590L X3 Nvidia surround Corsair K65 
PowerCaseMouseMouse Pad
Corsair CX750M Phanteks Enthoo Evolv Micro ATX Logitech G502 Proteus Core Logitech G440 
  hide details  
Grendel
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel 4790K Asus Maximus VII Gene GTX970  32gb DDR3 2133Mhz 
Hard DriveHard DriveHard DriveHard Drive
120gb Kingston SSD 120gb Kingston SSD 2tb WD caviar green 3tb WD caviar green 
CoolingOSMonitorKeyboard
NH-D15 Windows 10 Samsung S24D590L X3 Nvidia surround Corsair K65 
PowerCaseMouseMouse Pad
Corsair CX750M Phanteks Enthoo Evolv Micro ATX Logitech G502 Proteus Core Logitech G440 
  hide details  
post #49 of 159
Quote:
Originally Posted by pyra View Post
Installing the latest beta 11.1a I messed up and blamed it on the driver, tried to reinstall the old drivers and buggered that up too, it took me around 7-8 attempts to get one of them installed stable... still not sure what I did wrong but the 10.12 had installed flawlessly the first time around.
7-8 Attempts? how long did that take you?

And what part of Birmingham you from?

I'm a Yardley boy
    
CPUMotherboardGraphicsRAM
|i7 2600K| |EVGA P67 SLI| |N560GTX-Ti Hawk| Waiting on Sandy Bridge :) 
Hard DriveOSMonitorPower
Waiting on Sandy Bridge :) |Windows 7 Ulitmate 64-Bit| |Hanns-G HZ281HPB 1920x1200| |Silverstone Strider Plus 850W| 
Case
|SilverStone RV03| ETA: 04/05/11 
  hide details  
    
CPUMotherboardGraphicsRAM
|i7 2600K| |EVGA P67 SLI| |N560GTX-Ti Hawk| Waiting on Sandy Bridge :) 
Hard DriveOSMonitorPower
Waiting on Sandy Bridge :) |Windows 7 Ulitmate 64-Bit| |Hanns-G HZ281HPB 1920x1200| |Silverstone Strider Plus 850W| 
Case
|SilverStone RV03| ETA: 04/05/11 
  hide details  
post #50 of 159
I use both, and have had issues with both. Some nVIDIA drivers seem to cause system freezes and instability. It's a problem that's been going on for years. ATI, on the other hand, successfully killed one of my CRT monitors by repeatedly changing the resolution to something far beyond what it supported.

I'd say they're about even. Both have flaws, but neither is too bad.
 
GhettoBook
(13 items)
 
Pink EEE PC
(6 items)
 
CPUMotherboardGraphicsRAM
258x Omron MY4N relay @ 4 Hz plywood um, blinky lights? 4096 bit core memory 
OSMonitorKeyboardPower
Machine code FTW! 100+ LEDs lots of switches some huge 24V transformer 
CaseAudio
plywood CLICK CLICK CLICK 
CPUMotherboardGraphicsRAM
Q9000 @2.0 GHz HP DV7 2270us Mobility Radeon 4650 4GB DDR3 
Hard DriveOptical DriveOSMonitor
40GB Hitachi DVD-RW drive Debian + W7 Home premium x64 23" AOC panel 
KeyboardPowerCaseMouse
Undecided 500 Whr Lithium ion homemade out of ABS sheet Wacom Bamboo touch 
Mouse Pad
N/A 
CPUGraphicsRAMHard Drive
Atom N270 Intel GMA 1GB DDR2 160GB 
OSMonitor
Ubuntu 12.04 10.1 inch 1024x600 lcd 
  hide details  
 
GhettoBook
(13 items)
 
Pink EEE PC
(6 items)
 
CPUMotherboardGraphicsRAM
258x Omron MY4N relay @ 4 Hz plywood um, blinky lights? 4096 bit core memory 
OSMonitorKeyboardPower
Machine code FTW! 100+ LEDs lots of switches some huge 24V transformer 
CaseAudio
plywood CLICK CLICK CLICK 
CPUMotherboardGraphicsRAM
Q9000 @2.0 GHz HP DV7 2270us Mobility Radeon 4650 4GB DDR3 
Hard DriveOptical DriveOSMonitor
40GB Hitachi DVD-RW drive Debian + W7 Home premium x64 23" AOC panel 
KeyboardPowerCaseMouse
Undecided 500 Whr Lithium ion homemade out of ABS sheet Wacom Bamboo touch 
Mouse Pad
N/A 
CPUGraphicsRAMHard Drive
Atom N270 Intel GMA 1GB DDR2 160GB 
OSMonitor
Ubuntu 12.04 10.1 inch 1024x600 lcd 
  hide details  
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
This thread is locked  
Overclock.net › Forums › Graphics Cards › AMD/ATI › ATI, your drivers are evidently still crap