Overclock.net › Forums › Video Games › PC Gaming › GTA IV System Help
New Posts  All Forums:Forum Nav:

GTA IV System Help - Page 2

post #11 of 18
Quote:
Originally Posted by pioneerisloud View Post
I'd say CPU clock speed. Sure, its an i7...but its only clocked at 2.93GHz. Your PSU isn't that great either, but I don't think its specifically the problem here.
I'm not sure on that one man. I run this game at 2.8
and OC'd to 3.5 and 3.6 i don't see any real differences

Edit: I say this with little Knowledge on I7's
Dorianime
(15 items)
 
School Rig
(5 items)
 
 
MotherboardGraphicsRAMHard Drive
Clevo W120HNM/w170HN GT540M Samsung Seagate Momentus 
OS
Windows 7 ultimate 
  hide details  
Reply
Dorianime
(15 items)
 
School Rig
(5 items)
 
 
MotherboardGraphicsRAMHard Drive
Clevo W120HNM/w170HN GT540M Samsung Seagate Momentus 
OS
Windows 7 ultimate 
  hide details  
Reply
post #12 of 18
Ljbeer, and for everyone else on on this thread that doesn't remember that GTA IV is a POORLY optimized game.

The game is CRAZY CPU hungry more than BC2 even OC'd i7's have problems running this game.
post #13 of 18
Shouldn't. First thing i'd try right now is to turn of speedboost, EIST (I think that's what intel calls it) and turbo. Then a uninstall of the drivers t hen driversweepering it then a reinstall of the latest.
8-ball: my system on stock settings manages to run the game fine on high, my 4850 ran it on medium fine. The system with a 4850 had a e8400 on it originally and it ran it fine too.
Edited by Eagle1337 - 1/26/11 at 11:11pm
post #14 of 18
Quote:
Originally Posted by Eagle1337 View Post
Shouldn't. First thing i'd try right now is to turn of speedboost, EIST (I think that's what intel calls it) and turbo. Then a uninstall of the drivers t hen driversweepering it then a reinstall of the latest.
8-ball: my system on stock settings manages to run the game fine on high, my 4850 ran it on medium fine. The system with a 4850 had a e8400 on it originally and it ran it fine too.
Resolution and fps?
post #15 of 18
Quote:
Originally Posted by 8-Ball View Post
Resolution and fps?
1080, with the 5870 it's hitting 45-50 usually but randomly dips to really low.
4850 was at 1680x1050. it did about 50 fps and not too much of dipping.
post #16 of 18
Quote:
Originally Posted by Eagle1337 View Post
1080, with the 5870 it's hitting 45-50 usually but randomly dips to really low.
4850 was at 1680x1050. it did about 50 fps and not too much of dipping.
See..I don't think that's justified for the hardware you have.

It's a poorly coded/optimized game, many users agree as well.
post #17 of 18
Quote:
Originally Posted by 8-Ball View Post
See..I don't think that's justified for the hardware you have.

It's a poorly coded/optimized game, many users agree as well.
I don't disagree that it's poorly coded/optimized, but fact is i get those frames playing it. friend has a gtx 460 and doesn't have the issue either.
post #18 of 18
Thread Starter 
ok ill try all that and see if i have any more luck. it isn't even playable at the moment so not sure if i can salvage it with my limited knowledge!
Megamind
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 870 2.93GHz Gigabyte GA-P55A-UD3R Gainward GTX460 1G D5 GS Goes Like Hell Zeppelin 2048 1333 DDR3 x 2 
Hard DriveOptical DriveOSKeyboard
OCZ Vertex 2 120GB SSD & Seagate 2TB Samsung SH-B083A Bluray Reader Windows 7 64 bit Logitech G15 
PowerCaseMouse
Cooler Master Extreme Power 550W Cooler Master HAF RC-922m Logitech MX518 
  hide details  
Reply
Megamind
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 870 2.93GHz Gigabyte GA-P55A-UD3R Gainward GTX460 1G D5 GS Goes Like Hell Zeppelin 2048 1333 DDR3 x 2 
Hard DriveOptical DriveOSKeyboard
OCZ Vertex 2 120GB SSD & Seagate 2TB Samsung SH-B083A Bluray Reader Windows 7 64 bit Logitech G15 
PowerCaseMouse
Cooler Master Extreme Power 550W Cooler Master HAF RC-922m Logitech MX518 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › GTA IV System Help