Overclock.net › Forums › Video Games › PC Gaming › Getting extremely heavy lag from Dead Space 2?
New Posts  All Forums:Forum Nav:

Getting extremely heavy lag from Dead Space 2?

post #1 of 11
Thread Starter 
Hi guys, just got DS2 today and noticed when i started to play that the game is lagging(10-15 FPS with a HD5850?!!) very heavily.. i also noticed this with bad company 2 this week as at the start of my game it will lag pretty bad? what could be the issue? anyone else having this problem.
specs in sig.
DooM
(14 items)
 
  
CPUGraphicsRAMHard Drive
AMD FX 8320 @ 4.8 Ghz Powercolor Radeon HD7950 @ 1150 C/ 1575 M Gskill DDR3 1600 8GB Western Digital Black 7200RPM 1TB 
OSMonitorKeyboardPower
Windows 7 Ultimate x64 LG 55' LCD-LED 120hz 3DTV Razer Blackwidow Ultimate 550w Corsair 
CaseMouseMouse PadAudio
Coolermaster HAF 922 Logitech G502 Steelseries Auzentech Forte 7.1 
  hide details  
Reply
DooM
(14 items)
 
  
CPUGraphicsRAMHard Drive
AMD FX 8320 @ 4.8 Ghz Powercolor Radeon HD7950 @ 1150 C/ 1575 M Gskill DDR3 1600 8GB Western Digital Black 7200RPM 1TB 
OSMonitorKeyboardPower
Windows 7 Ultimate x64 LG 55' LCD-LED 120hz 3DTV Razer Blackwidow Ultimate 550w Corsair 
CaseMouseMouse PadAudio
Coolermaster HAF 922 Logitech G502 Steelseries Auzentech Forte 7.1 
  hide details  
Reply
post #2 of 11
a lot of newer games are being optimized for quad cores, so that could be part of it, but I would start your task manager and check out your cpu, memory, and graphics usage. Also what settings are you trying to run? If your trying to run everything maxed out, thats not going to cut it with your sig rig unfortunately.
The Laptop
(6 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7 2860QM AMD Radeon HD 6770M Corsair Vengence 1600MHz Samsung 840 Pro 256GB 
OSMonitor
Mac OS X 10.8 1680 x 1050 anti-glare high resolution  
  hide details  
Reply
The Laptop
(6 items)
 
  
CPUGraphicsRAMHard Drive
Intel i7 2860QM AMD Radeon HD 6770M Corsair Vengence 1600MHz Samsung 840 Pro 256GB 
OSMonitor
Mac OS X 10.8 1680 x 1050 anti-glare high resolution  
  hide details  
Reply
post #3 of 11
Thread Starter 
o_O
I had no issues running metro 2033 at max settings dx11, same goes with bad company 2 among other games. this is the first game where I have actually had "lag"
DooM
(14 items)
 
  
CPUGraphicsRAMHard Drive
AMD FX 8320 @ 4.8 Ghz Powercolor Radeon HD7950 @ 1150 C/ 1575 M Gskill DDR3 1600 8GB Western Digital Black 7200RPM 1TB 
OSMonitorKeyboardPower
Windows 7 Ultimate x64 LG 55' LCD-LED 120hz 3DTV Razer Blackwidow Ultimate 550w Corsair 
CaseMouseMouse PadAudio
Coolermaster HAF 922 Logitech G502 Steelseries Auzentech Forte 7.1 
  hide details  
Reply
DooM
(14 items)
 
  
CPUGraphicsRAMHard Drive
AMD FX 8320 @ 4.8 Ghz Powercolor Radeon HD7950 @ 1150 C/ 1575 M Gskill DDR3 1600 8GB Western Digital Black 7200RPM 1TB 
OSMonitorKeyboardPower
Windows 7 Ultimate x64 LG 55' LCD-LED 120hz 3DTV Razer Blackwidow Ultimate 550w Corsair 
CaseMouseMouse PadAudio
Coolermaster HAF 922 Logitech G502 Steelseries Auzentech Forte 7.1 
  hide details  
Reply
post #4 of 11
Yes games are optimized for quads these days but there's no way that a highly overclocked E8400 and 5850 are not enough horsepower for gaming...

Did you recently install a new GPU driver or make any other configuration/OC changes?
At long last...
(13 items)
 
  
CPUMotherboardGraphicsRAM
920 D0 | 4104MHz@1.23V Big Bang XPower 5850 | 880/1050 6GB Sector 7 | 1728MHz 
Hard DriveOSMonitorPower
F115 W7P64 245BW SPI Magna 1kW 
Case
cardboard (case/loop in prog) 
  hide details  
Reply
At long last...
(13 items)
 
  
CPUMotherboardGraphicsRAM
920 D0 | 4104MHz@1.23V Big Bang XPower 5850 | 880/1050 6GB Sector 7 | 1728MHz 
Hard DriveOSMonitorPower
F115 W7P64 245BW SPI Magna 1kW 
Case
cardboard (case/loop in prog) 
  hide details  
Reply
post #5 of 11
Thread Starter 
Nope, none what so ever. I tried upgrading my drivers just now from 10.8 to 11.1 and that didnt fix the issue what so ever. I tried running on stock clocks and made no difference. I don't know.. oftly random thats forsure.
I checked my temps but as always it isn't peaking 53c.
DooM
(14 items)
 
  
CPUGraphicsRAMHard Drive
AMD FX 8320 @ 4.8 Ghz Powercolor Radeon HD7950 @ 1150 C/ 1575 M Gskill DDR3 1600 8GB Western Digital Black 7200RPM 1TB 
OSMonitorKeyboardPower
Windows 7 Ultimate x64 LG 55' LCD-LED 120hz 3DTV Razer Blackwidow Ultimate 550w Corsair 
CaseMouseMouse PadAudio
Coolermaster HAF 922 Logitech G502 Steelseries Auzentech Forte 7.1 
  hide details  
Reply
DooM
(14 items)
 
  
CPUGraphicsRAMHard Drive
AMD FX 8320 @ 4.8 Ghz Powercolor Radeon HD7950 @ 1150 C/ 1575 M Gskill DDR3 1600 8GB Western Digital Black 7200RPM 1TB 
OSMonitorKeyboardPower
Windows 7 Ultimate x64 LG 55' LCD-LED 120hz 3DTV Razer Blackwidow Ultimate 550w Corsair 
CaseMouseMouse PadAudio
Coolermaster HAF 922 Logitech G502 Steelseries Auzentech Forte 7.1 
  hide details  
Reply
post #6 of 11
Thread Starter 
if i change the resolution its fine, but if its on 1920x1080 i
get hella lag
DooM
(14 items)
 
  
CPUGraphicsRAMHard Drive
AMD FX 8320 @ 4.8 Ghz Powercolor Radeon HD7950 @ 1150 C/ 1575 M Gskill DDR3 1600 8GB Western Digital Black 7200RPM 1TB 
OSMonitorKeyboardPower
Windows 7 Ultimate x64 LG 55' LCD-LED 120hz 3DTV Razer Blackwidow Ultimate 550w Corsair 
CaseMouseMouse PadAudio
Coolermaster HAF 922 Logitech G502 Steelseries Auzentech Forte 7.1 
  hide details  
Reply
DooM
(14 items)
 
  
CPUGraphicsRAMHard Drive
AMD FX 8320 @ 4.8 Ghz Powercolor Radeon HD7950 @ 1150 C/ 1575 M Gskill DDR3 1600 8GB Western Digital Black 7200RPM 1TB 
OSMonitorKeyboardPower
Windows 7 Ultimate x64 LG 55' LCD-LED 120hz 3DTV Razer Blackwidow Ultimate 550w Corsair 
CaseMouseMouse PadAudio
Coolermaster HAF 922 Logitech G502 Steelseries Auzentech Forte 7.1 
  hide details  
Reply
post #7 of 11
ive noticed if i turn AA just on 2 in CCC and off in game, it goes to an absolute crawl. doesn't seem normal for ai7 920 and 4850x2 at 1080p and no vsync
post #8 of 11
Thread Starter 
Quote:
Originally Posted by corpse fan;12179912 
ive noticed if i turn AA just on 2 in CCC and off in game, it goes to an absolute crawl. doesn't seem normal for ai7 920 and 4850x2 at 1080p and no vsync

WINNER! turned off AA in CCC and it completely fixed my issues, getting way passed 50 fps
DooM
(14 items)
 
  
CPUGraphicsRAMHard Drive
AMD FX 8320 @ 4.8 Ghz Powercolor Radeon HD7950 @ 1150 C/ 1575 M Gskill DDR3 1600 8GB Western Digital Black 7200RPM 1TB 
OSMonitorKeyboardPower
Windows 7 Ultimate x64 LG 55' LCD-LED 120hz 3DTV Razer Blackwidow Ultimate 550w Corsair 
CaseMouseMouse PadAudio
Coolermaster HAF 922 Logitech G502 Steelseries Auzentech Forte 7.1 
  hide details  
Reply
DooM
(14 items)
 
  
CPUGraphicsRAMHard Drive
AMD FX 8320 @ 4.8 Ghz Powercolor Radeon HD7950 @ 1150 C/ 1575 M Gskill DDR3 1600 8GB Western Digital Black 7200RPM 1TB 
OSMonitorKeyboardPower
Windows 7 Ultimate x64 LG 55' LCD-LED 120hz 3DTV Razer Blackwidow Ultimate 550w Corsair 
CaseMouseMouse PadAudio
Coolermaster HAF 922 Logitech G502 Steelseries Auzentech Forte 7.1 
  hide details  
Reply
post #9 of 11
wow, i inadvertently fixed someones problem. GO ME!
we will probably have to wait for a fix like for ME2.
post #10 of 11
im having the same problem and i have Geforce graphics card instead of Radeon. i tried to turn off AA on this thing but it still lags. what should i do?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Getting extremely heavy lag from Dead Space 2?