Overclock.net › Forums › Video Games › PC Gaming › Antuk15's Anti-Aliasing Fix For Crysis ( ATI Only )
New Posts  All Forums:Forum Nav:

Antuk15's Anti-Aliasing Fix For Crysis ( ATI Only )

post #1 of 4
Thread Starter 
Right my fellow ATI users and Crysis players, Sick of Crysis's sub-standard image quality? Sick of turning on anti-aliasing and it not smoothing everything out like it should? For some reason the engine will not apply transparency anti-aliasing to transparent/alpha textures which in a game that's full of said textures is an eye sore!

Not anymore, Follow these steps to get Anti-Aliasing that WORKS as it should in Crysis...

Setting up the drivers :

1. Install 11.1a Beta drivers or the WHQL 11.1 drivers
2. Go into 3D options and put 'Anti-Aliasing Mode' to 'ADAPTIVE'
3. Go the 'Adaptive Anti-Aliasing' box and tick the check box to enable Adaptive anti-aliasing.
4. Set Adaptive anti-aliasing to 'QUALITY'
5. Apply the settings.

Setting up Crysis :

1. Load the game up in DX10
2. Load a map of your choice and find a tree/bush
3. Look at how jaggie it is, Look how the tree's in the foreground/background flicker and generally just look a mess.
4. Go up to a tree, Look at the jaggies. Turn on atleast 4xMSAA, Notice it's still jaggie?
5. Exist the game, Create a shortcut and add '-dx9' to force the game in DX9 mode.
6. Load the game up with the same map/area you did when in DX10 mode.
7. Once in the map notice how the trees/bushes are still a jaggie mess?
8. Turn on atleast 4xMSAA...voila!!! Perfect anti-aliased polygon edges and trees/bushes...

Excuse the pictures, Converting them to JPEG has degraded the quality. The difference is much much obvious when playing the game as none of the distant tree's/bushes flicker any more, they'er just razor sharp and crisp

DX9 No MSAA ( Jaggie tree leafs )



DX9 4XMSAA+4XTRSAA ( Jaggie Free leafs )



Again much more obvious in game play then screen shots.

NOTE : Due to anti-aliasing now working properly do expect a performance drop from turning MSAA on as it's actually being applied this time and thus is using your GPU's power more.

NOTE 2 : Running in DX9 will require a config file to get DX10 like effects, I recommend CCC config pack
post #2 of 4
Not to be a troll but you're still gonna crash That's how Crysis is but hey it's nice to see finally you guys have AA control now. Congrats for the fix, i'm sure others are excited but hey i think most are just ready for Crysis 2. What if you couldn't use AA in Crysis 2? Now what? Just kiddin
post #3 of 4
Thread Starter 
Random shock I took from about 30mins ago while playing the 'Tank' level.

4xMSAA+4XTRSAA



The difference proper anti-aliasing makes to the game is unreal!
post #4 of 4
Thread Starter 
Quote:
Originally Posted by 78@pwnt4lif3 View Post
Not to be a troll but you're still gonna crash That's how Crysis is but hey it's nice to see finally you guys have AA control now. Congrats for the fix, i'm sure others are excited but hey i think most are just ready for Crysis 2. What if you couldn't use AA in Crysis 2? Now what? Just kiddin
ATI has always had MSAA control, It's just never applied it to transparent/alpha textures till now and I don't remember it working on Nvidia hardware either from back when I used Nvidia cards, you sure it's kicking in properly? Go up to a bush with no AA, then with AA and see if it's been MSAA'd properly.
Edited by antuk15 - 2/4/11 at 10:26am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Antuk15's Anti-Aliasing Fix For Crysis ( ATI Only )