Overclock.net › Forums › Software, Programming and Coding › Other Software › Chrome Displays Site in wrong language
New Posts  All Forums:Forum Nav:

Chrome Displays Site in wrong language

post #1 of 12
Thread Starter 
The browser's language is English and all sites work well except for thepiratebay.

For some reason, it automatically goes to Finnish. Any idea how to change it?

Capture-15.jpg

Thanks

edit: even if I click translate, the following time it will default to Finnish again.

edit II: Using 11.0.659.0 canary build
Edited by makecoldplayhistory - 2/4/11 at 11:09pm
My do-it-all rig
(17 items)
 
  
CPUMotherboardGraphicsGraphics
AMD K15 970A-D3P NVIDIA GeForce GTX 660  NVIDIA GeForce GTX 460 
RAMRAMHard DriveOptical Drive
Kingston  Kingston  Crucial M4 64Gb, 4x 1Tb, 1x 500Gb WD Caviar Black LG LiteScribe GH24 
OSMonitorKeyboardPower
Win 10 x64 LG E2350 23" 1920x1080 / Samsung 19.5" 1366x768 Razer Lycosa (Mirror Edition) Corsair HX850w 
CaseMouseMouse PadAudio
CoolerMaster 690 Razer Mamba 2012 Razer Goliath XL Logitech X-530 speakers 
Audio
Creative SupremeFX X-Fi sound card 
  hide details  
Reply
My do-it-all rig
(17 items)
 
  
CPUMotherboardGraphicsGraphics
AMD K15 970A-D3P NVIDIA GeForce GTX 660  NVIDIA GeForce GTX 460 
RAMRAMHard DriveOptical Drive
Kingston  Kingston  Crucial M4 64Gb, 4x 1Tb, 1x 500Gb WD Caviar Black LG LiteScribe GH24 
OSMonitorKeyboardPower
Win 10 x64 LG E2350 23" 1920x1080 / Samsung 19.5" 1366x768 Razer Lycosa (Mirror Edition) Corsair HX850w 
CaseMouseMouse PadAudio
CoolerMaster 690 Razer Mamba 2012 Razer Goliath XL Logitech X-530 speakers 
Audio
Creative SupremeFX X-Fi sound card 
  hide details  
Reply
post #2 of 12
FWIW, I just tried TPB w/ FF, and it displayed in English. So I guess it really is a browser problem.
    
CPUMotherboardGraphicsRAM
Intel C2Q Q9550 @ 3.8 Asus P5K Deluxe MSI GTX460 1GB Cyclone G.Skill DDR2 - 4GB 
Hard DriveOptical DriveOSMonitor
2TB RAID0 F3, 2TB F4 (x2) DVD burner, Blu-ray reader Windows 7 Ult. (x64) Dell U3011 
KeyboardPowerCaseMouse
Filco Majestouch Linear R Corsair HX650W CM Sniper (Blk Ed.) Razer DeathAdder 
Mouse Pad
QcK cloth pad 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel C2Q Q9550 @ 3.8 Asus P5K Deluxe MSI GTX460 1GB Cyclone G.Skill DDR2 - 4GB 
Hard DriveOptical DriveOSMonitor
2TB RAID0 F3, 2TB F4 (x2) DVD burner, Blu-ray reader Windows 7 Ult. (x64) Dell U3011 
KeyboardPowerCaseMouse
Filco Majestouch Linear R Corsair HX650W CM Sniper (Blk Ed.) Razer DeathAdder 
Mouse Pad
QcK cloth pad 
  hide details  
Reply
post #3 of 12
Try to change something in the translator options.
4-year build.
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 @ 4GHz 1.27v (LOAD) EVGA 750i SLI EVGA GTX 460 768MB SC @ 870/1075 G.SKILL PI Black 4GB 4-4-4-12 850MHz 
Hard DriveOSMonitorPower
WD Blue Caviar 320GB Windows 7 x64 DELL SE198WFP ThermalTake TR2 430w 
Case
It's a table!! 
  hide details  
Reply
4-year build.
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 @ 4GHz 1.27v (LOAD) EVGA 750i SLI EVGA GTX 460 768MB SC @ 870/1075 G.SKILL PI Black 4GB 4-4-4-12 850MHz 
Hard DriveOSMonitorPower
WD Blue Caviar 320GB Windows 7 x64 DELL SE198WFP ThermalTake TR2 430w 
Case
It's a table!! 
  hide details  
Reply
post #4 of 12
Thread Starter 
It is a browser problem, but thanks smile.gif

I use Canary and my wife uses regular Chrome (saves her closing all my tabs mad.gif)

IE, FF, and normal Chrome all work fine. I did a clean install this week and it's since then that TPB's been screwy.

It's the only site to have problems. It's the same if I navigate to it through google.co.uk.
My do-it-all rig
(17 items)
 
  
CPUMotherboardGraphicsGraphics
AMD K15 970A-D3P NVIDIA GeForce GTX 660  NVIDIA GeForce GTX 460 
RAMRAMHard DriveOptical Drive
Kingston  Kingston  Crucial M4 64Gb, 4x 1Tb, 1x 500Gb WD Caviar Black LG LiteScribe GH24 
OSMonitorKeyboardPower
Win 10 x64 LG E2350 23" 1920x1080 / Samsung 19.5" 1366x768 Razer Lycosa (Mirror Edition) Corsair HX850w 
CaseMouseMouse PadAudio
CoolerMaster 690 Razer Mamba 2012 Razer Goliath XL Logitech X-530 speakers 
Audio
Creative SupremeFX X-Fi sound card 
  hide details  
Reply
My do-it-all rig
(17 items)
 
  
CPUMotherboardGraphicsGraphics
AMD K15 970A-D3P NVIDIA GeForce GTX 660  NVIDIA GeForce GTX 460 
RAMRAMHard DriveOptical Drive
Kingston  Kingston  Crucial M4 64Gb, 4x 1Tb, 1x 500Gb WD Caviar Black LG LiteScribe GH24 
OSMonitorKeyboardPower
Win 10 x64 LG E2350 23" 1920x1080 / Samsung 19.5" 1366x768 Razer Lycosa (Mirror Edition) Corsair HX850w 
CaseMouseMouse PadAudio
CoolerMaster 690 Razer Mamba 2012 Razer Goliath XL Logitech X-530 speakers 
Audio
Creative SupremeFX X-Fi sound card 
  hide details  
Reply
post #5 of 12
Thread Starter 
Quote:
Originally Posted by kora04;12268563 
Try to change something in the translator options.

Thanks.

I have "always translate Finnish to English" ticked, but it doesn't work...
My do-it-all rig
(17 items)
 
  
CPUMotherboardGraphicsGraphics
AMD K15 970A-D3P NVIDIA GeForce GTX 660  NVIDIA GeForce GTX 460 
RAMRAMHard DriveOptical Drive
Kingston  Kingston  Crucial M4 64Gb, 4x 1Tb, 1x 500Gb WD Caviar Black LG LiteScribe GH24 
OSMonitorKeyboardPower
Win 10 x64 LG E2350 23" 1920x1080 / Samsung 19.5" 1366x768 Razer Lycosa (Mirror Edition) Corsair HX850w 
CaseMouseMouse PadAudio
CoolerMaster 690 Razer Mamba 2012 Razer Goliath XL Logitech X-530 speakers 
Audio
Creative SupremeFX X-Fi sound card 
  hide details  
Reply
My do-it-all rig
(17 items)
 
  
CPUMotherboardGraphicsGraphics
AMD K15 970A-D3P NVIDIA GeForce GTX 660  NVIDIA GeForce GTX 460 
RAMRAMHard DriveOptical Drive
Kingston  Kingston  Crucial M4 64Gb, 4x 1Tb, 1x 500Gb WD Caviar Black LG LiteScribe GH24 
OSMonitorKeyboardPower
Win 10 x64 LG E2350 23" 1920x1080 / Samsung 19.5" 1366x768 Razer Lycosa (Mirror Edition) Corsair HX850w 
CaseMouseMouse PadAudio
CoolerMaster 690 Razer Mamba 2012 Razer Goliath XL Logitech X-530 speakers 
Audio
Creative SupremeFX X-Fi sound card 
  hide details  
Reply
post #6 of 12
Try this.
Quote:
1. Click the wrench menu .
2. Select Options. [4 from bottom!]
3. Click the Minor Tweaks tab (or Under the Hood if you're using Google Chrome Beta). [3rd Tab of 3.]
4. Click Change fonts and language settings .In the 'Fonts and Languages' dialog box, click the Languages tab. [4th Topic in BOLD and 1st Click box therein.]
5. Select the 2nd tab
6. Select the language you'd like to use in the 'Google Chrome language' drop-down menu. [The 2nd drop down box - all languages will be listed IN THAI - scroll down until you see "(United States)", "(Untied Kingdom)", or "(Australia)" - those are the English language choices. Choose the one that suits your locale.]
7. Restart the browser. Your new language setting should now take effect.
8. Go back and add "English (United States)" to the list of languages to use when reading websites in the same area.
9. Now, you are all set.
4-year build.
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 @ 4GHz 1.27v (LOAD) EVGA 750i SLI EVGA GTX 460 768MB SC @ 870/1075 G.SKILL PI Black 4GB 4-4-4-12 850MHz 
Hard DriveOSMonitorPower
WD Blue Caviar 320GB Windows 7 x64 DELL SE198WFP ThermalTake TR2 430w 
Case
It's a table!! 
  hide details  
Reply
4-year build.
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 @ 4GHz 1.27v (LOAD) EVGA 750i SLI EVGA GTX 460 768MB SC @ 870/1075 G.SKILL PI Black 4GB 4-4-4-12 850MHz 
Hard DriveOSMonitorPower
WD Blue Caviar 320GB Windows 7 x64 DELL SE198WFP ThermalTake TR2 430w 
Case
It's a table!! 
  hide details  
Reply
post #7 of 12
Thread Starter 
Thanks Kora. I'd tried that. I tried it again, but still no luck... comfusing.

Maybe it's an issue with the current Canary release.
My do-it-all rig
(17 items)
 
  
CPUMotherboardGraphicsGraphics
AMD K15 970A-D3P NVIDIA GeForce GTX 660  NVIDIA GeForce GTX 460 
RAMRAMHard DriveOptical Drive
Kingston  Kingston  Crucial M4 64Gb, 4x 1Tb, 1x 500Gb WD Caviar Black LG LiteScribe GH24 
OSMonitorKeyboardPower
Win 10 x64 LG E2350 23" 1920x1080 / Samsung 19.5" 1366x768 Razer Lycosa (Mirror Edition) Corsair HX850w 
CaseMouseMouse PadAudio
CoolerMaster 690 Razer Mamba 2012 Razer Goliath XL Logitech X-530 speakers 
Audio
Creative SupremeFX X-Fi sound card 
  hide details  
Reply
My do-it-all rig
(17 items)
 
  
CPUMotherboardGraphicsGraphics
AMD K15 970A-D3P NVIDIA GeForce GTX 660  NVIDIA GeForce GTX 460 
RAMRAMHard DriveOptical Drive
Kingston  Kingston  Crucial M4 64Gb, 4x 1Tb, 1x 500Gb WD Caviar Black LG LiteScribe GH24 
OSMonitorKeyboardPower
Win 10 x64 LG E2350 23" 1920x1080 / Samsung 19.5" 1366x768 Razer Lycosa (Mirror Edition) Corsair HX850w 
CaseMouseMouse PadAudio
CoolerMaster 690 Razer Mamba 2012 Razer Goliath XL Logitech X-530 speakers 
Audio
Creative SupremeFX X-Fi sound card 
  hide details  
Reply
post #8 of 12
Why are you using it btw?

I'm using 10.0.648 and it's perfectly fine.
4-year build.
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 @ 4GHz 1.27v (LOAD) EVGA 750i SLI EVGA GTX 460 768MB SC @ 870/1075 G.SKILL PI Black 4GB 4-4-4-12 850MHz 
Hard DriveOSMonitorPower
WD Blue Caviar 320GB Windows 7 x64 DELL SE198WFP ThermalTake TR2 430w 
Case
It's a table!! 
  hide details  
Reply
4-year build.
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 @ 4GHz 1.27v (LOAD) EVGA 750i SLI EVGA GTX 460 768MB SC @ 870/1075 G.SKILL PI Black 4GB 4-4-4-12 850MHz 
Hard DriveOSMonitorPower
WD Blue Caviar 320GB Windows 7 x64 DELL SE198WFP ThermalTake TR2 430w 
Case
It's a table!! 
  hide details  
Reply
post #9 of 12
Thread Starter 
I just let it auto update.

Using Chrome normal and Chrome Canary is the only way to have two installs of Chrome on one PC (isn't it?).

That way, my wife and I both keep our tabs, passwords etc saved.
My do-it-all rig
(17 items)
 
  
CPUMotherboardGraphicsGraphics
AMD K15 970A-D3P NVIDIA GeForce GTX 660  NVIDIA GeForce GTX 460 
RAMRAMHard DriveOptical Drive
Kingston  Kingston  Crucial M4 64Gb, 4x 1Tb, 1x 500Gb WD Caviar Black LG LiteScribe GH24 
OSMonitorKeyboardPower
Win 10 x64 LG E2350 23" 1920x1080 / Samsung 19.5" 1366x768 Razer Lycosa (Mirror Edition) Corsair HX850w 
CaseMouseMouse PadAudio
CoolerMaster 690 Razer Mamba 2012 Razer Goliath XL Logitech X-530 speakers 
Audio
Creative SupremeFX X-Fi sound card 
  hide details  
Reply
My do-it-all rig
(17 items)
 
  
CPUMotherboardGraphicsGraphics
AMD K15 970A-D3P NVIDIA GeForce GTX 660  NVIDIA GeForce GTX 460 
RAMRAMHard DriveOptical Drive
Kingston  Kingston  Crucial M4 64Gb, 4x 1Tb, 1x 500Gb WD Caviar Black LG LiteScribe GH24 
OSMonitorKeyboardPower
Win 10 x64 LG E2350 23" 1920x1080 / Samsung 19.5" 1366x768 Razer Lycosa (Mirror Edition) Corsair HX850w 
CaseMouseMouse PadAudio
CoolerMaster 690 Razer Mamba 2012 Razer Goliath XL Logitech X-530 speakers 
Audio
Creative SupremeFX X-Fi sound card 
  hide details  
Reply
post #10 of 12
You can use chromium portable.

http://news.softpedia.com/news/Google-Chrome-11-Now-Available-181710.shtml
4-year build.
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 @ 4GHz 1.27v (LOAD) EVGA 750i SLI EVGA GTX 460 768MB SC @ 870/1075 G.SKILL PI Black 4GB 4-4-4-12 850MHz 
Hard DriveOSMonitorPower
WD Blue Caviar 320GB Windows 7 x64 DELL SE198WFP ThermalTake TR2 430w 
Case
It's a table!! 
  hide details  
Reply
4-year build.
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8500 @ 4GHz 1.27v (LOAD) EVGA 750i SLI EVGA GTX 460 768MB SC @ 870/1075 G.SKILL PI Black 4GB 4-4-4-12 850MHz 
Hard DriveOSMonitorPower
WD Blue Caviar 320GB Windows 7 x64 DELL SE198WFP ThermalTake TR2 430w 
Case
It's a table!! 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Other Software
Overclock.net › Forums › Software, Programming and Coding › Other Software › Chrome Displays Site in wrong language