Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Ubuntu: Error: Dependency is not satisfiable: sun-java6-jdk ??
New Posts  All Forums:Forum Nav:

Ubuntu: Error: Dependency is not satisfiable: sun-java6-jdk ??

post #1 of 4
Thread Starter 
I've just installed Ubuntu 10.04 and I'm trying to install an application but I keep getting the error. I've downloaded the jdk from Sun's website and followed their instructions but I keep getting the error. Then I tried using the Ubuntu Software Center but it doesn't have Sun's jdk, only the default or open jdk.

What's going on here?

THanks!
    
CPUMotherboardGraphicsRAM
X2 5000+ BE Gigabyte GA-MA78GM-S2H AM2+ Integrated HD3200 2x2GB OCZ DDR2 
Hard DriveMonitorPowerCase
Maxtor 40GB Samsung 2220WM 22" Antec Neo HE 550W Ultra Wizard 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
X2 5000+ BE Gigabyte GA-MA78GM-S2H AM2+ Integrated HD3200 2x2GB OCZ DDR2 
Hard DriveMonitorPowerCase
Maxtor 40GB Samsung 2220WM 22" Antec Neo HE 550W Ultra Wizard 
  hide details  
Reply
post #2 of 4
What's wrong with openjdk?
Rena
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x6 1055T Asus M4A88TD-M/USB3 XFX 8800gt 512mb 2x2GB 1333MHz 
Hard DriveOptical DriveOSMonitor
250gb WD + 1tb WD + 2tb WD LG GSA-H55L Aptosid amd64 Samsung Syncmaster 216BW 
KeyboardPowerMouse
Genius Thermaltake TR2 W0379RU 500W Generic Microsoft Mouse 
  hide details  
Reply
Rena
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x6 1055T Asus M4A88TD-M/USB3 XFX 8800gt 512mb 2x2GB 1333MHz 
Hard DriveOptical DriveOSMonitor
250gb WD + 1tb WD + 2tb WD LG GSA-H55L Aptosid amd64 Samsung Syncmaster 216BW 
KeyboardPowerMouse
Genius Thermaltake TR2 W0379RU 500W Generic Microsoft Mouse 
  hide details  
Reply
post #3 of 4
You have to add a new source as they took it out of the Multiverse repository and into Partners for that release.

Instructions: http://happy-coding.com/install-sun-java6-jdk-on-ubuntu-10-04-lucid/
Release Notes: https://wiki.ubuntu.com/LucidLynx/ReleaseNotes
Edited by Nburnes - 2/5/11 at 12:21pm
    
CPUMotherboardGraphicsRAM
AMD Athlon X2 5000+ (4 cores unlock) @ 3.29GHz Gigabyte MA785G-UD3H Galaxy GTX 460 4GB DDR2 Mushkin Blackline 
Hard DriveOptical DriveOSMonitor
1 250GB Seagate and 1 external 160 GB Seagate LG Super-multidrive Ubuntu 11.10 x86_64/Windows 7 x64 22" ViewSonic 1080p Widescreen 
KeyboardPowerCaseMouse
Logitech Wireless Keyboard Y-RC14 Rosewill Performance RP550-2 @ 550w Coolermaster Centurion 531 Logitech MX700 
Mouse Pad
None 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
AMD Athlon X2 5000+ (4 cores unlock) @ 3.29GHz Gigabyte MA785G-UD3H Galaxy GTX 460 4GB DDR2 Mushkin Blackline 
Hard DriveOptical DriveOSMonitor
1 250GB Seagate and 1 external 160 GB Seagate LG Super-multidrive Ubuntu 11.10 x86_64/Windows 7 x64 22" ViewSonic 1080p Widescreen 
KeyboardPowerCaseMouse
Logitech Wireless Keyboard Y-RC14 Rosewill Performance RP550-2 @ 550w Coolermaster Centurion 531 Logitech MX700 
Mouse Pad
None 
  hide details  
Reply
post #4 of 4
Thread Starter 
Quote:
Originally Posted by Nburnes;12273294 
You have to add a new source as they took it out of the Multiverse repository and into Partners for that release.

Instructions: http://happy-coding.com/install-sun-java6-jdk-on-ubuntu-10-04-lucid/
Release Notes: https://wiki.ubuntu.com/LucidLynx/ReleaseNotes

That totally did the trick!

rep+ cheers.gif
    
CPUMotherboardGraphicsRAM
X2 5000+ BE Gigabyte GA-MA78GM-S2H AM2+ Integrated HD3200 2x2GB OCZ DDR2 
Hard DriveMonitorPowerCase
Maxtor 40GB Samsung 2220WM 22" Antec Neo HE 550W Ultra Wizard 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
X2 5000+ BE Gigabyte GA-MA78GM-S2H AM2+ Integrated HD3200 2x2GB OCZ DDR2 
Hard DriveMonitorPowerCase
Maxtor 40GB Samsung 2220WM 22" Antec Neo HE 550W Ultra Wizard 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Ubuntu: Error: Dependency is not satisfiable: sun-java6-jdk ??