Overclock.net › Forums › Consumer Electronics › Home Audio › Cant get surround sound working on PC
New Posts  All Forums:Forum Nav:

Cant get surround sound working on PC

post #1 of 10
Thread Starter 
When i connect my surround sound to my pc with an optical cable only the subwoofer and the 2 front speakers work. Any idea's why the back 2 or center speaker aren't working?

My surround sound - http://www.sonystyle.com/webapp/wcs/...52921666077692


Edited by Ubeermench - 2/10/11 at 6:40pm
post #2 of 10
Your source has to be 6 channels, or if the source is stereo, you can set your receiver to something like Pro Logic (?) and it will 'convert' it to surround sound.

What are you trying to play through it?
post #3 of 10
Did you configure it in "Sound" for 5.1?

Right click -> Configure -> 5.1
    
CPUGraphicsRAMHard Drive
1.8 GHz Intel Core i5 Intel HD4000 4 GB 1600 MHz DDR3 256GB Toshiba 6GB/s SSD 
OSMonitorMonitorMonitor
OS X Mavericks 10.9.2 Glossy 13" 1440x900  Dell U2412M Dell U2412M 
KeyboardCaseMouseAudio
IBM Model M  IT'S LIGHT AND ALUMINUM Magic Trackpad  Schiit Magni + Modi  
Audio
Beyerdynamic DT770 Pro 80ohm 
  hide details  
Reply
    
CPUGraphicsRAMHard Drive
1.8 GHz Intel Core i5 Intel HD4000 4 GB 1600 MHz DDR3 256GB Toshiba 6GB/s SSD 
OSMonitorMonitorMonitor
OS X Mavericks 10.9.2 Glossy 13" 1440x900  Dell U2412M Dell U2412M 
KeyboardCaseMouseAudio
IBM Model M  IT'S LIGHT AND ALUMINUM Magic Trackpad  Schiit Magni + Modi  
Audio
Beyerdynamic DT770 Pro 80ohm 
  hide details  
Reply
post #4 of 10
Try going to playback devices by right clicking on the sound button on the bottom right corner and configure the 5.1 audio , if that doesn't help, maybe ur not playing something that supports 5.1 surround . Try games because they all support it, but for movies you need to download 5.1 movies or you can play a blu-ray if you have a blu-ray drive
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom ii X4 965 Asrock Extreme3 970 EVGA GTX 560 ti 448 cores Classified Ultra 8gigs G.SKILL 1600mz DDR3 
Hard DriveHard DriveOptical DriveOS
Seagate 1.5TB 7200 rpm Crucial M4 128GB LG dvd/cd drive Windows 7 64-bit 
MonitorKeyboardPowerCase
LG EW224 22inch 1080p LED screen Logitech G510 Antec earthwatts 650W Thermaltake V9 
Mouse
Razer DeathAdder 
  hide details  
Reply
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom ii X4 965 Asrock Extreme3 970 EVGA GTX 560 ti 448 cores Classified Ultra 8gigs G.SKILL 1600mz DDR3 
Hard DriveHard DriveOptical DriveOS
Seagate 1.5TB 7200 rpm Crucial M4 128GB LG dvd/cd drive Windows 7 64-bit 
MonitorKeyboardPowerCase
LG EW224 22inch 1080p LED screen Logitech G510 Antec earthwatts 650W Thermaltake V9 
Mouse
Razer DeathAdder 
  hide details  
Reply
post #5 of 10
Realtek has some really "interesting" software included... Try first just using like an audio cable (3.5mm) (yes I know its stereo but just to check to make sure the speakers work) This should also i think test to make sure the audio chipest works... If that doesn't work update the drivers. If neither of those solutions work do the speakers work? If the speakers do work and the audio cable and optical don't, than maybe you have a DOA audio chipest... Best of luck

Andy
TEHCAKEISALIE
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x4 @3.55 Ghz GIGABYTE GA-880GA-UD3H AM3 AMD 880G HDMI SATA 6Gb/ 9600 GT 512mb 8 Gigabytes Ripjaws 
Hard DriveOptical DriveOSMonitor
1 Terabyte 7200 RPM WD Asus DVD/CD x52 Windows 7 Ultimate 64-bit 21.5 Full HD 
PowerCase
500 Watt OCZ Antec 300 Illusion 
  hide details  
Reply
TEHCAKEISALIE
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x4 @3.55 Ghz GIGABYTE GA-880GA-UD3H AM3 AMD 880G HDMI SATA 6Gb/ 9600 GT 512mb 8 Gigabytes Ripjaws 
Hard DriveOptical DriveOSMonitor
1 Terabyte 7200 RPM WD Asus DVD/CD x52 Windows 7 Ultimate 64-bit 21.5 Full HD 
PowerCase
500 Watt OCZ Antec 300 Illusion 
  hide details  
Reply
post #6 of 10
Thread Starter 
Quote:
Originally Posted by Aden Florian View Post
Your source has to be 6 channels, or if the source is stereo, you can set your receiver to something like Pro Logic (?) and it will 'convert' it to surround sound.

What are you trying to play through it?
Im trying to play my music from itunes and i changed the receiver to Pro Logic and nothing changed.


Quote:
Originally Posted by lob3s View Post
Did you configure it in "Sound" for 5.1?

Right click -> Configure -> 5.1
When i right click it configure doesn't come up
post #7 of 10
WAIT OMGZZ!!!!
!
!
!
!
So the window on the left go to that, click on the realtek optical output, if that doesn't bring anything up than go to the sound bar in your taskbar. click on it get it to its menu until you can click on the control sound. It should come up with a small display saying what is plugged in where. go down the bars (there are a few) find the one that is called like dolby digital or something, under it there is also something called natural bass and you can add bass to the sound. I have had this problem before, just remembered

DOUBLE CHEER N' LUCK!!!!
TEHCAKEISALIE
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x4 @3.55 Ghz GIGABYTE GA-880GA-UD3H AM3 AMD 880G HDMI SATA 6Gb/ 9600 GT 512mb 8 Gigabytes Ripjaws 
Hard DriveOptical DriveOSMonitor
1 Terabyte 7200 RPM WD Asus DVD/CD x52 Windows 7 Ultimate 64-bit 21.5 Full HD 
PowerCase
500 Watt OCZ Antec 300 Illusion 
  hide details  
Reply
TEHCAKEISALIE
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x4 @3.55 Ghz GIGABYTE GA-880GA-UD3H AM3 AMD 880G HDMI SATA 6Gb/ 9600 GT 512mb 8 Gigabytes Ripjaws 
Hard DriveOptical DriveOSMonitor
1 Terabyte 7200 RPM WD Asus DVD/CD x52 Windows 7 Ultimate 64-bit 21.5 Full HD 
PowerCase
500 Watt OCZ Antec 300 Illusion 
  hide details  
Reply
post #8 of 10
Thread Starter 
I changed the sound field to A.F.D Media and now they all work except the center speaker =/
post #9 of 10
Quote:
Originally Posted by Ubeermench View Post
I changed the sound field to A.F.D Media and now they all work except the center speaker =/
Yea, the thing on my receiver (samsung) puts it to all speakers but it's really quiet on the surround speakers, I can't remember if it played through the center speaker..
post #10 of 10
Thread Starter 
Quote:
Originally Posted by Aden Florian View Post
Yea, the thing on my receiver (samsung) puts it to all speakers but it's really quiet on the surround speakers, I can't remember if it played through the center speaker..
Same. I guess i can survive without the middle speaker unless someone knows how to fix it
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Home Audio
Overclock.net › Forums › Consumer Electronics › Home Audio › Cant get surround sound working on PC