Overclock.net › Forums › AMD › AMD Motherboards › New Asus M4A88TD-M EVO/USB3 Motherboard
New Posts  All Forums:Forum Nav:

New Asus M4A88TD-M EVO/USB3 Motherboard

post #1 of 3
Thread Starter 
Hi Guys, really need some help here. Its taken me weeks of planning and searching and finally got my parts. Took it home and then installed the Motherboard, CPU, RAM and a PSU.

It booted up the first 3 times but I got an error saying "too many connections". Tried unplugging some of the stuff and plugged it back in and the message disappeared. eek.gif

My OS came on briefly and then got a grey screen and everything froze. Red light came on next to MemOk button in solid, pressed the button once and held on for a few seconds and then it just keeps flashing. Rebooted the computer and light returned to solid Red. Cleared RTC RAM as per instructions in my manual but no good. Now the mouse, keyboard and monitor has no reaction and does not turn on. frown.gif

Don't have any spare monitors or Video cards at home to check anything else. headscratch.gif

I am running the following components, please help me:

-Asus M4A88TD-M EVO/USB3 Motherboard buttkick.gif
-AMD Phenomn II X4 965 Black Edition
-Corsair XMS 3 4GB(2 x 2GB DDR3) CMX4GX3M2A1600C8
-CoolerMaster Extreme Power Plus 460W
-Seagate IDE HDD 40GB
-Hitachi IDE HDD 250GB

Please reply or email me on jcyshin@hotmail.com. Thank you all in advance for your help. I have read through the forums and can't find a solution so please please help.

CY
post #2 of 3
sounds like the motherboard was bad from the start
    
CPUMotherboardGraphicsRAM
Intel Core i5 2500k @ 4.5GHZ (for now) MSI P67A-GD65 BFG GTX 260 OC SLI 2x2GB G.Skill Ripjaw X 2133 CL9 
Hard DriveOptical DriveOSMonitor
Barracuda 320GB, Spinpoint F3 1TB, Barracuda 1.5TB Sony Optiarc BD-ROM Windows 7 Ultimate x64 HP 2311x 
KeyboardPowerCaseMouse
Dell L100 In Win Commander 1200W RV02B-EW Trackman Wheel 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i5 2500k @ 4.5GHZ (for now) MSI P67A-GD65 BFG GTX 260 OC SLI 2x2GB G.Skill Ripjaw X 2133 CL9 
Hard DriveOptical DriveOSMonitor
Barracuda 320GB, Spinpoint F3 1TB, Barracuda 1.5TB Sony Optiarc BD-ROM Windows 7 Ultimate x64 HP 2311x 
KeyboardPowerCaseMouse
Dell L100 In Win Commander 1200W RV02B-EW Trackman Wheel 
  hide details  
Reply
post #3 of 3
Thread Starter 
Quote:
Originally Posted by OutOfBalanceOX;12381105 
sounds like the motherboard was bad from the start

Not sure, it was brand new and it did boot up the first time but didn't get to the OS as it said "Too Many Connections".

Any other ideas you may have?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD Motherboards
Overclock.net › Forums › AMD › AMD Motherboards › New Asus M4A88TD-M EVO/USB3 Motherboard