Overclock.net › Forums › Graphics Cards › AMD/ATI › Need help with friend's card.
New Posts  All Forums:Forum Nav:

Need help with friend's card.

post #1 of 7
Thread Starter 
Hey guys. My friend has a very old ATI graphics card, one of the 3000 series. The other day i went to his house and we installed dead space 2. We restarted PC (he has old wide screen and oldish PC too) and everything booted fine, it posted, but there was no image on screen. We tried everything, the screen would go on and everything, so that is fine. Is his graphics card dead or is it another problem?
Ol' Faithful
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 950 @3.83 Ghz ASUS Rampage III Formula MSI GTX 970 Gaming OC G.SKILL 6GB 1850Mhz 
Hard DriveOptical DriveCoolingOS
Western Digital 6GB/s 1TB Liteon 24X DVD R/W Noctua NH-D14  Windows 7 Professional 64-bit 
MonitorPowerCase
Samsung 23" 1920X1080p Aerocool V12XT 800 HAF 922 
  hide details  
Reply
Ol' Faithful
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 950 @3.83 Ghz ASUS Rampage III Formula MSI GTX 970 Gaming OC G.SKILL 6GB 1850Mhz 
Hard DriveOptical DriveCoolingOS
Western Digital 6GB/s 1TB Liteon 24X DVD R/W Noctua NH-D14  Windows 7 Professional 64-bit 
MonitorPowerCase
Samsung 23" 1920X1080p Aerocool V12XT 800 HAF 922 
  hide details  
Reply
post #2 of 7
Either its the GPU or the RAM. Try running with only one stick of RAM to determine the broken one.
Thor is here!!!
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930@4GHZ 1.23Vcore :) Gigabyte X58A UD3R Zotac GTX 480 AMP!@850|2000 Corsair 6gb 1333 mhz DDR3 
Hard DriveOptical DriveOSMonitor
Samsung Spinpoint F3 1TB LG DVD+Blu Ray Windows 7 64-Bit Samsung Syncmaster P2350 
KeyboardPowerCaseMouse
Razer Lycosa Mirror Corsair HX850 Watt Coolermaster HAF X Razer Mamba 
  hide details  
Reply
Thor is here!!!
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930@4GHZ 1.23Vcore :) Gigabyte X58A UD3R Zotac GTX 480 AMP!@850|2000 Corsair 6gb 1333 mhz DDR3 
Hard DriveOptical DriveOSMonitor
Samsung Spinpoint F3 1TB LG DVD+Blu Ray Windows 7 64-Bit Samsung Syncmaster P2350 
KeyboardPowerCaseMouse
Razer Lycosa Mirror Corsair HX850 Watt Coolermaster HAF X Razer Mamba 
  hide details  
Reply
post #3 of 7
Thread Starter 
It boots into windows, but nothing shows up on screen.
Ol' Faithful
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 950 @3.83 Ghz ASUS Rampage III Formula MSI GTX 970 Gaming OC G.SKILL 6GB 1850Mhz 
Hard DriveOptical DriveCoolingOS
Western Digital 6GB/s 1TB Liteon 24X DVD R/W Noctua NH-D14  Windows 7 Professional 64-bit 
MonitorPowerCase
Samsung 23" 1920X1080p Aerocool V12XT 800 HAF 922 
  hide details  
Reply
Ol' Faithful
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 950 @3.83 Ghz ASUS Rampage III Formula MSI GTX 970 Gaming OC G.SKILL 6GB 1850Mhz 
Hard DriveOptical DriveCoolingOS
Western Digital 6GB/s 1TB Liteon 24X DVD R/W Noctua NH-D14  Windows 7 Professional 64-bit 
MonitorPowerCase
Samsung 23" 1920X1080p Aerocool V12XT 800 HAF 922 
  hide details  
Reply
post #4 of 7
Quote:
Originally Posted by Lhino View Post
It boots into windows, but nothing shows up on screen.
how are you determining it boots to windows if nothing is showing up in screen? or you saying it goes all the way to windows desktop and suddenly goes blank? or are you saying everything is fine until you pop in your game? Or are you saying computer will post as in you hear it beep and all fans and LEDs coming on? Is there a LED screen in the motherboard to show a post code or do you hear a post beep - how many times it beeps?

When I was building my rig, I had this happen. It would post - as it I could see all LED indicators come on, fans whirling, but nothing on screen. Turned out I had my RAM in wrong slot. But it could very well be the graphics card.
Wife's bane
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.5 Ghz Gigabyte Z77 UD3H HIS R9-290 8 GB Samsung Wonder RAM 
Hard DriveHard DriveOptical DriveCooling
Crucial SSD for OS Samsung Spinpoint F3 Asus XSPC water block, 360 radiator, and 720 reservo... 
CoolingOSMonitorKeyboard
GPU cooling - XSPC Razer full GPU blocks Win 7 Home Premium Asus PB278Q 2560 X 1440p ISP Logitech G15 
PowerCaseMouseMouse Pad
NZXT Hale90 V2 NZXT Switch 810 Logitech G500 Steelseries QcK 
Audio
Optical out to Sony receiver; Deftech Monitor 3... 
  hide details  
Reply
Wife's bane
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.5 Ghz Gigabyte Z77 UD3H HIS R9-290 8 GB Samsung Wonder RAM 
Hard DriveHard DriveOptical DriveCooling
Crucial SSD for OS Samsung Spinpoint F3 Asus XSPC water block, 360 radiator, and 720 reservo... 
CoolingOSMonitorKeyboard
GPU cooling - XSPC Razer full GPU blocks Win 7 Home Premium Asus PB278Q 2560 X 1440p ISP Logitech G15 
PowerCaseMouseMouse Pad
NZXT Hale90 V2 NZXT Switch 810 Logitech G500 Steelseries QcK 
Audio
Optical out to Sony receiver; Deftech Monitor 3... 
  hide details  
Reply
post #5 of 7
Thread Starter 
It posted. Nothing is on the screen. The speakers work so we can hear the windows booting sound.
Ol' Faithful
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 950 @3.83 Ghz ASUS Rampage III Formula MSI GTX 970 Gaming OC G.SKILL 6GB 1850Mhz 
Hard DriveOptical DriveCoolingOS
Western Digital 6GB/s 1TB Liteon 24X DVD R/W Noctua NH-D14  Windows 7 Professional 64-bit 
MonitorPowerCase
Samsung 23" 1920X1080p Aerocool V12XT 800 HAF 922 
  hide details  
Reply
Ol' Faithful
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 950 @3.83 Ghz ASUS Rampage III Formula MSI GTX 970 Gaming OC G.SKILL 6GB 1850Mhz 
Hard DriveOptical DriveCoolingOS
Western Digital 6GB/s 1TB Liteon 24X DVD R/W Noctua NH-D14  Windows 7 Professional 64-bit 
MonitorPowerCase
Samsung 23" 1920X1080p Aerocool V12XT 800 HAF 922 
  hide details  
Reply
post #6 of 7
Is this a PCIe card or AGP card? I am assuming it does not take any power directly from the power supply. Do you see any fans (if any) running on the card? Can you tell if the card is powering up at all (fans, LED)? Is there on-boad video option on the motherboard? If so, can you hook your monitor up to the on-board video and see if you get pictures? If you do, than chances are your video card is not getting power or is fried.
Wife's bane
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.5 Ghz Gigabyte Z77 UD3H HIS R9-290 8 GB Samsung Wonder RAM 
Hard DriveHard DriveOptical DriveCooling
Crucial SSD for OS Samsung Spinpoint F3 Asus XSPC water block, 360 radiator, and 720 reservo... 
CoolingOSMonitorKeyboard
GPU cooling - XSPC Razer full GPU blocks Win 7 Home Premium Asus PB278Q 2560 X 1440p ISP Logitech G15 
PowerCaseMouseMouse Pad
NZXT Hale90 V2 NZXT Switch 810 Logitech G500 Steelseries QcK 
Audio
Optical out to Sony receiver; Deftech Monitor 3... 
  hide details  
Reply
Wife's bane
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.5 Ghz Gigabyte Z77 UD3H HIS R9-290 8 GB Samsung Wonder RAM 
Hard DriveHard DriveOptical DriveCooling
Crucial SSD for OS Samsung Spinpoint F3 Asus XSPC water block, 360 radiator, and 720 reservo... 
CoolingOSMonitorKeyboard
GPU cooling - XSPC Razer full GPU blocks Win 7 Home Premium Asus PB278Q 2560 X 1440p ISP Logitech G15 
PowerCaseMouseMouse Pad
NZXT Hale90 V2 NZXT Switch 810 Logitech G500 Steelseries QcK 
Audio
Optical out to Sony receiver; Deftech Monitor 3... 
  hide details  
Reply
post #7 of 7
Quote:
Originally Posted by Lhino View Post
It boots into windows, but nothing shows up on screen.
Boot into safe mode and clear the driver, then re-install the latest from ATI's website.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Need help with friend's card.