Overclock.net › Forums › Cooling › Water Cooling › dead pump
New Posts  All Forums:Forum Nav:

dead pump

post #1 of 5
Thread Starter 
I was just on my PC this morning and it turned off, I turned it back on and it went off again after a while, found out my GPU was overheating, and thus the pump wasn't running. I didn't hear any noises from it or anything, it just wasn't on anymore. I tried connecting the molex to other cables but nothing.

I could feel underneath the pump was wet aswell as the foam pad that it sits on top of, did it leak inside or something? none of the fittings were leaking.

it's an "Swiftech MCP355 18w with 3/8'' (10mm) Fitting, Max 22 PSI powered by Molex 4pin" with an "EK-DDC X-TOP V2 - Clear Plexi top"

what i'm worried about is I won't be able to return it because of the custom top..

any advice?
post #2 of 5
The o-ring seperating the motor from the impeller probably failed. I had it happen with a Swiftech 655. You could always put the stock top back on and try to return it. If they asked what happened, tell them straight out what you think happened. I wouldn't lie to them.
post #3 of 5
If it's an o-ring issue and the pump's electronics are not affected, grab an o-ring from the hardware store. Make sure the o-ring for the pump is EPDM or a syntheic grade. Regular rubber will break down over time and leak.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon 64 x2 5000 Black 2.6Ghz OC 3.3Ghz GigaByte GA-MA78GM-S2H Full Radeon 780G HD 3200 4GB Corsair DDR2 6400C4 
Hard DriveOSPowerCase
Seagate Barracuda 750GB 7200 RPM 32MB Cache Windows 7 Pro x64 Corsair HX620W Meridian XClio High Tower I 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Athlon 64 x2 5000 Black 2.6Ghz OC 3.3Ghz GigaByte GA-MA78GM-S2H Full Radeon 780G HD 3200 4GB Corsair DDR2 6400C4 
Hard DriveOSPowerCase
Seagate Barracuda 750GB 7200 RPM 32MB Cache Windows 7 Pro x64 Corsair HX620W Meridian XClio High Tower I 
  hide details  
Reply
post #4 of 5
My swiftec pump died on me when i came to reinstall the pump was odd that it w asnt shifting any water at all ,

But i got intouch with someone at swiftech and as there was an aftermarket top on it they wouldnt offer a replacement,

But in your case i assume you purchased it from somewhere like Newegg or something ,

So if you can pull a sneekey one and replace the top and send back you may get a replacement if its in warrentey
Black Noir CosmoS
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5-750 Asus P7P55D PRO 5850 CrossXFire 8GB Gskill Ripjaw 
Hard DriveOptical DriveOSMonitor
Gskill Pheonix 40GB SSD Pioneer Win 7 64Bit Sony 19" Viao Sony SDM-E96D 
KeyboardPowerCaseMouse
G15 V2 750 OCZ Faita1ty Custom Cosmos S Roccat Kone V1 
Mouse Pad
Roccat Taito 
  hide details  
Reply
Black Noir CosmoS
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5-750 Asus P7P55D PRO 5850 CrossXFire 8GB Gskill Ripjaw 
Hard DriveOptical DriveOSMonitor
Gskill Pheonix 40GB SSD Pioneer Win 7 64Bit Sony 19" Viao Sony SDM-E96D 
KeyboardPowerCaseMouse
G15 V2 750 OCZ Faita1ty Custom Cosmos S Roccat Kone V1 
Mouse Pad
Roccat Taito 
  hide details  
Reply
post #5 of 5
They are usually ok with RMAs. Just send them a mail, tell them what happened, and ask if you can RMA the pump.

Custom tops aren't something to worry about. Just email them.
Main system
(16 items)
 
Editing PC
(8 items)
 
 
CPUGraphicsGraphicsRAM
E5-1680v2 AMD FirePro D700 AMD FirePro D700 64GB 1866mhz 
Hard DriveOSMonitorCase
1TB PCIE SSD OSX 10.10.x Dell U2713H Mac Pro 
  hide details  
Reply
Main system
(16 items)
 
Editing PC
(8 items)
 
 
CPUGraphicsGraphicsRAM
E5-1680v2 AMD FirePro D700 AMD FirePro D700 64GB 1866mhz 
Hard DriveOSMonitorCase
1TB PCIE SSD OSX 10.10.x Dell U2713H Mac Pro 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › dead pump