Overclock.net › Forums › Graphics Cards › AMD/ATI › Low FPSs on most games...
New Posts  All Forums:Forum Nav:

Low FPSs on most games...

post #1 of 16
Thread Starter 
Just put my new rig together (see specs on my SigRig, relevant later on in the post) and I'm runnnig into a bunch of problems.

You see, on most games I get FPSs below 25, even on OC, and this sucks total donkey ass.

CoD4 is one of the more prominent titles (and most prone to hiccups). I really don't think that an XFX HD5770 would have ANY problems running CoD4 @ 1440x900, because my old card (XFX HD4850) played it @1080p without a hitch, with a core clock of 725MHz (my new one boasts a whopping 200MHz more).

But yeah, almost every game I play jerks (or even full-on lags) at high-ish resolutions, and I'm thinking this has to be hardware related.

I've done a tiny bit of snooping around, and from what I've seen some people are experiencing difficulties between the card and mobo that I have in my Rig at the moment.

I'd appreciate any help on the matter, saying as I don't wanna have wasted £250.

Quick Info: O/C'd with CCC, latest drivers for CCC and the card. Not sure if I have the latest drivers for the chipset etc, Windows hasn't alerted me otherwise. Connected via DVI
post #2 of 16
I wouldn't use the latest ATI Catalyst drivers, I would try version 10.5, or 10.10c. Many people swear by those two.

Give that a try, is it also possible you have your graphics settings too high?

Your CPU is a little on the slow side, but I wouldn't expect that to hinder performance so bad, especially if the 4850 ran better with everything else the same.

Did you do a clean install when you switch the cards out?

(Uninstall drivers, reboot into safe mode, run a program called DriverSweeper to remove residual files, reboot into windows regular, install new drivers.)
Edited by RagingCain - 2/15/11 at 3:11pm
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
post #3 of 16
Thread Starter 
Quote:
Originally Posted by RagingCain View Post
I wouldn't use the latest ATI Catalyst drivers, I would try version 10.5, or 10.10c. Many people swear by those two.

Give that a try, is it also possible you have your graphics settings too high?

Your CPU is a little on the slow side, but I wouldn't expect that to hinder performance so bad, especially if the 4850 ran better with everything else the same.

Did you do a clean install when you switch the cards out?

(Uninstall drivers, reboot into safe mode, run a program called DriverSweeper to remove residual files, reboot into windows regular, install new drivers.)
Yeah, I'll give that a try. And I'm realy just waiting for a better cooling solution to oc my CPU further, I just don't have the funds at the minute

And yeah, I did a clean install of windows, as I replaced just about everything in my Rig short of my HDD and my PSU.

Do you personally know of any conflicts between my Card and my MoBo?

thanks for the help bro.+
post #4 of 16
Quote:
Originally Posted by TakMan View Post
Yeah, I'll give that a try. And I'm realy just waiting for a better cooling solution to oc my CPU further, I just don't have the funds at the minute

And yeah, I did a clean install of windows, as I replaced just about everything in my Rig short of my HDD and my PSU.

Do you personally know of any conflicts between my Card and my MoBo?

thanks for the help bro.+
Definitely give the driver change a try. I don't personally see there being a problem with your CPU and its speed causing this issue.

If there were any Motherboard drivers be sure to install them too, and you can install the latest chipset drivers from ATi, just try not installing the latest display drivers. AMD now, whatever, you know what I mean.

Also since this is a fresh install, make sure that in Power Options under the Control Panel, be sure to put it on High Performance, I have had issues in the past where Balanced makes my games run ultra slow.

Secondly, use GPU-Z or MSI Afterburner to check and see if your GPU is getting 100% use. If its not, then we have identified a problem, and we can go from there. Usually something like that is fixed by changing either by drivers or profiles. Speaking of profiles, you can install the latest Catalyst Application Profiles (generally give bonus performance for CrossfireX users, but setup games a little better for everyone.)
Edited by RagingCain - 2/15/11 at 3:33pm
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
post #5 of 16
if u can should return it and go for a 6850 for an extra 30 bucks (or more) the performance will be better than ur 5770
First Gaming Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Amd Phenom II X4 955 BE Asus M4A89GTD PRO Series XFX HD 6870 6GB DDR3 
Hard DriveOSMonitorKeyboard
1 TB Windows 7 Ultimate 64 bit LG 20' and samsung 20' Razer Mirror 
PowerCaseMouseMouse Pad
corsair GS600w Coolermaster Haf 922 Razer Mamba Razer sphex 
  hide details  
Reply
First Gaming Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
Amd Phenom II X4 955 BE Asus M4A89GTD PRO Series XFX HD 6870 6GB DDR3 
Hard DriveOSMonitorKeyboard
1 TB Windows 7 Ultimate 64 bit LG 20' and samsung 20' Razer Mirror 
PowerCaseMouseMouse Pad
corsair GS600w Coolermaster Haf 922 Razer Mamba Razer sphex 
  hide details  
Reply
post #6 of 16
Thread Starter 
Quote:
Originally Posted by amd+ati View Post
if u can should return it and go for a 6850 for an extra 30 bucks (or more) the performance will be better than ur 5770
Can't, I've unlocked it, once you do that they won't take it back :/

anyway yeah, I'm onto installing CCC 10.5 now, then gonna post screens of GPU-Z results.
post #7 of 16
Thread Starter 
Right, here's 5 screens, one of my GPU info, one Idle and one running CoD4, one running Crysis and one running Metro 2033 @1440x900 ultra high.

Actually, each of these were running great this time around, even with 2 monitors attached (except for Metro 2033, which we know herps REALLY HARD with 2 Monitors). CoD4 was running @>120 FPS, Crysis @~50FPS and Metro 2033 @~35. Sorry for the rough estimates, I couldn't be bothered checking the actual ones

But yeah, whatever happened did the trick.

NOTE: I played each game for roughly 5 minutes to yield accurate readings.




post #8 of 16
Quote:
Originally Posted by TakMan View Post
Can't, I've unlocked it, once you do that they won't take it back :/

anyway yeah, I'm onto installing CCC 10.5 now, then gonna post screens of GPU-Z results.
By unlock do you mean flashed a new BIOS? Or clicked the pad-lock in Catalyst Control Panel?

One of those is permanent, the other is not

If you are just talking about the overclock controls, then you can still return your card. I personally would have gone with the 6850 over a 5770 (price wise are indeed fairly close.)
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
Snowdevil
(16 items)
 
ASUS G750JM
(9 items)
 
 
CPUMotherboardGraphicsGraphics
[i7 4790K @ 4.4 GHz (1.186v)] [Asus Sabertooth Z97 Mark S] [nVidia Geforce GTX 1080] [nVidia Geforce GTX 1080] 
RAMHard DriveCoolingOS
[G.Skill 32GB DDR3 2133 MHz] [Crucial MX100 256GB] [Phanteks PH-TC12DX] [Win 10.1 Pro] 
MonitorMonitorKeyboardPower
[LG 29UM65 (2560x1080)] [QNIX Evo II LED (2560x1440)] [WASD v2 Tenkeyless] [NZXT Hale90 v2 ] 
CaseMouseMouse PadAudio
[ThermalTake GT10 Snow Edition] [Razer Mamba - Chroma] [Razer Kabuto] [Razer Man O' War] 
CPUMotherboardGraphicsRAM
i7 4770HQ Intel HM87 Express Chipset Geforce GTX 860M 8GB DDR3L 1600 MHz 
Hard DriveOptical DriveCoolingOS
Samsung SSD EVO DVD-RW Stock Windows 8.1 
Monitor
1920x1080 TN 
  hide details  
Reply
post #9 of 16
Thread Starter 
Quote:
Originally Posted by RagingCain View Post
By unlock do you mean flashed a new BIOS? Or clicked the pad-lock in Catalyst Control Panel?

One of those is permanent, the other is not

If you are just talking about the overclock controls, then you can still return your card. I personally would have gone with the 6850 over a 5770 (price wise are indeed fairly close.)
I flashed it. I tend to still go with 'unlock' 'cause it's simpler to use in conversation xD
post #10 of 16
Quote:
Originally Posted by RagingCain View Post
I wouldn't use the latest ATI Catalyst drivers, I would try version 10.5, or 10.10c. Many people swear by those two.

Give that a try, is it also possible you have your graphics settings too high?

Your CPU is a little on the slow side, but I wouldn't expect that to hinder performance so bad, especially if the 4850 ran better with everything else the same.

Did you do a clean install when you switch the cards out?

(Uninstall drivers, reboot into safe mode, run a program called DriverSweeper to remove residual files, reboot into windows regular, install new drivers.)
A lot of people say doing that gave them issues afterwards, and AMD's drivers are better to do one over another instead of a clean sweep and installing. I use a 5770 not OC'd and I can run every game I try on max settings 1080p except GTA IV and Crysis.
Tuned Up Gamer
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 930 @ 3ghz Asus P6T SE Gigabyte GTX 560 Ti OC Corsair 6GB DDR3 1333 MHz 
Hard DriveOptical DriveCoolingOS
Seagate Hybrid Drive ST1000DX001 LG DVD-R iBuyPower Cooling Windows 7 Home Premium 
MonitorKeyboardPowerCase
LG W2486L Black 24" Vengeance® K90 Performance MMO Mechanical XION PowerReal 700W PSI CyborgX 
MouseMouse PadAudio
Razer Deathadder 2013 Black Mousepad Plantronics GameCom 780 
  hide details  
Reply
Tuned Up Gamer
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 930 @ 3ghz Asus P6T SE Gigabyte GTX 560 Ti OC Corsair 6GB DDR3 1333 MHz 
Hard DriveOptical DriveCoolingOS
Seagate Hybrid Drive ST1000DX001 LG DVD-R iBuyPower Cooling Windows 7 Home Premium 
MonitorKeyboardPowerCase
LG W2486L Black 24" Vengeance® K90 Performance MMO Mechanical XION PowerReal 700W PSI CyborgX 
MouseMouse PadAudio
Razer Deathadder 2013 Black Mousepad Plantronics GameCom 780 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Low FPSs on most games...