Overclock.net › Forums › Graphics Cards › AMD/ATI › XFXHD5970BE Graphical error
New Posts  All Forums:Forum Nav:

XFXHD5970BE Graphical error

post #1 of 9
Thread Starter 
Copy+pasted from another forum:
Quote:
Hello there,
For a long while now, I have been trying to figure out what's up with my 5970.
In games, appears to be DX10 and below, I get this weird and extremely annoying graphical error. In some games you barely notice it, in some it's unplayable (In DX9 and DX10 this seems to be hit and miss, but any game under that that I've tried are filled with this ****.)

Picture of the error:
http://i56.tinypic.com/15pk9bp.jpg

It used to appear in WoW, until I enabled DX11.
It also does not happen in Battlefield: Bad Company 2, which I am quite sure is DX11?
Also, if it's of any use, it does not happen in Minecraft.
It happens in games with and without CrossFire support.
It has happened on every driver, with and without application profiles, and through a BIOS flash (I nearly even bricked my card. ).
It happens on single and dual monitor setup, on both dvi ports.
I am quite sure I have formated my system disk while this has happened.
The card is at stock clocks.

What I have yet to try is to put in another PCIe slot, I am unsure I can make it fit in another one though but I will try.

I am 100% sure my card is not overheating (happens at ~40c).

I do not remember this happening as the card was new, if I recall correctly it pretty much got worse with time. I know for a fact it did with WoW, as it went from suddenly some weird buggy graphics to completely unplayable in some zones quite fast. It was mainly in the Outlands areas, and on some specific models. It didn't happen with just anything. In Counter-Strike Source it happens with gun models.

Have anyone else seen this? Can't find anything similar on google.
Is there anything I can do to fix this or should I look into getting it replaced?

So far, cause of the thing with only happening in DirectX 10 or below (Though I recently played Age of Empire 3 where it did not occur once), I am thinking it could be something with DirectX? As I can't remember if it has happened through formatting, maybe I should try wiping my DirectX installs?

Other than that I can't think of anything but a defected card, which sucks. :<

-Thanks,
Andeby
Appreciate any help I can get! Really don't want to have to send my card in. :<

So yeah, thanks for any replies!
Machine
(23 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k ASUS P8Z77-V Pro Gigabyte Radeon HD6990 Corsair Dominator 1600MHz 8GB 
Hard DriveHard DriveHard DriveHard Drive
Samsung SSD 830 Random HDD Random HDD Random HDD 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate x64 BenQ G2420HD 24" LCD BenQ E2400HD 24" LCD 
MonitorKeyboardPowerCase
ASUS V278Q 27" LED-LCD Logitech G19 Corsair TX950 Antec 1200 
MouseMouse PadAudioAudio
Logitech G9 Steelseries Asus Xonar Essence STX Beyerdynamic DT770Pro 80Ohm 
AudioAudioAudio
Xindak XA6950 Stereo Amp PSB Image 6T XTZ 99 W10.16 
  hide details  
Reply
Machine
(23 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k ASUS P8Z77-V Pro Gigabyte Radeon HD6990 Corsair Dominator 1600MHz 8GB 
Hard DriveHard DriveHard DriveHard Drive
Samsung SSD 830 Random HDD Random HDD Random HDD 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate x64 BenQ G2420HD 24" LCD BenQ E2400HD 24" LCD 
MonitorKeyboardPowerCase
ASUS V278Q 27" LED-LCD Logitech G19 Corsair TX950 Antec 1200 
MouseMouse PadAudioAudio
Logitech G9 Steelseries Asus Xonar Essence STX Beyerdynamic DT770Pro 80Ohm 
AudioAudioAudio
Xindak XA6950 Stereo Amp PSB Image 6T XTZ 99 W10.16 
  hide details  
Reply
post #2 of 9
Probably defective, I can only assume that the reason it doesn't happen with dx11 is that perhaps dx11 doesn't use certain circuitry on the card while dx9/10 do and that the circuitry not being used is defective.
I Love Cheese
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 3.4 Asus P8P67 Basic XFX 5970 2 gig Black Edition 2x 4 gig DDR 1600 G-Skill 
Hard DriveOSMonitorPower
2x500 gig WD Vista Ultimate 64-bit Dual 25" Hannspree LCD CM 750 Watt 
CaseMouse
Rosewill THOR Logitech Trackball 
  hide details  
Reply
I Love Cheese
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 3.4 Asus P8P67 Basic XFX 5970 2 gig Black Edition 2x 4 gig DDR 1600 G-Skill 
Hard DriveOSMonitorPower
2x500 gig WD Vista Ultimate 64-bit Dual 25" Hannspree LCD CM 750 Watt 
CaseMouse
Rosewill THOR Logitech Trackball 
  hide details  
Reply
post #3 of 9
To be honest, an RMA seems like the only way to fix this.
Try underclocking your 5970 and see if the problems persist.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X6 1055T M4A89GTD Pro / USB3 XFX 5750 4GB GSkill 1333 (8-8-8-21) 
Hard DriveOSMonitorPower
WD Black 640GB Windows 7 Acer 1917W OCZ 600W ModXStream 
Case
Antec 300 Illusion 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X6 1055T M4A89GTD Pro / USB3 XFX 5750 4GB GSkill 1333 (8-8-8-21) 
Hard DriveOSMonitorPower
WD Black 640GB Windows 7 Acer 1917W OCZ 600W ModXStream 
Case
Antec 300 Illusion 
  hide details  
Reply
post #4 of 9
At least is xfx and you get a double life warranty. I would call up xfx and see if they can help diagnose the problem. But it does sound like the card is going.
post #5 of 9
Thread Starter 
Downclocking it gave me some bad artifacts even on the desktop.

And unfortunately as I am not a US citizen I don't think I get that XFX warranty. :<

Not sure how hard it will be to get it replace but I will contact the store I bought it from firstly. Probably just gonna send it in as it seems hopeless.
Machine
(23 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k ASUS P8Z77-V Pro Gigabyte Radeon HD6990 Corsair Dominator 1600MHz 8GB 
Hard DriveHard DriveHard DriveHard Drive
Samsung SSD 830 Random HDD Random HDD Random HDD 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate x64 BenQ G2420HD 24" LCD BenQ E2400HD 24" LCD 
MonitorKeyboardPowerCase
ASUS V278Q 27" LED-LCD Logitech G19 Corsair TX950 Antec 1200 
MouseMouse PadAudioAudio
Logitech G9 Steelseries Asus Xonar Essence STX Beyerdynamic DT770Pro 80Ohm 
AudioAudioAudio
Xindak XA6950 Stereo Amp PSB Image 6T XTZ 99 W10.16 
  hide details  
Reply
Machine
(23 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k ASUS P8Z77-V Pro Gigabyte Radeon HD6990 Corsair Dominator 1600MHz 8GB 
Hard DriveHard DriveHard DriveHard Drive
Samsung SSD 830 Random HDD Random HDD Random HDD 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate x64 BenQ G2420HD 24" LCD BenQ E2400HD 24" LCD 
MonitorKeyboardPowerCase
ASUS V278Q 27" LED-LCD Logitech G19 Corsair TX950 Antec 1200 
MouseMouse PadAudioAudio
Logitech G9 Steelseries Asus Xonar Essence STX Beyerdynamic DT770Pro 80Ohm 
AudioAudioAudio
Xindak XA6950 Stereo Amp PSB Image 6T XTZ 99 W10.16 
  hide details  
Reply
post #6 of 9
The store you bought it from will tell you to call the manufacturer. They more then likely won't deal with returns for faulty products.
post #7 of 9
Rma.
Skyline
(13 items)
 
  
CPUMotherboardGraphicsRAM
|B55 3.6| |Gigabyte MA770UD3| |GTX460SE 900/2000| |4GB G.Skill 1600| 
Hard DriveOSMonitorPower
|1Tb 7200rpm| |W7u 64bit| |23" Acer LED| |Hec-X Pro 750w| 
Case
|Blitz Mid-Tower| 
  hide details  
Reply
Skyline
(13 items)
 
  
CPUMotherboardGraphicsRAM
|B55 3.6| |Gigabyte MA770UD3| |GTX460SE 900/2000| |4GB G.Skill 1600| 
Hard DriveOSMonitorPower
|1Tb 7200rpm| |W7u 64bit| |23" Acer LED| |Hec-X Pro 750w| 
Case
|Blitz Mid-Tower| 
  hide details  
Reply
post #8 of 9
Thread Starter 
Quote:
Originally Posted by animal0307 View Post
The store you bought it from will tell you to call the manufacturer. They more then likely won't deal with returns for faulty products.
It depends a lot on the store. I once received a faulty motherboard, one mail and I could send it in. Unfortunately this was not bought from that store, so I am not sure how it will be done. I am quite sure I can get it replaced though, just not money back.
Machine
(23 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k ASUS P8Z77-V Pro Gigabyte Radeon HD6990 Corsair Dominator 1600MHz 8GB 
Hard DriveHard DriveHard DriveHard Drive
Samsung SSD 830 Random HDD Random HDD Random HDD 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate x64 BenQ G2420HD 24" LCD BenQ E2400HD 24" LCD 
MonitorKeyboardPowerCase
ASUS V278Q 27" LED-LCD Logitech G19 Corsair TX950 Antec 1200 
MouseMouse PadAudioAudio
Logitech G9 Steelseries Asus Xonar Essence STX Beyerdynamic DT770Pro 80Ohm 
AudioAudioAudio
Xindak XA6950 Stereo Amp PSB Image 6T XTZ 99 W10.16 
  hide details  
Reply
Machine
(23 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k ASUS P8Z77-V Pro Gigabyte Radeon HD6990 Corsair Dominator 1600MHz 8GB 
Hard DriveHard DriveHard DriveHard Drive
Samsung SSD 830 Random HDD Random HDD Random HDD 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate x64 BenQ G2420HD 24" LCD BenQ E2400HD 24" LCD 
MonitorKeyboardPowerCase
ASUS V278Q 27" LED-LCD Logitech G19 Corsair TX950 Antec 1200 
MouseMouse PadAudioAudio
Logitech G9 Steelseries Asus Xonar Essence STX Beyerdynamic DT770Pro 80Ohm 
AudioAudioAudio
Xindak XA6950 Stereo Amp PSB Image 6T XTZ 99 W10.16 
  hide details  
Reply
post #9 of 9
Thread Starter 
Sorry for doubleposting now, but in case someone gets this issue later on and stumble upon this thread, I would like to report that I have fixed this issue by upping the GPU voltage to 1.1V!
Machine
(23 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k ASUS P8Z77-V Pro Gigabyte Radeon HD6990 Corsair Dominator 1600MHz 8GB 
Hard DriveHard DriveHard DriveHard Drive
Samsung SSD 830 Random HDD Random HDD Random HDD 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate x64 BenQ G2420HD 24" LCD BenQ E2400HD 24" LCD 
MonitorKeyboardPowerCase
ASUS V278Q 27" LED-LCD Logitech G19 Corsair TX950 Antec 1200 
MouseMouse PadAudioAudio
Logitech G9 Steelseries Asus Xonar Essence STX Beyerdynamic DT770Pro 80Ohm 
AudioAudioAudio
Xindak XA6950 Stereo Amp PSB Image 6T XTZ 99 W10.16 
  hide details  
Reply
Machine
(23 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k ASUS P8Z77-V Pro Gigabyte Radeon HD6990 Corsair Dominator 1600MHz 8GB 
Hard DriveHard DriveHard DriveHard Drive
Samsung SSD 830 Random HDD Random HDD Random HDD 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate x64 BenQ G2420HD 24" LCD BenQ E2400HD 24" LCD 
MonitorKeyboardPowerCase
ASUS V278Q 27" LED-LCD Logitech G19 Corsair TX950 Antec 1200 
MouseMouse PadAudioAudio
Logitech G9 Steelseries Asus Xonar Essence STX Beyerdynamic DT770Pro 80Ohm 
AudioAudioAudio
Xindak XA6950 Stereo Amp PSB Image 6T XTZ 99 W10.16 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › XFXHD5970BE Graphical error