Overclock.net › Forums › Components › Sound Cards and Computer Audio › Audio technica CKMS70 left earphone broken
New Posts  All Forums:Forum Nav:

Audio technica CKMS70 left earphone broken

post #1 of 3
Thread Starter 
I've just recently noticed a problem with my Audio technica CKMS70 earphones.
(http://www.audiocubes.com/product_in...oducts_id=2679)

The left earphone outputs sound at a substantially lower volume to the right. I know it is not my ears, since I regularly take care of them with oil and the occasional syringe and from testing them with other headphones. Also I have switched the ear pieces around to test their loudness in one ear vs the other.

My first thought was that it might be the cables, so naturally i tried tweaking them around a bit but there's no difference, and also there's no actual distortion in sound from the left ear piece. I've had these earphones for just over a year now and paid a lot for them. I'm not a person to break things easily either, I take care of my equipment.

Any suggestions on what to do would be welcome.

Thanks for reading.
post #2 of 3
Thread Starter 
bump
post #3 of 3
If Audio technica is anything like BOSE, they might replace it for you. I had one ear piece not functional where the wire eventually gave out. E-mailed them and I was able to get new in-ears.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Audio technica CKMS70 left earphone broken