Overclock.net › Forums › Graphics Cards › AMD/ATI › HD5850 CF bad peformance?
New Posts  All Forums:Forum Nav:

HD5850 CF bad peformance?

post #1 of 95
Thread Starter 
Hello.

I just got my self another 5850 card and set it up for crossfire, tho it seems as crossfire makes every game run whit lower fps then with only 1 card ???

In Bad Company 2 i got about 35-45 fps, and it laggs badly, it did not do this with one card. Also in every game i play it loads only 20-30% ?

Sure low load is ok, but in games as bad company 2 i want to have atleast 60fps stable, this shud be achiveable with 5850cf?

My specs:

Cpu: Q9950 @ 3.7ghz
Mem: 4gb ddr2 1066mhz ram
Gpu, Well ofc 2x 5850 cards in cf. [Clocked with msi afterburner to 820mhz core and 1100mhz mem.

Any 1 got any ideas on whats wrong ?
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
post #2 of 95
You check your drivers? What version do you have? This is usually the culprit. Hopefully with the added card, your PSU isn't being bottle-necked.
My System
(13 items)
 
Ivy Bridge
(10 items)
 
 
CPUMotherboardGraphicsRAM
C2D E6600 @ 3.71ghz | q6600 @ 3.8ghz P5N-E Sli | P5Q XFX HD5770 | HD5850 6gb G.Skill (900mhz) | 4gb Patriot (1000mhz) 
Hard DriveOSMonitorKeyboard
750gb Caviar Black | 2x120gb Raid 0 Windows 7 64bit Home 2x Acer H233H | Acer P244W Microsoft x4 
PowerCaseMouseMouse Pad
Rocketfish 550w x2 Thermaltake V3 | Haf 912 Razer Abyssus Steel Series 
CPUMotherboardGraphicsRAM
i7-3770k Asus Maximus V Gene Sapphire HD6950 unlocked to HD6970 16gb RipJawsX 
Hard DriveOptical DriveCoolingOS
Crucial 1TB Western Digital Green Sata III Corsair H80 Windows 7 
PowerCase
Corsair HX650 CM Storm Enforcer 
  hide details  
Reply
My System
(13 items)
 
Ivy Bridge
(10 items)
 
 
CPUMotherboardGraphicsRAM
C2D E6600 @ 3.71ghz | q6600 @ 3.8ghz P5N-E Sli | P5Q XFX HD5770 | HD5850 6gb G.Skill (900mhz) | 4gb Patriot (1000mhz) 
Hard DriveOSMonitorKeyboard
750gb Caviar Black | 2x120gb Raid 0 Windows 7 64bit Home 2x Acer H233H | Acer P244W Microsoft x4 
PowerCaseMouseMouse Pad
Rocketfish 550w x2 Thermaltake V3 | Haf 912 Razer Abyssus Steel Series 
CPUMotherboardGraphicsRAM
i7-3770k Asus Maximus V Gene Sapphire HD6950 unlocked to HD6970 16gb RipJawsX 
Hard DriveOptical DriveCoolingOS
Crucial 1TB Western Digital Green Sata III Corsair H80 Windows 7 
PowerCase
Corsair HX650 CM Storm Enforcer 
  hide details  
Reply
post #3 of 95
Thread Starter 
Quote:
Originally Posted by hellfire72 View Post
You check your drivers? What version do you have? This is usually the culprit. Hopefully with the added card, your PSU isn't being bottle-necked.
I got 11.2 (Newest) I uninstalled ATI drivers with drive sweeper before reinstalling them after installed the cards, so drivers shud be ok.
Also im using a 620W psu with good quality and i can stress test the cards with no problems at all, so that shudent be a problem either.

Problem seems to be that the card only loads 25-30% when im playing.
is it possible to make the card run at lets say like 75% all the time when im playing so i can get better fps? It's ridicilus that it only loads 25-30% when im bairly getting 40fps in bc2.
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
post #4 of 95
Try uninstalling any GPU overclocking software and then uninstalling drivers again but this time run driversweeper in safe mode. Reboot to normal desktop, run ccleaner on the registry and reinstall drivers. I used to have similar issues and I learned that running driversweeper in safe mode fixes them.
MPower
(15 items)
 
Honey Badger
(15 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i5 4690K @ 4.5GHz MSI Z87 MPower MAX AC ASUS GTX 1070 STRIX OC G.Skill Sniper 1600 16GB 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO 1TB Sony Optiarc DVD+RW Corsair H100i Windows 10 Pro x64 
MonitorKeyboardPowerCase
ASUS VG248QE 144Hz Corsair STRAFE MX Blue Seasonic X-850 Fractal Define R4 Blackout 
MouseMouse PadAudio
Cooler Master Xornet II SteelSeries QcK Mass Plantronics Gamecon 818 
CPUMotherboardGraphicsRAM
Intel Core i5 4670K @ 4.6GHz ASUS Z87i-Deluxe NVIDIA GTX 980 4GB ADATA XPG V2 1600 8GB 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO 250GB ASUS 24x DVD+RW Corsair H60 V2 Windows 8.1 Pro x64 
MonitorKeyboardPowerCase
ASUS VG248QE 144Hz Logitech G610 MX Brown Corsair CX500M BitFenix Prodigy 
MouseMouse PadAudio
Cooler Master Xornet II Razer Goliathus Plantronics Gamecon 818  
  hide details  
Reply
MPower
(15 items)
 
Honey Badger
(15 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i5 4690K @ 4.5GHz MSI Z87 MPower MAX AC ASUS GTX 1070 STRIX OC G.Skill Sniper 1600 16GB 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO 1TB Sony Optiarc DVD+RW Corsair H100i Windows 10 Pro x64 
MonitorKeyboardPowerCase
ASUS VG248QE 144Hz Corsair STRAFE MX Blue Seasonic X-850 Fractal Define R4 Blackout 
MouseMouse PadAudio
Cooler Master Xornet II SteelSeries QcK Mass Plantronics Gamecon 818 
CPUMotherboardGraphicsRAM
Intel Core i5 4670K @ 4.6GHz ASUS Z87i-Deluxe NVIDIA GTX 980 4GB ADATA XPG V2 1600 8GB 
Hard DriveOptical DriveCoolingOS
Samsung 850 EVO 250GB ASUS 24x DVD+RW Corsair H60 V2 Windows 8.1 Pro x64 
MonitorKeyboardPowerCase
ASUS VG248QE 144Hz Logitech G610 MX Brown Corsair CX500M BitFenix Prodigy 
MouseMouse PadAudio
Cooler Master Xornet II Razer Goliathus Plantronics Gamecon 818  
  hide details  
Reply
post #5 of 95
Thread Starter 
Quote:
Originally Posted by Regamaster View Post
Try uninstalling any GPU overclocking software and then uninstalling drivers again but this time run driversweeper in safe mode. Reboot to normal desktop, run ccleaner on the registry and reinstall drivers. I used to have similar issues and I learned that running driversweeper in safe mode fixes them.
Alright, ill try that now. Tho im going to try the 11.1a drivers since lots of ppl say that 11.2 drivers are killing bad company 2's fps with crossfire setup
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
post #6 of 95
Thread Starter 
Same problem still, 30% load on both card and fps under 50.
just got even more bugs with older drivers >.<
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
post #7 of 95
Thread Starter 
Bump!
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
post #8 of 95
Try setting Catalyst AI to Advanced, at least some level of Catalyst AI is required for CrossFire. Though, with the new CCC, they've forced Catalyst AI to be enabled. Double check and try setting it to whatever settings are available.

Also, I've been hearing from fellow OCNers and the Catalyst Driver Team that drivers should be installed over each other and they discourage usage of Driver Sweeper.

If all else fails, try a reformat. Run 3DMark Vantage or some other GPU intensive benchmark to see if scores have gone up or if it's just the games.
Sinking Box
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 2500k 4.8Ghz 1.37v ASRock P67 Extreme4 Gen3 ASUS HD5850 955/1250 8GB G.Skill Snipers 1600Mhz 
Hard DriveCoolingOSMonitor
2x Western Digital 640GB Caviar Blacks RAID 0 XSPC Rasa + RX360 Windows 7 Ultimate 64 Bit Sharp 32" 1080p LCD HDTV 
KeyboardPowerCaseMouse
Logitech Illuminated Keyboard Corsair HX620 Corsair Obsidian 700D Logitech G3 Mouse 
  hide details  
Reply
Sinking Box
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 2500k 4.8Ghz 1.37v ASRock P67 Extreme4 Gen3 ASUS HD5850 955/1250 8GB G.Skill Snipers 1600Mhz 
Hard DriveCoolingOSMonitor
2x Western Digital 640GB Caviar Blacks RAID 0 XSPC Rasa + RX360 Windows 7 Ultimate 64 Bit Sharp 32" 1080p LCD HDTV 
KeyboardPowerCaseMouse
Logitech Illuminated Keyboard Corsair HX620 Corsair Obsidian 700D Logitech G3 Mouse 
  hide details  
Reply
post #9 of 95
Thread Starter 
Quote:
Originally Posted by Rpg2 View Post
Try setting Catalyst AI to Advanced, at least some level of Catalyst AI is required for CrossFire. Though, with the new CCC, they've forced Catalyst AI to be enabled. Double check and try setting it to whatever settings are available.

Also, I've been hearing from fellow OCNers and the Catalyst Driver Team that drivers should be installed over each other and they discourage usage of Driver Sweeper.

If all else fails, try a reformat. Run 3DMark Vantage or some other GPU intensive benchmark to see if scores have gone up or if it's just the games.
What do you mean with catlys AI to advanced ?

Mine is currently like this:



And i dont think a reformat does any good. ive trying 3 diffrent drivers and diffrent ways to install them and they all peform the same. Tho in stress test and benchmark in games they load 100%, tho in css and bc2 they only load 25-30% when playing =/
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
post #10 of 95
Thread Starter 
hm this is strange.

In bc2 and css the cards loads only 25-30% but in tf2 they loads at 55-70%
so in tf2 my fps jumps from 250 and past 400 depending on the load. So that is the problem, for some reason my cards is just loads at 25-30% in most of my games, making my fps poor.

Tho i have no idea how i can fix it so it loads atleast 75% so i can get avrage fps in bc2
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7-2600K 3.40GHz (at 5047 MHz) Asus P8P67 Deluxe ATI HD 5850 @ 950MHz Crossfire Corsair Vengance 1600Mhz @ 8Gb 1.5v 
Hard DriveOSMonitorKeyboard
Spinpoint F3 500gb x2 Raid 0 Windows 7 x64 LG W2363D 120Hz + BenQ 22" G15 v2 
PowerCaseMouseMouse Pad
Enermax 620w CM STORM Sniper mesh edition Coolermaster Storm sentinel Steelseries QCK Heavy 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › HD5850 CF bad peformance?