Overclock.net › Forums › Video Games › PC Gaming › Dead Space 2 Sudden Frame Drop
New Posts  All Forums:Forum Nav:

Dead Space 2 Sudden Frame Drop

post #1 of 5
Thread Starter 
Hey guys I'm having problems when playing Dead Space 2. Every 5-10 mins in the game my framerate will just suddenly drop big time from 200ish to 1fps and the game barely moves. Sometimes it will go fine right away, but most of the time it'll be like that for like a minute or when I press Ctrl + Alt + Del then go back to the game.

I tried VSync on and that solves the problem but I'm lock to 30fps and the game is not smooth... Is this some kind of SLI problem? I have my game settings on max.
geez_man!
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 4.10 - 1.27v EVGA Classified E-760 EVGA 285GTX in SLI 3x 2GB Mushkin 1600 
Hard DriveOptical DriveOSMonitor
2x 320GB WD in Raid 0 Sony Optiarc DVD Windows 7 Pro x64 25.5" Samsung T260 
PowerCaseMouse
PC Power 910W Antec 900 Logitech Nano 
  hide details  
Reply
geez_man!
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 4.10 - 1.27v EVGA Classified E-760 EVGA 285GTX in SLI 3x 2GB Mushkin 1600 
Hard DriveOptical DriveOSMonitor
2x 320GB WD in Raid 0 Sony Optiarc DVD Windows 7 Pro x64 25.5" Samsung T260 
PowerCaseMouse
PC Power 910W Antec 900 Logitech Nano 
  hide details  
Reply
post #2 of 5
Here's a few things I can think of:

Are OCs stable? Is anything overheating and resulting in throttling? Are your hard drives working fine (not clicking or dying)? Also defrag your drives and/or see if defragging the game cache helps (assuming you have it on Steam). Try playing DS2 with 1 gfx card in your system. Test each card individually.

Hmm...is this problem with just DS2? Try playing in windowed mode. Or try reinstalling the game.

When you enable vsync, is it from in game or nVidia control panel? If not in game, try forcing vsync in the control panel with triple buffering and see what happens. It should be set at 60 but I'm not sure if it'll be smooth because (for me) 60 wasn't smooth for the first Dead Space. I assume that vsync will be crappy with DS2.

If that doesn't work, reinstall/update drivers.

Last resort: I had a somewhat similar issue on my laptop but it happened to all my games. Restoring helped.
    
CPUMotherboardGraphicsRAM
[i7 930 4Ghz] [P6X58D Premium] [GTX 580] [6GB OCZ+Corsair] 
Hard DriveOSMonitorPower
[4x500GB Seagates Short-Stroked] [Windows 7 Professional x64] [24" S243HLbMII][22" 2220WM] [Corsair 850TX] 
CaseMouse
??? [G9] 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
[i7 930 4Ghz] [P6X58D Premium] [GTX 580] [6GB OCZ+Corsair] 
Hard DriveOSMonitorPower
[4x500GB Seagates Short-Stroked] [Windows 7 Professional x64] [24" S243HLbMII][22" 2220WM] [Corsair 850TX] 
CaseMouse
??? [G9] 
  hide details  
Reply
post #3 of 5
Thread Starter 
OC Stable, no overheating on CPU and GFX, HD's are working fine, defrag is good. Yes this is just a problem with DS2. VSync is enable thru the in-game settings and even though my monitors refresh rate is 60hz my fps is only fix at 30fps so its not really smooth.

Haven't tried reinstalling drivers. Right now I can play it somewhat smooth but I noticed after the last framerate drop my gfx is core clock is downclock to 400 (648 stock). Card temp doesn go above 70c so i dont think its overheating and its not overclock either.
geez_man!
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 4.10 - 1.27v EVGA Classified E-760 EVGA 285GTX in SLI 3x 2GB Mushkin 1600 
Hard DriveOptical DriveOSMonitor
2x 320GB WD in Raid 0 Sony Optiarc DVD Windows 7 Pro x64 25.5" Samsung T260 
PowerCaseMouse
PC Power 910W Antec 900 Logitech Nano 
  hide details  
Reply
geez_man!
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 4.10 - 1.27v EVGA Classified E-760 EVGA 285GTX in SLI 3x 2GB Mushkin 1600 
Hard DriveOptical DriveOSMonitor
2x 320GB WD in Raid 0 Sony Optiarc DVD Windows 7 Pro x64 25.5" Samsung T260 
PowerCaseMouse
PC Power 910W Antec 900 Logitech Nano 
  hide details  
Reply
post #4 of 5
I'd advise you to turn off the V-Sync.
Marshmallow
(14 items)
 
Corsair H100 - Excellent Compact Cooler
Corsair Hydro Series H100 Extreme Performance Liquid CPU Cooler (CWCH100)
 
CPUMotherboardGraphicsRAM
Core i7 920 @ 4.0GHz - 1.21v EVGA Classified X58 Asus GTX 580 DirectCU II 6GB Mushkin Blackline 
Hard DriveCoolingOSMonitor
Corsair F60 + 1TB Spinpoint F3 Corsair H100 Windows 7 Ultimate x64 Asus MK241H 24" 1920x1200 
KeyboardPowerCaseMouse
Das Model S Professional Silent Antec BP550 Plus NZXT Phantom Razer DeathAdder 
  hide details  
Reply
Marshmallow
(14 items)
 
Corsair H100 - Excellent Compact Cooler
Corsair Hydro Series H100 Extreme Performance Liquid CPU Cooler (CWCH100)
 
CPUMotherboardGraphicsRAM
Core i7 920 @ 4.0GHz - 1.21v EVGA Classified X58 Asus GTX 580 DirectCU II 6GB Mushkin Blackline 
Hard DriveCoolingOSMonitor
Corsair F60 + 1TB Spinpoint F3 Corsair H100 Windows 7 Ultimate x64 Asus MK241H 24" 1920x1200 
KeyboardPowerCaseMouse
Das Model S Professional Silent Antec BP550 Plus NZXT Phantom Razer DeathAdder 
  hide details  
Reply
post #5 of 5
Try the Vsync force through the Nvidia control panel. I don't see why it would fix it, but if it does, don't question it! biggrin.gif

The control panel method (as opposed to ingame Vsync) is known to, in both DS1 and DS2, to fix the laggy framerate and the floaty game controls, so there you have some added benefits in addition to solving your specific problem.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Dead Space 2 Sudden Frame Drop