Overclock.net › Forums › AMD › AMD Motherboards › need help with RAID0 on ASUS M4A89TD Pro Motherboard
New Posts  All Forums:Forum Nav:

need help with RAID0 on ASUS M4A89TD Pro Motherboard

post #1 of 3
Thread Starter 
I read the manual to the mobo a few times, but one point is unclear to me.
The mobo has 6 SATA connections. They recommend using ports 5 and/or 6 if you are going to connect optical drives and use them to installl the OS, which is what I am doing. So 5 and 6 are taken by my optical drives.

That leaves ports 1-4. I have one SSD for the OS only, and 2 HDDs I want to use in RAID0. So can I connect the SSD to port 1 in IDE mode, and the 2 HDDs to ports 3 and 4 and have those run in RAID0? This was my plan, but the manual seems to say that ports 1-4 must all be running in the same mode. But it is unclear, I do not know if I am reading this correctly or not.

Here are the portions of the manual that are confusing me:

Chp2-28
mobomanual2-28.png

So that sounds to me like you can either have Ports1-4 all in RAID or Ports5-6 all in RAID. You cannot have say Port 1 and 4 in IDE, and Ports 2 and 3 in RAID0. Same with 5 and 6, sounds like ports 5 and 6 have to be set to the same configuration, you can't have port 5 IDE and port 6 in RAID

That says to see section 3.4.2 Storage Configuration in the manual so here that is:

Chp3-13
mobomanual3-13.png

It seems fairly obvious from the BIOS there that you can set configs for 1-4 and 5-6, but not individually. Also, you can see where it says I should use ports 5/6 for optical drives that will install the OS.

Finally, here is one more piece of info that confirms my fears.

Chp4-13
mobomanual4-13.png


Here is a link to the manual if you are that interested in helping me (it is a pdf you will have to download). You can skip right to the chapter-page I reference in this thread if needed.


So what should I do for my configuration if I am correct in my fears that sata 1-4 will have to be either all RAID or all IDE and so will 5/6?
My only thought is as follows:

Ports 5 and 6 in IDE
SATA 5 - for an optical drive I use to install the OS
SATA 6 - for my SSD with the OS

Ports 1-4 in RAID
SATA 1 and 2 - for two HDDs in RAID0
SATA 3 - for another HDD or SDD later, but since it will be forced to be in RAID how will that affect how I can use it?
SATA 4 for the other optical drive - but how is an optical drive affected if the Port is set to RAID mode?

Or could I do something like have both optical drives in ports 5/6 (I guess in IDE mode). Have my SSD in port 1 (in IDE I would suspect?) Then have my two HDDS in ports 3/4 in RAID0, leaving port 2 for some future use. But if ports 3/4 are in RAID0, would I even be able to use Port 1 for the SSD?


Hopefully I just do not know what I am talking about and there is a solution because I just do not have experience with this aspect of pc building.

Much appreciation and rep to anyone who takes the time to digest all this info and help me out smile.gif
Sprite Brain
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T Black Edition Thuban 3.2GHz ASUS M4A89TD PRO/USB3 AM3 AMD 890FX X-Fire'd Radeon HD 6870's 1GB 256-bit DDR5 G.SKILL Ripjaws X Series 8GB (2 x 4GB) DDR3 1600 
Hard DriveOptical DriveOSMonitor
Crucial SSD 64GB & 2 x HITACHI 2TB 7200 RPM RAID 1 ASUS 24x dvd-r & HP 24x dvd-r SATA & Lightscribe Windows 7 Pro 64 bit 2 x ASUS VH236H (3rd soon) 
KeyboardPowerCaseMouse
TBD CORSAIR CMPSU-750HX 750W ATX12V / EPS12V Antec Three Hundred Black Steel ATX Mid Tower TBD 
  hide details  
Reply
Sprite Brain
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T Black Edition Thuban 3.2GHz ASUS M4A89TD PRO/USB3 AM3 AMD 890FX X-Fire'd Radeon HD 6870's 1GB 256-bit DDR5 G.SKILL Ripjaws X Series 8GB (2 x 4GB) DDR3 1600 
Hard DriveOptical DriveOSMonitor
Crucial SSD 64GB & 2 x HITACHI 2TB 7200 RPM RAID 1 ASUS 24x dvd-r & HP 24x dvd-r SATA & Lightscribe Windows 7 Pro 64 bit 2 x ASUS VH236H (3rd soon) 
KeyboardPowerCaseMouse
TBD CORSAIR CMPSU-750HX 750W ATX12V / EPS12V Antec Three Hundred Black Steel ATX Mid Tower TBD 
  hide details  
Reply
post #2 of 3
Quote:
Originally Posted by mkohanek;12463837 
Ports 1-4 in RAID
SATA 1 and 2 - for two HDDs in RAID0
SATA 3 - for another HDD or SDD later, but since it will be forced to be in RAID how will that affect how I can use it?
SATA 4 for the other optical drive - but how is an optical drive affected if the Port is set to RAID mode?

Or could I do something like have both optical drives in ports 5/6 (I guess in IDE mode). Have my SSD in port 1 (in IDE I would suspect?) Then have my two HDDS in ports 3/4 in RAID0, leaving port 2 for some future use. But if ports 3/4 are in RAID0, would I even be able to use Port 1 for the SSD?


Hopefully I just do not know what I am talking about and there is a solution because I just do not have experience with this aspect of pc building.

Much appreciation and rep to anyone who takes the time to digest all this info and help me out smile.gif

Follow the setup you had listed at the top here in the quote. Put the SSD into AHCI mode on the 5/6 ports and put the HDD's into raid on the 1-4 ports. Also connect the optical drive on the 1-4 ports. It won't matter they are in RAID. You won't be able to include the drive in the array and it will passthrough automatically to AHCI or IDE depending on your controller.

That way you can add another HDD to the array later if you want or even RAID the SSD's in the future. Though you could always put the Optical Drive on the other 5/6 port as that would be fine too even in AHCI mode. Then you would have 2 SATA ports open for another HDD for possible RAID1 setup to backup your HDD RAID0 if you wanted.

Hope this helped.
    
CPUMotherboardGraphicsRAM
[INTEL] i7 930, 4.4ghz @ 1.27V [Asus] Rampage III Extreme [Sapphire] 2X 6950's Flashed to 6970's @950/1425 [G.SKILL] Ripjaws X Series 12GB DDR3 @ 2133 
Hard DriveOptical DriveOSMonitor
[Crucial] 2X C300's in Raid0 & [Samsung] 2X 1TB F3 [Hewlett-Packard] DVD-RW [Microsoft] Windows 7 64-bit [Asus] 3X 23" LCD 
KeyboardPowerCaseMouse
[Microsoft] Sidewinder X6 [Kingwin] Lazer LZ-1000 [Xigmatek] Elysium (Being Modded) [Microsoft] Sidewinder 
Mouse Pad
[XTrac] Ripper 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
[INTEL] i7 930, 4.4ghz @ 1.27V [Asus] Rampage III Extreme [Sapphire] 2X 6950's Flashed to 6970's @950/1425 [G.SKILL] Ripjaws X Series 12GB DDR3 @ 2133 
Hard DriveOptical DriveOSMonitor
[Crucial] 2X C300's in Raid0 & [Samsung] 2X 1TB F3 [Hewlett-Packard] DVD-RW [Microsoft] Windows 7 64-bit [Asus] 3X 23" LCD 
KeyboardPowerCaseMouse
[Microsoft] Sidewinder X6 [Kingwin] Lazer LZ-1000 [Xigmatek] Elysium (Being Modded) [Microsoft] Sidewinder 
Mouse Pad
[XTrac] Ripper 
  hide details  
Reply
post #3 of 3
I would put your SSD on the 1-4 ports, you can then enter the raid setup (i think its CTRL+i) to configure your member disks, make sure the 2 hard drives you want are part of a RAID config, and just dont add the SSD to the array, I have done this with a Stripe setup and a single velociraptor.

Keep 5-6 as IDE for your DVD drive smile.gif
    
CPUMotherboardGraphicsRAM
Phenom II x6 1090T @ 4.71ghz, 3000mhz CPU-NB 1.32v Crosshair IV Formula AMD 6990 2 x 2gb Corsair Dominator GT (Hypers) / 6-7-6-18 
Hard DriveOSMonitorPower
2 x 1tb Samsung F3 7 Ultimate 64bit Hannspree HF287 28" Corsair TX950 
Case
Corsair 800D 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Phenom II x6 1090T @ 4.71ghz, 3000mhz CPU-NB 1.32v Crosshair IV Formula AMD 6990 2 x 2gb Corsair Dominator GT (Hypers) / 6-7-6-18 
Hard DriveOSMonitorPower
2 x 1tb Samsung F3 7 Ultimate 64bit Hannspree HF287 28" Corsair TX950 
Case
Corsair 800D 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD Motherboards
Overclock.net › Forums › AMD › AMD Motherboards › need help with RAID0 on ASUS M4A89TD Pro Motherboard