post #21 of 21
Thread Starter 
Just gonna close this thread with the fact that it was my PSU. When I took everything home from the repairman, I checked the PSU with another rig I had set up while my new one was away and I confirmed it was dead. I bought a Corsair HX750W (too much power for now, for further upgrades later XD) from Amazon and it arrived yesterday so I set everything up and it worked perfectly.

Thanks everyone for your suggestions, I do appreciate that it can be difficult to diagnose this sort of thing without the pieces in hand. But I'm glad I listened to the repairman, it saved me a considerable amount of trouble and time.
Project Omnia
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core 2 Quad Q8400 Gigabyte EP45T-USB3P MSI Radeon R9 290 with Twin Frozr IV 4x2GB G.SKILL 1600MHz DDR3 
Hard DriveOptical DriveOSMonitor
500GB 850 Evo, 60GB Agility 2 SSD & 1TB Barracuda ASUS Combo Drive Windows 10 / Fedora 22 24" Dell IPS 
KeyboardPowerCaseMouse
Das Keyboard Model S Ultimate (Brown Switches) Corsair HX750i Thermaltake Armor Logitech G9x 
  hide details  
Reply
Project Omnia
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core 2 Quad Q8400 Gigabyte EP45T-USB3P MSI Radeon R9 290 with Twin Frozr IV 4x2GB G.SKILL 1600MHz DDR3 
Hard DriveOptical DriveOSMonitor
500GB 850 Evo, 60GB Agility 2 SSD & 1TB Barracuda ASUS Combo Drive Windows 10 / Fedora 22 24" Dell IPS 
KeyboardPowerCaseMouse
Das Keyboard Model S Ultimate (Brown Switches) Corsair HX750i Thermaltake Armor Logitech G9x 
  hide details  
Reply