post #1 of 1
Thread Starter 
Hey everyone, I'm suffering from a ground loop hum on my laptop when using a USB headset microphone. It's from the cheap power supply. It's not an uncommon issue, but does anyone have a cheap and easy fix?

Things I've heard:

Get 3 prong to 2 prong adapter. Get a line conditioner.

Take note, I'm using a laptop cause I've just moved... in a hotel currently, and may not have an apartment for several days. Any cheap remedies?

(yes, I've searched probably 2-3 dozen diff search terms and have found very little to do with actually solving the issue)
The Big Ugly 2.5
(14 items)
 
Spectre x360
(7 items)
 
 
CPUMotherboardGraphicsGraphics
Intel i7 2600k Asus P8P67 B3 MSI GTX 980 GTX 580 (physx) 
RAMHard DriveHard DriveHard Drive
16GB Corsair XMS3 1600 Samsung 850 Pro 512GB Barracuda 7200.12 1TB Hitachi 7K3000 2TB 
Optical DriveOSMonitorPower
Pioneer BDR-206D W7 Pro x64 Dell U3415W Corsair AX850 
CaseMouse
Corsair 600T Logitech G500 
CPURAMHard DriveOS
i7 6500U 8GB DDL3L 256GB M.2  Windows 10 
MonitorKeyboardCase
2560 x 1440 Touchscreen Awesome! Aluminum Billet 
  hide details  
Reply
The Big Ugly 2.5
(14 items)
 
Spectre x360
(7 items)
 
 
CPUMotherboardGraphicsGraphics
Intel i7 2600k Asus P8P67 B3 MSI GTX 980 GTX 580 (physx) 
RAMHard DriveHard DriveHard Drive
16GB Corsair XMS3 1600 Samsung 850 Pro 512GB Barracuda 7200.12 1TB Hitachi 7K3000 2TB 
Optical DriveOSMonitorPower
Pioneer BDR-206D W7 Pro x64 Dell U3415W Corsair AX850 
CaseMouse
Corsair 600T Logitech G500 
CPURAMHard DriveOS
i7 6500U 8GB DDL3L 256GB M.2  Windows 10 
MonitorKeyboardCase
2560 x 1440 Touchscreen Awesome! Aluminum Billet 
  hide details  
Reply