Overclock.net › Forums › Intel › Intel - General › rampage 3 no display!!help!! WARNING:long post
New Posts  All Forums:Forum Nav:

rampage 3 no display!!help!! WARNING:long post

post #1 of 10
Thread Starter 
Hi all,

I recently dived into the world of watercooling and watercooled my gpu and cpu.my gpu worked for a bit and then died.so I got really annoyed so I went and bought 2 5850's.Ok, now I put them both in and pressed the power button on and then the pc went BOOM!!

not a loud one but it was like a surge i think.this happened twice and then the comp wouldn't even power up after this. the mobo led started flashing and i had this problem before so I though ok the mobo is fried because it is not getting enough power, maybe i blew something on the mobo.so after that i got even more pissed off and went out and used every last penny of my money to buy a new mobo.

I went and bought the ASUS RAMPAGE 3 EXTREME.
A 1200W Coolermaster silent gold pro just incase my 700w watt ocz psu couln't handle my 5850's in xfire. 1200w is just making sure, I know I won't need that much.
and just because I was buying all this powerful gear, I bought an extra 6gb of ram so 12gb altogether, an OCZ VERTEX ssd and Samsung spinpoint 1tb hdd.because my external hd broke.

Now I put all of this together, here are my specs now:

i7 920
asus rampage 3
xfx 5850 and his 5850
1200w coolermaster silent pro gold
corsair xms3 1333mhz CL: 99924
xspc delta v3 cpu waterblock with the dual bay reservoir/pump and 220 radiator and 120 radiator.only cpu is under water.

i put it all together and moment of truth and NOTHING! not one thing.
the comp powers up, everything sounds like its loading.the mouse lights up so that indicates to me that it has past the asus screen.but I'm getting no image. the LED on the mobo shows everything loading properly apart from the VGA, I have no idea what the led means but I'm guessing that there is something wrong with the gpu.

I have not put the gpus under water. I put them in one at a time, tested with only 1 stick of ram but still nothing.i have no speaker so that just makes it worse to diagnose the problem. no image no matter what I try to do.
I'm asking my friend to bring his gpu today to test but knowing him he'll forget. any way I could fix this? BOTH my gpus show no image. The fans spin on the gpu though. I might of shorted the gpu when i shoprted the mobo.will this affect my cpu aswel? or my ram?

ANY help will be appreciated.I seriously am just annoyed now as I have so many problems when it comes to pc's.everything just keeps breaking.

and yes i know it is a VERY long post but I'm just depressed as I spilled out 900 pounds for all the new stuff and it doesn't work. and now I'm dead broke.i have nothing left.and i still got more stuff to fix that has broken around me.(funny how it's only the expensive stuff that breaks) I'm broken and might give up building high end pc's because of the VERY bad experiences I've had with faulty boards and psus and all that. Please just pity me and give me some advice CALLING TO ALL YOU OVERCLOCK.NET VETERANS!! REVIVE ME!!!!!!! BRING ME BACK TO THE HIGH END WORLD!! sorry, I got carried away.

Thanks for all the replies in advance, and reading about my ranting, so very sorry for the long post. Thanks. Kevin
RO0D
(14 items)
 
R0V2
(10 items)
 
 
CPUMotherboardGraphicsRAM
INTEL I7 3930k ASUS RAMPAGE IV EXTREME MSI 7970 16GB CORSAIR VENGEANCE RED  
Hard DriveCoolingOSMonitor
2X OCZ AGILITY 3/SAMSUNG F3/SEAGATE AQUACOMPUTER CUPLEX CRYOS/PHOBYA G-CHANGER 360/... WINDOWS 7 64 BIT 3X ASUS VS247 
KeyboardPowerCaseMouse
CYBORG V7 COOLERMASTER SILENT PRO GOLD 1200W CORSAIR OBSIDIAN 800D RAZER NAGA MOLTEN 
Mouse PadAudio
RAZER GOLIATHUS EXTENDED EDITION PEARL 8 STUIDO MONITOR/M-AUDIO DELTA 2496/ ALES... 
CPUMotherboardGraphicsRAM
I7 920 C0 @3.6GHZ / XSPC DELTA V3 BLOCK ASUS RAMPAGE III EXTREME GIGABYTE 6850 12GB CORSAIR VENGEANCE 
Hard DriveCoolingOSMonitor
WD 500GB XSPC DELTA V3/ 240 RAD/ PHOBYA PUMP/PHOBYA RES WINDOWS 7 64-BIT 19" HANNS-G MONITOR 
PowerCase
ANTEC TRUE POWER 750W SILVERSTONE RAVEN 2 
  hide details  
Reply
RO0D
(14 items)
 
R0V2
(10 items)
 
 
CPUMotherboardGraphicsRAM
INTEL I7 3930k ASUS RAMPAGE IV EXTREME MSI 7970 16GB CORSAIR VENGEANCE RED  
Hard DriveCoolingOSMonitor
2X OCZ AGILITY 3/SAMSUNG F3/SEAGATE AQUACOMPUTER CUPLEX CRYOS/PHOBYA G-CHANGER 360/... WINDOWS 7 64 BIT 3X ASUS VS247 
KeyboardPowerCaseMouse
CYBORG V7 COOLERMASTER SILENT PRO GOLD 1200W CORSAIR OBSIDIAN 800D RAZER NAGA MOLTEN 
Mouse PadAudio
RAZER GOLIATHUS EXTENDED EDITION PEARL 8 STUIDO MONITOR/M-AUDIO DELTA 2496/ ALES... 
CPUMotherboardGraphicsRAM
I7 920 C0 @3.6GHZ / XSPC DELTA V3 BLOCK ASUS RAMPAGE III EXTREME GIGABYTE 6850 12GB CORSAIR VENGEANCE 
Hard DriveCoolingOSMonitor
WD 500GB XSPC DELTA V3/ 240 RAD/ PHOBYA PUMP/PHOBYA RES WINDOWS 7 64-BIT 19" HANNS-G MONITOR 
PowerCase
ANTEC TRUE POWER 750W SILVERSTONE RAVEN 2 
  hide details  
Reply
post #2 of 10
Alright so if you could tell us which LEDs on your board are green and which are red/orange we could help you.

Possibilities:

1. Dead PCIe lane
2. Dead GPU(improbable since you have two exhibiting the same problem)
3. Monitor Issue(Test your computer out using another display.
4. HDMI cable(Highly improbable)

Don't worry if the light on your peripherals comes on it means it shouldn't be hard to figure out.
Edited by Razultull - 2/26/11 at 10:06am
Bernard
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 3.71 Ghz | 1.17v Rampage III Extreme EVGA GTX 580 Corsair Dominators GTX 6gb 1925MHz 7-7-7-20 
Hard DriveOptical DriveOSMonitor
64Gb C300 SATA 6 Gb/s, 2 x 320 Gb F4's RAID 0 ASUS 24x -_- Windows 7 Home(Who needs ultimate?!) ASUS VH226H 21.5 Inch 1080p 
PowerCaseMouseMouse Pad
Corsair HX1000 + Custom Sleeving NZXT Tempest Evo Razer Naga NONE 
  hide details  
Reply
Bernard
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 3.71 Ghz | 1.17v Rampage III Extreme EVGA GTX 580 Corsair Dominators GTX 6gb 1925MHz 7-7-7-20 
Hard DriveOptical DriveOSMonitor
64Gb C300 SATA 6 Gb/s, 2 x 320 Gb F4's RAID 0 ASUS 24x -_- Windows 7 Home(Who needs ultimate?!) ASUS VH226H 21.5 Inch 1080p 
PowerCaseMouseMouse Pad
Corsair HX1000 + Custom Sleeving NZXT Tempest Evo Razer Naga NONE 
  hide details  
Reply
post #3 of 10
check the Q_led
I love Corsair
(14 items)
 
  
CPUMotherboardGraphicsRAM
2x Xeon E5645 OC'd 4GHZ EVGA Super Record 2 (SR-2) Palit + Gigabyte GTX 580 3GB in SLI 12GB Corsair XMS3 + 12GB Patriot 
Hard DriveOptical DriveOSMonitor
4x Intel 510 in RAID for boot + 4TB for storage Blu Ray combo drive from samsung Windows 7 "pro" 3x Asus VEH467 with trifxstand + LG IPS  
KeyboardPowerCaseMouse
Blackwidow Ultimate Strider 1k Silver 800D G500 
Mouse PadAudio
Miniature rug Some 100$ sound card my dad used to own. 
  hide details  
Reply
I love Corsair
(14 items)
 
  
CPUMotherboardGraphicsRAM
2x Xeon E5645 OC'd 4GHZ EVGA Super Record 2 (SR-2) Palit + Gigabyte GTX 580 3GB in SLI 12GB Corsair XMS3 + 12GB Patriot 
Hard DriveOptical DriveOSMonitor
4x Intel 510 in RAID for boot + 4TB for storage Blu Ray combo drive from samsung Windows 7 "pro" 3x Asus VEH467 with trifxstand + LG IPS  
KeyboardPowerCaseMouse
Blackwidow Ultimate Strider 1k Silver 800D G500 
Mouse PadAudio
Miniature rug Some 100$ sound card my dad used to own. 
  hide details  
Reply
post #4 of 10
also try booting off the other bios and reseting the Q_led itself
I love Corsair
(14 items)
 
  
CPUMotherboardGraphicsRAM
2x Xeon E5645 OC'd 4GHZ EVGA Super Record 2 (SR-2) Palit + Gigabyte GTX 580 3GB in SLI 12GB Corsair XMS3 + 12GB Patriot 
Hard DriveOptical DriveOSMonitor
4x Intel 510 in RAID for boot + 4TB for storage Blu Ray combo drive from samsung Windows 7 "pro" 3x Asus VEH467 with trifxstand + LG IPS  
KeyboardPowerCaseMouse
Blackwidow Ultimate Strider 1k Silver 800D G500 
Mouse PadAudio
Miniature rug Some 100$ sound card my dad used to own. 
  hide details  
Reply
I love Corsair
(14 items)
 
  
CPUMotherboardGraphicsRAM
2x Xeon E5645 OC'd 4GHZ EVGA Super Record 2 (SR-2) Palit + Gigabyte GTX 580 3GB in SLI 12GB Corsair XMS3 + 12GB Patriot 
Hard DriveOptical DriveOSMonitor
4x Intel 510 in RAID for boot + 4TB for storage Blu Ray combo drive from samsung Windows 7 "pro" 3x Asus VEH467 with trifxstand + LG IPS  
KeyboardPowerCaseMouse
Blackwidow Ultimate Strider 1k Silver 800D G500 
Mouse PadAudio
Miniature rug Some 100$ sound card my dad used to own. 
  hide details  
Reply
post #5 of 10
could be incompatible memory,just my 2 cents
Black Edition
(17 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X4 870K @ 4.60 ASUS A68HM-Plus FM2+ MSI GeForce GTX 970 OC Crucial Ballistix Sports (8GB.) (DDR3-1600) 
Hard DriveHard DriveHard DriveHard Drive
SanDisk SSD Plus 240GB. Toshiba (500GB.) Hitachi Deskstar (500GB.) WD Ultra Passport 
Optical DriveCoolingOSMonitor
Samsung DVD Burner 24X SH-224DB/BEBE Cooler Master Hyper T4 Windows 10 Pro x64 Samsung S23A350H 23" 1080p 
KeyboardPowerCaseMouse
Logitech G105 Gaming Keyboard CORSAIR CX series CX600M 600W Thermaltake V3 Black Edition Logitech G300s Gaming Mouse 
Audio
ASUS DG 5.1 DD 
  hide details  
Reply
Black Edition
(17 items)
 
  
CPUMotherboardGraphicsRAM
AMD Athlon X4 870K @ 4.60 ASUS A68HM-Plus FM2+ MSI GeForce GTX 970 OC Crucial Ballistix Sports (8GB.) (DDR3-1600) 
Hard DriveHard DriveHard DriveHard Drive
SanDisk SSD Plus 240GB. Toshiba (500GB.) Hitachi Deskstar (500GB.) WD Ultra Passport 
Optical DriveCoolingOSMonitor
Samsung DVD Burner 24X SH-224DB/BEBE Cooler Master Hyper T4 Windows 10 Pro x64 Samsung S23A350H 23" 1080p 
KeyboardPowerCaseMouse
Logitech G105 Gaming Keyboard CORSAIR CX series CX600M 600W Thermaltake V3 Black Edition Logitech G300s Gaming Mouse 
Audio
ASUS DG 5.1 DD 
  hide details  
Reply
post #6 of 10
if those 5850s ran off that OCZ rubbish PSU then i say the 5850s have died. my OCZ mXs 700W killed my mobo.
Main Rig
(15 items)
 
Work Rig
(9 items)
 
 
CPUMotherboardGraphicsRAM
5820k Asus X99 Deluxe MSI GTX980 Ti Gaming/EK GPU Block Corsair 16GB 
Hard DriveCoolingOSMonitor
M4 128GB,C300 128GB, F3 1TB  480mm RAD, 655/top, 250mm RES, EK LX CPU Block windows 7 PRO 64bit Asus PB278Q 
PowerCase
Enermax Platimax 1500W Cosmos S 
CPUMotherboardGraphicsRAM
Core i7 2600k ASUS P8Z77-V MSI GT 610 1GB Corsair 1333mhz 16GB 
Hard DriveCoolingOSPower
Intel 330 60GB Cooler Master Hyper 212 EVO W7 Corsair CX500M 
Case
Cooler Master Elite 334U 
  hide details  
Reply
Main Rig
(15 items)
 
Work Rig
(9 items)
 
 
CPUMotherboardGraphicsRAM
5820k Asus X99 Deluxe MSI GTX980 Ti Gaming/EK GPU Block Corsair 16GB 
Hard DriveCoolingOSMonitor
M4 128GB,C300 128GB, F3 1TB  480mm RAD, 655/top, 250mm RES, EK LX CPU Block windows 7 PRO 64bit Asus PB278Q 
PowerCase
Enermax Platimax 1500W Cosmos S 
CPUMotherboardGraphicsRAM
Core i7 2600k ASUS P8Z77-V MSI GT 610 1GB Corsair 1333mhz 16GB 
Hard DriveCoolingOSPower
Intel 330 60GB Cooler Master Hyper 212 EVO W7 Corsair CX500M 
Case
Cooler Master Elite 334U 
  hide details  
Reply
post #7 of 10
Thread Starter 
ok thanks for replying mate,

the light next to the sata is green,
the one near the bottom of the board is orange, im guessing that's the bios.
the ROG logo is a solid red but it flashes like a heartbeat when turned off (is that normal?)
the 2 lights on the side of the northbridge and ROG logo are green.
The start and reset buttons are lit.
the red led's on the mobo say:

CPU: this flashes and then goes to the next one
DRAM: same thing as above
VGA: this one stays lit
BOOT DEVICE: this one also flashes and then goes blank

that's all the lights I see.

There are 2 slots for the 12v power, am I supposed to only put it into one of the slots? I put 1 4pin into the top one and another 4pin into the one below that because I don't have any power adapters that fit into the second slot of the first connector (sorry if that sounds confusing)

I've been waiting for my friend to bring his gpu but he's taking hours.
If I've blown both my gpu's then thats 300 pounds gone.

The monitor is working fine because I am plugging it in this laptop im using to write this post.im also using the hdmi cable to connect it so theres nothing wrong with that.

The only thing I can do is wait for my friend to bring his gpu i guess.

Thanks for your reply mate.
RO0D
(14 items)
 
R0V2
(10 items)
 
 
CPUMotherboardGraphicsRAM
INTEL I7 3930k ASUS RAMPAGE IV EXTREME MSI 7970 16GB CORSAIR VENGEANCE RED  
Hard DriveCoolingOSMonitor
2X OCZ AGILITY 3/SAMSUNG F3/SEAGATE AQUACOMPUTER CUPLEX CRYOS/PHOBYA G-CHANGER 360/... WINDOWS 7 64 BIT 3X ASUS VS247 
KeyboardPowerCaseMouse
CYBORG V7 COOLERMASTER SILENT PRO GOLD 1200W CORSAIR OBSIDIAN 800D RAZER NAGA MOLTEN 
Mouse PadAudio
RAZER GOLIATHUS EXTENDED EDITION PEARL 8 STUIDO MONITOR/M-AUDIO DELTA 2496/ ALES... 
CPUMotherboardGraphicsRAM
I7 920 C0 @3.6GHZ / XSPC DELTA V3 BLOCK ASUS RAMPAGE III EXTREME GIGABYTE 6850 12GB CORSAIR VENGEANCE 
Hard DriveCoolingOSMonitor
WD 500GB XSPC DELTA V3/ 240 RAD/ PHOBYA PUMP/PHOBYA RES WINDOWS 7 64-BIT 19" HANNS-G MONITOR 
PowerCase
ANTEC TRUE POWER 750W SILVERSTONE RAVEN 2 
  hide details  
Reply
RO0D
(14 items)
 
R0V2
(10 items)
 
 
CPUMotherboardGraphicsRAM
INTEL I7 3930k ASUS RAMPAGE IV EXTREME MSI 7970 16GB CORSAIR VENGEANCE RED  
Hard DriveCoolingOSMonitor
2X OCZ AGILITY 3/SAMSUNG F3/SEAGATE AQUACOMPUTER CUPLEX CRYOS/PHOBYA G-CHANGER 360/... WINDOWS 7 64 BIT 3X ASUS VS247 
KeyboardPowerCaseMouse
CYBORG V7 COOLERMASTER SILENT PRO GOLD 1200W CORSAIR OBSIDIAN 800D RAZER NAGA MOLTEN 
Mouse PadAudio
RAZER GOLIATHUS EXTENDED EDITION PEARL 8 STUIDO MONITOR/M-AUDIO DELTA 2496/ ALES... 
CPUMotherboardGraphicsRAM
I7 920 C0 @3.6GHZ / XSPC DELTA V3 BLOCK ASUS RAMPAGE III EXTREME GIGABYTE 6850 12GB CORSAIR VENGEANCE 
Hard DriveCoolingOSMonitor
WD 500GB XSPC DELTA V3/ 240 RAD/ PHOBYA PUMP/PHOBYA RES WINDOWS 7 64-BIT 19" HANNS-G MONITOR 
PowerCase
ANTEC TRUE POWER 750W SILVERSTONE RAVEN 2 
  hide details  
Reply
post #8 of 10
Thread Starter 
lemme try all of these things, I will also check the vendor list to see if the ram is compatible.how do i boot off the other bios and reset q led? ima read the manual in a bit to find out that stuff. lol I had the same psu as you mate. OCZ 700w mod xtreme.My mobo died aswel.
RO0D
(14 items)
 
R0V2
(10 items)
 
 
CPUMotherboardGraphicsRAM
INTEL I7 3930k ASUS RAMPAGE IV EXTREME MSI 7970 16GB CORSAIR VENGEANCE RED  
Hard DriveCoolingOSMonitor
2X OCZ AGILITY 3/SAMSUNG F3/SEAGATE AQUACOMPUTER CUPLEX CRYOS/PHOBYA G-CHANGER 360/... WINDOWS 7 64 BIT 3X ASUS VS247 
KeyboardPowerCaseMouse
CYBORG V7 COOLERMASTER SILENT PRO GOLD 1200W CORSAIR OBSIDIAN 800D RAZER NAGA MOLTEN 
Mouse PadAudio
RAZER GOLIATHUS EXTENDED EDITION PEARL 8 STUIDO MONITOR/M-AUDIO DELTA 2496/ ALES... 
CPUMotherboardGraphicsRAM
I7 920 C0 @3.6GHZ / XSPC DELTA V3 BLOCK ASUS RAMPAGE III EXTREME GIGABYTE 6850 12GB CORSAIR VENGEANCE 
Hard DriveCoolingOSMonitor
WD 500GB XSPC DELTA V3/ 240 RAD/ PHOBYA PUMP/PHOBYA RES WINDOWS 7 64-BIT 19" HANNS-G MONITOR 
PowerCase
ANTEC TRUE POWER 750W SILVERSTONE RAVEN 2 
  hide details  
Reply
RO0D
(14 items)
 
R0V2
(10 items)
 
 
CPUMotherboardGraphicsRAM
INTEL I7 3930k ASUS RAMPAGE IV EXTREME MSI 7970 16GB CORSAIR VENGEANCE RED  
Hard DriveCoolingOSMonitor
2X OCZ AGILITY 3/SAMSUNG F3/SEAGATE AQUACOMPUTER CUPLEX CRYOS/PHOBYA G-CHANGER 360/... WINDOWS 7 64 BIT 3X ASUS VS247 
KeyboardPowerCaseMouse
CYBORG V7 COOLERMASTER SILENT PRO GOLD 1200W CORSAIR OBSIDIAN 800D RAZER NAGA MOLTEN 
Mouse PadAudio
RAZER GOLIATHUS EXTENDED EDITION PEARL 8 STUIDO MONITOR/M-AUDIO DELTA 2496/ ALES... 
CPUMotherboardGraphicsRAM
I7 920 C0 @3.6GHZ / XSPC DELTA V3 BLOCK ASUS RAMPAGE III EXTREME GIGABYTE 6850 12GB CORSAIR VENGEANCE 
Hard DriveCoolingOSMonitor
WD 500GB XSPC DELTA V3/ 240 RAD/ PHOBYA PUMP/PHOBYA RES WINDOWS 7 64-BIT 19" HANNS-G MONITOR 
PowerCase
ANTEC TRUE POWER 750W SILVERSTONE RAVEN 2 
  hide details  
Reply
post #9 of 10
Quote:
Originally Posted by noobsrus View Post
lemme try all of these things, I will also check the vendor list to see if the ram is compatible.how do i boot off the other bios and reset q led? ima read the manual in a bit to find out that stuff. lol I had the same psu as you mate. OCZ 700w mod xtreme.My mobo died aswel.
If your VGA light stays on then its not the gpu(most probably). It seems you're not being able to boot. Try switching the BIOS...remove the CMOS battery and unplug your PSU for 10 minutes. Press the power button a few times with everything unplugged to drain the power. Then put everything back in and try again.
Bernard
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 3.71 Ghz | 1.17v Rampage III Extreme EVGA GTX 580 Corsair Dominators GTX 6gb 1925MHz 7-7-7-20 
Hard DriveOptical DriveOSMonitor
64Gb C300 SATA 6 Gb/s, 2 x 320 Gb F4's RAID 0 ASUS 24x -_- Windows 7 Home(Who needs ultimate?!) ASUS VH226H 21.5 Inch 1080p 
PowerCaseMouseMouse Pad
Corsair HX1000 + Custom Sleeving NZXT Tempest Evo Razer Naga NONE 
  hide details  
Reply
Bernard
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 3.71 Ghz | 1.17v Rampage III Extreme EVGA GTX 580 Corsair Dominators GTX 6gb 1925MHz 7-7-7-20 
Hard DriveOptical DriveOSMonitor
64Gb C300 SATA 6 Gb/s, 2 x 320 Gb F4's RAID 0 ASUS 24x -_- Windows 7 Home(Who needs ultimate?!) ASUS VH226H 21.5 Inch 1080p 
PowerCaseMouseMouse Pad
Corsair HX1000 + Custom Sleeving NZXT Tempest Evo Razer Naga NONE 
  hide details  
Reply
post #10 of 10
Thread Starter 
i just tried it, didn't work unfortunately.switched the bios and everything is still the same.it powers up but i get no image.everything powers up, hdd spinning and lights all come on and stuff so im pretty sure its a gpu problem.i read the manual and it said that the leds on the mobo represent a problem with a compenent. the cpu,ram and boot device is ok apparently from what the manual says and if the light stays lit,there is a problem with it.My friend still hasn't come. no one else i can get a spare gpu off of.

Thanks for all your replies though, i really appreciate it.
RO0D
(14 items)
 
R0V2
(10 items)
 
 
CPUMotherboardGraphicsRAM
INTEL I7 3930k ASUS RAMPAGE IV EXTREME MSI 7970 16GB CORSAIR VENGEANCE RED  
Hard DriveCoolingOSMonitor
2X OCZ AGILITY 3/SAMSUNG F3/SEAGATE AQUACOMPUTER CUPLEX CRYOS/PHOBYA G-CHANGER 360/... WINDOWS 7 64 BIT 3X ASUS VS247 
KeyboardPowerCaseMouse
CYBORG V7 COOLERMASTER SILENT PRO GOLD 1200W CORSAIR OBSIDIAN 800D RAZER NAGA MOLTEN 
Mouse PadAudio
RAZER GOLIATHUS EXTENDED EDITION PEARL 8 STUIDO MONITOR/M-AUDIO DELTA 2496/ ALES... 
CPUMotherboardGraphicsRAM
I7 920 C0 @3.6GHZ / XSPC DELTA V3 BLOCK ASUS RAMPAGE III EXTREME GIGABYTE 6850 12GB CORSAIR VENGEANCE 
Hard DriveCoolingOSMonitor
WD 500GB XSPC DELTA V3/ 240 RAD/ PHOBYA PUMP/PHOBYA RES WINDOWS 7 64-BIT 19" HANNS-G MONITOR 
PowerCase
ANTEC TRUE POWER 750W SILVERSTONE RAVEN 2 
  hide details  
Reply
RO0D
(14 items)
 
R0V2
(10 items)
 
 
CPUMotherboardGraphicsRAM
INTEL I7 3930k ASUS RAMPAGE IV EXTREME MSI 7970 16GB CORSAIR VENGEANCE RED  
Hard DriveCoolingOSMonitor
2X OCZ AGILITY 3/SAMSUNG F3/SEAGATE AQUACOMPUTER CUPLEX CRYOS/PHOBYA G-CHANGER 360/... WINDOWS 7 64 BIT 3X ASUS VS247 
KeyboardPowerCaseMouse
CYBORG V7 COOLERMASTER SILENT PRO GOLD 1200W CORSAIR OBSIDIAN 800D RAZER NAGA MOLTEN 
Mouse PadAudio
RAZER GOLIATHUS EXTENDED EDITION PEARL 8 STUIDO MONITOR/M-AUDIO DELTA 2496/ ALES... 
CPUMotherboardGraphicsRAM
I7 920 C0 @3.6GHZ / XSPC DELTA V3 BLOCK ASUS RAMPAGE III EXTREME GIGABYTE 6850 12GB CORSAIR VENGEANCE 
Hard DriveCoolingOSMonitor
WD 500GB XSPC DELTA V3/ 240 RAD/ PHOBYA PUMP/PHOBYA RES WINDOWS 7 64-BIT 19" HANNS-G MONITOR 
PowerCase
ANTEC TRUE POWER 750W SILVERSTONE RAVEN 2 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel - General
Overclock.net › Forums › Intel › Intel - General › rampage 3 no display!!help!! WARNING:long post