Overclock.net › Forums › Video Games › PC Gaming › BFBC2 problems connection to server lost
New Posts  All Forums:Forum Nav:

BFBC2 problems connection to server lost

post #1 of 6
Thread Starter 
I keep getting disconnected from games, either sometimes i can enter them and play for 3-4 minutes and then i get kicked out it says connection to server disconnected or something like that, tells me to check my connections.

Well i have done all the port forwarding for this game too, and even updated punkbuster correctly.

Sometimes/most of the time i cannot connect to the server to begin with. its giving me a freaking headache.

i bought the BFBC2 through steam.
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz Always Changing VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz Always Changing VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
post #2 of 6
You could be banned from the specific servers you're trying to connect to, but my first guess would be that it's a Punkbuster issue. I know you've already tried fixing that, but Punkbuster can be very hairy sometimes. I'd start by uninstalling it, deleting all its registry files, user files/application data, and other PB-related files, then downloading pbsvc.exe again and updating everything again. If that doesn't work, you could repeat that first step of deleting all the PB files, then trying sfc /SCANNOW , then restarting and installing PB again. I know similar patterns of tweaking fix a number of PB freezing and connectivity issues.
Budget
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 7600K @ 4.8GHz Turbo ASUS PRIME Z270-K Sapphire RX 580 8GB Nitro+ 16GB Corsair LPX DDR4 3000 
Hard DriveCoolingMonitorKeyboard
Crucial MX300 525GB M.2 CRYORIG H7 ASUS VE258Q Thermaltake Poseidon Z 
PowerCaseMouseMouse Pad
Corsair TX650M Thermaltake F31 Tempered Glass Razer DeathAdder Chroma SteelSeries QcK+ 
Audio
Corsair VOID Wireless 
  hide details  
Reply
Budget
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 7600K @ 4.8GHz Turbo ASUS PRIME Z270-K Sapphire RX 580 8GB Nitro+ 16GB Corsair LPX DDR4 3000 
Hard DriveCoolingMonitorKeyboard
Crucial MX300 525GB M.2 CRYORIG H7 ASUS VE258Q Thermaltake Poseidon Z 
PowerCaseMouseMouse Pad
Corsair TX650M Thermaltake F31 Tempered Glass Razer DeathAdder Chroma SteelSeries QcK+ 
Audio
Corsair VOID Wireless 
  hide details  
Reply
post #3 of 6
Probably punkbuster kicking you for lost packets.
post #4 of 6
I've had that same thing happen but not very often at all. Maybe 3-4 times since I started playing. No idea what causes it unless it is something like random packet loss.
post #5 of 6
Which ports did you forward?
Omicron Lyrae
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 720 BE @3.6 Asus M4A785TD-V EVO Sapphire HD5770 V2 OCZ 2x2GB Gold DDR3-1333 
Hard DriveOptical DriveOSMonitor
Samsung Spinpoint F3 1TB Sony Lightscribe DVD-RW Windows 7 Professional 64-bit AOC F22+ 1080p 
KeyboardPowerCaseMouse
Cherry Scissor Switch Flat Keyboard OCZ StealthXstream 600W Cooler Master Elite 334 Microsoft Sidewinder 
  hide details  
Reply
Omicron Lyrae
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 720 BE @3.6 Asus M4A785TD-V EVO Sapphire HD5770 V2 OCZ 2x2GB Gold DDR3-1333 
Hard DriveOptical DriveOSMonitor
Samsung Spinpoint F3 1TB Sony Lightscribe DVD-RW Windows 7 Professional 64-bit AOC F22+ 1080p 
KeyboardPowerCaseMouse
Cherry Scissor Switch Flat Keyboard OCZ StealthXstream 600W Cooler Master Elite 334 Microsoft Sidewinder 
  hide details  
Reply
post #6 of 6
Thread Starter 
idk as many ports as i could i don't know crap about port forwarding or anything. i will try reinstall punkbuster.

BUT i also tried searching for servers that do NOT use punkbuster, and well that came to the same crap.
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz Always Changing VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
X99 Main Rig
(10 items)
 
  
CPUMotherboardGraphicsRAM
Intel 5960X Extreme Edition @ 4.5GHz Always Changing VisonTek R9 290 G.Skill Ripjaws 4 16GB (4x4GB) DDR4 @ 3200MHz 
Hard DriveHard DriveHard DriveCooling
Samsung 128GB M.2 PCI-E 4x SSD Apotop 256GB SSD 1.82TB NAS Noctua NH-D15 with both fans 
OSPower
Win7 Pro Enermax 1000W 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › BFBC2 problems connection to server lost