Overclock.net › Forums › Cooling › Air Cooling › Problem with an Arctic Cooling Freezer 64 Pro
New Posts  All Forums:Forum Nav:

Problem with an Arctic Cooling Freezer 64 Pro

post #1 of 7
Thread Starter 
Hi, i just got an AC Freezer 64 Pro from a friend of mine and i wanted to see how the temps on it would compare to the stock cooler i have so i put on some new TIM mounted the cooler and turned on my rig.

Sadly the results weren't that great... In fact they were horrible since the temperature kept rising steadily in the BIOS, from 20C to 60C(after a couple of minutes). I also tried going all the way into windows and the temps in CoreTemp were even higher(~90C). Given the (surface of the cooler) i tried applying a tad more TIM, but still no results.

Then i thought it could be caused by my AM2 retention module which only has 1 fixing point on each side so i switched that one out with one module that has 3 fixing points on each side just like the cooler mounting bracket. Still nothing... temperatures kept rising as they did at first. I even tried some of Noctua's NT-H1 TIM but that didn't work either.

So anybody have any ideas on what might be wrong with this cooler?
Edited by kyuubi654 - 2/27/11 at 5:25am
My System
(19 items)
 
  
CPUMotherboardGraphicsGraphics
Athlon II X4 640 GA-M57SLI-S4 rev 2.0 ASUS EN8600GT ASUS EN8600GT 
RAMHard DriveHard DriveOptical Drive
Kingston WDC 500GB 00AADS-00S9B SAMSUNG HD103-SI ASUS DRW-20B1LT 
CoolingCoolingCoolingOS
Cooler Master Hyper 212+ 120mm Xilence Red Wing @ 1300rpm 120mm Xilence Red Wing @ 1500rpm Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
LG M208WA 20" A4Tech Wireless Keyworks Office Thermaltake TR2 500W PP Nameless 
MouseMouse PadAudio
A4Tech Wireless Optical Mouse 
  hide details  
Reply
My System
(19 items)
 
  
CPUMotherboardGraphicsGraphics
Athlon II X4 640 GA-M57SLI-S4 rev 2.0 ASUS EN8600GT ASUS EN8600GT 
RAMHard DriveHard DriveOptical Drive
Kingston WDC 500GB 00AADS-00S9B SAMSUNG HD103-SI ASUS DRW-20B1LT 
CoolingCoolingCoolingOS
Cooler Master Hyper 212+ 120mm Xilence Red Wing @ 1300rpm 120mm Xilence Red Wing @ 1500rpm Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
LG M208WA 20" A4Tech Wireless Keyworks Office Thermaltake TR2 500W PP Nameless 
MouseMouse PadAudio
A4Tech Wireless Optical Mouse 
  hide details  
Reply
post #2 of 7
examine the heatpipes for damage, check the fan to make sure its actually spinning, and when its actually in, put some pressure on the top of the heatsink and see if the temps improve.
Leviathan
(17 items)
 
Charred
(10 items)
 
 
CPUMotherboardGraphicsGraphics
Xeon E5-2690 Biostar TPower X79 PNY GTX 660 2GB HP GT 440 OEM 
RAMHard DriveHard DriveHard Drive
Gskill Ripjaws 4x2GB 1600mhz Seagate Barracuda 500GB Seagate Barracuda 1.5TB Western Digital Caviar Blue 640GB 
Hard DriveCoolingOSMonitor
Patriot Pyro 60GB Xigmatek Gaia Windows 7 Ultimate Acer S230HL 
MonitorKeyboardPowerCase
Princeton 1280x1024 19" Logitech K120 Seasonic G550 Xclio Nighthawk 
Mouse
Logitech MX310 
  hide details  
Reply
Leviathan
(17 items)
 
Charred
(10 items)
 
 
CPUMotherboardGraphicsGraphics
Xeon E5-2690 Biostar TPower X79 PNY GTX 660 2GB HP GT 440 OEM 
RAMHard DriveHard DriveHard Drive
Gskill Ripjaws 4x2GB 1600mhz Seagate Barracuda 500GB Seagate Barracuda 1.5TB Western Digital Caviar Blue 640GB 
Hard DriveCoolingOSMonitor
Patriot Pyro 60GB Xigmatek Gaia Windows 7 Ultimate Acer S230HL 
MonitorKeyboardPowerCase
Princeton 1280x1024 19" Logitech K120 Seasonic G550 Xclio Nighthawk 
Mouse
Logitech MX310 
  hide details  
Reply
post #3 of 7
I dont know if your temps should be THAT bad with that cooler but i had one of those a long time ago and it was just in general a horrible cooler.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
I5 760 GA-H55N GTX 470 PNY Optima 8GB 
Hard DriveMonitorPowerCase
Spinpoint F4 LG227WTG sg07 PSU Sugo sg07 
Mouse
CM Sentinel 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
I5 760 GA-H55N GTX 470 PNY Optima 8GB 
Hard DriveMonitorPowerCase
Spinpoint F4 LG227WTG sg07 PSU Sugo sg07 
Mouse
CM Sentinel 
  hide details  
Reply
post #4 of 7
Thread Starter 
Quote:
Originally Posted by Cyrious 
examine the heatpipes for damage, check the fan to make sure its actually spinning, and when its actually in, put some pressure on the top of the heatsink and see if the temps improve.

i'll look over the heatpipes once more to check if everything is in place, but the fan is spinning and i've tried pushing down on it a bit.. without results of course smile.gif
Quote:
Originally Posted by mykah89 
I dont know if your temps should be THAT bad with that cooler but i had one of those a long time ago and it was just in general a horrible cooler.

i see. thanks for the info mykah89, cause according to reviews back then when it was sort of new on the market, it used to perform somewhat better than an AMD stock cooler. i still wonder why it worked in my friend's rig and it won't in mine -.-

btw... if none of the above are causing this problem, could it be because of the cooler surface? in that case would lapping help any?
Edited by kyuubi654 - 2/27/11 at 9:09am
My System
(19 items)
 
  
CPUMotherboardGraphicsGraphics
Athlon II X4 640 GA-M57SLI-S4 rev 2.0 ASUS EN8600GT ASUS EN8600GT 
RAMHard DriveHard DriveOptical Drive
Kingston WDC 500GB 00AADS-00S9B SAMSUNG HD103-SI ASUS DRW-20B1LT 
CoolingCoolingCoolingOS
Cooler Master Hyper 212+ 120mm Xilence Red Wing @ 1300rpm 120mm Xilence Red Wing @ 1500rpm Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
LG M208WA 20" A4Tech Wireless Keyworks Office Thermaltake TR2 500W PP Nameless 
MouseMouse PadAudio
A4Tech Wireless Optical Mouse 
  hide details  
Reply
My System
(19 items)
 
  
CPUMotherboardGraphicsGraphics
Athlon II X4 640 GA-M57SLI-S4 rev 2.0 ASUS EN8600GT ASUS EN8600GT 
RAMHard DriveHard DriveOptical Drive
Kingston WDC 500GB 00AADS-00S9B SAMSUNG HD103-SI ASUS DRW-20B1LT 
CoolingCoolingCoolingOS
Cooler Master Hyper 212+ 120mm Xilence Red Wing @ 1300rpm 120mm Xilence Red Wing @ 1500rpm Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
LG M208WA 20" A4Tech Wireless Keyworks Office Thermaltake TR2 500W PP Nameless 
MouseMouse PadAudio
A4Tech Wireless Optical Mouse 
  hide details  
Reply
post #5 of 7
Yea, there was a thread back awhile ago when i was having higher temps and nobody really had any kind words for the cooler. I had bought it new from newegg at the time with thousands of good reviews, i ended up getting a hyper 212 after and the difference was just night and day.

I would say that if it worked in your friends rig and not yours that maybe his case just has better air flow or something, as long as your properly installing it that can be the only thing i can think of.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
I5 760 GA-H55N GTX 470 PNY Optima 8GB 
Hard DriveMonitorPowerCase
Spinpoint F4 LG227WTG sg07 PSU Sugo sg07 
Mouse
CM Sentinel 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
I5 760 GA-H55N GTX 470 PNY Optima 8GB 
Hard DriveMonitorPowerCase
Spinpoint F4 LG227WTG sg07 PSU Sugo sg07 
Mouse
CM Sentinel 
  hide details  
Reply
post #6 of 7
I also had that cooler at one point and the temps were pretty good for a cheap cooler. You shouldn't be getting the temps you're getting. I'm wondering if you applied the TIM correctly and in the amount you're supposed to. Apparently it's supposed to be in the size of an uncooked grain of rice. Main thing is not to have bubbles though.
2nd Gig
(24 items)
 
Sayonara
(20 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition Asus M4A79T Deluxe NVIDIA GTX 670 FTW OCZ Platinum 4GB 1600 DDR3 
Hard DriveCoolingOSMonitor
OCZ Vertex 2 90GB & Samsung Spinpoint F3 1TB Scythe MUGEN-2 Microsoft Windows 8 Professional Dell UltraSharp u2410 & Samsung 2333SW 
KeyboardPowerCaseMouse
Logitech G15 OCZ GameXStream 700w HAF 932 Advanced Logitech G300 
AudioAudioAudioAudio
Denon AVR-1912 Harman Kardon Infinity Primus P153  HIFIMAN HE-400 Vsonic GR07 
AudioAudioAudioAudio
Shure SE-535 Limited Edition Beyerdynamic DT880 ODAC/Objective 2 Amplfiier Audio Technica AD700 
  hide details  
Reply
2nd Gig
(24 items)
 
Sayonara
(20 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition Asus M4A79T Deluxe NVIDIA GTX 670 FTW OCZ Platinum 4GB 1600 DDR3 
Hard DriveCoolingOSMonitor
OCZ Vertex 2 90GB & Samsung Spinpoint F3 1TB Scythe MUGEN-2 Microsoft Windows 8 Professional Dell UltraSharp u2410 & Samsung 2333SW 
KeyboardPowerCaseMouse
Logitech G15 OCZ GameXStream 700w HAF 932 Advanced Logitech G300 
AudioAudioAudioAudio
Denon AVR-1912 Harman Kardon Infinity Primus P153  HIFIMAN HE-400 Vsonic GR07 
AudioAudioAudioAudio
Shure SE-535 Limited Edition Beyerdynamic DT880 ODAC/Objective 2 Amplfiier Audio Technica AD700 
  hide details  
Reply
post #7 of 7
Thread Starter 
Quote:
Originally Posted by mykah89 
Yea, there was a thread back awhile ago when i was having higher temps and nobody really had any kind words for the cooler. I had bought it new from newegg at the time with thousands of good reviews, i ended up getting a hyper 212 after and the difference was just night and day.

I would say that if it worked in your friends rig and not yours that maybe his case just has better air flow or something, as long as your properly installing it that can be the only thing i can think of.

well my case may be a bit old, but i've managed to squeeze all the cables in the back, installed an 80mm intake fan and another 80mm one for outtake.

my amd stock cooler runs at idle - 30C and under load - 60C max. the freezer64 pro just keeps rising smile.gif the heatpipes and fins don't get any warmer, in fact they get a bit colder since the fan is going at full speed.
Quote:
Originally Posted by Simca 
I also had that cooler at one point and the temps were pretty good for a cheap cooler. You shouldn't be getting the temps you're getting. I'm wondering if you applied the TIM correctly and in the amount you're supposed to. Apparently it's supposed to be in the size of an uncooked grain of rice. Main thing is not to have bubbles though.

yup. TIM was rice grain sized and i applied a bit of pressure on the cooler to make it spread as much as possible.
Edited by kyuubi654 - 2/27/11 at 9:20am
My System
(19 items)
 
  
CPUMotherboardGraphicsGraphics
Athlon II X4 640 GA-M57SLI-S4 rev 2.0 ASUS EN8600GT ASUS EN8600GT 
RAMHard DriveHard DriveOptical Drive
Kingston WDC 500GB 00AADS-00S9B SAMSUNG HD103-SI ASUS DRW-20B1LT 
CoolingCoolingCoolingOS
Cooler Master Hyper 212+ 120mm Xilence Red Wing @ 1300rpm 120mm Xilence Red Wing @ 1500rpm Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
LG M208WA 20" A4Tech Wireless Keyworks Office Thermaltake TR2 500W PP Nameless 
MouseMouse PadAudio
A4Tech Wireless Optical Mouse 
  hide details  
Reply
My System
(19 items)
 
  
CPUMotherboardGraphicsGraphics
Athlon II X4 640 GA-M57SLI-S4 rev 2.0 ASUS EN8600GT ASUS EN8600GT 
RAMHard DriveHard DriveOptical Drive
Kingston WDC 500GB 00AADS-00S9B SAMSUNG HD103-SI ASUS DRW-20B1LT 
CoolingCoolingCoolingOS
Cooler Master Hyper 212+ 120mm Xilence Red Wing @ 1300rpm 120mm Xilence Red Wing @ 1500rpm Windows 7 Ultimate x64 
MonitorKeyboardPowerCase
LG M208WA 20" A4Tech Wireless Keyworks Office Thermaltake TR2 500W PP Nameless 
MouseMouse PadAudio
A4Tech Wireless Optical Mouse 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Air Cooling
Overclock.net › Forums › Cooling › Air Cooling › Problem with an Arctic Cooling Freezer 64 Pro