Overclock.net › Forums › Graphics Cards › AMD/ATI › 6970 frame rate issues in WoW
New Posts  All Forums:Forum Nav:

6970 frame rate issues in WoW

post #1 of 47
Thread Starter 
Recently set up with 6970's crossfired , This is my sig rig

I have eyefinity set up in a 1 over 3 on ASUS VE248H's (flipped 'T') using the top monitor as extended desktop to monitor temps and such.

Playing WoW is a headache at best, the frames are above 100 if moving straight forward, but if I try to turn its choppy and frames drop to 5 or so.

I have tried disabling crossfire, disabling extended desktop, various Overclocks on the CPU but nothing seems to help unless I set WoWs settings to good... as high or ultra produces horrible performance.

I was using an Nvidia 9600 GSO and was able to run on Ultra settings with no problems..

I shouldnt be experiencing this kind of problems with these cards I have now. I also realize I am pushing 5760x1080 res, but still shouldnt I be able to play at ultra or high at least ? Can anyone please help me ??
BlueMonster
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 950 (batch 3041A657) Gigabyte x58-ud3r XFX HD6970 2Gb Crossfire Corsair Dominator 6gb 
Hard DriveOptical DriveOSMonitor
C-300 64 Gb In Raid, WD 500Gb in Raid DVD/CD RW Windows 7 64bit Asus VE248H 1 over 3 Eyefinity with Ergotech Stand 
KeyboardPowerCaseMouse
Logitech 510 Corsair HX850 Cooler Master HAF 932 (mod'd AMD version) Razer Naga 
  hide details  
Reply
BlueMonster
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 950 (batch 3041A657) Gigabyte x58-ud3r XFX HD6970 2Gb Crossfire Corsair Dominator 6gb 
Hard DriveOptical DriveOSMonitor
C-300 64 Gb In Raid, WD 500Gb in Raid DVD/CD RW Windows 7 64bit Asus VE248H 1 over 3 Eyefinity with Ergotech Stand 
KeyboardPowerCaseMouse
Logitech 510 Corsair HX850 Cooler Master HAF 932 (mod'd AMD version) Razer Naga 
  hide details  
Reply
post #2 of 47
I play on ultra on my rig and it only gets choppy in really busy cities. If you play on single monitor do you experience the same problem with turning?

If you still do on one monitor I'd definitely say reinstall the video card drivers and see if that fixes it. If that doesn't work I'd say reinstall WoW.

If you have no issues with WoW on a single monitor I'd just reinstall the drivers and see if the eyefinity setup works without problems. If the probelm persists after reinstallation of WoW and video card drivers it may be a problem with eyefinity.

Reinstallation is never fun but I think it may help your situation.

hope this helps, Argosy
t7 v2
(14 items)
 
t7 v1
(13 items)
 
t7 v3
(15 items)
 
CPUMotherboardGraphicsRAM
1055T |3.96 GHz| MSI 790FX QuadroFX 540 8GB Gskill Sniper |1600 MHz| 
Hard DriveCoolingOSPower
Seagate Barracuda 250GB Xigmatek Thor's Hammer Ubuntu 11.10 Antec HGC 400W 
Case
Antec 100 
CPUMotherboardGraphicsRAM
i7 920 D0 |3.8 GHz| Foxconn BloodRage EVGA 9600GT 6 GB Corsair DDR3 |1604MHz| 
Hard DriveOptical DriveOSMonitor
1TB Caviar Black 24X Sony Optaric Windows 7 64 bit Acer LED 23" |1920x1080| 
KeyboardPowerCaseMouse
Razer Lycosa Antec HCG 400 Xigmatek Asgard Logitech G500 
Mouse Pad
SteelSeries 5L 
CPUGraphicsRAMHard Drive
Pentium 4 Dual Core 2.8 GHz GTX 480 3GB DDR2 533 2x 80 GB WD 
CoolingCoolingOSPower
Cooler Master Hyper 212+ Cooler Master Hyper 212+ Windows BVista 64-bit Corsair HX 850 
Case
Antec 1200 
  hide details  
Reply
t7 v2
(14 items)
 
t7 v1
(13 items)
 
t7 v3
(15 items)
 
CPUMotherboardGraphicsRAM
1055T |3.96 GHz| MSI 790FX QuadroFX 540 8GB Gskill Sniper |1600 MHz| 
Hard DriveCoolingOSPower
Seagate Barracuda 250GB Xigmatek Thor's Hammer Ubuntu 11.10 Antec HGC 400W 
Case
Antec 100 
CPUMotherboardGraphicsRAM
i7 920 D0 |3.8 GHz| Foxconn BloodRage EVGA 9600GT 6 GB Corsair DDR3 |1604MHz| 
Hard DriveOptical DriveOSMonitor
1TB Caviar Black 24X Sony Optaric Windows 7 64 bit Acer LED 23" |1920x1080| 
KeyboardPowerCaseMouse
Razer Lycosa Antec HCG 400 Xigmatek Asgard Logitech G500 
Mouse Pad
SteelSeries 5L 
CPUGraphicsRAMHard Drive
Pentium 4 Dual Core 2.8 GHz GTX 480 3GB DDR2 533 2x 80 GB WD 
CoolingCoolingOSPower
Cooler Master Hyper 212+ Cooler Master Hyper 212+ Windows BVista 64-bit Corsair HX 850 
Case
Antec 1200 
  hide details  
Reply
post #3 of 47
Thread Starter 
Quote:
Originally Posted by Argosy View Post
I play on ultra on my rig and it only gets choppy in really busy cities. If you play on single monitor do you experience the same problem with turning?

If you still do on one monitor I'd definitely say reinstall the video card drivers and see if that fixes it. If that doesn't work I'd say reinstall WoW.

If you have no issues with WoW on a single monitor I'd just reinstall the drivers and see if the eyefinity setup works without problems. If the probelm persists after reinstallation of WoW and video card drivers it may be a problem with eyefinity.

Reinstallation is never fun but I think it may help your situation.

hope this helps, Argosy

well after spending the last several hours playing with settings, I am able to get it playable by adjusting sunshafts to disabled, and liquid detail one notch down from Ultra. Also brought view distance one notch down from Ultra.
I tried it with and without Crossfire. Actually crossfire made it somewhat better after I changed my setting to disable power savings in my CCC

I am still disapointed in my investment in ATI/AMD as IMO these cards should perform better than this. Heck my old 9600 GSO performed with all on Ultra and never had any issues.
BlueMonster
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 950 (batch 3041A657) Gigabyte x58-ud3r XFX HD6970 2Gb Crossfire Corsair Dominator 6gb 
Hard DriveOptical DriveOSMonitor
C-300 64 Gb In Raid, WD 500Gb in Raid DVD/CD RW Windows 7 64bit Asus VE248H 1 over 3 Eyefinity with Ergotech Stand 
KeyboardPowerCaseMouse
Logitech 510 Corsair HX850 Cooler Master HAF 932 (mod'd AMD version) Razer Naga 
  hide details  
Reply
BlueMonster
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 950 (batch 3041A657) Gigabyte x58-ud3r XFX HD6970 2Gb Crossfire Corsair Dominator 6gb 
Hard DriveOptical DriveOSMonitor
C-300 64 Gb In Raid, WD 500Gb in Raid DVD/CD RW Windows 7 64bit Asus VE248H 1 over 3 Eyefinity with Ergotech Stand 
KeyboardPowerCaseMouse
Logitech 510 Corsair HX850 Cooler Master HAF 932 (mod'd AMD version) Razer Naga 
  hide details  
Reply
post #4 of 47
Try running with just one card, on one moniter and see if you have the same issues. Plus, remember. WoW is 70% CPU 30% GPU. Its still a old coded game.
You can also add the the tag to run it in DX11, see if that helps. -dx11 ? I think is the line you put at the end of the name in your shortcut, or you can put the line in your config file.
SixthElement
(17 items)
 
   
CPUMotherboardGraphicsRAM
i7-4770k Z87-GD65 MSI R7950 TF3 RipjawsX 8G 1600 CL9 
Hard DriveHard DriveOptical DriveCooling
OCZ Vertex 3 Western Digital Caviar Black LG DVD Multi / Lightscribe H100 
OSMonitorKeyboardPower
Win 7 Ult x64 Samsung 2494SW CM Storm Quickfire Reds Corsair HX750 
CaseMouseMouse PadAudio
550D G700 XTrac Ripper XXL Onkyo TX-SR804 
Audio
Bowers & Wilkins 686 BookShelfs 
CPUMotherboardGraphicsRAM
AMD 1090t 990FXA-UD7 MSI R7950 TF3 TBD 
Hard DriveOSPowerCase
Samsung 20G Win 7 Ultimate Corsair CM650 Fractal Design XL 
  hide details  
Reply
SixthElement
(17 items)
 
   
CPUMotherboardGraphicsRAM
i7-4770k Z87-GD65 MSI R7950 TF3 RipjawsX 8G 1600 CL9 
Hard DriveHard DriveOptical DriveCooling
OCZ Vertex 3 Western Digital Caviar Black LG DVD Multi / Lightscribe H100 
OSMonitorKeyboardPower
Win 7 Ult x64 Samsung 2494SW CM Storm Quickfire Reds Corsair HX750 
CaseMouseMouse PadAudio
550D G700 XTrac Ripper XXL Onkyo TX-SR804 
Audio
Bowers & Wilkins 686 BookShelfs 
CPUMotherboardGraphicsRAM
AMD 1090t 990FXA-UD7 MSI R7950 TF3 TBD 
Hard DriveOSPowerCase
Samsung 20G Win 7 Ultimate Corsair CM650 Fractal Design XL 
  hide details  
Reply
post #5 of 47
World of Warcraft doesn't properly support Crossfire and SLI from what I've read.
Koneko
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD R5 1600 Gigabyte GA-AB350M-Gaming 3 Sapphire RX560 (2GB) Corsair CMK16GX4M2B3200C16W (16GB) 
Hard DriveHard DriveMonitorKeyboard
Samsung 840 Pro (256GB) Seagate ST3000DM001 (3TB) Alienware OptX AW2310 (120Hz) Generic Dell 
PowerCaseMouseMouse Pad
Corsair AX750 Corsair Carbide 88R Mionix Naos 7000 Steelseries Qck 
  hide details  
Reply
Koneko
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD R5 1600 Gigabyte GA-AB350M-Gaming 3 Sapphire RX560 (2GB) Corsair CMK16GX4M2B3200C16W (16GB) 
Hard DriveHard DriveMonitorKeyboard
Samsung 840 Pro (256GB) Seagate ST3000DM001 (3TB) Alienware OptX AW2310 (120Hz) Generic Dell 
PowerCaseMouseMouse Pad
Corsair AX750 Corsair Carbide 88R Mionix Naos 7000 Steelseries Qck 
  hide details  
Reply
post #6 of 47
Thread Starter 
Quote:
Originally Posted by Rebelord View Post
Try running with just one card, on one moniter and see if you have the same issues. Plus, remember. WoW is 70% CPU 30% GPU. Its still a old coded game.
You can also add the the tag to run it in DX11, see if that helps. -dx11 ? I think is the line you put at the end of the name in your shortcut, or you can put the line in your config file.


Can you give me specific instructions on how to do this ?


I did run with one card on one monitor and the issue was still there, just not as bad. So When I go to spanned on three screens of course this amplifies the already poor performance. as far as being 70% CPU, I have even OC'd to 4.2Ghz without even a nudge in performance.

Interesting issue came up though. I got an error from windows that my system performance was slow, and that I needed to change my Aero settings to help improve performance. I was like *** ?? So now I am also thinking that maybe I need to look into changing my hard disk arrangements. I currently have 2 C300 64g raid 0 with OS and WoW on them, then I have 2 WD 500 Cav Blues in raid 0 as well. I am thinking this could somehow be hindering performance??
BlueMonster
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 950 (batch 3041A657) Gigabyte x58-ud3r XFX HD6970 2Gb Crossfire Corsair Dominator 6gb 
Hard DriveOptical DriveOSMonitor
C-300 64 Gb In Raid, WD 500Gb in Raid DVD/CD RW Windows 7 64bit Asus VE248H 1 over 3 Eyefinity with Ergotech Stand 
KeyboardPowerCaseMouse
Logitech 510 Corsair HX850 Cooler Master HAF 932 (mod'd AMD version) Razer Naga 
  hide details  
Reply
BlueMonster
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 950 (batch 3041A657) Gigabyte x58-ud3r XFX HD6970 2Gb Crossfire Corsair Dominator 6gb 
Hard DriveOptical DriveOSMonitor
C-300 64 Gb In Raid, WD 500Gb in Raid DVD/CD RW Windows 7 64bit Asus VE248H 1 over 3 Eyefinity with Ergotech Stand 
KeyboardPowerCaseMouse
Logitech 510 Corsair HX850 Cooler Master HAF 932 (mod'd AMD version) Razer Naga 
  hide details  
Reply
post #7 of 47
Quote:
Originally Posted by TDS View Post
Can you give me specific instructions on how to do this ?


I did run with one card on one monitor and the issue was still there, just not as bad. So When I go to spanned on three screens of course this amplifies the already poor performance. as far as being 70% CPU, I have even OC'd to 4.2Ghz without even a nudge in performance.

Interesting issue came up though. I got an error from windows that my system performance was slow, and that I needed to change my Aero settings to help improve performance. I was like *** ?? So now I am also thinking that maybe I need to look into changing my hard disk arrangements. I currently have 2 C300 64g raid 0 with OS and WoW on them, then I have 2 WD 500 Cav Blues in raid 0 as well. I am thinking this could somehow be hindering performance??
im confused, whats wrong with your current HD arrangement lol? sounds pretty good to me
Server/Gaming Rig
(22 items)
 
  
CPUCPUMotherboardGraphics
Intel E5-2670 intel E5-2670 Asus Z9PE-D8 WS Visiontek R9 390 
RAMHard DriveHard DriveHard Drive
8x4GB DDR3 1333 ECC Registered Toshiba 5TB X300 Seagate 4TB HGST 4TB 
Hard DriveHard DriveHard DriveHard Drive
Sandisk 240GB Sandisk 480GB Samsung 830 128GB Toshiba 6TB X300 
Hard DriveHard DriveOptical DriveOS
Toshiba 5TB X300 Toshiba 5TB X300 WH16NS40 Windows 10 Pro 
MonitorMonitorKeyboardPower
Dell S1715H Dell u2311h blackwidow ultimate Kingwin Lazer platinum 1000w 
CaseMouse
Corsair 800D Deathadder Chroma 
  hide details  
Reply
Server/Gaming Rig
(22 items)
 
  
CPUCPUMotherboardGraphics
Intel E5-2670 intel E5-2670 Asus Z9PE-D8 WS Visiontek R9 390 
RAMHard DriveHard DriveHard Drive
8x4GB DDR3 1333 ECC Registered Toshiba 5TB X300 Seagate 4TB HGST 4TB 
Hard DriveHard DriveHard DriveHard Drive
Sandisk 240GB Sandisk 480GB Samsung 830 128GB Toshiba 6TB X300 
Hard DriveHard DriveOptical DriveOS
Toshiba 5TB X300 Toshiba 5TB X300 WH16NS40 Windows 10 Pro 
MonitorMonitorKeyboardPower
Dell S1715H Dell u2311h blackwidow ultimate Kingwin Lazer platinum 1000w 
CaseMouse
Corsair 800D Deathadder Chroma 
  hide details  
Reply
post #8 of 47
Thread Starter 
Quote:
Originally Posted by Blindsay View Post
im confused, whats wrong with your current HD arrangement lol? sounds pretty good to me


Well aside from benchmarks, I personally have not seen any improvement in performance since going from one SSD to two raided. My personal "what I see factor" is that there was no difference and that if anything I have noticed a slow down at times of things that used to be fast. I personally am thinking its a more is too much kind of thing.


Anyhow, I still would like to know why almost $800 in cards wont run any better than this. Even on one I cant get the performance I was accustomed to with my old 9600 GSO in this same rig.
BlueMonster
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 950 (batch 3041A657) Gigabyte x58-ud3r XFX HD6970 2Gb Crossfire Corsair Dominator 6gb 
Hard DriveOptical DriveOSMonitor
C-300 64 Gb In Raid, WD 500Gb in Raid DVD/CD RW Windows 7 64bit Asus VE248H 1 over 3 Eyefinity with Ergotech Stand 
KeyboardPowerCaseMouse
Logitech 510 Corsair HX850 Cooler Master HAF 932 (mod'd AMD version) Razer Naga 
  hide details  
Reply
BlueMonster
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 950 (batch 3041A657) Gigabyte x58-ud3r XFX HD6970 2Gb Crossfire Corsair Dominator 6gb 
Hard DriveOptical DriveOSMonitor
C-300 64 Gb In Raid, WD 500Gb in Raid DVD/CD RW Windows 7 64bit Asus VE248H 1 over 3 Eyefinity with Ergotech Stand 
KeyboardPowerCaseMouse
Logitech 510 Corsair HX850 Cooler Master HAF 932 (mod'd AMD version) Razer Naga 
  hide details  
Reply
post #9 of 47
Quote:
Originally Posted by TDS View Post
Recently set up with 6970's crossfired , This is my sig rig

I have eyefinity set up in a 1 over 3 on ASUS VE248H's (flipped 'T') using the top monitor as extended desktop to monitor temps and such.

Playing WoW is a headache at best, the frames are above 100 if moving straight forward, but if I try to turn its choppy and frames drop to 5 or so.

I have tried disabling crossfire, disabling extended desktop, various Overclocks on the CPU but nothing seems to help unless I set WoWs settings to good... as high or ultra produces horrible performance.

I was using an Nvidia 9600 GSO and was able to run on Ultra settings with no problems..

I shouldnt be experiencing this kind of problems with these cards I have now. I also realize I am pushing 5760x1080 res, but still shouldnt I be able to play at ultra or high at least ? Can anyone please help me ??
Now being a vivid WOW player myself i have found that once u go to bigger resolutions and more monitors in a cf or sli scenerio it jst hates it for some odd reason. when running 2 monitors with my 2 6950 in a raid and massive aoe happends im good on ultra settings but while in cites its weird and lagging. my wife actually getting more fps in a major city and her choppyness is non exsisting with her single 6870 1 monitor setup. Im actually convinsed that WOW just doesnt like CF support
H2GO BABY
(13 items)
 
  
CPUMotherboardGraphicsRAM
955 Black Edition @4.013 ASUS Crossfire IV Extreme Sapphire 6950 O/C 950/1325 8G G Skill 
Hard DriveOSMonitorKeyboard
SSD Vertex 3 120gb,HD 1.5 TB Win 7 Acer 24" Razer 
PowerCaseMouseMouse Pad
RaidMax 750W Mountain Mod H2GO Razer Naga Razer 
  hide details  
Reply
H2GO BABY
(13 items)
 
  
CPUMotherboardGraphicsRAM
955 Black Edition @4.013 ASUS Crossfire IV Extreme Sapphire 6950 O/C 950/1325 8G G Skill 
Hard DriveOSMonitorKeyboard
SSD Vertex 3 120gb,HD 1.5 TB Win 7 Acer 24" Razer 
PowerCaseMouseMouse Pad
RaidMax 750W Mountain Mod H2GO Razer Naga Razer 
  hide details  
Reply
post #10 of 47
Thread Starter 
well let me ask this,

ONE -- do I need one or both the Crossfire ribbons ? I have one installed in the connector closest to the PCI slot (rear of case) as I had read somewhere thats all thats needed as the other connector is for tri fire or quad fire connections.

TWO- simply disabling crossfire in CCC is ok? Or do I need to physically eliminate the card altogether?
BlueMonster
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 950 (batch 3041A657) Gigabyte x58-ud3r XFX HD6970 2Gb Crossfire Corsair Dominator 6gb 
Hard DriveOptical DriveOSMonitor
C-300 64 Gb In Raid, WD 500Gb in Raid DVD/CD RW Windows 7 64bit Asus VE248H 1 over 3 Eyefinity with Ergotech Stand 
KeyboardPowerCaseMouse
Logitech 510 Corsair HX850 Cooler Master HAF 932 (mod'd AMD version) Razer Naga 
  hide details  
Reply
BlueMonster
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 950 (batch 3041A657) Gigabyte x58-ud3r XFX HD6970 2Gb Crossfire Corsair Dominator 6gb 
Hard DriveOptical DriveOSMonitor
C-300 64 Gb In Raid, WD 500Gb in Raid DVD/CD RW Windows 7 64bit Asus VE248H 1 over 3 Eyefinity with Ergotech Stand 
KeyboardPowerCaseMouse
Logitech 510 Corsair HX850 Cooler Master HAF 932 (mod'd AMD version) Razer Naga 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › 6970 frame rate issues in WoW