Overclock.net › Forums › Graphics Cards › AMD/ATI › HD4890 FPS issues in WoW
New Posts  All Forums:Forum Nav:

HD4890 FPS issues in WoW

post #1 of 5
Thread Starter 
So I have a HD4890 Superclocked Edition from Club3d which comes with a 950MHz core and 1050MHz memory. I have bumped these up to 1000 & 1100 respectively and it stays perfectly stable (maxes around 70 degrees).

Now I have been playing with this card since WotLK with everything on Ultra, 1920x1080 resolution and 8x AA. Then Cataclysm launched and I had no issues.

Now recently I have been getting really low frames in places like Twilight Highlands and the weird thing is that I have 40-50 fps when I stand still in the air, and it drops to 20-30 when I move straight forward....

I don't know if this is caused by my driver or by the new patch they released. I went from 11.2 back down to 10.12 and I seemed to gain a lot of frames, but I still retain the major FPS drop when moving. I was hoping people with the same or a similar card could tell me if they have the same issue and what settings they run on.
post #2 of 5
If it's twilight highlands then it's just the nature of the zone. Do you get it everywhere?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.6Ghz INTEL DP67BG - Intel Extreme Motherboard 2 x XFX 5850 1GB DDR5 4096MB OCZ GOLD 1600 DDR3 
Hard DriveOptical DriveOSMonitor
800GB SATA Drives Lite-on 16x DVD-R/W windows 7 professional 3x Dell ST2210 in eyefinity 
KeyboardPowerCaseMouse
Zboard Merc Thermaltake W0315RU thermaltake V9 black razer Naga gaming mouse 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.6Ghz INTEL DP67BG - Intel Extreme Motherboard 2 x XFX 5850 1GB DDR5 4096MB OCZ GOLD 1600 DDR3 
Hard DriveOptical DriveOSMonitor
800GB SATA Drives Lite-on 16x DVD-R/W windows 7 professional 3x Dell ST2210 in eyefinity 
KeyboardPowerCaseMouse
Zboard Merc Thermaltake W0315RU thermaltake V9 black razer Naga gaming mouse 
  hide details  
Reply
post #3 of 5
Thread Starter 
It also happens in other open areas, but to a lesser extent. The problem is that while I was leveling (before patch 4.0.6 and AMD driver 11.1/11.2) I leveled up 2 characters to 85 with everything on ultra and 8x AA but I never noticed any FPS problems.

Now I have the biggest issues in Uldum and Twilight Highlands, and I did not have the issues before... that is why I am confused.
post #4 of 5
they made simple changes to the enviroment for better looking zones more shrubs, more skylights,real looking water ect it was in the hotfixes

if its a dx11 card do the force dx11 your fps will go drastically up
post #5 of 5
Thread Starter 
Quote:
Originally Posted by solar0987 View Post
they made simple changes to the enviroment for better looking zones more shrubs, more skylights,real looking water ect it was in the hotfixes

if its a dx11 card do the force dx11 your fps will go drastically up
So you're saying they've updated the graphics/enviroments since Cataclysm launch? Could you possibly find these notes for me as I have not seen them before.

And no the HD4890 is a dx10 card.

Also does anybody know which ATI/AMD driver makes WoW run the best for my card?

EDIT: I am pretty amazed that a HD4890 which has been overclocked almost as high as possible can run 90% of the games out there right now on the highest possible settings yet I can't max out WoW.
Edited by Codyksp - 3/1/11 at 12:41pm
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › HD4890 FPS issues in WoW