Overclock.net › Forums › Video Games › PC Gaming › EQ2=Horrible performance!!
New Posts  All Forums:Forum Nav:

EQ2=Horrible performance!!

post #1 of 2
Thread Starter 
So just got back into everquest2 and got it all up and running last night. Now i have played this game on dual cores with a 4670, a quad core with a 5770/4850 and on my sig rig, i get horrible lag in game. fps drops down to 20's in guild hall with no one in the guild hall, in zones with less people, still nasty dips in fps. WTH is going on? if i set it to medium display, it runs ok with dips only into the upper 20's instead of lower 20's. i can play metro2033 and hardly dip below 30's so what is going on.
Haf of an 2500K
(13 items)
 
  
CPUMotherboardGraphicsRAM
I5 2500K MSI GD65 GTX 580 Windforce G Skill ECO 
Hard DriveOSKeyboardPower
64GB A-Data SSD+500GB F3 Win7 Razer Blackwidow 750W Black Edition 
CaseMouseMouse Pad
HAF 932 Razer Deathadder X-Trac Ripper 
  hide details  
Reply
Haf of an 2500K
(13 items)
 
  
CPUMotherboardGraphicsRAM
I5 2500K MSI GD65 GTX 580 Windforce G Skill ECO 
Hard DriveOSKeyboardPower
64GB A-Data SSD+500GB F3 Win7 Razer Blackwidow 750W Black Edition 
CaseMouseMouse Pad
HAF 932 Razer Deathadder X-Trac Ripper 
  hide details  
Reply
post #2 of 2
What are the speeds of your CPU as this game is heavily CPU dependent. On top of that, the game is single threaded which means that the speed of one core is really important.

If you want more information about this, I suggest that you look more about it in EverQuest 2 performance forum http://forums.station.sony.com/eq2/f...?forum_id=2637
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › EQ2=Horrible performance!!