Overclock.net › Forums › Graphics Cards › AMD/ATI › Is this an issue with the card itself?
New Posts  All Forums:Forum Nav:

Is this an issue with the card itself?

post #1 of 8
Thread Starter 
Lately my display has been acting up. It's never happened while gaming but sometimes while on the desktop a simple movement of the mouse will cause the screen's colors to go crazy and the display will go black for a couple seconds. Once the display returns and I move the mouse again it will continue to have this issue until I reboot. I have reinstalled the drivers and I thought it helped but apparently not. It's happened twice this past week. Is this a sign that my 4890 is going out?

Would this be covered under warranty? My card has a 2 year warranty which is over in 2 months. Sapphire requires warranties to be handled through the original place of purchase, correct?

Sapphire 4890
Gaming
(20 items)
 
HTPC
(21 items)
 
My Stuff
(12 photos)
CPUMotherboardGraphicsRAM
Intel Core i3-3220 ASRock H77M EVGA 750ti CORSAIR Vengeance 8GB DDR3 1600 
Hard DriveHard DriveHard DriveOptical Drive
1TB WD Black  2TB WD Green 4TB WD My Book Samsung Blu-Ray 
CoolingOSMonitorKeyboard
Cougar 120mm PWM Windows 10 60" Vizio M60-C3 4K Logitech K400 
PowerCaseMouseAudio
OCZ ModXStream 600w Silverstone GD05 Logitech K400 / MCE Remote Denon AVR-X2200W 
AudioAudioAudioAudio
Polk Audio Monitor II - CS2 BIC F12 - 12" Sub Polk Audio Monitor II - Monitor 70 x 2 Polk Audio Monitor II - Monitor 30 x 2 
  hide details  
Reply
Gaming
(20 items)
 
HTPC
(21 items)
 
My Stuff
(12 photos)
CPUMotherboardGraphicsRAM
Intel Core i3-3220 ASRock H77M EVGA 750ti CORSAIR Vengeance 8GB DDR3 1600 
Hard DriveHard DriveHard DriveOptical Drive
1TB WD Black  2TB WD Green 4TB WD My Book Samsung Blu-Ray 
CoolingOSMonitorKeyboard
Cougar 120mm PWM Windows 10 60" Vizio M60-C3 4K Logitech K400 
PowerCaseMouseAudio
OCZ ModXStream 600w Silverstone GD05 Logitech K400 / MCE Remote Denon AVR-X2200W 
AudioAudioAudioAudio
Polk Audio Monitor II - CS2 BIC F12 - 12" Sub Polk Audio Monitor II - Monitor 70 x 2 Polk Audio Monitor II - Monitor 30 x 2 
  hide details  
Reply
post #2 of 8
I had something simmilar happen a while back. Whenever i would use my mouse wheel the monitor would turn off and then on again in a few seconds. Im not sure how it happened but the hz got switched something strange. I put it back to 60 and everything was cool.
Comp
(13 items)
 
  
CPUMotherboardGraphicsRAM
3770K EVGA Z77 FTW Two 6970s Xfired 950 MHz/ 1450 MHz +20 8 gigs DDR3 1600mhz 
Hard DriveOptical DriveOSMonitor
SSD 1)Blue ray player 2) DVD writter Linux from scratch 24in Gateway 
KeyboardPowerCaseMouse
Its a keyboard 1200 Danger Den Doublewide yes 
Mouse Pad
Jack Skellington (overclocked) 
  hide details  
Reply
Comp
(13 items)
 
  
CPUMotherboardGraphicsRAM
3770K EVGA Z77 FTW Two 6970s Xfired 950 MHz/ 1450 MHz +20 8 gigs DDR3 1600mhz 
Hard DriveOptical DriveOSMonitor
SSD 1)Blue ray player 2) DVD writter Linux from scratch 24in Gateway 
KeyboardPowerCaseMouse
Its a keyboard 1200 Danger Den Doublewide yes 
Mouse Pad
Jack Skellington (overclocked) 
  hide details  
Reply
post #3 of 8
Thread Starter 
Was worth a shot.. but just checked and it's at 60hz..

This was artifacting in Windows as well, not just the monitor going blank.
Gaming
(20 items)
 
HTPC
(21 items)
 
My Stuff
(12 photos)
CPUMotherboardGraphicsRAM
Intel Core i3-3220 ASRock H77M EVGA 750ti CORSAIR Vengeance 8GB DDR3 1600 
Hard DriveHard DriveHard DriveOptical Drive
1TB WD Black  2TB WD Green 4TB WD My Book Samsung Blu-Ray 
CoolingOSMonitorKeyboard
Cougar 120mm PWM Windows 10 60" Vizio M60-C3 4K Logitech K400 
PowerCaseMouseAudio
OCZ ModXStream 600w Silverstone GD05 Logitech K400 / MCE Remote Denon AVR-X2200W 
AudioAudioAudioAudio
Polk Audio Monitor II - CS2 BIC F12 - 12" Sub Polk Audio Monitor II - Monitor 70 x 2 Polk Audio Monitor II - Monitor 30 x 2 
  hide details  
Reply
Gaming
(20 items)
 
HTPC
(21 items)
 
My Stuff
(12 photos)
CPUMotherboardGraphicsRAM
Intel Core i3-3220 ASRock H77M EVGA 750ti CORSAIR Vengeance 8GB DDR3 1600 
Hard DriveHard DriveHard DriveOptical Drive
1TB WD Black  2TB WD Green 4TB WD My Book Samsung Blu-Ray 
CoolingOSMonitorKeyboard
Cougar 120mm PWM Windows 10 60" Vizio M60-C3 4K Logitech K400 
PowerCaseMouseAudio
OCZ ModXStream 600w Silverstone GD05 Logitech K400 / MCE Remote Denon AVR-X2200W 
AudioAudioAudioAudio
Polk Audio Monitor II - CS2 BIC F12 - 12" Sub Polk Audio Monitor II - Monitor 70 x 2 Polk Audio Monitor II - Monitor 30 x 2 
  hide details  
Reply
post #4 of 8
hmm
it could be a problem with the monitor. I would RMA now, just in case.
Don't Panic
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 450M @ 2.4GHz Samsung Q430/Q530 Nvidia GeForce 310M Elpida 4GB DDR3 @ 533MHz 
Hard DriveOptical DriveOSMonitor
WD 500GB DVD Burner Windows 7 x64 Integrated 1336x786 LCD 
KeyboardPowerCaseMouse
Saitek Cyborg v.5 Battery Laptop Logitech G500 
  hide details  
Reply
Don't Panic
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 450M @ 2.4GHz Samsung Q430/Q530 Nvidia GeForce 310M Elpida 4GB DDR3 @ 533MHz 
Hard DriveOptical DriveOSMonitor
WD 500GB DVD Burner Windows 7 x64 Integrated 1336x786 LCD 
KeyboardPowerCaseMouse
Saitek Cyborg v.5 Battery Laptop Logitech G500 
  hide details  
Reply
post #5 of 8
Thread Starter 
I don't think it's the monitor because of the artifacting.. it looks eerily similar to an old 6800gt that went out on me.

According to Sapphire they repair the cards.. do they really repair an almost 2 year old card?

I was holding off on ordering a new card but I guess I will go ahead and do so and get this one RMA'd.
Gaming
(20 items)
 
HTPC
(21 items)
 
My Stuff
(12 photos)
CPUMotherboardGraphicsRAM
Intel Core i3-3220 ASRock H77M EVGA 750ti CORSAIR Vengeance 8GB DDR3 1600 
Hard DriveHard DriveHard DriveOptical Drive
1TB WD Black  2TB WD Green 4TB WD My Book Samsung Blu-Ray 
CoolingOSMonitorKeyboard
Cougar 120mm PWM Windows 10 60" Vizio M60-C3 4K Logitech K400 
PowerCaseMouseAudio
OCZ ModXStream 600w Silverstone GD05 Logitech K400 / MCE Remote Denon AVR-X2200W 
AudioAudioAudioAudio
Polk Audio Monitor II - CS2 BIC F12 - 12" Sub Polk Audio Monitor II - Monitor 70 x 2 Polk Audio Monitor II - Monitor 30 x 2 
  hide details  
Reply
Gaming
(20 items)
 
HTPC
(21 items)
 
My Stuff
(12 photos)
CPUMotherboardGraphicsRAM
Intel Core i3-3220 ASRock H77M EVGA 750ti CORSAIR Vengeance 8GB DDR3 1600 
Hard DriveHard DriveHard DriveOptical Drive
1TB WD Black  2TB WD Green 4TB WD My Book Samsung Blu-Ray 
CoolingOSMonitorKeyboard
Cougar 120mm PWM Windows 10 60" Vizio M60-C3 4K Logitech K400 
PowerCaseMouseAudio
OCZ ModXStream 600w Silverstone GD05 Logitech K400 / MCE Remote Denon AVR-X2200W 
AudioAudioAudioAudio
Polk Audio Monitor II - CS2 BIC F12 - 12" Sub Polk Audio Monitor II - Monitor 70 x 2 Polk Audio Monitor II - Monitor 30 x 2 
  hide details  
Reply
post #6 of 8
is it OC'd at all?
Comp
(13 items)
 
  
CPUMotherboardGraphicsRAM
3770K EVGA Z77 FTW Two 6970s Xfired 950 MHz/ 1450 MHz +20 8 gigs DDR3 1600mhz 
Hard DriveOptical DriveOSMonitor
SSD 1)Blue ray player 2) DVD writter Linux from scratch 24in Gateway 
KeyboardPowerCaseMouse
Its a keyboard 1200 Danger Den Doublewide yes 
Mouse Pad
Jack Skellington (overclocked) 
  hide details  
Reply
Comp
(13 items)
 
  
CPUMotherboardGraphicsRAM
3770K EVGA Z77 FTW Two 6970s Xfired 950 MHz/ 1450 MHz +20 8 gigs DDR3 1600mhz 
Hard DriveOptical DriveOSMonitor
SSD 1)Blue ray player 2) DVD writter Linux from scratch 24in Gateway 
KeyboardPowerCaseMouse
Its a keyboard 1200 Danger Den Doublewide yes 
Mouse Pad
Jack Skellington (overclocked) 
  hide details  
Reply
post #7 of 8
Totally video card issues. A friend of mine had the same issue like yours, he always ends up with some annoying power saving mode and it is disabled. His video card is bad.
post #8 of 8
Thread Starter 
I had it OC'd a little but have been running it at stock for the past few months as I'm tired of hearing the "blow dryer" kick in to keep it cool.
Gaming
(20 items)
 
HTPC
(21 items)
 
My Stuff
(12 photos)
CPUMotherboardGraphicsRAM
Intel Core i3-3220 ASRock H77M EVGA 750ti CORSAIR Vengeance 8GB DDR3 1600 
Hard DriveHard DriveHard DriveOptical Drive
1TB WD Black  2TB WD Green 4TB WD My Book Samsung Blu-Ray 
CoolingOSMonitorKeyboard
Cougar 120mm PWM Windows 10 60" Vizio M60-C3 4K Logitech K400 
PowerCaseMouseAudio
OCZ ModXStream 600w Silverstone GD05 Logitech K400 / MCE Remote Denon AVR-X2200W 
AudioAudioAudioAudio
Polk Audio Monitor II - CS2 BIC F12 - 12" Sub Polk Audio Monitor II - Monitor 70 x 2 Polk Audio Monitor II - Monitor 30 x 2 
  hide details  
Reply
Gaming
(20 items)
 
HTPC
(21 items)
 
My Stuff
(12 photos)
CPUMotherboardGraphicsRAM
Intel Core i3-3220 ASRock H77M EVGA 750ti CORSAIR Vengeance 8GB DDR3 1600 
Hard DriveHard DriveHard DriveOptical Drive
1TB WD Black  2TB WD Green 4TB WD My Book Samsung Blu-Ray 
CoolingOSMonitorKeyboard
Cougar 120mm PWM Windows 10 60" Vizio M60-C3 4K Logitech K400 
PowerCaseMouseAudio
OCZ ModXStream 600w Silverstone GD05 Logitech K400 / MCE Remote Denon AVR-X2200W 
AudioAudioAudioAudio
Polk Audio Monitor II - CS2 BIC F12 - 12" Sub Polk Audio Monitor II - Monitor 70 x 2 Polk Audio Monitor II - Monitor 30 x 2 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Is this an issue with the card itself?