Overclock.net › Forums › Components › Sound Cards and Computer Audio › Creative Sound Blaster X-FI Titanium Crackling in Left Channel
New Posts  All Forums:Forum Nav:

Creative Sound Blaster X-FI Titanium Crackling in Left Channel

post #1 of 7
Thread Starter 
I just bought a X-FI Titanium from someone on here, and it sounds great, except I've got crackling and static in the front-left channel. It's coming from somewhere on the bass end of the spectrum.

Lowering the bass frequencies gets rid of it, but it also reduces the bass in every other channel tongue.gif. What do? Is this the crossover I've heared about?

Related specs:
Creative Sound Blaster X-FI Titanium (latest drivers)
Altec Lansing 251 speakers
Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k MSI P67A-GD65 (B3) 760ti G.Skill Ripjaws 
Hard DriveCoolingOSMonitor
OCZ Vertex 2 Noctua NH D14 Windows 7 64bit Dell SP2309W 
MonitorMonitorKeyboardCase
Dell S2009W Dell S2009W CM Storm Quickfire XT NZXT Phantom Black 
Mouse
Razer Deathadder Chroma 
  hide details  
Reply
Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k MSI P67A-GD65 (B3) 760ti G.Skill Ripjaws 
Hard DriveCoolingOSMonitor
OCZ Vertex 2 Noctua NH D14 Windows 7 64bit Dell SP2309W 
MonitorMonitorKeyboardCase
Dell S2009W Dell S2009W CM Storm Quickfire XT NZXT Phantom Black 
Mouse
Razer Deathadder Chroma 
  hide details  
Reply
post #2 of 7
This happened on my XtremeMusic a while back. I asked around and the general consensus is that it wasn't worth repairing. I ended up tossing it.
FX Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD FX-8320e Gigabyte GA-970A-UD3P Sapphire R9 380 4GB 2x8GB Crucial Ballistix DDR3-1600 
Hard DriveHard DriveOptical DriveCooling
Intel 240GB SSD HGST 4TB Storage DVD-RW Cooler Master Hyper 212 EVO 
OSMonitorPowerCase
Windows 7 x64 AOC 27" 1080p Corsair CX750m Corsair 200R 
Audio
Asus Xonar DS 
  hide details  
Reply
FX Rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD FX-8320e Gigabyte GA-970A-UD3P Sapphire R9 380 4GB 2x8GB Crucial Ballistix DDR3-1600 
Hard DriveHard DriveOptical DriveCooling
Intel 240GB SSD HGST 4TB Storage DVD-RW Cooler Master Hyper 212 EVO 
OSMonitorPowerCase
Windows 7 x64 AOC 27" 1080p Corsair CX750m Corsair 200R 
Audio
Asus Xonar DS 
  hide details  
Reply
post #3 of 7
Have you tried it with different speakers? My experience is mostly that crackling=Speaker problem.
2nd Gig
(24 items)
 
Sayonara
(20 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition Asus M4A79T Deluxe NVIDIA GTX 670 FTW OCZ Platinum 4GB 1600 DDR3 
Hard DriveCoolingOSMonitor
OCZ Vertex 2 90GB & Samsung Spinpoint F3 1TB Scythe MUGEN-2 Microsoft Windows 8 Professional Dell UltraSharp u2410 & Samsung 2333SW 
KeyboardPowerCaseMouse
Logitech G15 OCZ GameXStream 700w HAF 932 Advanced Logitech G300 
AudioAudioAudioAudio
Denon AVR-1912 Harman Kardon Infinity Primus P153  HIFIMAN HE-400 Vsonic GR07 
AudioAudioAudioAudio
Shure SE-535 Limited Edition Beyerdynamic DT880 ODAC/Objective 2 Amplfiier Audio Technica AD700 
  hide details  
Reply
2nd Gig
(24 items)
 
Sayonara
(20 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition Asus M4A79T Deluxe NVIDIA GTX 670 FTW OCZ Platinum 4GB 1600 DDR3 
Hard DriveCoolingOSMonitor
OCZ Vertex 2 90GB & Samsung Spinpoint F3 1TB Scythe MUGEN-2 Microsoft Windows 8 Professional Dell UltraSharp u2410 & Samsung 2333SW 
KeyboardPowerCaseMouse
Logitech G15 OCZ GameXStream 700w HAF 932 Advanced Logitech G300 
AudioAudioAudioAudio
Denon AVR-1912 Harman Kardon Infinity Primus P153  HIFIMAN HE-400 Vsonic GR07 
AudioAudioAudioAudio
Shure SE-535 Limited Edition Beyerdynamic DT880 ODAC/Objective 2 Amplfiier Audio Technica AD700 
  hide details  
Reply
post #4 of 7
Try resetting your drivers to default?
Malignance
(24 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K Asus P8Z68-V eVGA GTX670 FTW 16GB Mushkin DDR3-2100 1.5V 
Hard DriveHard DriveHard DriveOptical Drive
2 x 128GB Crucial M4 2 x 1TB Samsung F3 RAID0 1.5TB Seagate Asus 22X DVDRW 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate 64-bit Dell Ultrasharp U2410 Asus ProArt PA248Q 
KeyboardPowerCaseMouse
Rosewill RK-9000BR PCP&P Silencer MKIII 600W Lian Li PC-A05NB Logitech G500 
Mouse PadAudioAudioAudio
Rocketfish Dual Sided Asus Xonar Essence STX Infinity Primus P153 | Dayton DTA-120 Amplifier... Shure SRH840 
AudioAudioAudio
Audio Technica ATH-AD700X Objective DAC Audio-Technica ATR2500-USB 
  hide details  
Reply
Malignance
(24 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K Asus P8Z68-V eVGA GTX670 FTW 16GB Mushkin DDR3-2100 1.5V 
Hard DriveHard DriveHard DriveOptical Drive
2 x 128GB Crucial M4 2 x 1TB Samsung F3 RAID0 1.5TB Seagate Asus 22X DVDRW 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate 64-bit Dell Ultrasharp U2410 Asus ProArt PA248Q 
KeyboardPowerCaseMouse
Rosewill RK-9000BR PCP&P Silencer MKIII 600W Lian Li PC-A05NB Logitech G500 
Mouse PadAudioAudioAudio
Rocketfish Dual Sided Asus Xonar Essence STX Infinity Primus P153 | Dayton DTA-120 Amplifier... Shure SRH840 
AudioAudioAudio
Audio Technica ATH-AD700X Objective DAC Audio-Technica ATR2500-USB 
  hide details  
Reply
post #5 of 7
Thread Starter 
Quote:
Originally Posted by RallyMaster;12642334 
Try resetting your drivers to default?
They were worse with the initial drivers, although they were standard Windows 7 drivers. I didn't get the CD with the sound card.
Quote:
Have you tried it with different speakers? My experience is mostly that crackling=Speaker problem.
My previous sound card didn't do this with the same speakers. I don't have alternative speakers, but I will try headphones.

Why would it only affect the front-left channel?
Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k MSI P67A-GD65 (B3) 760ti G.Skill Ripjaws 
Hard DriveCoolingOSMonitor
OCZ Vertex 2 Noctua NH D14 Windows 7 64bit Dell SP2309W 
MonitorMonitorKeyboardCase
Dell S2009W Dell S2009W CM Storm Quickfire XT NZXT Phantom Black 
Mouse
Razer Deathadder Chroma 
  hide details  
Reply
Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k MSI P67A-GD65 (B3) 760ti G.Skill Ripjaws 
Hard DriveCoolingOSMonitor
OCZ Vertex 2 Noctua NH D14 Windows 7 64bit Dell SP2309W 
MonitorMonitorKeyboardCase
Dell S2009W Dell S2009W CM Storm Quickfire XT NZXT Phantom Black 
Mouse
Razer Deathadder Chroma 
  hide details  
Reply
post #6 of 7
Quote:
Originally Posted by dzalias;12650874 
They were worse with the initial drivers, although they were standard Windows 7 drivers. I didn't get the CD with the sound card.

No, I'm not telling you to reinstall the initial drivers. Go into your Console Launcher and press the Reset to Default button.
Malignance
(24 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K Asus P8Z68-V eVGA GTX670 FTW 16GB Mushkin DDR3-2100 1.5V 
Hard DriveHard DriveHard DriveOptical Drive
2 x 128GB Crucial M4 2 x 1TB Samsung F3 RAID0 1.5TB Seagate Asus 22X DVDRW 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate 64-bit Dell Ultrasharp U2410 Asus ProArt PA248Q 
KeyboardPowerCaseMouse
Rosewill RK-9000BR PCP&P Silencer MKIII 600W Lian Li PC-A05NB Logitech G500 
Mouse PadAudioAudioAudio
Rocketfish Dual Sided Asus Xonar Essence STX Infinity Primus P153 | Dayton DTA-120 Amplifier... Shure SRH840 
AudioAudioAudio
Audio Technica ATH-AD700X Objective DAC Audio-Technica ATR2500-USB 
  hide details  
Reply
Malignance
(24 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K Asus P8Z68-V eVGA GTX670 FTW 16GB Mushkin DDR3-2100 1.5V 
Hard DriveHard DriveHard DriveOptical Drive
2 x 128GB Crucial M4 2 x 1TB Samsung F3 RAID0 1.5TB Seagate Asus 22X DVDRW 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate 64-bit Dell Ultrasharp U2410 Asus ProArt PA248Q 
KeyboardPowerCaseMouse
Rosewill RK-9000BR PCP&P Silencer MKIII 600W Lian Li PC-A05NB Logitech G500 
Mouse PadAudioAudioAudio
Rocketfish Dual Sided Asus Xonar Essence STX Infinity Primus P153 | Dayton DTA-120 Amplifier... Shure SRH840 
AudioAudioAudio
Audio Technica ATH-AD700X Objective DAC Audio-Technica ATR2500-USB 
  hide details  
Reply
post #7 of 7
Thread Starter 
Quote:
Originally Posted by RallyMaster;12653618 
No, I'm not telling you to reinstall the initial drivers. Go into your Console Launcher and press the Reset to Default button.
That's not reinstalling the driver, that's reverting back to defaults.

I've tried the latter; it didn't help. Haven't tried the former.

EDIT: Rolled back to generic driver. No longer getting distortion. Going to try reinstalling the newer driver, to see if it's better.

EDIT2: Reinstalled new driver, and the distortion is gone. I'm confused, but won't complain. Thanks! Reps all around.

EDIT3: I missed the initial "not" in your last post.
Edited by dzalias - 3/8/11 at 7:48pm
Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k MSI P67A-GD65 (B3) 760ti G.Skill Ripjaws 
Hard DriveCoolingOSMonitor
OCZ Vertex 2 Noctua NH D14 Windows 7 64bit Dell SP2309W 
MonitorMonitorKeyboardCase
Dell S2009W Dell S2009W CM Storm Quickfire XT NZXT Phantom Black 
Mouse
Razer Deathadder Chroma 
  hide details  
Reply
Rig
(16 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500k MSI P67A-GD65 (B3) 760ti G.Skill Ripjaws 
Hard DriveCoolingOSMonitor
OCZ Vertex 2 Noctua NH D14 Windows 7 64bit Dell SP2309W 
MonitorMonitorKeyboardCase
Dell S2009W Dell S2009W CM Storm Quickfire XT NZXT Phantom Black 
Mouse
Razer Deathadder Chroma 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › Creative Sound Blaster X-FI Titanium Crackling in Left Channel