Overclock.net › Forums › Graphics Cards › AMD/ATI › Need immediate assistance
New Posts  All Forums:Forum Nav:

Need immediate assistance

post #1 of 10
Thread Starter 

Well, here's the thing. I bought a Asus HD 5770. It wasn't working properly, so I took it back to the shop, and took a new one today. It was all working great and smoothly, until out of a sudden, weird thing happened. It happened while I was playing a game, closed the game, moved to desktop. The thing is, I get some sort of disortion, some triangles in the screen. They change everytime I move my cursor, so I doubt its my display. And the only thing that can change the image is the card. Well, I made a quick video of whats happening in short (sorry for bad quality).


Hope to get an answer soon. Oh, and by the way, when this started, the video cars was around 65 degrees Celsius, so I doubt it over heated.
Raptor_V1
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 B60 BE 3.30GHz Asus M4A89GTD PRO Sapphire HD 5770 FleX @ 950/1300 2x2GB Corsair XMS3 1600MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Blue 1TB 7200rpm Samsung Super WriteMaster Windows 7 Ultimate 64bit LG W2353V 23" 1080p 
KeyboardPowerCaseMouse
4Tech X-Audio Cooler Master GX 650W Custom modded tower Jetion GM 
Mouse Pad
Acme Retro 
  hide details  
Reply
Raptor_V1
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 B60 BE 3.30GHz Asus M4A89GTD PRO Sapphire HD 5770 FleX @ 950/1300 2x2GB Corsair XMS3 1600MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Blue 1TB 7200rpm Samsung Super WriteMaster Windows 7 Ultimate 64bit LG W2353V 23" 1080p 
KeyboardPowerCaseMouse
4Tech X-Audio Cooler Master GX 650W Custom modded tower Jetion GM 
Mouse Pad
Acme Retro 
  hide details  
Reply
post #2 of 10
I can't see Youtube videos at work, but are these "triangles" flashing different colors on polygon surfaces? It sounds like it could be artifacting.

The most common causes of artifacts, in my experience, are:
  • Over-volting.
  • Under-volting.
  • Factory defect.
Intellect v2
(9 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-6700K Processor ASUS ROG MAXIMUS VIII HERO LGA1151 DDR4 M.2 SAT... EVGA GTX 1080 SC ACX 3.0 Crucial Ballistix Sport 32GB DDR4 2400 MT/s (PC... 
CoolingKeyboardPowerCase
Noctua NH-D15 Das Keyboard 4 Professional (Brown) Corsair AX860 Fractal Design Define R5 
Mouse
MIONIX NAOS 7000 
  hide details  
Reply
Intellect v2
(9 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-6700K Processor ASUS ROG MAXIMUS VIII HERO LGA1151 DDR4 M.2 SAT... EVGA GTX 1080 SC ACX 3.0 Crucial Ballistix Sport 32GB DDR4 2400 MT/s (PC... 
CoolingKeyboardPowerCase
Noctua NH-D15 Das Keyboard 4 Professional (Brown) Corsair AX860 Fractal Design Define R5 
Mouse
MIONIX NAOS 7000 
  hide details  
Reply
post #3 of 10
Quote:
Originally Posted by Plex View Post
I can't see Youtube videos at work, but are these "triangles" flashing different colors on polygon surfaces? It sounds like it could be artifacting.

The most common causes of artifacts, in my experience, are:
  • Over-volting.
  • Under-volting.
  • Factory defect.
the random polygons are happening on his desk top... looks like a bad card or connector or cable somewhere between your graphics card and your monitor. have you switched back to your old card yet to see if it still happens?
    
CPUMotherboardGraphicsRAM
i5 2500k OC'd 4.9GHz Asus P8P67-M PRo Asus GTX-560 Ti Direct CU II  PNY XLR8 8GB DDR3 PC3-12800 
Hard DriveOptical DriveCoolingOS
WD Caviar Black WD1002FAEX 1TB 7200 RPM LG Black Blu-ray Disc Combo SATA w/Lightscribe Corsair H60 Windows 7 Ultimate 
MonitorPowerCase
Acer G235HAbd 23'' WideScreen LCD monitor OCZ ModXStream Pro OCZ700MXSP 700W Modular PSU Corsair Carbide Series 500R 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5 2500k OC'd 4.9GHz Asus P8P67-M PRo Asus GTX-560 Ti Direct CU II  PNY XLR8 8GB DDR3 PC3-12800 
Hard DriveOptical DriveCoolingOS
WD Caviar Black WD1002FAEX 1TB 7200 RPM LG Black Blu-ray Disc Combo SATA w/Lightscribe Corsair H60 Windows 7 Ultimate 
MonitorPowerCase
Acer G235HAbd 23'' WideScreen LCD monitor OCZ ModXStream Pro OCZ700MXSP 700W Modular PSU Corsair Carbide Series 500R 
  hide details  
Reply
post #4 of 10
Thread Starter 
Yes, they're changing colors. The thing is, on low usage, volts are 0.950. On high usage, 1.200 (ati power play). Can't be too low and too high.

EDIT: Haven't switched back yet, will try.

EDIT2: Old card works fine, I am seriously hoping its the cable now. Gonna try using DVI, but ehh, HDMI cable should work fine..
Edited by Nginx - 3/7/11 at 11:20am
Raptor_V1
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 B60 BE 3.30GHz Asus M4A89GTD PRO Sapphire HD 5770 FleX @ 950/1300 2x2GB Corsair XMS3 1600MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Blue 1TB 7200rpm Samsung Super WriteMaster Windows 7 Ultimate 64bit LG W2353V 23" 1080p 
KeyboardPowerCaseMouse
4Tech X-Audio Cooler Master GX 650W Custom modded tower Jetion GM 
Mouse Pad
Acme Retro 
  hide details  
Reply
Raptor_V1
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 B60 BE 3.30GHz Asus M4A89GTD PRO Sapphire HD 5770 FleX @ 950/1300 2x2GB Corsair XMS3 1600MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Blue 1TB 7200rpm Samsung Super WriteMaster Windows 7 Ultimate 64bit LG W2353V 23" 1080p 
KeyboardPowerCaseMouse
4Tech X-Audio Cooler Master GX 650W Custom modded tower Jetion GM 
Mouse Pad
Acme Retro 
  hide details  
Reply
post #5 of 10
Thread Starter 
Damn, DVI cable shows same. It seriously can't be a bad GPU twice in a row?
Raptor_V1
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 B60 BE 3.30GHz Asus M4A89GTD PRO Sapphire HD 5770 FleX @ 950/1300 2x2GB Corsair XMS3 1600MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Blue 1TB 7200rpm Samsung Super WriteMaster Windows 7 Ultimate 64bit LG W2353V 23" 1080p 
KeyboardPowerCaseMouse
4Tech X-Audio Cooler Master GX 650W Custom modded tower Jetion GM 
Mouse Pad
Acme Retro 
  hide details  
Reply
Raptor_V1
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 B60 BE 3.30GHz Asus M4A89GTD PRO Sapphire HD 5770 FleX @ 950/1300 2x2GB Corsair XMS3 1600MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Blue 1TB 7200rpm Samsung Super WriteMaster Windows 7 Ultimate 64bit LG W2353V 23" 1080p 
KeyboardPowerCaseMouse
4Tech X-Audio Cooler Master GX 650W Custom modded tower Jetion GM 
Mouse Pad
Acme Retro 
  hide details  
Reply
post #6 of 10
Thread Starter 
Another edit: Damn, I uninstalled the drivers, (only display drivers, CCC and everything else left) and the problem is gone. Apparently I can run games without drivers, or at least its on some kind of drivers now, since the resolution is normal, 1080. In the game, I had to reset the resolution, and it works. I have no idea what happened. I'll try using some older drivers.
Raptor_V1
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 B60 BE 3.30GHz Asus M4A89GTD PRO Sapphire HD 5770 FleX @ 950/1300 2x2GB Corsair XMS3 1600MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Blue 1TB 7200rpm Samsung Super WriteMaster Windows 7 Ultimate 64bit LG W2353V 23" 1080p 
KeyboardPowerCaseMouse
4Tech X-Audio Cooler Master GX 650W Custom modded tower Jetion GM 
Mouse Pad
Acme Retro 
  hide details  
Reply
Raptor_V1
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 B60 BE 3.30GHz Asus M4A89GTD PRO Sapphire HD 5770 FleX @ 950/1300 2x2GB Corsair XMS3 1600MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Blue 1TB 7200rpm Samsung Super WriteMaster Windows 7 Ultimate 64bit LG W2353V 23" 1080p 
KeyboardPowerCaseMouse
4Tech X-Audio Cooler Master GX 650W Custom modded tower Jetion GM 
Mouse Pad
Acme Retro 
  hide details  
Reply
post #7 of 10
Try updating drivers through steam. Has worked flawlessly for me a few times now. Also you connected to a 2nd monitor?
GPUz is a good app to look at clocks, driver version.
Edited by Newbie2009 - 3/7/11 at 12:26pm
post #8 of 10
What was bad about the first card?
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
The 3930
(26 items)
 
Junior's 3930
(22 items)
 
DATA/HTPC
(20 items)
 
  hide details  
Reply
post #9 of 10
Quote:
Originally Posted by Nginx View Post
Another edit: Damn, I uninstalled the drivers, (only display drivers, CCC and everything else left) and the problem is gone. Apparently I can run games without drivers, or at least its on some kind of drivers now, since the resolution is normal, 1080. In the game, I had to reset the resolution, and it works. I have no idea what happened. I'll try using some older drivers.
Did you happen to get a message after the uninstall process that windows applied a compatibility fix?
Wife's bane
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.5 Ghz Gigabyte Z77 UD3H HIS R9-290 8 GB Samsung Wonder RAM 
Hard DriveHard DriveOptical DriveCooling
Crucial SSD for OS Samsung Spinpoint F3 Asus XSPC water block, 360 radiator, and 720 reservo... 
CoolingOSMonitorKeyboard
GPU cooling - XSPC Razer full GPU blocks Win 7 Home Premium Asus PB278Q 2560 X 1440p ISP Logitech G15 
PowerCaseMouseMouse Pad
NZXT Hale90 V2 NZXT Switch 810 Logitech G500 Steelseries QcK 
Audio
Optical out to Sony receiver; Deftech Monitor 3... 
  hide details  
Reply
Wife's bane
(17 items)
 
  
CPUMotherboardGraphicsRAM
i5-3570K @ 4.5 Ghz Gigabyte Z77 UD3H HIS R9-290 8 GB Samsung Wonder RAM 
Hard DriveHard DriveOptical DriveCooling
Crucial SSD for OS Samsung Spinpoint F3 Asus XSPC water block, 360 radiator, and 720 reservo... 
CoolingOSMonitorKeyboard
GPU cooling - XSPC Razer full GPU blocks Win 7 Home Premium Asus PB278Q 2560 X 1440p ISP Logitech G15 
PowerCaseMouseMouse Pad
NZXT Hale90 V2 NZXT Switch 810 Logitech G500 Steelseries QcK 
Audio
Optical out to Sony receiver; Deftech Monitor 3... 
  hide details  
Reply
post #10 of 10
Thread Starter 
Quote:
Originally Posted by Awaz View Post
Did you happen to get a message after the uninstall process that windows applied a compatibility fix?
Nope, yet the windows has used the default drivers.

tsm106, the first card was malfunctioning, ati power play wasn't working properly, it was freezing the display, etc.

Newbie2009, nope, only using one monitor.

Anyway, what I did, was uninstalled the drivers. Used driver sweeper and cleaned everything. Rebooted, then installed the drivers that came in the CD, and rebooted again. Everything seems to be working flawlessly now, I just hope it stays this way. CCC (Catalyst Control Center) shows me the clocks and temp, I also have a gadget for that, so no need for the GPUz. Thanks for the help guys, and sorry for multiposting. If I have any trouble again, I will just return it and demand my money back.
Raptor_V1
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 B60 BE 3.30GHz Asus M4A89GTD PRO Sapphire HD 5770 FleX @ 950/1300 2x2GB Corsair XMS3 1600MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Blue 1TB 7200rpm Samsung Super WriteMaster Windows 7 Ultimate 64bit LG W2353V 23" 1080p 
KeyboardPowerCaseMouse
4Tech X-Audio Cooler Master GX 650W Custom modded tower Jetion GM 
Mouse Pad
Acme Retro 
  hide details  
Reply
Raptor_V1
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X3 B60 BE 3.30GHz Asus M4A89GTD PRO Sapphire HD 5770 FleX @ 950/1300 2x2GB Corsair XMS3 1600MHz 
Hard DriveOptical DriveOSMonitor
WD Caviar Blue 1TB 7200rpm Samsung Super WriteMaster Windows 7 Ultimate 64bit LG W2353V 23" 1080p 
KeyboardPowerCaseMouse
4Tech X-Audio Cooler Master GX 650W Custom modded tower Jetion GM 
Mouse Pad
Acme Retro 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Need immediate assistance