Overclock.net › Forums › Graphics Cards › AMD/ATI › Extremely low fps with new ati card
New Posts  All Forums:Forum Nav:

Extremely low fps with new ati card

post #1 of 16
Thread Starter 
Hello I just got an ati 6850 today, and tried to play some games with it but i'm noticing my fps are extremely low....in a couple games I normally get hundreds of frames per second with my 8800gtx. But with my 6850 (which should be twice as powerful as the 8800gtx) i'm getting 20fps. And when I try to play wow I get these brutal crashes. I also had this same issue with another 6850 I bought a couple weeks ago but sent it back for a new branded one. Can anyone tell me whats wrong?
2 the Max
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 970 Gigabyte 890XA-UD3 GTX 260 4x4gb g.skill ddr3 1600 
Hard DriveOSMonitorKeyboard
250gb harddrive Windows Home Premium 64 Bit SyncMaster 955df Saitek Eclipse 
PowerMouseMouse Pad
Cosair 850watt Intellimouse 1.1a Corepad Eyepad 
  hide details  
Reply
2 the Max
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 970 Gigabyte 890XA-UD3 GTX 260 4x4gb g.skill ddr3 1600 
Hard DriveOSMonitorKeyboard
250gb harddrive Windows Home Premium 64 Bit SyncMaster 955df Saitek Eclipse 
PowerMouseMouse Pad
Cosair 850watt Intellimouse 1.1a Corepad Eyepad 
  hide details  
Reply
post #2 of 16
What drivers are you using? Did you uninstall your Nvidia drivers when you installed the ATI drivers?
Future Proof 2.0
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 6700k Gigabyte z170n-Gaming 5 ASUS Strix GTX 1070 OC G.Skill DDR4 3200 (2x8Gb) 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 Evo Samsung 850 Evo Toshiba Q Series Pro WD Black 
CoolingOSMonitorKeyboard
Corsair H100i V2 Windows 7 Ultimate 64bit Dell S2716DG Corsair K70 
PowerCaseMouse
Silversont ST1000P NZXT Manta Steel Series Rival 
  hide details  
Reply
Future Proof 2.0
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 6700k Gigabyte z170n-Gaming 5 ASUS Strix GTX 1070 OC G.Skill DDR4 3200 (2x8Gb) 
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 Evo Samsung 850 Evo Toshiba Q Series Pro WD Black 
CoolingOSMonitorKeyboard
Corsair H100i V2 Windows 7 Ultimate 64bit Dell S2716DG Corsair K70 
PowerCaseMouse
Silversont ST1000P NZXT Manta Steel Series Rival 
  hide details  
Reply
post #3 of 16
Hi and welcome to the forum!

As sort of stated, you should have completely removed your Nvidia driver suite and then shut off the PC. Pop the AMD in, go to AMD's website and download/install latest drivers.

Can you open CCC and change around settings?
How do other games run?
buildX
(16 items)
 
X3Elite (HTPC)
(14 items)
 
Dell XPS L702X
(11 items)
 
CPUMotherboardGraphicsRAM
Core i7 930 @ 4.0GHz (24/7) HT/on  Asus P6TD Deluxe Gigabyte 2GB GTX 670 Windforce3X OC  6GB OCZ Gold 1600 (tri-channel) 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 250GB Seagate Barracuda 500GB 7.2K 16MB Cache Prolimatech Megahalem Rev.B (Push/Pull) Windows 7 Home Premium 64 
MonitorKeyboardPowerCase
Acer X233H Razer BlackWidow Ultimate  OCZ ModXStream Pro 600W XClio Windtunnel 
MouseMouse Pad
Logitech G502 Proteus Core Tunable  Razer Goliathus 444mm x 355mm - Speed Edition ... 
CPUMotherboardGraphicsRAM
AMD Phenom II 720 X3 BE @ 3.2GHz 24/7 MSi 770-G45 Sapphire Radeon HD 6870  8GB GSkill RipJaw 1333Mhz  
Hard DriveOptical DriveOSMonitor
1TB Samsung F3  DVD+-RW  Windows 7 Home Premium 64bit 60" LG 60PA5500 Plasma 
MonitorPowerCase
Acer X1373WH Projector Corsair CX500 Cooler Master 430 
CPUGraphicsGraphicsRAM
i5-2430M Intel HD Graphics  Nvidia 1GB GT 550M (GF116) w/Optimus|DX11|144 ... 6GB DDR3  
Hard DriveHard DriveOSMonitor
120GB PNY 1311 SSD 500GB 7.2K RPM Windows7 Home Premium 64 17.3" WLED TL 1600 X 900 with 2.0MP HD webcam 
KeyboardCaseAudio
Backlit Keyboard Elemental Silver Aluminum JBL 2.1 W/ Built-in Subwoofer 
  hide details  
Reply
buildX
(16 items)
 
X3Elite (HTPC)
(14 items)
 
Dell XPS L702X
(11 items)
 
CPUMotherboardGraphicsRAM
Core i7 930 @ 4.0GHz (24/7) HT/on  Asus P6TD Deluxe Gigabyte 2GB GTX 670 Windforce3X OC  6GB OCZ Gold 1600 (tri-channel) 
Hard DriveHard DriveCoolingOS
Samsung 850 EVO 250GB Seagate Barracuda 500GB 7.2K 16MB Cache Prolimatech Megahalem Rev.B (Push/Pull) Windows 7 Home Premium 64 
MonitorKeyboardPowerCase
Acer X233H Razer BlackWidow Ultimate  OCZ ModXStream Pro 600W XClio Windtunnel 
MouseMouse Pad
Logitech G502 Proteus Core Tunable  Razer Goliathus 444mm x 355mm - Speed Edition ... 
CPUMotherboardGraphicsRAM
AMD Phenom II 720 X3 BE @ 3.2GHz 24/7 MSi 770-G45 Sapphire Radeon HD 6870  8GB GSkill RipJaw 1333Mhz  
Hard DriveOptical DriveOSMonitor
1TB Samsung F3  DVD+-RW  Windows 7 Home Premium 64bit 60" LG 60PA5500 Plasma 
MonitorPowerCase
Acer X1373WH Projector Corsair CX500 Cooler Master 430 
CPUGraphicsGraphicsRAM
i5-2430M Intel HD Graphics  Nvidia 1GB GT 550M (GF116) w/Optimus|DX11|144 ... 6GB DDR3  
Hard DriveHard DriveOSMonitor
120GB PNY 1311 SSD 500GB 7.2K RPM Windows7 Home Premium 64 17.3" WLED TL 1600 X 900 with 2.0MP HD webcam 
KeyboardCaseAudio
Backlit Keyboard Elemental Silver Aluminum JBL 2.1 W/ Built-in Subwoofer 
  hide details  
Reply
post #4 of 16
Thread Starter 
Quote:
Originally Posted by M0E View Post
What drivers are you using? Did you uninstall your Nvidia drivers when you installed the ATI drivers?
I did uninstall them, got this same problem with the same card just a different brand a couple weeks ago. I really wonder whats wrong.
2 the Max
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 970 Gigabyte 890XA-UD3 GTX 260 4x4gb g.skill ddr3 1600 
Hard DriveOSMonitorKeyboard
250gb harddrive Windows Home Premium 64 Bit SyncMaster 955df Saitek Eclipse 
PowerMouseMouse Pad
Cosair 850watt Intellimouse 1.1a Corepad Eyepad 
  hide details  
Reply
2 the Max
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 970 Gigabyte 890XA-UD3 GTX 260 4x4gb g.skill ddr3 1600 
Hard DriveOSMonitorKeyboard
250gb harddrive Windows Home Premium 64 Bit SyncMaster 955df Saitek Eclipse 
PowerMouseMouse Pad
Cosair 850watt Intellimouse 1.1a Corepad Eyepad 
  hide details  
Reply
post #5 of 16
Thread Starter 
Can anyone help?
2 the Max
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 970 Gigabyte 890XA-UD3 GTX 260 4x4gb g.skill ddr3 1600 
Hard DriveOSMonitorKeyboard
250gb harddrive Windows Home Premium 64 Bit SyncMaster 955df Saitek Eclipse 
PowerMouseMouse Pad
Cosair 850watt Intellimouse 1.1a Corepad Eyepad 
  hide details  
Reply
2 the Max
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 970 Gigabyte 890XA-UD3 GTX 260 4x4gb g.skill ddr3 1600 
Hard DriveOSMonitorKeyboard
250gb harddrive Windows Home Premium 64 Bit SyncMaster 955df Saitek Eclipse 
PowerMouseMouse Pad
Cosair 850watt Intellimouse 1.1a Corepad Eyepad 
  hide details  
Reply
post #6 of 16
You should uninstall the 6850 drivers and then run driver sweeper and remove any NVIDIA drivers and reboot, then reinstall them from the AMD website.
Edited by Razi3l - 3/7/11 at 4:08pm
    
CPUMotherboardGraphicsRAM
i5-2500k @ 4300Mhz Biostar TP67XE Waiting to buy a new one 8GB 1600Mhz 7-8-7-21 1T 
Hard DriveCoolingOSMonitor
Samsung 840 SSD [250GB] Antec H20 620 Windows 7 x64 Acer S242HL 
PowerCase
Thermaltake 775W NZXT Phantom [White] 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2500k @ 4300Mhz Biostar TP67XE Waiting to buy a new one 8GB 1600Mhz 7-8-7-21 1T 
Hard DriveCoolingOSMonitor
Samsung 840 SSD [250GB] Antec H20 620 Windows 7 x64 Acer S242HL 
PowerCase
Thermaltake 775W NZXT Phantom [White] 
  hide details  
Reply
post #7 of 16
Quote:
Originally Posted by Razi3l View Post
You should uninstall the 6850 drivers and then run driver sweeper and remove any AMD/ATI drivers and NVIDIA drivers and reboot, then reinstall them from the AMD website.
Do not run driver sweeper if you are going to use an ATi card. It causes massive problems.
SUPERPWN
(12 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 4670K Asus z87-Pro MSI GTX 1080 Aero 32GB DDR3 Gskill Ripjaws 
Hard DriveOSMonitorMonitor
4TB Seagate Windows 8 x64 Overlord x270 OC HP ZR27 
MonitorKeyboardPowerAudio
Asus PG279Q G-Tune Topre Realforce 800w Yulong D100 DAC with Denon D7000 headphones 
  hide details  
Reply
SUPERPWN
(12 items)
 
  
CPUMotherboardGraphicsRAM
Core i5 4670K Asus z87-Pro MSI GTX 1080 Aero 32GB DDR3 Gskill Ripjaws 
Hard DriveOSMonitorMonitor
4TB Seagate Windows 8 x64 Overlord x270 OC HP ZR27 
MonitorKeyboardPowerAudio
Asus PG279Q G-Tune Topre Realforce 800w Yulong D100 DAC with Denon D7000 headphones 
  hide details  
Reply
post #8 of 16
Quote:
Originally Posted by Crazy9000 View Post
Do not run driver sweeper if you are going to use an ATi card. It causes massive problems.
Yea I know, I just use it to remove nvidia drivers, never ati. If its his second card it could just be something else in his system too.. hmm..
    
CPUMotherboardGraphicsRAM
i5-2500k @ 4300Mhz Biostar TP67XE Waiting to buy a new one 8GB 1600Mhz 7-8-7-21 1T 
Hard DriveCoolingOSMonitor
Samsung 840 SSD [250GB] Antec H20 620 Windows 7 x64 Acer S242HL 
PowerCase
Thermaltake 775W NZXT Phantom [White] 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2500k @ 4300Mhz Biostar TP67XE Waiting to buy a new one 8GB 1600Mhz 7-8-7-21 1T 
Hard DriveCoolingOSMonitor
Samsung 840 SSD [250GB] Antec H20 620 Windows 7 x64 Acer S242HL 
PowerCase
Thermaltake 775W NZXT Phantom [White] 
  hide details  
Reply
post #9 of 16
Thread Starter 
Well, I tried uninstalling ati drivers nvidia too, and used driver sweeper to clean everything up. But for some reason I'm still getting this problem....guess I'm just gonna send this back and get an nvidia card instead. If anyone has any other ideas, let me know.
2 the Max
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 970 Gigabyte 890XA-UD3 GTX 260 4x4gb g.skill ddr3 1600 
Hard DriveOSMonitorKeyboard
250gb harddrive Windows Home Premium 64 Bit SyncMaster 955df Saitek Eclipse 
PowerMouseMouse Pad
Cosair 850watt Intellimouse 1.1a Corepad Eyepad 
  hide details  
Reply
2 the Max
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 970 Gigabyte 890XA-UD3 GTX 260 4x4gb g.skill ddr3 1600 
Hard DriveOSMonitorKeyboard
250gb harddrive Windows Home Premium 64 Bit SyncMaster 955df Saitek Eclipse 
PowerMouseMouse Pad
Cosair 850watt Intellimouse 1.1a Corepad Eyepad 
  hide details  
Reply
post #10 of 16
Quote:
Originally Posted by Crazy9000 View Post
Do not run driver sweeper if you are going to use an ATi card. It causes massive problems.
Whoa what, please explain? How else then would you recommend the drivers be completely uninstalled?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Extremely low fps with new ati card