Overclock.net › Forums › Specialty Builds › HTPC › HTPC losing sound on HDTV
New Posts  All Forums:Forum Nav:

HTPC losing sound on HDTV

post #1 of 7
Thread Starter 
Hey guys maybe someone would have an idea as to why I keep losing sound when my HTPC is plugged in my HDTV via HDMI??? Sometimes it's fine for a couple of days but today it played fine on the morning then I shut the HDTV and come back later with NO SOUND. Happened a couple of times already... All I have to do to solve the problem is to plug my old vga monitor or sometimes it comes back alone for no reason....

HTPC is on at all times with no sleep/ screen saver... sound playback is on HDMI at all times and works even when no sound coming from the HDTV.

here's the spec of the machine even tho it sounds more like a HDTV problem.

Win7 x64
g31m-es2l mobo
2 gb ddr2
5450 hd ati
e8400 c2d
HDTV is a KDL-46XBR6 bravia

Would plugging the HTPC via HDMI in a receiver solve the problem???
Could I have sound even with HDTV OFF with a receiver?

Many thanks to whoever reply to any of my questions !!! eek.gif
post #2 of 7
Try installing the latest driver from realtek and see if that helps.
http://218.210.127.131/downloads/downloadsCheck.aspx?Langid=1&PNid=14&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false
HTPC
(19 items)
 
  
CPUMotherboardGraphicsRAM
Athlon X2 4850e (45w) GIGABYTE GA-MA790GP-DS4H 790GX HDMI Asus HD5670 A-DATA  
Hard DriveHard DriveHard DriveOptical Drive
WD Blue  WD Black WD Green Lg Bluray 
CoolingOSMonitorKeyboard
Scythe Ninja Mini Windows 7 Pro 55" Vizio 3D LED MS Bluetooth 
PowerCaseMouseAudio
SeaSonic M12II SS-430GM 430W Silverstone LC10B-E MS Bluetooth Pioneer VSX-819H 
AudioAudio
Polk CS2 Center Polk Monitor 50s x4 
  hide details  
Reply
HTPC
(19 items)
 
  
CPUMotherboardGraphicsRAM
Athlon X2 4850e (45w) GIGABYTE GA-MA790GP-DS4H 790GX HDMI Asus HD5670 A-DATA  
Hard DriveHard DriveHard DriveOptical Drive
WD Blue  WD Black WD Green Lg Bluray 
CoolingOSMonitorKeyboard
Scythe Ninja Mini Windows 7 Pro 55" Vizio 3D LED MS Bluetooth 
PowerCaseMouseAudio
SeaSonic M12II SS-430GM 430W Silverstone LC10B-E MS Bluetooth Pioneer VSX-819H 
AudioAudio
Polk CS2 Center Polk Monitor 50s x4 
  hide details  
Reply
post #3 of 7
When you lose sound do you see which audio device it says it is using? Like is it switching over to s/pdif or speakers?
Got Cheap?
(13 items)
 
Server
(19 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II 965 Asrock 870 Extreme3 Sapphire 6850 sniper 2x4gb DDR3 1600 
Hard DriveOptical DriveOSMonitor
WD blue 500gb cheap dvd-rw 7 x64 21" LG 
KeyboardPowerCaseMouse
KA-558 Antec TP-750 NZXT Gamma MX518 
Mouse Pad
Xtrac Ripper 
CPUMotherboardRAMHard Drive
Athlon II x2 240 Biostar A870u3 2x2gb gb ddr1066 Samsung h154ui 
Hard DriveHard DriveHard DriveHard Drive
Samsung 204ui Western Digital WD10 EADS Western Digital WD20 EARS Western digital WD2500 
Hard DriveOptical DriveOSMonitor
Western Digital Blue 500gb dvd burner Windows 7 x64 Remote Desktop 
PowerCaseOther
Antec EA500-d Norco 470 Flexraid 
CPUMotherboardGraphicsRAM
Athlon II x4 620 ASUS M3A78-EM 5450 G.Skil 2x2gb DDR3 1600 
Hard DriveOptical DriveOSMonitor
Western Digital Blue 500gb none Windows 7 x64 46" lcd 
KeyboardPowerCaseAudio
RII Antec EarthWatts EA-380 Norco 420 Polk Audio Monitor50 x5 
AudioAudioOther
Polk Audio Monitor 30 x2 Bic F12 sub Acoustic Research ARRX18G 
  hide details  
Reply
Got Cheap?
(13 items)
 
Server
(19 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II 965 Asrock 870 Extreme3 Sapphire 6850 sniper 2x4gb DDR3 1600 
Hard DriveOptical DriveOSMonitor
WD blue 500gb cheap dvd-rw 7 x64 21" LG 
KeyboardPowerCaseMouse
KA-558 Antec TP-750 NZXT Gamma MX518 
Mouse Pad
Xtrac Ripper 
CPUMotherboardRAMHard Drive
Athlon II x2 240 Biostar A870u3 2x2gb gb ddr1066 Samsung h154ui 
Hard DriveHard DriveHard DriveHard Drive
Samsung 204ui Western Digital WD10 EADS Western Digital WD20 EARS Western digital WD2500 
Hard DriveOptical DriveOSMonitor
Western Digital Blue 500gb dvd burner Windows 7 x64 Remote Desktop 
PowerCaseOther
Antec EA500-d Norco 470 Flexraid 
CPUMotherboardGraphicsRAM
Athlon II x4 620 ASUS M3A78-EM 5450 G.Skil 2x2gb DDR3 1600 
Hard DriveOptical DriveOSMonitor
Western Digital Blue 500gb none Windows 7 x64 46" lcd 
KeyboardPowerCaseAudio
RII Antec EarthWatts EA-380 Norco 420 Polk Audio Monitor50 x5 
AudioAudioOther
Polk Audio Monitor 30 x2 Bic F12 sub Acoustic Research ARRX18G 
  hide details  
Reply
post #4 of 7
hick is asking the right questions - but gut instinct leads me either suspect the HDMI cable/connections (cheap cables suck like that), or the PC could use a restart every once in a while - a few sources (that of course I can't remember/site right now) recommend letting a PC (in any use) shut down fully leads to a much more stable experience. FWIW, mine is scheduled to shut down around 3AM, and from the BIOS wakes up just before I usually get home from work.
Smalls
(9 items)
 
HTPC
(15 items)
 
 
CPUMotherboardGraphicsRAM
Intel i5 3570 Asus P8Z77I-Deluxe EVGA GTX 660 Ti SC Corsair Vengeance LP DDR3 8GB 
Hard DriveCoolingOSPower
OCZ Vertex 3 120GB Scythe Big Shuriken 2 Windows 7 Home 64 Bit Silverstone SST-ST45SF 
Case
Silverstone SG05-450 
CPUMotherboardGraphicsRAM
Phenom II X2 560 MSI 785GM-P45 MSI HD6570 1GB DDR3 Microcenter/A-Data DDR3 4GB 1333 
Hard DriveHard DriveOptical DriveCooling
OCZ Agility 2 Western Digital Caviar Green 2TB Samsung Bluray Scythe Big Shuriken 
OSMonitorPowerCase
Windows 7 Home 32 Bit Vizio 26" LED/LCD TV Antec Earthwatts 380 w/modded fan SilverStone Milo ML03B 
Other
Hauppauge 2250 Tuner 
  hide details  
Reply
Smalls
(9 items)
 
HTPC
(15 items)
 
 
CPUMotherboardGraphicsRAM
Intel i5 3570 Asus P8Z77I-Deluxe EVGA GTX 660 Ti SC Corsair Vengeance LP DDR3 8GB 
Hard DriveCoolingOSPower
OCZ Vertex 3 120GB Scythe Big Shuriken 2 Windows 7 Home 64 Bit Silverstone SST-ST45SF 
Case
Silverstone SG05-450 
CPUMotherboardGraphicsRAM
Phenom II X2 560 MSI 785GM-P45 MSI HD6570 1GB DDR3 Microcenter/A-Data DDR3 4GB 1333 
Hard DriveHard DriveOptical DriveCooling
OCZ Agility 2 Western Digital Caviar Green 2TB Samsung Bluray Scythe Big Shuriken 
OSMonitorPowerCase
Windows 7 Home 32 Bit Vizio 26" LED/LCD TV Antec Earthwatts 380 w/modded fan SilverStone Milo ML03B 
Other
Hauppauge 2250 Tuner 
  hide details  
Reply
post #5 of 7
if your connected via hdmi I suspect that when the mobo/pc goes to sleep it affects the system when it wakes up it disconnects and messes up the audio settings...did it come from sleep mode? does the sound icon on your task bar still show AMD hdmi audio device?
Quote:
Would plugging the HTPC via HDMI in a receiver solve the problem???
Could I have sound even with HDTV OFF with a receiver?
#1 depends if the sound icon reveals amd hdmi audio is constant #2 if you got an hdmi receiver yes...
Edited by pohtangina - 3/9/11 at 7:17am
pscott
(13 items)
 
  
CPUMotherboardGraphicsRAM
3.4@stock Gigabyte 7600gs 1gb corsair cmx512 
Hard DriveOptical DriveOSMonitor
160+250 sata +80ide LiteonDL+SonyDRU800a Win7/vbox.Ubuntu/vbox.XP'sp3' Dell17"+Samsung17" 
PowerCase
Antec 500w APevia 
  hide details  
Reply
pscott
(13 items)
 
  
CPUMotherboardGraphicsRAM
3.4@stock Gigabyte 7600gs 1gb corsair cmx512 
Hard DriveOptical DriveOSMonitor
160+250 sata +80ide LiteonDL+SonyDRU800a Win7/vbox.Ubuntu/vbox.XP'sp3' Dell17"+Samsung17" 
PowerCase
Antec 500w APevia 
  hide details  
Reply
post #6 of 7
Thread Starter 
Thanks for the quick answers guys!! As for Hick's question, I only have the AMD HDMI out for sound, nothing else plugged in. When no sound comes out of the HDTV, my volume device is set for hdmi and works just like it would normally...

As for DaveG If I had a cable problem, sound should work completely or not at all, am I wrong???

pohtangina like I said I don't use any sleep mode/screen saver and yes the volume device is set to amd hdmi out.
post #7 of 7
I use a KDLex400 bravia...and my sound config is such that I have an hdmi from pc then an optical out from tv to receiver....no problems so far...I would suspect a bad cable but your getting picture (digital is digital)
pscott
(13 items)
 
  
CPUMotherboardGraphicsRAM
3.4@stock Gigabyte 7600gs 1gb corsair cmx512 
Hard DriveOptical DriveOSMonitor
160+250 sata +80ide LiteonDL+SonyDRU800a Win7/vbox.Ubuntu/vbox.XP'sp3' Dell17"+Samsung17" 
PowerCase
Antec 500w APevia 
  hide details  
Reply
pscott
(13 items)
 
  
CPUMotherboardGraphicsRAM
3.4@stock Gigabyte 7600gs 1gb corsair cmx512 
Hard DriveOptical DriveOSMonitor
160+250 sata +80ide LiteonDL+SonyDRU800a Win7/vbox.Ubuntu/vbox.XP'sp3' Dell17"+Samsung17" 
PowerCase
Antec 500w APevia 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: HTPC
Overclock.net › Forums › Specialty Builds › HTPC › HTPC losing sound on HDTV